About BEMCLI Cmdlets

Backup Exec Management Command Line Interface Help
About BEMCLI Cmdlets
TOPIC
  about_BEMCLI_Cmdlets

SHORT DESCRIPTION
  Provides information about the Backup Exec Management Command Line
  Interface (BEMCLI)

LONG DESCRIPTION
  This topic provides information about prerequisites for using Backup Exec
  Management Command Line Interface (BEMCLI), how to load BEMCLI, BEMCLI
  commands, and a description of the BEMCLI commands.  This topic also
  provides links to more information about Windows PowerShell.

ABOUT THE BACKUP EXEC MANAGEMENT COMMAND LINE INTERFACE
  The Backup Exec Command Line Interface (BEMCLI) is a convenient way to
  automate some of the most useful features of Backup Exec. The BEMCLI module
  contains commands that perform most Backup Exec functions and utilities
  in a Windows PowerShell console.

  BEMCLI runs on the Backup Exec Server on which it is installed. To
  run BEMCLI from a remote computer, use PowerShell remoting. For more
  information see Get-Help about_remote.

BACKUP EXEC MANAGEMENT COMMAND LINE INTERFACE REQUIREMENTS
  Requirements to run BEMCLI include:

  - Windows PowerShell V2

  - .NET 3.5

  - PowerShell's execution policy must set to a value that is less restrictive
    than Restricted (e.g. AllSigned). For more information, see
    Get-Help Set-ExecutionPolicy.

USING THE BACKUP EXEC MANAGEMENT COMMAND LINE INTERFACE
  The Backup Exec Management Command Line Interface (BEMCLI) is installed with
  Backup Exec. To open BEMCLI do one of the following:

  - On the computer on which Backup Exec is installed, on the taskbar, click
    Start > All Programs > Symantec Backup Exec > Backup Exec Management
    Command Line Interface.

  - On the computer on which Backup Exec is installed, launch PowerShell, and
    then type Import-Module BEMCLI.

FREQUENTLY USED BACKUP EXEC COMMAND LINE OPERATIONS

  ALERT MONITORING

  To clear all of the active information alerts, type:
  Get-BEAlert -Severity Information | Clear-BEAlert -Response Ok

  To display the number of all active error alerts, type:
  @(Get-BEAlert -Severity Error).Count

  To display a list of alerts for a specified server, type:
  Get-BEAgentServer <FQDN server name> | Get-BEAlert

  JOB MONITORING

  To start an existing job and wait for it to complete, type:
  Start-BEJob <job name> | Wait-BEJob

  To display the job log for the last run of a job, type:
  Get-BEJob <job name> |
    Get-BEJobHistory -FromLastJobRun |
    Get-BEJobLog

  To display the job history for a specified server, type:
  Get-BEAgentServer <FQDN server name> | Get-BEJobHistory

  DEVICE MANAGEMENT

  To create a disk-based storage device pool, type:
  New-BEStorageDevicePool -Name <desired storage pool name> -StoragePoolType Disk

  To create a new disk-based storage on a specified volume, type:
  New-BEDiskStorageDevice -Name <disk storage name> -DriveLetter <drive letter:>

  To add disk-based storage to a storage device pool, type:
  Get-BEStorageDevicePool -Name <storage pool name> |
    Add-BEDeviceToStorageDevicePool -DiskStorageDevice <disk storage name>

  BACKUPS

  To create a one time backup job of an entire server and wait for the job to
  complete, type:
  Get-BEAgentServer <FQDN server name> |
    Submit-BEOnetimeBackupJob |
    Wait-BEJob

  To create a one time backup job of a specific directory on a server, type:
  Get-BEAgentServer <FQDN server name> |
    Submit-BEOnetimeBackupJob -FileSystemSelection <drive letter:>\<directory>\*

  To create a one time backup job of an entire server that excludes a
  specified volume, type:
  $exclude = New-BEFileSystemSelection <drive letter:>\* -Recurse -Exclude
  Get-BEAgentServer <FQDN server name> |
    Submit-BEOnetimeBackupJob -FileSystemSelection $exclude

  To create a one time backup job for the System State of a server, type:
  Get-BEAgentServer <FQDN server name> |
    Submit-BEOnetimeBackupJob -SystemStateSelection Include

  To create recurring jobs of an entire server using the backup-to-disk job
  defaults, type:
  Get-BEAgentServer <FQDN server name> |
    New-BEBackupDefinition BackupToDisk |
    Save-BEBackupDefinition

  RESTORES

  To restore a specific file from the most recent
  backup of a server and wait for the job to complete, type:
  Get-BEAgentServer <FQDN server name> |
    Submit-BEFileSystemRestoreJob <drive:>\<directory>\<filename> |
    Wait-BEJob

  To restore a specific file from the most recent backup from a
  point-in-time, type:
  Get-BEAgentServer <FQDN server name> |
    Submit-BEFileSystemRestoreJob <drive:>\<directory>\<filename> -PointInTime "<date>"

  To restore a specific file from the last run of a job, type:
  Get-BEJob <job name> |
    Get-BEJobHistory -FromLastJobRun |
    Submit-BEFileSystemRestoreJob <drive letter:>\<directory>\<filename>

SEE ALSO
  Windows PowerShell Getting Started Guide:
      http://msdn.microsoft.com/en-us/library/aa973757(v=vs.85).aspx
  Windows PowerShell V2 Download:
      http://support.microsoft.com/kb/968929
  Set-ExecutionPolicy
  Import-Module
  about_remote
  Get-BEAlert
  Clear-BEAlert
  Get-BEAgentServer
  New-BEStorageDevicePool
  New-BEDiskStorageDevice
  Add-BEDeviceToStorageDevicePool
  Start-BEJob
  Wait-BEJob
  Get-BEJobHistory
  Get-BEJobLog
  Submit-BEOnetimeBackupJob
  New-BEBackupDefinition
  Save-BEBackupDefinition
  Submit-BEFileSystemRestoreJob

KEYWORDS
  about_BackupExec


Add-BEConvertToVirtualStageBackupTask Help

Add-BEConvertToVirtualStageBackupTask Cmdlet
Synopsis

Adds a convert to virtual stage to a backup definition in Backup Exec.

Syntax
Add-BEConvertToVirtualStageBackupTask -BackupDefinition [<BEBackupDefinition>] -SimultaneouslyWithBackup [<SwitchParameter>] -TargetEnvironment [<BEConvertToVirtualTargetEnvironment>] [-OverwriteExistingVirtualMachine [<Boolean>]] [-VirtualMachinePhysicalRamMB [<UInt32>]] [-VirtualMachineCpuCount [<UInt32>]] [-VirtualMachineName [<String>]] [<CommonParameters>]

Add-BEConvertToVirtualStageBackupTask -BackupDefinition [<BEBackupDefinition>] -ImmediatelyAfterFullBackup [<String>] -TargetEnvironment [<BEConvertToVirtualTargetEnvironment>] [-VirtualMachinePhysicalRamMB [<UInt32>]] [-OverwriteExistingVirtualMachine [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-VirtualMachineCpuCount [<UInt32>]] [-Name [<String>]] [-VirtualMachineName [<String>]] [<CommonParameters>]

Add-BEConvertToVirtualStageBackupTask -BackupDefinition [<BEBackupDefinition>] [-SourceBackup] {AllBackups | MostRecentFullBackup} -Schedule [<BESchedule>] -TargetEnvironment [<BEConvertToVirtualTargetEnvironment>] [-VirtualMachinePhysicalRamMB [<UInt32>]] [-OverwriteExistingVirtualMachine [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-VirtualMachineCpuCount [<UInt32>]] [-VirtualMachineName [<String>]] [-Name [<String>]] [<CommonParameters>]
Description

Adds a convert to virtual stage to a backup definition in Backup Exec.

You can add a convert to virtual stage to a new backup definition or edit a backup definition.

To add a convert to virtual stage to a new backup definition, use Add-BEConvertToVirtualStageBackupTask and New-BEBackupDefinition.

To edit a backup definition and add a convert to virtual stage, use Add-BEConvertToVirtualStageBackupTask and Get-BEBackupDefinition.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String>

Specifies the name of the convert to virtual stage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SimultaneouslyWithBackup <SwitchParameter>

Creates a backup job with the simultaneous conversion to a virtual machine.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterFullBackup <String>

Creates a backup job and runs the conversion to virtual machine immediately after the backup.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SourceBackup

Specifies the backup source in the backup definition for the convert to a virtual machine.

The valid values are:
AllBackups
MostRecentFullBackup

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TargetEnvironment <BEConvertToVirtualTargetEnvironment>

Specifies the virtual environment to create the virtual machine. See New-BEConvertToVirtualTargetEnvironment.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineName <String>

Specifies the name of the virtual machine to create.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingVirtualMachine <Boolean>

Overwrites an existing virtual machine with the same name if it already exists.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachinePhysicalRamMB <UInt32>

Specifies the amount of RAM in MB for the virtual machine.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineCpuCount <UInt32>

Specifies the number of CPUs for the virtual machine.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Add-BEConvertToVirtualStageBackupTask.

Return Value
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

Examples

Example 1

C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -HyperVServerName hypervserver01 -HyperVDestinationPath c:\vms -LogonAccount "System Logon Account" -ToolsIsoPath c:\hypervtools.iso
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEConvertToVirtualStageBackupTask -SimultaneouslyWithBackup -TargetEnvironment $targetEnvironment | Save-BEBackupDefinition

These commands create a backup definition that has a convert to virtual stage that creates a virtual machine on a Hyper-V server simultaneously with a backup job.

Example 2
C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -VMwareVCenterServerName vcenterserver01 -VMwareHostName hostserver01 -VMwareDataStoreName datastore01 -LogonAccount "System Logon Account" -ToolsIsoPath c:\vmwaretools.iso
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEConvertToVirtualStageBackupTask -SourceBackup AllBackups -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) -TargetEnvironment $targetEnvironment | Save-BEBackupDefinition

These commands create a backup definition that has a convert to virtual stage that creates a virtual machine in a VMware vCenter from any of the backup jobs every weekday at 10pm.

Related Links


Add-BEDeviceToStorageDevicePool Help

Add-BEDeviceToStorageDevicePool Cmdlet
Synopsis

Adds a device to a storage device pool in Backup Exec.

Syntax
Add-BEDeviceToStorageDevicePool -DiskStorageDevicePool [<BEDiskStorageDevicePool>] [-DiskStorageDevice] [<BEDiskStorageDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Add-BEDeviceToStorageDevicePool -TapeStorageDevicePool [<BETapeStorageDevicePool>] [-TapeDriveDevice] [<BETapeDriveDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Add-BEDeviceToStorageDevicePool -DiskStorageDevicePool [<BEDiskStorageDevicePool>] [-VirtualDiskDevice] [<BEVirtualDiskDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Add-BEDeviceToStorageDevicePool -DiskCartridgeStorageDevicePool [<BEDiskCartridgeStorageDevicePool>] [-DiskCartridgeDevice] [<BEDiskCartridgeDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Adds a device to a storage device pool in Backup Exec.

Parameters

-TapeStorageDevicePool <BETapeStorageDevicePool>

Specifies a tape storage device pool to add devices.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskStorageDevicePool <BEDiskStorageDevicePool>

Specifies a disk storage device pool to add devices.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskCartridgeStorageDevicePool <BEDiskCartridgeStorageDevicePool>

Specifies a disk cartridge storage device pool to add devices.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskCartridgeDevice <BEDiskCartridgeDevice[]>

Specifies a Backup Exec disk cartridge device to add to the storage device pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageDevice <BEDiskStorageDevice[]>

Specifies a Backup Exec disk storage device to add to the storage device pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualDiskDevice <BEVirtualDiskDevice[]>

Specifies a Backup Exec virtual disk device to add to the storage device pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice[]>

Specifies a Backup Exec tape drive device to add to the storage device pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeStorageDevicePool

You can pipe a Backup Exec tape storage device pool object to Add-BEDeviceToStorageDevicePool.

BackupExec.Management.CLI.BEDiskStorageDevicePool

You can pipe a Backup Exec disk storage device pool object to Add-BEDeviceToStorageDevicePool.

BackupExec.Management.CLI.BEDiskCartridgeStorageDevicePool

You can pipe a Backup Exec disk cartridge storage device pool object to Add-BEDeviceToStorageDevicePool.

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Add-BEDeviceFromStorageDevicePool returns a Backup Exec storage device pool object.

Example

C:\PS> Get-BEStorageDevicePool "StorageDevicePool 0001" | Add-BEDeviceToStorageDevicePool "Device 0001"

These commands add a device named "Device 0001" to a storage device pool named "StorageDevicePool 0001.

Related Link

Get-BEStorageDevicePool


Add-BEDifferentialBackupTask Help

Add-BEDifferentialBackupTask Cmdlet
Synopsis

Adds a differential backup to a backup definition in Backup Exec.

Syntax
Add-BEDifferentialBackupTask -BackupDefinition [<BEBackupDefinition>] [[-Name] [<String>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-DominoMarkArchiveLogsForRecycling [<Boolean>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-BackupSetDescription [<String>]] [-PreCommand [<String>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-PostCommand [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-Schedule [<BESchedule>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Add-BEDifferentialBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [[-Name] [<String>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-DominoMarkArchiveLogsForRecycling [<Boolean>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-BackupSetDescription [<String>]] [-PreCommand [<String>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-PostCommand [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-Schedule [<BESchedule>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Adds a differential backup to a backup definition in Backup Exec.

You can add a differential backup to a new backup definition or edit a backup definition. You can also add a differential backup to the backup job defaults. A backup definition cannot contain a differential backup and an incremental backup.

To add a differential backup to a new backup definition, use Add-BEDifferentialBackupTask and New-BEBackupDefinition.

To edit a backup definition, use Add-BEDifferentialBackupTask and Get-BEBackupDefinition.

To add a differential backup to the backup job defaults, use Add-BEDifferentialBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for a backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

Specifies the type of data compression to use performed by the hardware or software. The Storage parameter must be set to a tape-based storage device.

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Allows backup data to be sent directly to the device specified in the Storage parameter from the Agent for Windows if the device supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

Specifies a command to run before the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

Specifies a command to run after the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Allows Backup Exec to check the return codes of the pre- and post-commands to determine if they completed successfully.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

Runs the backup job only if the pre-command is successful. If the pre-command fails, the job does not run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

Runs the post-command only if the pre-command is successful.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

Runs the post-command regardless of whether the job is successful or not.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

Runs the post-command after the verification completes if you selected to verify the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

Designates the number of minutes Backup Exec should wait before canceling a pre- or post-command that did not complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

Determines the location where the pre- and post-command run.

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

Runs a verify operation automatically when the backup job completes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

Specifies the type of consistency check to perform before the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

Specifies the type of consistency check to use after the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

For SQL 2005 or later, adds checksums to the SQL database data being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

Creates an on-disk copy of the SQL database being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

Specifies the path for the on-disk copy of the SQL database being backed up. CreateDiskCopy must be set to $true.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

For SQL 2008 or later, specifies the compression setting you want to use.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

Lets you delete the archived log files automatically after the backup.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

Enables Backup Exec to skip any archived logfiles that were already backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

Enables Backup Exec to take the database offline before you start the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DominoMarkArchiveLogsForRecycling <Boolean>

Reuses the transaction log after it has been backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the differential backup job.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Add-BEDifferentialBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Add-BEDifferentialBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask * | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

These commands create a new backup definition for the local computer with an initial full and a differential backup.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

These commands add a differential backup to a backup definition named "Backup Definition 01".

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Add-BEDifferentialBackupTask | Save-BEBackupJobDefault

These commands add a differential backup to the backup-to-disk job defaults.

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BEAgentServer
Remove-BEBackupTask


Add-BEDuplicateStageBackupTask Help

Add-BEDuplicateStageBackupTask Cmdlet
Synopsis

Adds a duplicate stage to a backup definition in Backup Exec.

Syntax
Add-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [[-Name] [<String>]] -ImmediatelyAfterBackup [<String>] [-VerifyAsPartOfJob [<Boolean>]] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-DoNotAddDefaultVerifyTask [<SwitchParameter>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey [<BEEncryptionKey>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-SubmitOnHold [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [-SourceBackup] {AllBackups | MostRecentFullBackup | SpecificSourceBackups} [[-Name] [<String>]] [[-SpecificSourceBackup] [<String[]>]] -Schedule [<BESchedule>] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-VerifyAsPartOfJob [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-BackupSetDescription [<String>]] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-DoNotAddDefaultVerifyTask [<SwitchParameter>]] [-EncryptionKey [<BEEncryptionKey>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-TapeStorageExportMedia [<Boolean>]] [-Storage [<BEStorage>]] [-SubmitOnHold [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [[-Name] [<String>]] -ImmediatelyAfterDuplicate [<String>] [-VerifyAsPartOfJob [<Boolean>]] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-DoNotAddDefaultVerifyTask [<SwitchParameter>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey [<BEEncryptionKey>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-SubmitOnHold [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Add-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [[-Name] [<String>]] -SourceDuplicate [<String>] -Schedule [<BESchedule>] [-VerifyAsPartOfJob [<Boolean>]] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-DoNotAddDefaultVerifyTask [<SwitchParameter>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-EncryptionKey [<BEEncryptionKey>]] [-SubmitOnHold [<Boolean>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-TapeStorageExportMedia [<Boolean>]] [-Storage [<BEStorage>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Adds a duplicate stage to a backup definition in Backup Exec.

You can add a duplicate stage to a new backup definition or edit a backup definition.

To add a duplicate stage to a new backup definition, use Add-BEDuplicateStageBackupTask and New-BEBackupDefinition.

To edit a backup definition and add a duplicate stage, use Add-BEDuplicateStageBackupTask and Get-BEBackupDefinition.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SourceBackup

Specifies the backup source in the backup definition to duplicate.

The valid values are:
AllBackups
MostRecentFullBackup
SpecificSourceBackups

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-SpecificSourceBackup <String[]>

Specifies one or more backup jobs in the backup definition to duplicate by name (string). To specify multiple names, use commas to separate the names. The Source parameter must be set to SpecificBackups.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterBackup <String>

Specifies the name of the backup job in the backup definition to duplicate.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterDuplicate <String>

Specifies the name of a duplicate backup job in the backup definition to duplicate.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SourceDuplicate <String>

Specifies the name of the duplicate backup job in the backup definition to duplicate.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

Runs a verify operation automatically when the backup job completes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnabledHardwareCompression <Boolean>

Specifies if you want to enable hardware compression. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DoNotAddDefaultVerifyTask <SwitchParameter>

Prevents the verify task from being added with the duplicate stage, if a default verify task is associated with a duplicate stage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the duplicate stage.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Add-BEDuplicateStageBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Add-BEDuplicateStageBackupTask.

Return Value
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEDuplicateStageBackupTask -SourceBackup AllBackups -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) | Save-BEBackupDefinition

These commands create a backup definition that has a duplicate stage that duplicates the data from all backup jobs every weekday at 10PM.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEDuplicateStageBackupTask -SourceBackup SpecificSourceBackups -SpecificSourceBackup Full -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) | Save-BEBackupDefinition

These commands add a duplicate stage to a backup definition named "Backup Definition 01" that duplicates the data from a backup job named "Full" every weekday at 10PM.

Example 3
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEDuplicateStageBackupTask -ImmediatelyAfterBackup Full | Save-BEBackupDefinition

These commands create a backup definition that has a duplicate stage that duplicates the data from a backup job named "Full" after the backup job completes.

Example 4
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDiskThenDuplicateToTape | Add-BEDuplicateStageBackupTask -SourceDuplicate Duplicate -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) | Save-BEBackupDefinition

These commands create a backup definition that has a duplicate stage that duplicates the data from a duplicate stage named "Duplicate" every weekday at 10PM.

Example 5
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDiskThenDuplicateToTape | Add-BEDuplicateStageBackupTask -ImmediatelyAfterDuplicate Duplicate | Save-BEBackupDefinition

These commands create a backup definition that has a duplicate stage that duplicates the data from a duplicate stage named "Duplicate" after the duplication completes.

Related Links


Add-BEFullBackupTask Help

Add-BEFullBackupTask Cmdlet
Synopsis

Adds a full backup to a backup definition in Backup Exec.

Syntax
Add-BEFullBackupTask -BackupDefinition [<BEBackupDefinition>] [[-Name] [<String>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-Storage [<BEStorage>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageExportMedia [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PreCommand [<String>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-PostCommand [<String>]] [-Schedule [<BESchedule>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Force [<SwitchParameter>]] [<CommonParameters>]

Add-BEFullBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [[-Name] [<String>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-OraclePerformBackupOffline [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PreCommand [<String>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-PostCommand [<String>]] [-Schedule [<BESchedule>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Adds a full backup to a backup definition in Backup Exec.

You can add a full backup to a new backup definition or edit a backup definition. You can also add a full backup to the backup job defaults.

To add a full backup to a new backup definition, use Add-BEFullBackupTask and New-BEBackupDefinition.

To edit backup definition and add a full backup, use Add-BEFullBackupTask and Get-BEBackupDefinition.

To add a full backup to the backup job defaults, use Add-BEFullBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

Specifies the type of data compression to use performed by the hardware or software. The Storage parameter must be set to a tape-based storage device.

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Allows backup data to be sent directly to the device specified in the Storage parameter from the Agent for Windows if the device supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

Specifies a command to run before the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

Specifies a command to run after the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Allows Backup Exec to check the return codes of the pre- and post-commands to determine if they completed successfully.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

Runs the backup job only if the pre-command is successful. If the pre-command fails, the job does not run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

Runs the post-command only if the pre-command is successful.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

Runs the post-command regardless of whether the job is successful or not.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

Runs the post-command after the verification completes if you selected to verify the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

Designates the number of minutes Backup Exec should wait before canceling a pre- or post-command that did not complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

Determines the location where the pre- and post-command run.

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

Runs a verify operation automatically when the backup job completes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

Specifies the type of consistency check to perform before the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

Specifies the type of consistency check to use after the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

For SQL 2005 or later, adds checksums to the SQL database data being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

Creates an on-disk copy of the SQL database being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

Specifies the path for the on-disk copy of the SQL database being backed up. CreateDiskCopy must be set to $true.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

For SQL 2008 or later, specifies the compression setting you want to use.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

Lets you delete the archived log files automatically after the backup.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

Enables Backup Exec to skip any archived logfiles that were already backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

Enables Backup Exec to take the database offline before you start the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

Backs up the selected data, verifies the media, and then deletes the data from the volume. Since the operation deletes the files and you must perform a restore to get the data back, you must specify the Force parameter when enabling this option.

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the full backup job.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

Confirms that the DeleteSelectedFilesAfterSuccessfulBackup parameter results in a loss of data and want to continue to use it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Add-BEFullBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Add-BEFullBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask * | Add-BEFullBackupTask | Save-BEBackupDefinition

These commands create a new backup definition for the local computer with an initial full backup and an additional full backup.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEFullBackupTask | Save-BEBackupDefinition

These commands add a full backup to a backup definition named "Backup Definition 01".

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Add-BEFullBackupTask | Save-BEBackupJobDefault

These commands add a differential backup to the back up to disk job defaults.

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BEAgentServer
Remove-BEBackupTask


Add-BEIncrementalBackupTask Help

Add-BEIncrementalBackupTask Cmdlet
Synopsis

Adds an incremental backup to a backup definition in Backup Exec.

Syntax
Add-BEIncrementalBackupTask -BackupDefinition [<BEBackupDefinition>] [[-Name] [<String>]] [-EncryptionKey [<BEEncryptionKey>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-VerifyAsPartOfJob [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlIncrementalBackupMethod {Log | Differential}] [-OraclePerformBackupOffline [<Boolean>]] [-DominoMarkArchiveLogsForRecycling [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-BackupSetDescription [<String>]] [-PreCommand [<String>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-PostCommand [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-Schedule [<BESchedule>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Add-BEIncrementalBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [[-Name] [<String>]] [-EncryptionKey [<BEEncryptionKey>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-VerifyAsPartOfJob [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlIncrementalBackupMethod {Log | Differential}] [-OraclePerformBackupOffline [<Boolean>]] [-DominoMarkArchiveLogsForRecycling [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-BackupSetDescription [<String>]] [-PreCommand [<String>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-PostCommand [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-Schedule [<BESchedule>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Adds an incremental backup to a backup definition in Backup Exec. A backup definition cannot contain a differential backup and an incremental backup.

You can add an incremental backup to a new backup definition or edit a backup definition. You can also add an incremental backup to the backup job defaults.

To add an incremental backup to a new backup definition, use Add-BEIncrementalBackupTask and New-BEBackupDefinition.

To edit a backup definition and add an incremental backup, use Add-BEIncrementalBackupTask and Get-BEBackupDefinition.

To add an incremental backup to the backup job defaults, use Add-BEIncrementalBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

Specifies the type of data compression to use performed by the hardware or software. The Storage parameter must be set to a tape-based storage device.

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Allows backup data to be sent directly to the device specified in the Storage parameter from the Agent for Windows if the device supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

Specifies a command to run before the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

Specifies a command to run after the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Allows Backup Exec to check the return codes of the pre- and post-commands to determine if they completed successfully.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

Runs the backup job only if the pre-command is successful. If the pre-command fails, the job does not run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

Runs the post-command only if the pre-command is successful.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

Runs the post-command regardless of whether the job is successful or not.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

Runs the post-command after the verification completes if you selected to verify the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

Designates the number of minutes Backup Exec should wait before canceling a pre- or post-command that did not complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

Determines the location where the pre- and post-command run.

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

Runs a verify operation automatically when the backup job completes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

Specifies the type of consistency check to perform before the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

Specifies the type of consistency check to use after the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

For SQL 2005 or later, adds checksums to the SQL database data being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

Creates an on-disk copy of the SQL database being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

Specifies the path for the on-disk copy of the SQL database being backed up. CreateDiskCopy must be set to $true.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

For SQL 2008 or later, specifies the compression setting you want to use.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

Lets you delete the archived log files automatically after the backup.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

Enables Backup Exec to skip any archived logfiles that were already backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

Enables Backup Exec to take the database offline before you start the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlIncrementalBackupMethod

Specifies the SQL incremental backup for the backup job.

The valid values are:
Log
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DominoMarkArchiveLogsForRecycling <Boolean>

Reuses the transaction log after it has been backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the incremental backup job.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Add-BEIncrementalBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Add-BEIncrementalBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask * | Add-BEIncrementalBackupTask | Save-BEBackupDefinition

These commands create a new backup definition for the local computer with an initial full and an incremental backup.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEIncrementalBackupTask | Save-BEBackupDefinition

These commands add an incremental backup to a backup definition named "Backup Definition 01".

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Add-BEIncrementalBackupTask | Save-BEBackupJobDefault

These commands add an incremental backup to the backup-to-disk job defaults.

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule
Get-BEAgentServer
Remove-BEBackupTask


Add-BEServerToBackupExecServerPool Help

Add-BEServerToBackupExecServerPool Cmdlet
Synopsis

Adds a managed Backup Exec server to a Backup Exec server pool.

Syntax
Add-BEServerToBackupExecServerPool -InputObject [<BEBackupExecServerPool[]>] [-BackupExecServer] [<BEBackupExecServer[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Adds a managed Backup Exec server to a Backup Exec server pool.

Parameters

-BackupExecServer <BEBackupExecServer[]>

The managed Backup Exec server to add to the pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

Specifies one or more Backup Exec server pool objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServerPool

You can pipe a Backup Exec server pool object to Add-BEServerToBackupExecServerPool.

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

Add-BEServerToBackupExecServerPool returns a Backup Exec server pool object.

Example

C:\PS> Get-BEBackupExecServerPool "Server Pool 0001" | Add-BEServerToBackupExecServerPool -BackupExecServer "MyManagedServer"

These commands add a managed Backup Exec server named "MyManagedServer" to a server pool named "Server Pool 0001".

Related Link

Get-BEBackupExecServerPool


Add-BESharePointFarmAgentServer Help

Add-BESharePointFarmAgentServer Cmdlet
Synopsis

Adds a SharePoint Farm to Backup Exec.

Syntax
Add-BESharePointFarmAgentServer [-Name] [<String>] [-LogonAccount] [<BELogonAccount>] -WebServerName [<String>] [-Description [<String>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-Force [<SwitchParameter>]] [<CommonParameters>]
Description

Adds a SharePoint Farm to Backup Exec.

Parameters

-WebServerName <String>

Specifies the name of a web server in the SharePoint Farm

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

Specifies a Backup Exec logon account to use to access the servers in the SharePoint Farm.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the SharePoint Farm.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the SharePoint Farm.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-Force <SwitchParameter>

Confirms that Add-BESharePointFarmAgentServer can establish a trust with all servers in the SharePoint Farm.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the SharePoint Farm object to add to Add-BESharePointFarmAgentServer.

Return Value
BackupExec.Management.CLI.BESharePointFarmAgentServer

Add-BESharePointFarmAgentServer returns the SharePoint Farm agent server that was added.

Example

C:\PS> Add-BESharePointFarmAgentServer -Name Farm01 -WebServerName webserver01 -LogonAccount "System Logon Account"

This command adds the SharePoint Farm of which the web server named "webserver01" is a member.


Add-BETapeDriveDeviceToRoboticLibraryPartition Help

Add-BETapeDriveDeviceToRoboticLibraryPartition Cmdlet
Synopsis

Adds a tape drive device to a robotic library partition in Backup Exec.

Syntax
Add-BETapeDriveDeviceToRoboticLibraryPartition -InputObject [<BERoboticLibraryPartition[]>] [-TapeDriveDevice] [<BETapeDriveDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Adds a tape drive device to a robotic library partition in Backup Exec.

The tape drive device must be attached to the robotic library device that is associated with the robotic library partition.

To create robotic library partitions, use the -SlotsPerPartition and -BERoboticLibraryDevice.

Parameters

-TapeDriveDevice <BETapeDriveDevice[]>

Tape device to add to the robotic library partition. See Get-BETapeDriveDevice.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibraryPartition[]>

Specifies one or more robotic library partition objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Add-BETapeDriveDeviceToRoboticLibraryPartition.

Return Value
BackupExec.Management.CLI.BERoboticLibraryPartition

Add-BETapeDriveDeviceToRoboticLibraryPartition outputs a Backup Exec robotic library partition object.

Example

C:\PS> Get-BERoboticLibraryDevice "Robotic library 0001" | Get-BERoboticLibraryPartition -FirstSlotNumber 1 | Add-BETapeDriveDeviceToRoboticLibraryPartition "Tape drive 0001"

These commands add a tape drive device named "Tape drive 0001" to the robotic library partition that starts with slot 1 in the robotic library device named "Robotic library 0001".

Related Links


Add-BEVerifyBackupTask Help

Add-BEVerifyBackupTask Cmdlet
Synopsis

Adds a verify task to a backup definition in Backup Exec.

Syntax
Add-BEVerifyBackupTask -BackupDefinition [<BEBackupDefinition>] [[-Name] [<String>]] -ImmediatelyAfterBackup [<String>] [-VerifyDataOnClient [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Add-BEVerifyBackupTask -BackupDefinition [<BEBackupDefinition>] [[-Name] [<String>]] -SourceBackup [<String[]>] -Schedule [<BESchedule>] [-VerifyDataOnClient [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Add-BEVerifyBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [[-Name] [<String>]] -ImmediatelyAfterBackup [<String>] [-VerifyDataOnClient [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Add-BEVerifyBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [[-Name] [<String>]] -SourceBackup [<String[]>] -Schedule [<BESchedule>] [-VerifyDataOnClient [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Adds a verify task to a backup definition in Backup Exec.

You can add a verify task to a new backup definition or edit an existing backup definition. You can also add a verify task to the backup job defaults.

To add a verify task to a new backup definition, use Add-BEVerifyBackupTask and New-BEBackupDefinition.

To edit a backup definition and add a verify task, use Add-BEVerifyBackupTask and Get-BEBackupDefinition.

To add a verify task to the backup job defaults, use Add-BEVerifyBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SourceBackup <String[]>

Specifies one or more backups in the backup definition to verify on a scheduled basis.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterBackup <String>

Specifies the name of the backup job in the backup definition to verify.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyDataOnClient <Boolean>

Lets you run the verify operation remotely, if the Backup Exec agent supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the verify task.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Add-BEVerifyBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Add-BEVerifyBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEVerifyBackupTask -SourceBackup Full,Incremental -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) | Save-BEBackupDefinition

These commands create a backup definition that verifies the data from a backup job named "Full" and "Incremental" every weekday at 10PM.

Example 2
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEVerifyBackupTask -ImmediatelyAfterBackup Full | Save-BEBackupDefinition

These commands create a backup definition that has a verify task that verfies the data from a backup job named "Full" after the backup job completes.

Related Links


Clear-BEAlert Help

Clear-BEAlert Cmdlet
Synopsis

Clears active Backup Exec alerts.

Syntax
Clear-BEAlert -InputObject [<BEAlert[]>] [-Response] {None | Ok | Cancel | Abort | Retry | Ignore | Yes | No | Try | Continue} [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Clears active Backup Exec alerts.

Use Get-BEAlert to get the active Backup Exec alerts.

Parameters

-Response

Specifies your response to the alert.

The valid values are:
None
Ok
Cancel
Abort
Retry
Ignore
Yes
No
Try
Continue

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAlert[]>

Specifies one or more alert objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAlert

You can pipe a Backup Exec alert object to Clear-BEAlert.

Return Value
BackupExec.Management.CLI.BEAlert

Clear-BEAlert returns an object that represents Backup Exec alert you cleared.

Example

C:\PS> Get-BEAlert -Severity Information | Clear-BEAlert -Response Ok

These commands clear all active Backup Exec informational alerts.

Related Link

Get-BEAlert


Export-BEBackupDefinition Help

Export-BEBackupDefinition Cmdlet
Synopsis

Exports a backup definition's job settings to a PowerShell script.

Syntax
Export-BEBackupDefinition [-BackupDefinition] <BEBackupDefinition> [<CommonParameters>]
Description

Exports a backup definition's job settings to a PowerShell script.

The script that Export-BEBackupDefinition generates is synonymous to a job policy in previous releases of Backup Exec.

The script can be used to create new backup jobs for additional agent servers and backup selections using the same job settings that were contained in the original backup definition.

Since the script is self-contained, it can be run on other Backup Exec servers.

In order to run the generated script, PowerShell's execution policy must set to a value that is less restrictive than AllSigned (e.g. RemoteSigned). For more information, see Get-Help Set-ExecutionPolicy.

Parameters

-BackupDefinition <BEBackupDefinition>

The backup definition to export.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a backup definition object to Export-BEBackupDefinition

Return Value
System.String

Export-BEBackupDefinition returns a PowerShell script capable of recreating the backup definition's job settings.

Example

C:\PS> Get-BEBackupDefinition "Backup 01" | Export-BEBackupDefinition > ExportedBackup01.ps1
C:\PS> Get-BEAgentServer "myserver.mycompany.com" | .\ExportedBackup01.ps1 -FileSystemSelection C:\Users\* | Save-BEBackupDefinition

These commands export the job settings of a backup definition named "Backup 01" to a PowerShell script file named "ExportedBackup01.ps1". The script file is then used to back up the C:\Users directory of a server named "myserver.mycompany.com" using the same job settings that were in the backup definition named "Backup 01".

Since the script file is self-contained, it can be copied to and run from a different Backup Exec server.

Related Links


Get-BEActiveJobDetail Help

Get-BEActiveJobDetail Cmdlet
Synopsis

Gets active job details in Backup Exec.

Syntax
Get-BEActiveJobDetail [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEActiveJobDetail -Job [<BEJob[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEActiveJobDetail [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEActiveJobDetail -InputObject [<BEActiveJobDetail[]>] [<CommonParameters>]
Description

Gets active job details in Backup Exec.

Without parameters, Get-BEActiveJobDetail gets all of the Backup Exec active job details. You can also specify an active job detail by active job detail name or active job detail ID (Guid) or pass a Backup Exec active job status object through the pipeline to Get-BEActiveJobDetail.

Parameters

-Job <BEJob[]>

Specifies one or more job objects to filter the active job details. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEJob.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more active job details by active job detail name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more active job details by active job detail ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEActiveJobDetail[]>

Specifies one or more active job detail objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to filter active job details returned by Get-BEActiveJobDetail.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec active job detail object to Get-BEActiveJobDetail.

BackupExec.Management.CLI.BEActiveJobDetail

You can pipe a Backup Exec active job detail object to Get-BEActiveJobDetail.

Return Value
BackupExec.Management.CLI.BEActiveJobDetail

Get-BEActiveJobDetail returns objects that represent Backup Exec active job details.

Examples

Example 1

C:\PS> Get-BEActiveJobDetail

This command gets all of the Backup Exec active job detail objects.

Example 2
C:\PS> Get-BEJob "Backup Job 0001" | Get-BEActiveJobDetail

These commands get the active job detail for a job named "Backup Job 0001".

Related Link

Get-BEJob


Get-BEAgentServer Help

Get-BEAgentServer Cmdlet
Synopsis

Gets agent servers in Backup Exec.

Syntax
Get-BEAgentServer [[-Name] [<String[]>]] [-BackupStatus {Unknown | BackupSucceeded | BackupSucceededWithExceptions | NeverBackedUp | FirstBackupScheduled | BackupCanceled | BackupFailed}] [<CommonParameters>]

Get-BEAgentServer [-Local [<SwitchParameter>]] [<CommonParameters>]

Get-BEAgentServer -LogonAccount [<BELogonAccount[]>] [[-Name] [<String[]>]] [-BackupStatus {Unknown | BackupSucceeded | BackupSucceededWithExceptions | NeverBackedUp | FirstBackupScheduled | BackupCanceled | BackupFailed}] [<CommonParameters>]

Get-BEAgentServer [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEAgentServer -InputObject [<BEAgentServer[]>] [<CommonParameters>]
Description

Gets agent servers in Backup Exec.

Agent server objects represent servers that can be backed up or restored and associated with logon accounts.

Without parameters, Get-BEAgentServer gets all of the Backup Exec agent servers. You can also specify an agent server by agent server name or agent server ID (Guid) or pass a Backup Exec agent server object through the pipeline to Get-BEAgentServer.

To get the agent server object that represents the local computer, specify the -Local parameter.

Parameters

-Local <SwitchParameter>

Gets the agent server object for the local computer.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount[]>

Specifies one or more logon account objects to filter the agent servers. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BELogonAccount.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more agent servers by agent server name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-BackupStatus

Specifies one or more backup status objects to filter the agent servers. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupStatus.

The valid values are:
Unknown
BackupSucceeded
BackupSucceededWithExceptions
NeverBackedUp
FirstBackupScheduled
BackupCanceled
BackupFailed

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

Specifies one or more agent servers by agent server ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEAgentServer[]>

Specifies one or more agent server objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object to filter agent servers returned by Get-BEAgentServer.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec agent server object to Get-BEAgentServer.

BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to Get-BEAgentServer.

Return Value
BackupExec.Management.CLI.BEAgentServer

Get-BEAgentServer returns objects that represent Backup Exec agent servers.

Examples

Example 1

C:\PS> Get-BEAgentServer

This command gets all of the agent servers.

Example 2
C:\PS> Get-BEAgentServer -Name "myserver.mycompany.com"

This command gets the agent server named "myserver.mycompany.com".

Example 3
C:\PS> Get-BEAgentServer -Name "*.mycompany.com"

This command gets all of the agent servers that match the wildcard "*.mycompany.com".

Example 4
C:\PS> Get-BEAgentServer -Local

This command gets the agent server for the local computer.

Example 5
C:\PS> Get-BEAgentServer -Local | Set-BEAgentServerBackupSource

These commands get the backup sources for the local computer.

Example 6
C:\PS> Get-BEAgentServer -Local | Set-BEAgentServer -LogonAccount "System Logon Account"

These commands set the logon account for the agent server representing the local computer.

Example 7
C:\PS> Get-BEAgentServer -Local | Test-BELogonAccount

These commands test the logon account for the agent server representing the local computer.

Example 8
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackup

These commands submit a one-time backup that backs up the entire local computer.

Example 9
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Save-BEBackupDefinition

These commands submit a backup definition that backs up the entire local computer.

Related Links


Get-BEAgentServerBackupSource Help

Get-BEAgentServerBackupSource Cmdlet
Synopsis

Gets agent server backup sources in Backup Exec.

Syntax
Get-BEAgentServerBackupSource -AgentServer [<BEAgentServer>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEAgentServerBackupSource -InputObject [<BEAgentServerBackupSource[]>] [-Children [<SwitchParameter>]] [<CommonParameters>]

Get-BEAgentServerBackupSource [-Id] [<Guid[]>] [<CommonParameters>]
Description

Gets agent server backup sources in Backup Exec.

Agent server backup sources represent resources of an agent server that can be backed up and associated with logon accounts.

To get the top-level agent server backup sources associated with an agent server, Get-BEAgentServerBackupSource requires an agent server object. See Get-BEAgentServer.

Without any additional parameters, Get-BEAgentServerBackupSource gets all of the Backup Exec agent server backup sources. You can also specify an agent server backup source by agent server backup source name or agent server backup source ID (Guid) or pass a Backup Exec agent server backup source object through the pipeline to Get-BEAgentServerBackupSource.

Parameters

-AgentServer <BEAgentServer>

Specifies the agent server that you want to get the agent server backup sources.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Children <SwitchParameter>

Gets the children agent server backups sources associated with the agent server backup source object specified by the -InputObject parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServerBackupSource[]>

Specifies one or more agent server backup source objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more agent server backup sources by agent server backup source name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more agent server backup sources by agent server backup source ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

You an pipe a Backup Exec agent server object to Get-BEAgentServerBackupSource.

BackupExec.Management.CLI.BEAgentServerBackupSource

You can pipe a Backup Exec agent server backup source object to Get-BEAgentServerBackupSource.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec agent server backup source object to Get-BEAgentServerBackupSource.

Return Value
BackupExec.Management.CLI.BEAgentServerBackupSource

Get-BEAgentServerBackupSource returns objects that represent Backup Exec agent server backup sources.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | Get-BEAgentServerBackupSource

These commands get the top-level agent server backup sources associated with the local computer.

Example 2
C:\PS> Get-BEAgentServer -Local | Get-BEAgentServerBackupSource "Microsoft SQL Server Instances" | Get-BEAgentServerBackupSource -Children

These commands get the Microsoft SQL instance backup sources associated with the local computer.

Example 3
C:\PS> Get-BEAgentServer -Local | Get-BEAgentServerBackupSource C: | Set-BEAgentServerBackupSource -LogonAccount "System Logon Account"

These commands set the logon account associated with the C: volume of the local computer.

Example 4
C:\PS> Get-BEAgentServer -Local | Get-BEAgentServerBackupSource C: | Test-BELogonAccount

These commands test the logon account associated with the C: volume of the local computer.

Related Links


Get-BEAlert Help

Get-BEAlert Cmdlet
Synopsis

Gets active Backup Exec alerts.

Syntax
Get-BEAlert [[-Name] [<String[]>]] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | ArchivingOptionOperationInformation | ArchivingOptionOperationFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlert -Storage [<BEStorage[]>] [[-Name] [<String[]>]] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | ArchivingOptionOperationInformation | ArchivingOptionOperationFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlert -Job [<BEJob[]>] [[-Name] [<String[]>]] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | ArchivingOptionOperationInformation | ArchivingOptionOperationFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlert -AgentServer [<BEAgentServer[]>] [[-Name] [<String[]>]] [-Category {None | JobWarning | JobSuccess | JobFailure | JobCancellation | CatalogError | SoftwareUpdateInformation | SoftwareUpdateWarning | SoftwareUpdateError | InstallInformation | InstallWarning | GeneralInformation | DatabaseMaintenanceInformation | DatabaseMaintenanceFailure | BackupExecRetrieveUrlUpdateInformation | BackupExecRetrieveUrlUpdateFailure | ArchivingOptionOperationInformation | ArchivingOptionOperationFailure | IdrCopyFailed | IdrFullBackupSuccess | BackupJobContainsNoData | JobCompletedWithExceptions | JobStart | ServiceStart | ServiceStop | DeviceError | DeviceWarning | DeviceInformation | DeviceIntervention | MediaError | MediaWarning | MediaInformation | MediaIntervention | MediaInsert | MediaOverwrite | MediaRemove | LibraryInsert | TapeAlertInformation | TapeAlertWarning | TapeAlertError}] [-Severity {None | Information | Question | Warning | Error}] [<CommonParameters>]

Get-BEAlert [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEAlert -InputObject [<BEAlert[]>] [<CommonParameters>]
Description

Gets active Backup Exec alerts.

Without parameters, Get-BEAlert gets all of the active Backup Exec alerts. You can also specify an alert by alert name or alert ID (Guid) or pass a Backup Exec alert object through the pipeline to Get-BEAlert.

Parameters

-Storage <BEStorage[]>

Specifies one or more storage objects to filter the alerts. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEStorage.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Job <BEJob[]>

Specifies one or more job objects to filter the alerts. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEJob.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

Specifies one or more agent server objects to filter the alerts. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEAgentServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more alerts by alert name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Severity

Specifies one or more severity values to filter the alerts. To specify multiple values, use commas to separate the values.

The valid values are:
None
Information
Question
Warning
Error

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Category

Specifies one or more category values to filter the alerts. To specify multiple values, use commas to separate the values.

The valid values are:
None
JobWarning
JobSuccess
JobFailure
JobCancellation
CatalogError
SoftwareUpdateInformation
SoftwareUpdateWarning
SoftwareUpdateError
InstallInformation
InstallWarning
GeneralInformation
DatabaseMaintenanceInformation
DatabaseMaintenanceFailure
BackupExecRetrieveUrlUpdateInformation
BackupExecRetrieveUrlUpdateFailure
ArchivingOptionOperationInformation
ArchivingOptionOperationFailure
IdrCopyFailed
IdrFullBackupSuccess
BackupJobContainsNoData
JobCompletedWithExceptions
JobStart
ServiceStart
ServiceStop
DeviceError
DeviceWarning
DeviceInformation
DeviceIntervention
MediaError
MediaWarning
MediaInformation
MediaIntervention
MediaInsert
MediaOverwrite
MediaRemove
LibraryInsert
TapeAlertInformation
TapeAlertWarning
TapeAlertError

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

Specifies one or more alerts by alert ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEAlert[]>

Specifies one or more alert objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

You can pipe a Backup Exec storage object to filter alerts returned by Get-BEAlert.

BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to filter alerts returned by Get-BEAlert.

BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to filter alerts returned by Get-BEAlert.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec alert object to Get-BEAlert.

BackupExec.Management.CLI.BEAlert

You can pipe a Backup Exec alert object to Get-BEAlert.

Return Value
BackupExec.Management.CLI.BEAlert

Get-BEAlert returns objects that represent Backup Exec alerts.

Examples

Example 1

C:\PS> Get-BEAlert

This command gets all of the active Backup Exec alerts.

Example 2
C:\PS> @(Get-BEAlert -Severity Error).Count

This command gets the number of active error alerts.

Example 3
C:\PS> Get-BEAlert -Severity Information | Clear-BEAlert -Response Ok

These commands clear all of the active informational alerts.

Example 4
C:\PS> Get-BEAgentServer myserver.mycompany.com | Get-BEAlert

These commands get all of the active alerts for a computer named "myserver.mycompany.com".

Example 5
C:\PS> Get-BEDiskStorageDevice "Disk storage 0001" | Get-BEAlert

These commands get all of the active alerts for a disk storage device named "Disk storage 0001".

Example 6
C:\PS> Get-BEJob "Backup of myserver.mycompany.com" | Get-BEAlert

These commands get all of the active alerts for a job named "Backup of myserver.mycompany.com".

Related Links


Get-BEAlertCategory Help

Get-BEAlertCategory Cmdlet
Synopsis

Gets alert categories in Backup Exec.

Syntax
Get-BEAlertCategory [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEAlertCategory [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEAlertCategory -InputObject [<BEAlertCategory[]>] [<CommonParameters>]
Description

Gets alert categories in Backup Exec.

Without parameters, Get-BEAlertCategory gets all of the Backup Exec alert categories. You can also specify an alert category by alert category name or alert category ID (Guid) or pass a Backup Exec alert category object through the pipeline to Get-BEAlertCategory.

Parameters

-Name <String[]>

Specifies one or more alert categories by alert category name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more alert categories by alert category ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEAlertCategory[]>

Specifies one or more alert category objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec alert category object to Get-BEAlertCategory.

BackupExec.Management.CLI.BEAlertCategory

You can pipe a Backup Exec alert category object to Get-BEAlertCategory.

Return Value
BackupExec.Management.CLI.BEAlertCategory

Get-BEAlertCategory returns objects that represent Backup Exec alert categories.

Examples

Example 1

C:\PS> Get-BEAlertCategory

This command gets all of the alert categories.

Example 2
C:\PS> Get-BEAlertCategory -Name "Job Completed with Exceptions"

This command gets the alert category named "Job Completed with Exceptions".

Example 3
C:\PS> Get-BEAlertCategory -Name "Job*"

This command gets all of the alert categories that match the wildcard "Job*".

Example 4
C:\PS> Get-BEAlertCategory -Name "Job Start" | Set-BEAlertCategory -Enabled $true

These commands enabled the alert category named "Job Start".

Related Link

Set-BEAlertCategory


Get-BEBackupDefinition Help

Get-BEBackupDefinition Cmdlet
Synopsis

Gets backup definitions in Backup Exec.

Syntax
Get-BEBackupDefinition [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEBackupDefinition -AgentServer [<BEAgentServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEBackupDefinition [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEBackupDefinition -InputObject [<BEBackupDefinition[]>] [<CommonParameters>]
Description

Gets backup definitions in Backup Exec.

Without parameters, Get-BEBackupDefinition gets all of the Backup Exec backup definitions. You can also specify an backup definition by backup definition name or backup definition ID (Guid) or pass a backup definition object through the pipeline to Get-BEBackupDefinition.

Get-BEBackupDefinition can be used with the following commands to modify the tasks in the backup definition: Set-BEBackupDefinition, Add-BEIncrementalBackupTask, Add-BEDifferentialBackupTask, Add-BEDuplicateStageBackupTask, Add-BEConvertToVirtualStageBackupTask, Add-BEVerifyBackupTask, Set-BEIncrementalBackupTask, Set-BEDifferentialBackupTask, Set-BEDuplicateStageBackupTask, Set-BEVerifyBackupTask, and Remove-BEBackupTask.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

Parameters

-AgentServer <BEAgentServer[]>

Specifies one or more agent server objects to filter the backup definitions. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEAgentServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more backup definitions by backup definition name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more backup definitions by backup definition ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEBackupDefinition[]>

Specifies one or more backup definition objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to filter backup definitions returned by Get-BEBackupDefinition.

System.Guid

You can pipe a System.Guid that contains the ID of a backup definition object to Get-BEBackupDefinition.

BackupExec.Management.CLI.BEBackupDefinition

You can pipe a backup definition object to Get-BEBackupDefinition.

Return Value
BackupExec.Management.CLI.BEBackupDefinition

Get-BEBackupDefinition returns objects that represent Backup Exec backup definitions.

Examples

Example 1

C:\PS> Get-BEBackupDefinition

This command gets all of the backup definitions.

Example 2
C:\PS> Get-BEBackupDefinition -Name "Backup Definition 01"

This command gets the backup definition named "Backup Definition 01".

Example 3
C:\PS> Get-BEBackupDefinition -Name "Backup*"

This command gets all of the backup definitions that match the wildcard "Backup*".

Example 4
C:\PS> Get-BEAgentServer -Local | Get-BEBackupDefinition

These commands get all of the backup definitions for the local computer.

Example 5
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEBackupDefinition -FileSystemSelection D:\* | Save-BEBackupDefinition

These commands add D:\* to the backup selections for the backup definition named "Backup Definition 01".

Example 6
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

These commands add a differential backup to a backup definition named "Backup Definition 01".

Related Links

Set-BEBackupDefinition
Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEConvertToVirtualStageBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupDefinition
Get-BEAgentServer


Get-BEBackupExecServer Help

Get-BEBackupExecServer Cmdlet
Synopsis

Gets servers in Backup Exec.

Syntax
Get-BEBackupExecServer [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEBackupExecServer [-Local [<SwitchParameter>]] [<CommonParameters>]

Get-BEBackupExecServer [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEBackupExecServer -InputObject [<BEBackupExecServer[]>] [<CommonParameters>]
Description

Gets servers in Backup Exec.

When run on a Backup Exec server that is not a central administration server, Get-BEBackupExecServer returns the local Backup Exec server.

Without parameters, Get-BEBackupExecServer gets all of the managed Backup Exec servers in the CASO environment. You can also specify a managed Backup Exec server by Backup Exec server name or Backup Exec server ID (Guid) or pass a Backup Exec server object through the pipeline to Get-BEBackupExecServer.

Parameters

-Local <SwitchParameter>

Gets the Backup Exec server object for the local computer.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more Backup Exec servers by server name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more Backup Exec servers by server ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec server object to Get-BEBackupExecServer.

BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to Get-BEBackupExecServer.

Return Value
BackupExec.Management.CLI.BEBackupExecServer

Get-BEBackupExecServer returns objects that represent Backup Exec servers.

Examples

Example 1

C:\PS> Get-BEBackupExecServer

This command gets all of the Backup Exec servers.

Example 2
C:\PS> Get-BEBackupExecServer -Name "MyManagedServer"

This command gets the Backup Exec server named "MyManagedServer"

Example 3
C:\PS> Get-BEBackupExecServer -Name "*Managed*"

This command gets all of the Backup Exec servers that match the wildcard "*Managed*"

Example 4
C:\PS> Get-BEBackupExecServer -Local

This command gets the local Backup Exec server.

Example 5
C:\PS> Get-BEBackupExecServer -Local | Get-BEStorage

This command gets all of the backup storage accessible to the local Backup Exec server.

Related Link

Get-BEStorage


Get-BEBackupExecServerPool Help

Get-BEBackupExecServerPool Cmdlet
Synopsis

Gets Backup Exec server pools.

Syntax
Get-BEBackupExecServerPool [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEBackupExecServerPool [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEBackupExecServerPool -InputObject [<BEBackupExecServerPool[]>] [<CommonParameters>]
Description

Gets Backup Exec server pools.

Without parameters, Get-BEBackupExecServerPool gets all of the Backup Exec server pools. You can also specify a Backup Exec server pool by server pool name or server pool ID (Guid) or pass a Backup Exec server pool object through the pipeline to Get-BEBackupExecServerPool.

Parameters

-Name <String[]>

Specifies one or more Backup Exec server pools by server pool name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more Backup Exec server pools by server pool ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

Specifies one or more Backup Exec server pool objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec server pool object to Get-BEBackupExecServerPool.

BackupExec.Management.CLI.BEBackupExecServerPool

You can pipe a Backup Exec server pool object to Get-BEBackupExecServerPool.

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

Get-BEBackupExecServerPool returns objects that represent Backup Exec server pools.

Examples

Example 1

C:\PS> Get-BEBackupExecServerPool

This command returns all the Backup Exec server pools.

Example 2
C:\PS> Get-BEBackupExecServerPool -Name "Server Pool 0001"

This command returns the Backup Exec server pool named "Server Pool 0001".


Get-BEBackupExecSetting Help

Get-BEBackupExecSetting Cmdlet
Synopsis

Gets global Backup Exec settings.

Syntax
Get-BEBackupExecSetting [<CommonParameters>]
Description

Gets global Backup Exec settings.

To modify the settings, use Set-BEBackupExecSetting.

Parameters

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
BackupExec.Management.CLI.BEBackupExecSettings

Get-BEBackupExecSetting returns an object that represents global Backup Exec settings.

Example

C:\PS> Get-BEBackupExecSetting

This command gets the global Backup Exec settings.

Related Link

Set-BEBackupExecSetting


Get-BEBackupJobDefault Help

Get-BEBackupJobDefault Cmdlet
Synopsis

Gets Backup Exec job defaults.

Syntax
Get-BEBackupJobDefault [-BackupJobDefaultType] {BackupToDisk | BackupToDiskCartridge | BackupToDeduplication | BackupToTape} [<CommonParameters>]
Description

Gets Backup Exec job defaults.

Get-BEBackupJobDefault can be used with the following commands to modify the tasks in the backup job defaults: Set-BEBackupJobDefault, Add-BEIncrementalBackupTask, Add-BEDifferentialBackupTask, Add-BEVerifyBackupTask, Set-BEIncrementalBackupTask, Set-BEDifferentialBackupTask, Set-BEVerifyBackupTask, and Remove-BEBackupTask.

When you edit backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupJobDefaultType

Specifies the type of backup job defaults to edit.

The valid values are:
BackupToDisk
BackupToDiskCartridge
BackupToDeduplication
BackupToTape

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
BackupExec.Management.CLI.BEBackupJobDefaults

Get-BEBackupJobDefault returns an object that represents Backup Exec job defaults.

Examples

Example 1

C:\PS> Get-BEBackupJobDefault BackupToDisk

This command gets the backup-to-disk job defaults.

Example 2
C:\PS> Get-BEBackupJobDefault BackupToTape | Add-BEDifferentalBackupTask | Save-BEBackupJobDefault

These commands add a differential backup to the backup-to-tape job defaults.

Related Links

Set-BEBackupJobDefault
Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupJobDefault


Get-BEBarcodeRule Help

Get-BEBarcodeRule Cmdlet
Synopsis

Gets barcode rules in Backup Exec.

Syntax
Get-BEBarcodeRule [[-Name] [<String[]>]] [-BarcodePrefix [<String[]>]] [-BarcodeSuffix [<String[]>]] [-Vendor [<String[]>]] [<CommonParameters>]

Get-BEBarcodeRule -MediaType [<BEMediaType[]>] [[-Name] [<String[]>]] [-BarcodePrefix [<String[]>]] [-BarcodeSuffix [<String[]>]] [-Vendor [<String[]>]] [<CommonParameters>]

Get-BEBarcodeRule [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEBarcodeRule -InputObject [<BEBarcodeRule[]>] [<CommonParameters>]
Description

Gets barcode rules in Backup Exec.

Without parameters, Get-BEBarcodeRule gets all of the Backup Exec barcode rules. You can also specify a barcode rule by barcode rule name or barcode rule ID (Guid) or pass a Backup Exec barcode rule object through the pipeline to Get-BEBarcodeRule.

Parameters

-MediaType <BEMediaType[]>

Specifies one or more media type objects to filter the barcode rules. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMediaType.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more barcode rules by barcode rule name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Vendor <String[]>

Specifies one or more vendor values to filter the barcode rules. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodePrefix <String[]>

Specifies one or more barcode prefix values to filter the barcode rules. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodeSuffix <String[]>

Specifies one or more barcode suffix values to filter the barcode rules. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

Specifies one or more barcode rules by barcode rule ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEBarcodeRule[]>

Specifies one or more barcode rule objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEMediaType

You can pipe a Backup Exec media type object to filter barcode rules returned by Get-BEBarcodeRule.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec barcode rule object to Get-BEBarcodeRule.

BackupExec.Management.CLI.BEBarcodeRule

You can pipe a Backup Exec barcode rule object to Get-BEBarcodeRule.

Return Value
BackupExec.Management.CLI.BEBarcodeRule

Get-BEBarcodeRule returns objects that represent Backup Exec barcode rules.

Examples

Example 1

C:\PS> Get-BEBarcodeRule

This command gets all of the barcode rules.

Example 2
C:\PS> Get-BEBarcodeRule -BarcodePrefix CLN

This command gets all of the barcode rules that have the barcode prefix named "CLN".

Example 3
C:\PS> Get-BEMediaType LTO-100 | Get-BEBarcodeRule

These commands get the barcode rules associated with the LTO-100 media type.

Related Link

Get-BEMediaType


Get-BECloudStorageDevice Help

Get-BECloudStorageDevice Cmdlet
Synopsis

Gets Backup Exec cloud storage devices.

Syntax
Get-BECloudStorageDevice [[-Name] [<String[]>]] [<CommonParameters>]

Get-BECloudStorageDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BECloudStorageDevice -LogonAccount [<BELogonAccount[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BECloudStorageDevice [-Id] [<Guid[]>] [<CommonParameters>]

Get-BECloudStorageDevice -InputObject [<BECloudStorageDevice[]>] [<CommonParameters>]
Description

Gets Backup Exec cloud storage devices.

Without parameters, Get-BECloudStorageDevice gets all of the Backup Exec cloud storage devices. You can also specify a particular cloud storage device by cloud storage device name or cloud storage device ID (Guid) or pass a Backup Exec cloud storage device object through the pipeline to Get-BECloudStorageDevice.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the cloud storage devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount[]>

Specifies one or more logon account objects to filter the cloud storage devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BELogonAccount.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more cloud storage devices by cloud storage device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more cloud storage devices by cloud storage device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BECloudStorageDevice[]>

Specifies one or more cloud storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter cloud storage devices returned by Get-BECloudStorageDevice.

BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object as a means to filter cloud storage devices returned by Get-BECloudStorageDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec cloud storage device object to Get-BECloudStorageDevice.

BackupExec.Management.CLI.BECloudStorageDevice

You can pipe a Backup Exec cloud storage device object to Get-BECloudStorageDevice.

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

Get-BECloudStorageDevice returns objects that represent Backup Exec cloud storage devices.

Examples

Example 1

C:\PS> Get-BECloudStorageDevice

This command gets all of the cloud storage devices.

Example 2
C:\PS> Get-BECloudStorageDevice -Name "Device 01"

This command gets the cloud storage device named "Device 01".

Example 3
C:\PS> Get-BECloudStorageDevice -Name "Device*"

This command gets all of the cloud storage devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BECloudStorageDevice

This command gets all of the cloud storage devices attached to the local Backup Exec server.

Related Links


Get-BECloudStorageServerType Help

Get-BECloudStorageServerType Cmdlet
Synopsis

Gets the registered cloud storage server types installed on the Backup Exec server.

Syntax
Get-BECloudStorageServerType [-BackupExecServer [<BEBackupExecServer>]] [<CommonParameters>]
Description

Gets the registered cloud storage server types installed on the Backup Exec server.

The values returned by Get-BECloudStorageServerType can be used as the value for the ServerType parameter for the New-BECloudStorageDevice command.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server to get the cloud storage server types from.

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to Get-BECloudStorageServerType.

Return Value
System.String

The registered cloud storage server types.

Example

C:\PS> Get-BECloudStorageServerType

This command gets all of the cloud storage server types registered on the local Backup Exec server.

Related Link

New-BECloudStorageDevice


Get-BEDeduplicationDiskStorageDevice Help

Get-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Gets deduplication disk storage devices in Backup Exec.

Syntax
Get-BEDeduplicationDiskStorageDevice [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEDeduplicationDiskStorageDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEDeduplicationDiskStorageDevice -LogonAccount [<BELogonAccount[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEDeduplicationDiskStorageDevice [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEDeduplicationDiskStorageDevice -InputObject [<BEDeduplicationDiskStorageDevice[]>] [<CommonParameters>]
Description

Gets deduplication disk storage devices in Backup Exec.

Without parameters, Get-BEDeduplicationDiskStorageDevice gets all of the Backup Exec deduplication disk storage devices. You can also specify a deduplication disk storage device by deduplication disk storage device name or deduplication disk storage device ID (Guid) or pass a Backup Exec deduplication disk storage device object through the pipeline to Get-BEDeduplicationDiskStorageDevice.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the deduplication disk storage devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount[]>

Specifies one or more logon account objects to filter the deduplication disk storage devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BELogonAccount.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more deduplication disk storage devices by deduplication disk storage device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more deduplication disk storage devices by deduplication disk storage device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEDeduplicationDiskStorageDevice[]>

Specifies one or more deduplication disk storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter deduplication disk storage devices returned by Get-BEDeduplicationDiskStorageDevice.

BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object to filter deduplication disk storage devices returned by Get-BEDeduplicationDiskStorageDevice.

BackupExec.Management.CLI.BEStorageArrayDevice

You can pipe a Backup Exec storage array device object to filter deduplication disk storage devices returned by Get-BEDeduplicationDiskStorageDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec deduplication disk storage device object to Get-BEDeduplicationDiskStorageDevice.

BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

You can pipe a Backup Exec deduplication disk storage device object to Get-BEDeduplicationDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Get-BEDeduplicationDiskStorageDevice returns objects that represent Backup Exec deduplication disk storage devices.

Examples

Example 1

C:\PS> Get-BEDeduplicationDiskStorageDevice

This command gets all of the deduplication disk storage devices.

Example 2
C:\PS> Get-BEDeduplicationDiskStorageDevice -Name "Device 01"

This command gets the deduplication disk storage device named "Device 01".

Example 3
C:\PS> Get-BEDeduplicationDiskStorageDevice -Name "Device*"

This command gets all of the deduplication disk storage devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEDeduplicationDiskStorageDevice

This command gets all of the deduplication disk storage devices attached to the local Backup Exec server.

Related Links


Get-BEDiskCartridgeDevice Help

Get-BEDiskCartridgeDevice Cmdlet
Synopsis

Gets disk cartridge devices in Backup Exec.

Syntax
Get-BEDiskCartridgeDevice [[-Name] [<String[]>]] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEDiskCartridgeDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEDiskCartridgeDevice -Media [<BEMedia[]>] [[-Name] [<String[]>]] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEDiskCartridgeDevice [-Id] [<Guid[]>] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEDiskCartridgeDevice -InputObject [<BEDiskCartridgeDevice[]>] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]
Description

Gets disk cartridge devices in Backup Exec.

Without parameters, Get-BEDiskCartridgeDevice gets all of the Backup Exec disk cartridge devices. You can also specify a disk cartridge device by disk cartridge device name or disk cartridge device ID (Guid) or pass a Backup Exec disk cartridge device object through the pipeline to Get-BEDiskCartridgeDevice.

By default, Get-BEDiskCartridgeDevice does not return unconfigured disk cartridge devices. Specify the -Unconfigured parameter to get unconfigured disk cartridge devices.

Parameters

-Unconfigured <SwitchParameter>

Returns unconfigured disk cartridge devices.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the disk cartridge devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Media <BEMedia[]>

Specifies one or more Backup Exec media objects to filter the disk cartridge devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMedia.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more disk cartridge devices by disk cartridge device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more disk cartridge devices by disk cartridge device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEDiskCartridgeDevice[]>

Specifies one or more disk cartridge device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter disk cartridge devices returned by Get-BEDiskCartridgeDevice.

BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to filter disk cartridge devices returned by Get-BEDiskCartridgeDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec disk cartridge device object to Get-BEDiskCartridgeDevice.

BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Get-BEDiskCartridgeDevice.

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

Get-BEDiskCartridgeDevice returns objects that represent Backup Exec disk cartridge devices.

Examples

Example 1

C:\PS> Get-BEDiskCartridgeDevice

This command gets all of the disk cartridge devices.

Example 2
C:\PS> Get-BEDiskCartridgeDevice -Name "Device 01"

This command gets the disk cartridge device named "Device 01".

Example 3
C:\PS> Get-BEDiskCartridgeDevice -Name "Device*"

This command gets all of the disk cartridge devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEDiskCartridgeDevice

This command gets all of the disk cartridge devices attached to the local Backup Exec server.

Related Links


Get-BEDiskStorageDevice Help

Get-BEDiskStorageDevice Cmdlet
Synopsis

Gets disk storage devices in Backup Exec.

Syntax
Get-BEDiskStorageDevice [[-Name] [<String[]>]] [-DriveLetter [<String[]>]] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEDiskStorageDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [-DriveLetter [<String[]>]] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEDiskStorageDevice [-Id] [<Guid[]>] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEDiskStorageDevice -InputObject [<BEDiskStorageDevice[]>] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]
Description

Gets disk storage devices in Backup Exec.

Without parameters, Get-BEDiskStorageDevice gets all of the Backup Exec disk storage devices. You can also specify a disk storage device by disk storage device name or disk storage device ID (Guid) or pass a Backup Exec disk storage device object through the pipeline to Get-BEDiskStorageDevice.

By default, Get-BEDiskStorageDevice does not return unconfigured disk storage devices. Specify the -Unconfigured parameter to get unconfigured disk storage devices.

Parameters

-Unconfigured <SwitchParameter>

Returns unconfigured disk storage devices.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the disk storage devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more disk storage devices by disk storage device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-DriveLetter <String[]>

Specifies one or more drive letter values to filter the disk storage devices. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

Specifies one or more disk storage devices by disk storage device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEDiskStorageDevice[]>

Specifies one or more disk storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter disk storage devices returned by Get-BEDiskStorageDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec disk storage device object to Get-BEDiskStorageDevice.

BackupExec.Management.CLI.BEDiskStorageDevice

You can pipe a Backup Exec disk storage device object to Get-BEDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Get-BEDiskStorageDevice returns objects that represent Backup Exec disk storage devices.

Examples

Example 1

C:\PS> Get-BEDiskStorageDevice

This command gets all of the disk storage devices.

Example 2
C:\PS> Get-BEDiskStorageDevice -Name "Device 01"

This command gets the disk storage device named "Device 01".

Example 3
C:\PS> Get-BEDiskStorageDevice -Name "Device*"

This command gets all of the disk storage devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEDiskStorageDevice

This command gets all of the disk storage devices attached to the local Backup Exec server.

Related Link

Get-BEBackupExecServer


Get-BEEncryptionKey Help

Get-BEEncryptionKey Cmdlet
Synopsis

Gets encryption keys in Backup Exec.

Syntax
Get-BEEncryptionKey [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEEncryptionKey [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEEncryptionKey -InputObject [<BEEncryptionKey[]>] [<CommonParameters>]
Description

Gets encryption keys in Backup Exec.

Without parameters, Get-BEEncryptionKey gets all of the Backup Exec encryption keys. You can also specify an encryption key by encryption key name or encryption key ID (Guid) or pass a Backup Exec encryption key object through the pipeline to Get-BEEncryptionKey.

Parameters

-Name <String[]>

Specifies one or more encryption keys by encryption key name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more encryption keys by encryption key ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEEncryptionKey[]>

Specifies one or more encryption key objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec encryption key object to Get-BEEncryptionKey.

BackupExec.Management.CLI.BEEncryptionKey

You can pipe a Backup Exec encryption key object to Get-BEEncryptionKey.

Return Value
BackupExec.Management.CLI.BEEncryptionKey

Get-BEEncryptionKey returns objects that represent Backup Exec encryption keys.

Examples

Example 1

C:\PS> Get-BEEncryptionKey

This command gets all of the encryption keys.

Example 2
C:\PS> Get-BEEncryptionKey -Name "Encryption Key 01"

This command gets the encryption key named "Encryption Key 01".

Example 3
C:\PS> Get-BEEncryptionKey -Name "Encryption Key*"

This command gets all of the encryption keys that match the wildcard "Encryption Key*".


Get-BEErrorHandlingRule Help

Get-BEErrorHandlingRule Cmdlet
Synopsis

Gets error handling rules in Backup Exec.

Syntax
Get-BEErrorHandlingRule [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEErrorHandlingRule [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEErrorHandlingRule -InputObject [<BEErrorHandlingRule[]>] [<CommonParameters>]
Description

Gets error handling rules in Backup Exec.

Without parameters, Get-BEErrorHandlingRule gets all of the Backup Exec error handling rules. You can also specify an error handling rule by error handling rule name or error handling rule ID (Guid) or pass a Backup Exec error handling rule object through the pipeline to Get-BEErrorHandlingRule.

Parameters

-Name <String[]>

Specifies one or more error handling rules by error handling rule name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more error handling rules by error handling rule ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEErrorHandlingRule[]>

Specifies one or more error handling rule objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec error handling rule object to Get-BEErrorHandlingRule.

BackupExec.Management.CLI.BEErrorHandlingRule

You can pipe a Backup Exec error handling rule object to Get-BEErrorHandlingRule.

Return Value
BackupExec.Management.CLI.BEErrorHandlingRule

Get-BEErrorHandlingRule returns objects that represent Backup Exec error handling rules.

Examples

Example 1

C:\PS> Get-BEErrorHandlingRule

This command gets all of the error handling rules.

Example 2
C:\PS> Get-BEErrorHandlingRule -Name "Job Cancellation"

This command gets the error handling rule named "Job Cancellation".

Example 3
C:\PS> Get-BEErrorHandlingRule -Name "*Job*"

This command gets all of the error handling rules that match the wildcard "*Job*".


Get-BEJob Help

Get-BEJob Cmdlet
Synopsis

Gets jobs in Backup Exec.

Syntax
Get-BEJob [[-Name] [<String[]>]] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | Incremental | Differential | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Archive | Verify | DelayedCatalog | ExportMediaToVault | TestRun}] [-IsActive [<Boolean>]] [-TaskName [<String[]>]] [<CommonParameters>]

Get-BEJob -Storage [<BEStorage[]>] [[-Name] [<String[]>]] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | Incremental | Differential | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Archive | Verify | DelayedCatalog | ExportMediaToVault | TestRun}] [-IsActive [<Boolean>]] [-TaskName [<String[]>]] [<CommonParameters>]

Get-BEJob -MediaSet [<BEMediaSet[]>] [[-Name] [<String[]>]] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | Incremental | Differential | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Archive | Verify | DelayedCatalog | ExportMediaToVault | TestRun}] [-IsActive [<Boolean>]] [-TaskName [<String[]>]] [<CommonParameters>]

Get-BEJob -MediaVault [<BEMediaVault[]>] [[-Name] [<String[]>]] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | Incremental | Differential | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Archive | Verify | DelayedCatalog | ExportMediaToVault | TestRun}] [-IsActive [<Boolean>]] [-TaskName [<String[]>]] [<CommonParameters>]

Get-BEJob -BackupDefinition [<BEBackupDefinition[]>] [[-Name] [<String[]>]] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | Incremental | Differential | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Archive | Verify | DelayedCatalog | ExportMediaToVault | TestRun}] [-IsActive [<Boolean>]] [-TaskName [<String[]>]] [<CommonParameters>]

Get-BEJob -AgentServer [<BEAgentServer[]>] [[-Name] [<String[]>]] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | Incremental | Differential | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Archive | Verify | DelayedCatalog | ExportMediaToVault | TestRun}] [-IsActive [<Boolean>]] [-TaskName [<String[]>]] [<CommonParameters>]

Get-BEJob -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [-Status {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-TaskType {None | OnetimeBackup | Full | IndependentFull | Incremental | Differential | Duplicate | ConvertToVirtual | ConvertBackupToVirtual | Archive | Verify | DelayedCatalog | ExportMediaToVault | TestRun}] [-IsActive [<Boolean>]] [-TaskName [<String[]>]] [<CommonParameters>]

Get-BEJob [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEJob -InputObject [<BEJob[]>] [<CommonParameters>]
Description

Gets jobs in Backup Exec.

Without parameters, Get-BEJob gets all of the Backup Exec jobs. You can also specify a job by job name or job ID (Guid) or pass a Backup Exec job object through the pipeline to Get-BEJob.

Parameters

-Storage <BEStorage[]>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-MediaSet <BEMediaSet[]>

Specifies one or more media set objects to filter the jobs. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMediaSet.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-MediaVault <BEMediaVault[]>

Specifies one or more media vault objects to filter the jobs. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMediaVault.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupDefinition <BEBackupDefinition[]>

Specifies one or more backup definition objects to filter the jobs. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupDefinition.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

Specifies one or more agent server objects to filter the jobs. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEAgentServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the jobs. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more jobs by job name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-TaskName <String[]>

Specifies one or more task name values to filter the jobs. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsActive <Boolean>

Specifies one or more active values to filter the jobs. To specify multiple values, use commas to separate the values.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Status

Specifies one or more status values to filter the jobs. To specify multiple values, use commas to separate the values.

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobType

Specifies one or more job type objects to filter the jobs. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEJobType.

The valid values are:
Unknown
Backup
Restore
Verify
Catalog
Utility
Report
Duplicate
TestRun
ResourceDiscovery
CopyJob
Archive
RestoreFromArchive
DeleteFromArchive
Install
ConvertToVirtual

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TaskType

Specifies one or more task type objects to filter the jobs. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BETaskType.

The valid values are:
None
OnetimeBackup
Full
IndependentFull
Incremental
Differential
Duplicate
ConvertToVirtual
ConvertBackupToVirtual
Archive
Verify
DelayedCatalog
ExportMediaToVault
TestRun

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

Specifies one or more jobs by job ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEJob[]>

Specifies one or more job objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorage

You can pipe a Backup Exec storage object to filter jobs returned by Get-BEJob.

BackupExec.Management.CLI.BEMediaSet

You can pipe a Backup Exec media set object to filter jobs returned by Get-BEJob.

BackupExec.Management.CLI.BEMediaVault

You can pipe a Backup Exec media vault object to filter jobs returned by Get-BEJob.

BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to filter jobs returned by Get-BEJob.

BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to filter jobs returned by Get-BEJob.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec job object to Get-BEJob.

BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to Get-BEJob.

Return Value
BackupExec.Management.CLI.BEJob

Get-BEJob returns objects that represent Backup Exec jobs.

Examples

Example 1

C:\PS> Get-BEJob

This command gets all of the Backup Exec jobs.

Example 2
C:\PS> Get-BEJob -Name "Job 01"

This command gets the Backup Exec job named "Job 01".

Example 3
C:\PS> Get-BEJob -Name "Job*"

This command gets all of the Backup Exec jobs that match the wildcard "Job*".

Example 4
C:\PS> Get-BEJob -Name "Job 01" | Wait-BEJob

These commands wait for the Backup Exec job named "Job 01" to complete.

Example 5
C:\PS> Get-BEJob -Name "Job 01" | Suspend-BEJob

These commands place the Backup Exec job named "Job 01" on hold.

Example 6
C:\PS> Get-BEJob -Name "Job 01" | Resume-BEJob

These commands resumes the Backup Exec job named "Job 01".

Example 7
C:\PS> Get-BEJob -Name "Job 01" | Stop-BEJob

These commands cancel the Backup Exec job named "Job 01".

Related Links

Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
Get-BEBackupDefinition
Get-BEAgentServer
Get-BEBackupExecServer
Wait-BEJob
Suspend-BEJob
Resume-BEJob
Stop-BEJob


Get-BEJobHistory Help

Get-BEJobHistory Cmdlet
Synopsis

Gets job histories in Backup Exec.

Syntax
Get-BEJobHistory [[-Name] [<String[]>]] [-JobStatus {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-FromLastJobRun [<SwitchParameter>]] [-FromStartTime [<DateTime>]] [-ToStartTime [<DateTime>]] [<CommonParameters>]

Get-BEJobHistory -Job [<BEJob[]>] [[-Name] [<String[]>]] [-JobStatus {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-FromLastJobRun [<SwitchParameter>]] [-FromStartTime [<DateTime>]] [-ToStartTime [<DateTime>]] [<CommonParameters>]

Get-BEJobHistory -Storage [<BEStorage[]>] [[-Name] [<String[]>]] [-JobStatus {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-FromLastJobRun [<SwitchParameter>]] [-FromStartTime [<DateTime>]] [-ToStartTime [<DateTime>]] [<CommonParameters>]

Get-BEJobHistory -AgentServer [<BEAgentServer[]>] [[-Name] [<String[]>]] [-JobStatus {Unknown | Canceled | Completed | SucceededWithExceptions | OnHold | Error | Missed | Recovered | Resumed | Succeeded | ThresholdAbort | Dispatched | DispatchFailed | InvalidSchedule | InvalidTimeWindow | NotInTimeWindow | Queued | Disabled | Active | Ready | Scheduled | Superseded | ToBeScheduled | Linked | RuleBlocked}] [-JobType {Unknown | Backup | Restore | Verify | Catalog | Utility | Report | Duplicate | TestRun | ResourceDiscovery | CopyJob | Archive | RestoreFromArchive | DeleteFromArchive | Install | ConvertToVirtual}] [-FromLastJobRun [<SwitchParameter>]] [-FromStartTime [<DateTime>]] [-ToStartTime [<DateTime>]] [<CommonParameters>]

Get-BEJobHistory [-Id] [<Guid[]>] [-FromLastJobRun [<SwitchParameter>]] [-ToStartTime [<DateTime>]] [-FromStartTime [<DateTime>]] [<CommonParameters>]

Get-BEJobHistory -InputObject [<BEJobHistory[]>] [-FromLastJobRun [<SwitchParameter>]] [-ToStartTime [<DateTime>]] [-FromStartTime [<DateTime>]] [<CommonParameters>]
Description

Gets job histories in Backup Exec.

Without parameters, Get-BEJobHistory gets all of the Backup Exec job histories. You can also specify a job history by job history name or job history ID (Guid) or pass a Backup Exec job history object through the pipeline to Get-BEJobHistory.

Parameters

-FromStartTime <DateTime>

Specifies a DateTime object to filter job histories with a start time that is after the specified DateTime.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToStartTime <DateTime>

Specifies a DateTime object to filter job histories with a start time that is before the specified DateTime.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromLastJobRun <SwitchParameter>

Returns the job histories from the most recent run of a job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Job <BEJob[]>

Specifies one or more job objects to filter the job histories. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEJob.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Storage <BEStorage[]>

Specifies one or more storage objects to filter the job histories. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEStorage.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

Specifies one or more agent server objects to filter the job histories. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEAgentServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more job histories by job history name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-JobStatus

Specifies one or more job status objects to filter the job histories. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEJobStatus.

The valid values are:
Unknown
Canceled
Completed
SucceededWithExceptions
OnHold
Error
Missed
Recovered
Resumed
Succeeded
ThresholdAbort
Dispatched
DispatchFailed
InvalidSchedule
InvalidTimeWindow
NotInTimeWindow
Queued
Disabled
Active
Ready
Scheduled
Superseded
ToBeScheduled
Linked
RuleBlocked

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobType

Specifies one or more job type objects to filter the job histories. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEJobType.

The valid values are:
Unknown
Backup
Restore
Verify
Catalog
Utility
Report
Duplicate
TestRun
ResourceDiscovery
CopyJob
Archive
RestoreFromArchive
DeleteFromArchive
Install
ConvertToVirtual

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

Specifies one or more job histories by job history ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEJobHistory[]>

Specifies one or more job history objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to filter job histories returned by Get-BEJobHistory.

BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to filter job histories returned by Get-BEJobHistory.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec job history object to Get-BEJobHistory.

BackupExec.Management.CLI.BEJobHistory

You can pipe a Backup Exec job history object to Get-BEJobHistory.

Return Value
BackupExec.Management.CLI.BEJobHistory

Get-BEJobHistory returns objects that represent Backup Exec job histories.

Examples

Example 1

C:\PS> Get-BEJobHistory

This command gets all of the Backup Exec job histories.

Example 2
C:\PS> Get-BEJob "Job 01" | Get-BEJobHistory

These commands get all of the Backup Exec job histories for the Backup Exec job named "Job 01".

Example 3
C:\PS> Get-BEAgentServer -Local | Get-BEJobHistory

These commands get all of the Backup Exec job histories for the local computer.

Related Links


Get-BEJobLog Help

Get-BEJobLog Cmdlet
Synopsis

Gets the job log for a job history in Backup Exec.

Syntax
Get-BEJobLog [-Path] [<String>] [[-OutputStyle] {Text | Html}] [<CommonParameters>]

Get-BEJobLog -JobHistory [<BEJobHistory>] [[-OutputStyle] {Text | Html}] [<CommonParameters>]
Description

Gets the job log for a job history in Backup Exec.

Parameters

-JobHistory <BEJobHistory>

Specifies the job history to get the job log for.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Path <String>

Specifies the path for a job history XML file.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-OutputStyle

Specifies the desired job log format.

The valid values are:
Text
Html

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJobHistory

You can pipe a Backup Exec job history object to Get-BEJobLog.

Return Value
System.String

Get-BEJobLog returns the string that represents the contents of the job log.

Example

C:\PS> Get-BEJob "Job 01" | Get-BEJobHistory -FromLastJobRun | Get-BEJobLog

These commands get the last job log for the Backup Exec job named "Job 01".

Related Links


Get-BELegacyBackupToDiskFolderDevice Help

Get-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Gets legacy backup-to-disk folders in Backup Exec.

Syntax
Get-BELegacyBackupToDiskFolderDevice [[-Name] [<String[]>]] [<CommonParameters>]

Get-BELegacyBackupToDiskFolderDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BELegacyBackupToDiskFolderDevice [-Id] [<Guid[]>] [<CommonParameters>]

Get-BELegacyBackupToDiskFolderDevice -InputObject [<BELegacyBackupToDiskFolderDevice[]>] [<CommonParameters>]
Description

Gets legacy backup-to-disk folders in Backup Exec.

Without parameters, Get-BELegacyBackupToDiskFolderDevice gets all of the legacy backup-to-disk folders. You can also specify a specific legacy backup-to-disk folder by the folder name or the folder ID (Guid) or pass a folder object through the pipeline to Get-BELegacyBackupToDiskFolderDevice.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the legacy backup-to-disk folders. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more legacy backup-to-disk folder devices by legacy backup-to-disk folder device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more legacy backup-to-disk folder devices by legacy backup-to-disk folder device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BELegacyBackupToDiskFolderDevice[]>

Specifies one or more legacy backup-to-disk folder device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter legacy backup-to-disk folder devices returned by Get-BELegacyBackupToDiskFolderDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec legacy backup-to-disk folder device object to Get-BELegacyBackupToDiskFolderDevice.

BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

You can pipe a Backup Exec legacy backup-to-disk folder device object to Get-BELegacyBackupToDiskFolderDevice.

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Get-BELegacyBackupToDiskFolderDevice returns objects that represent Backup Exec legacy backup-to-disk folder devices.

Examples

Example 1

C:\PS> Get-BELegacyBackupToDiskFolderDevice

This command gets all of the legacy backup-to-disk folder devices.

Example 2
C:\PS> Get-BELegacyBackupToDiskFolderDevice -Name "Device 01"

This command gets the legacy backup-to-disk folder device named "Device 01".

Example 3
C:\PS> Get-BELegacyBackupToDiskFolderDevice -Name "Device*"

This command gets all of the legacy backup-to-disk folder devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BELegacyBackupToDiskFolderDevice

This command gets all of the legacy backup-to-disk folder devices attached to the local Backup Exec server.

Related Link

Get-BEBackupExecServer


Get-BELicenseInformation Help

Get-BELicenseInformation Cmdlet
Synopsis

Gets Backup Exec licenses.

Syntax
Get-BELicenseInformation [-BackupExecServer [<BEBackupExecServer>]] [[-Name] [<String[]>]] [<CommonParameters>]
Description

Gets Backup Exec licenses.

Without parameters, Get-BELicenseInformation gets all of the Backup Exec licenses. You can also specify a license by license name or license ID (Guid) or pass a Backup Exec license object through the pipeline to Get-BELicenseInformation.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies one or more Backup Exec server objects to filter the licenses. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more licenses by license name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter licenses returned by Get-BELicenseInformation.

Return Value
BackupExec.Management.CLI.BELicenseInformation

Get-BELicenseInformation returns objects that represent Backup Exec licenses.

Examples

Example 1

C:\PS> Get-BELicenseInformation

This command gets all of the license objects.

Example 2
C:\PS> Get-BELicenseInformation -Name "Agent for Windows"

This command gets the license object named "Agent for Windows".

Example 3
C:\PS> Get-BELicenseInformation -Name "*agent*"

This command gets all of the license objects that match the wildcard "*agent*"

Related Link

Get-BEBackupExecServer


Get-BELogonAccount Help

Get-BELogonAccount Cmdlet
Synopsis

Gets Backup Exec logon accounts.

Syntax
Get-BELogonAccount [[-Name] [<String[]>]] [<CommonParameters>]

Get-BELogonAccount [-Id] [<Guid[]>] [<CommonParameters>]

Get-BELogonAccount -InputObject [<BELogonAccount[]>] [<CommonParameters>]
Description

Gets Backup Exec logon accounts.

Without parameters, Get-BELogonAccount gets all of the Backup Exec logon accounts. You can also specify a logon account by logon account name or logon account ID (Guid) or pass a Backup Exec logon account object through the pipeline to Get-BELogonAccount.

Parameters

-Name <String[]>

Specifies one or more logon accounts by logon account name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more logon accounts by logon account ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BELogonAccount[]>

Specifies one or more logon account objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec logon account object to Get-BELogonAccount.

BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object to Get-BELogonAccount.

Return Value
BackupExec.Management.CLI.BELogonAccount

Get-BELogonAccount returns objects that represent Backup Exec logon accounts.

Examples

Example 1

C:\PS> Get-BELogonAccount

This command gets all of the logon accounts.

Example 2
C:\PS> Get-BELogonAccount -Name "System Logon Account"

This command gets the logon account named "System Logon Account".

Example 3
C:\PS> Get-BELogonAccount -Name "*system*"

This command gets all of the logon accounts that match the wildcard "*system*".


Get-BEMedia Help

Get-BEMedia Cmdlet
Synopsis

Gets media in Backup Exec.

Syntax
Get-BEMedia [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEMedia -MediaSet [<BEMediaSet[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEMedia -MediaVault [<BEMediaVault[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEMedia [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEMedia -InputObject [<BEMedia[]>] [<CommonParameters>]
Description

Gets media in Backup Exec.

Without parameters, Get-BEMedia gets all of the Backup Exec media. You can also specify a media by media name or media ID (Guid) or pass a Backup Exec media object through the pipeline to Get-BEMedia.

Parameters

-MediaSet <BEMediaSet[]>

Specifies one or more media set objects to filter the media. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMediaSet.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-MediaVault <BEMediaVault[]>

Specifies one or more media vault objects to filter the media. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMediaVault.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more media by media name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more media by media ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEMedia[]>

Specifies one or more media objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEMediaSet

You can pipe a Backup Exec media set object to filter media returned by Get-BEMedia.

BackupExec.Management.CLI.BEMediaVault

You can pipe a Backup Exec media vault object to filter media returned by Get-BEMedia.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec media object to Get-BEMedia.

BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to Get-BEMedia.

Return Value
BackupExec.Management.CLI.BEMedia

Get-BEMedia returns objects that represent Backup Exec media.

Examples

Example 1

C:\PS> Get-BEMedia

This command gets all of the media.

Example 2
C:\PS> Get-BEMedia -Name "Media 01"

This command gets the media named "Media 01".

Example 3
C:\PS> Get-BEMedia -Name "*media*"

This command gets all of the media that match the wildcard "*media*".

Example 4
C:\PS> Get-BEMediaSet -Name "MediaSet 01" | Get-BEMedia

These commands get all of the media associated with the media set named "MediaSet 01".

Example 5
C:\PS> Get-BEMediaVault -Name "MediaVault 01" | Get-BEMedia

These commands get all of the media associated with the media vault named "MediaVault 01".

Related Links


Get-BEMediaSet Help

Get-BEMediaSet Cmdlet
Synopsis

Gets media sets in Backup Exec.

Syntax
Get-BEMediaSet [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEMediaSet -MediaVault [<BEMediaVault[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEMediaSet [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEMediaSet -InputObject [<BEMediaSet[]>] [<CommonParameters>]
Description

Gets media sets in Backup Exec.

Without parameters, Get-BEMediaSet gets all of the Backup Exec media sets. You can also specify a media set by media set name or media set ID (Guid) or pass a Backup Exec media set object through the pipeline to Get-BEMediaSet.

Parameters

-MediaVault <BEMediaVault[]>

Specifies one or more media vault objects to filter the media set. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMediaVault.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more media sets by media set name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more media sets by media set ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEMediaSet[]>

Specifies one or more media set objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEMediaVault

You can pipe a Backup Exec media vault object to filter media sets returned by Get-BEMediaSet.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec media set object to Get-BEMediaSet.

BackupExec.Management.CLI.BEMediaSet

You can pipe a Backup Exec media set object to Get-BEMediaSet.

Return Value
BackupExec.Management.CLI.BEMediaSet

Get-BEMediaSet returns objects that represent Backup Exec media sets.

Examples

Example 1

C:\PS> Get-BEMediaSet

This command gets all of the media sets.

Example 2
C:\PS> Get-BEMediaSet -Name "MediaSet 01"

This command gets the media sets named "MediaSet 01".

Example 3
C:\PS> Get-BEMediaSet -Name "*mediaset*"

This command gets all of the media sets that match the wildcard "*mediaset*".

Related Link

Get-BEMediaVault


Get-BEMediaType Help

Get-BEMediaType Cmdlet
Synopsis

Gets media types in Backup Exec.

Syntax
Get-BEMediaType [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEMediaType -TapeDriveDevice [<BETapeDriveDevice>] [-WritableMediaType [<SwitchParameter>]] [-ReadableMediaType [<SwitchParameter>]] [<CommonParameters>]

Get-BEMediaType [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEMediaType -InputObject [<BEMediaType[]>] [<CommonParameters>]
Description

Gets media types in Backup Exec.

Without parameters, Get-BEMediaType gets all of the Backup Exec media types. You can also specify a media type by media type name or media type ID (Guid) or pass a Backup Exec media type object through the pipeline to Get-BEMediaType.

To configure bar code rules, you can specify the -TapeDriveDevice parameter which returns the media types that the tape drive device supports. You can also specify the -ReadableMediaType and -WritableMediaType parameters to get the media types that the tape drive device is configured to read from and write to. See New-BEBarcodeRule and Set-BETapeDriveDevice for more information.

Parameters

-TapeDriveDevice <BETapeDriveDevice>

Specifies a tape drive device object to get the media types supported by it.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ReadableMediaType <SwitchParameter>

Returns the media types that a tape drive device is configured to read from.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WritableMediaType <SwitchParameter>

Returns the media types that a tape drive device is configured to write to.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more media types by media type name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more media types by media type ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEMediaType[]>

Specifies one or more media type objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Get-BEMediaType.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec media type object to Get-BEMediaType.

BackupExec.Management.CLI.BEMediaType

You can pipe a Backup Exec media type object to Get-BEMediaType.

Return Value
BackupExec.Management.CLI.BEMediaType

Get-BEMediaType returns objects that represent Backup Exec media types.

Examples

Example 1

C:\PS> Get-BEMediaType

This command gets all of the media types.

Example 2
C:\PS> Get-BEMediaType -Name "LTO"

This command gets the media types named "LTO".

Example 3
C:\PS> Get-BEMediaType -Name "*LTO*"

This command gets all of the media types that match the wildcard "*LTO*".

Related Links


Get-BEMediaVault Help

Get-BEMediaVault Cmdlet
Synopsis

Gets media vaults in Backup Exec.

Syntax
Get-BEMediaVault [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEMediaVault [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEMediaVault -InputObject [<BEMediaVault[]>] [<CommonParameters>]
Description

Gets media vaults in Backup Exec.

Without parameters, Get-BEMediaVault gets all of the Backup Exec media vaults. You can also specify a media vault by media vault name or media vault ID (Guid) or pass a Backup Exec media vault object through the pipeline to Get-BEMediaVault.

Parameters

-Name <String[]>

Specifies one or more media vaults by media vault name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more media vaults by media vault ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEMediaVault[]>

Specifies one or more media vault objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec media vault object to Get-BEMediaVault.

BackupExec.Management.CLI.BEMediaVault

You can pipe a Backup Exec media vault object to Get-BEMediaVault.

Return Value
BackupExec.Management.CLI.BEMediaVault

Get-BEMediaVault returns objects that represent Backup Exec media vaults.

Examples

Example 1

C:\PS> Get-BEMediaVault

This command gets all of the media vaults.

Example 2
C:\PS> Get-BEMediaVault -Name "MediaVault 01"

This command gets the media vault named "MediaVault 01".

Example 3
C:\PS> Get-BEMediaVault -Name "*mediavault*"

This command gets all of the media vaults that match the wildcard "*mediavault*".


Get-BENetworkInterface Help

Get-BENetworkInterface Cmdlet
Synopsis

Gets the network interfaces of the local Backup Exec server.

Syntax
Get-BENetworkInterface [[-Name] [<String[]>]] [<CommonParameters>]

Get-BENetworkInterface [-Id] [<Guid[]>] [<CommonParameters>]

Get-BENetworkInterface -InputObject [<BENetworkInterface[]>] [<CommonParameters>]
Description

Gets the network interfaces of the local Backup Exec server.

Without parameters, Get-BENetworkInterface gets all of the Backup Exec network interfaces. You can also specify a particular network interface by network interface name or network interface ID (Guid) or pass a Backup Exec network interface object through the pipeline to Get-BENetworkInterface.

The objects returned from Get-BENetworkInterface are used to set the NetworkInterface parameter of the Net-BEBackupDefiniton, Set-BEBackupDefinition, Set-BEbackupJobDefault, and Submit-BEOnetimeBackupJob commands.

Parameters

-Name <String[]>

Specifies one or more network interfaces by network interface name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more network interfaces by network interface ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BENetworkInterface[]>

Specifies one or more network interface objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec network interface object to Get-BENetworkInterface.

BackupExec.Management.CLI.BENetworkInterface

You can pipe a Backup Exec network interface object to Get-BENetworkInterface.

Return Value
BackupExec.Management.CLI.BENetworkInterface

Get-BENetworkInterface returns objects that represent Backup Exec network interfaces.

Examples

Example 1

C:\PS> Get-BENetworkInterface

This command gets all of the network interfaces attached to the local Backup Exec server.

Example 2
C:\PS> Get-BENetworkInterface -Name "Local Area Connection"

This command gets the network interfaces named "Local Area Connection".

Example 3
C:\PS> $networkInterface = Get-BENetworkInterface -Name "Local Area Connection"
C:\PS> Get-BEAgentServer server01 | Submit-BEOnetimeBackupJob -NetworkInterface $networInterface

These commands submit a one-time backup job of a server named "server01" using the network interface named "Local Area Connection".

Related Links


Get-BEOpenStorageDevice Help

Get-BEOpenStorageDevice Cmdlet
Synopsis

Gets Backup Exec OpenStorage devices.

Syntax
Get-BEOpenStorageDevice [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEOpenStorageDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEOpenStorageDevice -LogonAccount [<BELogonAccount[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEOpenStorageDevice [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEOpenStorageDevice -InputObject [<BEOpenStorageDevice[]>] [<CommonParameters>]
Description

Gets Backup Exec OpenStorage devices.

Without parameters, Get-BEOpenStorageDevice gets all of the Backup Exec OpenStorage devices. You can also specify a particular OpenStorage device by OpenStorage device name or OpenStorage device ID (Guid) or pass a Backup Exec OpenStorage device object through the pipeline to Get-BEOpenStorageDevice.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the OpenStorage devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount[]>

Specifies one or more logon account objects to filter the OpenStorage devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BELogonAccount.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more OpenStorage devices by OpenStorage device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more OpenStorage devices by OpenStorage device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEOpenStorageDevice[]>

Specifies one or more OpenStorage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter OpenStorage devices returned by Get-BEOpenStorageDevice.

BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object as a means to filter OpenStorage devices returned by Get-BEOpenStorageDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec OpenStorage device object to Get-BEOpenStorageDevice.

BackupExec.Management.CLI.BEOpenStorageDevice

You can pipe a Backup Exec OpenStorage device object to Get-BEOpenStorageDevice.

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

Get-BEOpenStorageDevice returns objects that represent Backup Exec OpenStorage devices.

Examples

Example 1

C:\PS> Get-BEOpenStorageDevice

This command gets all of the OpenStorage devices.

Example 2
C:\PS> Get-BEOpenStorageDevice -Name "Device 01"

This command gets the OpenStorage device named "Device 01".

Example 3
C:\PS> Get-BEOpenStorageDevice -Name "Device*"

This command gets all of the OpenStorage devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEOpenStorageDevice

This command gets all of the OpenStorage devices attached to the local Backup Exec server.

Related Links


Get-BEOpenStorageLogicalStorageUnit Help

Get-BEOpenStorageLogicalStorageUnit Cmdlet
Synopsis

Gets the logical storage units of an OpenStorage server.

Syntax
Get-BEOpenStorageLogicalStorageUnit [-BackupExecServer [<BEBackupExecServer>]] -LogonAccount [<BELogonAccount>] -ServerType [<String>] -HostServer [<String>] [<CommonParameters>]
Description

Gets the logical storage units of an OpenStorage server.

The values returned by Get-BEOpenStorageLogicalStorageUnit can be used as the value for the ServerType parameter for the New-BEOpenStorageDevice and New-BECloudStorageDevice commands.

Parameters

-HostServer <String>

Specifies the fully-qualified name of the OpenStorage server.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServerType <String>

Specifies the type of OpenStorage server.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

Specifies a Backup Exec logon account for the OpenStorage server.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server where the OpenStorage server type is registered.

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to Get-BEOpenStorageLogicalStorageUnit.

Return Value
System.String

The logical storage units on the OpenStorage server.

Example

C:\PS> Get-BEOpenStorageLogicalStorageUnit -HostServer "nirvanix.com" -ServerType "nirvanix" -LogonAccount ""

This command gets the logical storage units on the Nirvanix host server named "nirvanix.com" with the logon account "Logon Account 0001".

Related Links


Get-BEOpenStorageServerType Help

Get-BEOpenStorageServerType Cmdlet
Synopsis

Gets the registered OpenStorage server types installed on the Backup Exec server.

Syntax
Get-BEOpenStorageServerType [-BackupExecServer [<BEBackupExecServer>]] [<CommonParameters>]
Description

Gets the registered OpenStorage server types installed on the Backup Exec server.

The values returned by Get-BEOpenStorageServerType can be used as the value for the ServerType parameter for the New-BEOpenStorageDevice command.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server to get the OpenStorage server types from.

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to Get-BEOpenStorageServerType.

Return Value
System.String

The registered OpenStorage server types.

Example

C:\PS> Get-BEOpenStorageServerType

This command gets all of the OpenStorage server types registered on the local Backup Exec server.

Related Link

New-BEOpenStorageDevice


Get-BEReport Help

Get-BEReport Cmdlet
Synopsis

Gets Backup Exec reports.

Syntax
Get-BEReport [[-Name] [<String[]>]] [-Category {Alerts | Archive | Configuration | Jobs | Media | Devices | Custom}] [<CommonParameters>]

Get-BEReport [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEReport -InputObject [<BEReport[]>] [<CommonParameters>]
Description

Gets Backup Exec reports.

Without parameters, Get-BEReport gets all of the Backup Exec reports. You can also specify a particular report by report name or report ID (Guid) or pass a Backup Exec report object through the pipeline to Get-BEReport.

Reports are run by passing the results of Get-BEReport to Invoke-BEReport

Parameters

-Category

Specifies one or more category values to filter the reports. To specify multiple values, use commas to separate the values.

The valid values are:
Alerts
Archive
Configuration
Jobs
Media
Devices
Custom

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more reports by report name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more reports by report ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEReport[]>

Specifies one or more report objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec report object to Get-BEReport.

BackupExec.Management.CLI.BEReport

You can pipe a Backup Exec report object to Get-BEReport.

Return Value
BackupExec.Management.CLI.BEReport

Get-BEReport returns objects that represent Backup Exec reports.

Examples

Example 1

C:\PS> Get-BEReport

This command gets all of the Backup Exec report objects.

Example 2
C:\PS> Get-BEReport -Name "Audit Log"

This command gets the Backup Exec report object named "Audit Log".

Example 3
C:\PS> Get-BEReport -Name "Media*"

This command gets all of the Backup Exec report objects that match the wildcard "Media*".

Example 4
C:\PS> Get-BEReport "Audit Log" | Invoke-BEReport -Path .\AuditLog.html | Invoke-Item

These commands run the report named "Audit Log" and displays the report in the default web browser.

Related Link

Invoke-BEReport


Get-BERoboticLibraryDevice Help

Get-BERoboticLibraryDevice Cmdlet
Synopsis

Gets robotic library devices in Backup Exec.

Syntax
Get-BERoboticLibraryDevice [[-Name] [<String[]>]] [<CommonParameters>]

Get-BERoboticLibraryDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BERoboticLibraryDevice [-Id] [<Guid[]>] [<CommonParameters>]

Get-BERoboticLibraryDevice -InputObject [<BERoboticLibraryDevice[]>] [<CommonParameters>]
Description

Gets robotic library devices in Backup Exec.

Without parameters, Get-BERoboticLibraryDevice gets all of the Backup Exec robotic library devices. You can also specify a robotic library device by robotic library device name or robotic library device ID (Guid) or pass a Backup Exec robotic library device object through the pipeline to Get-BERoboticLibraryDevice.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the robotic library devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more robotic library devices by robotic library device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more robotic library devices by robotic library device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BERoboticLibraryDevice[]>

Specifies one or more robotic library device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter robotic library devices returned by Get-BERoboticLibraryDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec robotic library device object to Get-BERoboticLibraryDevice.

BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Get-BERoboticLibraryDevice.

Return Value
BackupExec.Management.CLI.BERoboticLibraryDevice

Get-BERoboticLibraryDevice returns objects that represent Backup Exec robotic library devices.

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice

This command gets all of the robotic library devices.

Example 2
C:\PS> Get-BERoboticLibraryDevice -Name "Device 01"

This command gets the robotic library device named "Device 01".

Example 3
C:\PS> Get-BERoboticLibraryDevice -Name "Device*"

This command gets all of the robotic library devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BERoboticLibraryDevice

This command gets all of the robotic library devices attached to the local Backup Exec server.

Related Link

Get-BEBackupExecServer


Get-BERoboticLibraryPartition Help

Get-BERoboticLibraryPartition Cmdlet
Synopsis

Gets Backup Exec robotic library partitions.

Syntax
Get-BERoboticLibraryPartition -RoboticLibraryDevice [<BERoboticLibraryDevice[]>] [[-Name] [<String[]>]] [-LastSlotNumber [<Int32[]>]] [-FirstSlotNumber [<Int32[]>]] [<CommonParameters>]

Get-BERoboticLibraryPartition [-Id] [<Guid[]>] [<CommonParameters>]

Get-BERoboticLibraryPartition -InputObject [<BERoboticLibraryPartition[]>] [<CommonParameters>]
Description

Gets Backup Exec robotic library partitions.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice[]>

Specifies one or more robotic library device values to filter the robotic library partitions. To specify multiple values, use commas to separate the values.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-FirstSlotNumber <Int32[]>

Specifies one or more first slot number values to filter the robotic library partitions. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LastSlotNumber <Int32[]>

Specifies one or more last slot number values to filter the robotic library partitions. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more robotic library partitions by robotic library partition name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more robotic library partitions by robotic library partition ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BERoboticLibraryPartition[]>

Specifies one or more robotic library partition objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library object to Get-BERoboticLibraryPartition.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec robotic library partition object to Get-BERoboticLibraryPartition.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Get-BERoboticLibraryPartition.

Return Value
BackupExec.Management.CLI.BERoboticLibraryPartition

Get-BERoboticLibraryPartition returns objects that represent Backup Exec robotic library partitions.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 01" | Get-BERoboticLibraryPartition

These commands get the partitions of a robotic library device named "Device 01".

Related Link

Get-BERoboticLibraryDevice


Get-BERoboticLibrarySlot Help

Get-BERoboticLibrarySlot Cmdlet
Synopsis

Gets Backup Exec robotic library slots.

Syntax
Get-BERoboticLibrarySlot -RoboticLibraryDevice [<BERoboticLibraryDevice[]>] [[-Name] [<String[]>]] [-Barcode [<String[]>]] [-IsCleaningSlot [<Boolean>]] [-SlotNumber [<Int32[]>]] [<CommonParameters>]

Get-BERoboticLibrarySlot -Media [<BEMedia[]>] [[-Name] [<String[]>]] [-Barcode [<String[]>]] [-IsCleaningSlot [<Boolean>]] [-SlotNumber [<Int32[]>]] [<CommonParameters>]

Get-BERoboticLibrarySlot -RoboticLibraryPartition [<BERoboticLibraryPartition[]>] [[-Name] [<String[]>]] [-Barcode [<String[]>]] [-IsCleaningSlot [<Boolean>]] [-SlotNumber [<Int32[]>]] [<CommonParameters>]

Get-BERoboticLibrarySlot [-Id] [<Guid[]>] [<CommonParameters>]

Get-BERoboticLibrarySlot -InputObject [<BERoboticLibrarySlot[]>] [<CommonParameters>]
Description

Gets Backup Exec robotic library slots.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice[]>

Specifies one or more robotic library device values to filter the robotic library slots. To specify multiple values, use commas to separate the values.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Media <BEMedia[]>

Specifies one or more media objects to filter the robotic library slots. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMedia.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition[]>

Specifies one or more robotic library partition objects to filter the robotic library slots. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BERoboticLibraryPartition.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more robotic library slots by robotic library slot name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-SlotNumber <Int32[]>

Specifies one or more slot number values to filter the robotic library slots. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Barcode <String[]>

Specifies one or more barcode values to filter the robotic library slots. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsCleaningSlot <Boolean>

Specifies one or more cleaning slot values to filter the robotic library slots. To specify multiple values, use commas to separate the values.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Id <Guid[]>

Specifies one or more robotic library slots by robotic library slot ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BERoboticLibrarySlot[]>

Specifies one or more robotic library slot objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library object to Get-BERoboticLibrarySlot.

BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object as a means to filter robotic library slots returned by Get-BERoboticLibrarySlot.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object as a means to filter robotic library slots returned by Get-BERoboticLibrarySlot.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec robotic library slot object to Get-BERoboticLibrarySlot.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Get-BERoboticLibrarySlot.

Return Value
BackupExec.Management.CLI.BERoboticLibrarySlot

Get-BERoboticLibrarySlot returns objects that represent Backup Exec robotic library slots.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 01" | Get-BERoboticLibrarySlot

These commands get the slots of a robotic library device named "Device 01".

Related Links


Get-BEService Help

Get-BEService Cmdlet
Synopsis

Gets the Backup Exec services.

Syntax
Get-BEService [[-Name] [<String[]>]] [-ServiceType {Core | Deduplication}] [-ComputerName [<String[]>]] [<CommonParameters>]

Get-BEService -DisplayName [<String[]>] [-ServiceType {Core | Deduplication}] [-ComputerName [<String[]>]] [<CommonParameters>]
Description

Gets the Backup Exec services.

By default, Get-BEService retrieves the core Backup Exec services. You can specify other Backup Exec service types with the -ServiceType parameter.

To start, stop, and restart Backup Exec services, see Start-BEService, Stop-BEService and Restart-BEService.

Parameters

-ComputerName <String[]>

Gets the services running on the specified computers. The default is the local computer.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies the names of services. Wildcards are permitted.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-DisplayName <String[]>

Specifies the display names of services. Wildcards are permitted.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceType

Specifies the type of Backup Exec service.

The valid values are:
Core
Deduplication

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a service name to Get-BEService.

Return Value
System.ServiceProcess.ServiceController

Get-BEService returns objects that represent the Backup Exec services on the computer.

Examples

Example 1

C:\PS> Get-BEService

Gets all of the core Backup Exec services.

Example 2
C:\PS> Get-BEService "BackupExecRPCService"

Gets the Backup Exec service with service name "BackupExecRPCService".

Example 3
C:\PS> Get-BEService -DisplayName "Backup Exec Server"

Gets the Backup Exec service with display name "Backup Exec Server".

Example 4
C:\PS> Get-BEService -ServiceType Deduplication

Gets all of the Backup Exec deduplication service. If the Backup Exec Deduplication Option is not installed, Get-BEService returns an error.

Related Links


Get-BEStorage Help

Get-BEStorage Cmdlet
Synopsis

Gets storage in Backup Exec.

Syntax
Get-BEStorage [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEStorage -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEStorage [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEStorage -InputObject [<BEStorage[]>] [<CommonParameters>]
Description

Gets storage in Backup Exec.

Without parameters, Get-BEStorage gets all of the Backup Exec storage. You can also specify a storage by storage name or storage ID (Guid) or pass a Backup Exec storage object through the pipeline to Get-BEStorage.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the storage. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more storage by storage name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more storage by storage ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorage[]>

Specifies one or more storage objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter storage returned by Get-BEStorage.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec storage object to Get-BEStorage.

BackupExec.Management.CLI.BEStorage

You can pipe a Backup Exec storage object to Get-BEStorage.

Return Value
BackupExec.Management.CLI.BEStorage

Get-BEStorage returns objects that represent Backup Exec storage.

Examples

Example 1

C:\PS> Get-BEStorage

This command gets all of the Backup Exec storage objects.

Example 2
C:\PS> Get-BEStorage -Name "Device 01"

This command gets the Backup Exec storage object named "Device 01".

Example 3
C:\PS> Get-BEStorage -Name "Device*"

This command gets all of the Backup Exec storage objects that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEStorage

This command gets all of the Backup Exec storage objects attached to the local Backup Exec server.

Related Link

Get-BEBackupExecServer


Get-BEStorageArrayDevice Help

Get-BEStorageArrayDevice Cmdlet
Synopsis

Gets storage array devices in Backup Exec.

Syntax
Get-BEStorageArrayDevice [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEStorageArrayDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEStorageArrayDevice [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEStorageArrayDevice -InputObject [<BEStorageArrayDevice[]>] [<CommonParameters>]
Description

Gets storage array devices in Backup Exec.

Without parameters, Get-BEStorageArrayDevice gets all of the Backup Exec storage array devices. You can also specify a storage array device by storage array device name or storage array device ID (Guid) or pass a Backup Exec storage array device object through the pipeline to Get-BEStorageArrayDevice.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the storage array devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more storage array devices by storage array device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more storage array devices by storage array device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorageArrayDevice[]>

Specifies one or more storage array device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter storage array devices returned by Get-BEStorageArrayDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec storage array device object to Get-BEStorageArrayDevice.

BackupExec.Management.CLI.BEStorageArrayDevice

You can pipe a Backup Exec storage array device object to Get-BEStorageArrayDevice.

Return Value
BackupExec.Management.CLI.BEStorageArrayDevice

Get-BEStorageArrayDevice returns objects that represent Backup Exec storage array devices.

Examples

Example 1

C:\PS> Get-BEStorageArrayDevice

This command gets all of the storage array devices.

Example 2
C:\PS> Get-BEStorageArrayDevice -Name "Device 01"

This command gets the storage array device named "Device 01".

Example 3
C:\PS> Get-BEStorageArrayDevice -Name "Device*"

This command gets all of the storage array devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEStorageArrayDevice

This command gets all of the storage array devices attached to the local Backup Exec server.

Related Link

Get-BEBackupExecServer


Get-BEStorageArrayPhysicalDisk Help

Get-BEStorageArrayPhysicalDisk Cmdlet
Synopsis

Gets the physical disks of a storage array.

Syntax
Get-BEStorageArrayPhysicalDisk -StorageArrayDevice [<BEStorageArrayDevice[]>] [[-Name] [<String[]>]] [-IsConfigured [<Boolean>]] [-Slot [<UInt32[]>]] [-Enclosure [<UInt32[]>]] [<CommonParameters>]

Get-BEStorageArrayPhysicalDisk [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEStorageArrayPhysicalDisk -InputObject [<BEStorageArrayPhysicalDisk[]>] [<CommonParameters>]
Description

Gets the physical disks of a storage array.

The objects returned from Get-BEStorageArrayPhysicalDisk are used to set the DiskGroupPhysicalDisk, AddHotSparePhysicalDisk, and RemoveHotSparePhysicalDisk parameters of the Submit-BEStorageArrayDeviceConfigurationJob command.

Parameters

-StorageArrayDevice <BEStorageArrayDevice[]>

Specifies one or more storage array values to filter the storage array physical disks. To specify multiple values, use commas to separate the values.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Enclosure <UInt32[]>

Specifies one or more enclosure values to filter the storage array physical disks. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Slot <UInt32[]>

Specifies one or more slot values to filter the storage array physical disks. To specify multiple values, use commas to separate the values.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsConfigured <Boolean>

Specifies one or more is configured values to filter the storage array physical disks. To specify multiple values, use commas to separate the values.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more storage array physical disks by storage array physical disk name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more storage array physical disks by storage array physical disk ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorageArrayPhysicalDisk[]>

Specifies one or more storage array physical disk objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEStorageArrayDevice

You can pipe a Backup Exec storage array object to Get-BEStorageArrayPhysicalDisk.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec storage array physical disk object to Get-BEStorageArrayPhysicalDisk.

BackupExec.Management.CLI.BEStorageArrayPhysicalDisk

You can pipe a Backup Exec storage array physical disk object to Get-BEStorageArrayPhysicalDisk.

Return Value
BackupExec.Management.CLI.BEStorageArrayPhysicalDisk

Get-BEStorageArrayPhysicalDisk returns objects that represent Backup Exec storage array physical disks.

Examples

Example 1

C:\PS> $physicalDisks = Get-BEStorageArrayDevice -Name "Device 0001" | Get-BEStorageArrayPhysicalDisk -IsConfigured $false
C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -ConfigureHotSparesOnly -AddHotSparePhysicalDisk $physicalDisks

These commands configure all of the unconfigured physical disks on a storage array named "Device 0001" as hot spares.

Example 2
C:\PS> $physicalDisks = Get-BEStorageArrayDevice -Name "Device 0001" | Get-BEStorageArrayPhysicalDisk -IsConfigured $false
C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -DiskGroupPhysicalDisk $physicalDisks

These commands configure a disk storage group with all of the unconfigured physical disks on a storage array named "Device 0001".

Related Links


Get-BEStorageDevice Help

Get-BEStorageDevice Cmdlet
Synopsis

Gets storage devices in Backup Exec.

Syntax
Get-BEStorageDevice [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEStorageDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEStorageDevice [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEStorageDevice -InputObject [<BEStorageDevice[]>] [<CommonParameters>]
Description

Gets storage devices in Backup Exec.

Without parameters, Get-BEStorageDevice gets all of the Backup Exec storage devices. You can also specify a storage device by storage device name or storage device ID (Guid) or pass a Backup Exec storage device object through the pipeline to Get-BEStorageDevice.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the storage devices. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more storage devices by storage device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more storage devices by storage device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorageDevice[]>

Specifies one or more storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter storage devices returned by Get-BEStorageDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec storage device object to Get-BEStorageDevice.

BackupExec.Management.CLI.BEStorageDevice

You can pipe a Backup Exec storage device object to Get-BEStorageDevice.

Return Value
BackupExec.Management.CLI.BEStorageDevice

Get-BEStorageDevice returns objects that represent Backup Exec storage devices.

Examples

Example 1

C:\PS> Get-BEStorageDevice

This command gets all of the storage devices.

Example 2
C:\PS> Get-BEStorageDevice -Name "Device 01"

This command gets the storage device named "Device 01".

Example 3
C:\PS> Get-BEStorageDevice -Name "Device*"

This command gets all of the storage devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEStorageDevice

This command gets all of the storage devices attached to the local Backup Exec server.

Related Link

Get-BEBackupExecServer


Get-BEStorageDevicePool Help

Get-BEStorageDevicePool Cmdlet
Synopsis

Gets storage device pools in Backup Exec.

Syntax
Get-BEStorageDevicePool [[-Name] [<String[]>]] [<CommonParameters>]

Get-BEStorageDevicePool [-Id] [<Guid[]>] [<CommonParameters>]

Get-BEStorageDevicePool -InputObject [<BEStorageDevicePool[]>] [<CommonParameters>]
Description

Gets storage device pools in Backup Exec.

Without parameters, Get-BEStorageDevicePool gets all of the Backup Exec storage device pools. You can also specify a storage device pool by storage device pool name or storage device pool ID (Guid) or pass a Backup Exec storage device pool object through the pipeline to Get-BEStorageDevicePool.

Parameters

-Name <String[]>

Specifies one or more storage device pools by storage device pool name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more storage device pools by storage device pool ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEStorageDevicePool[]>

Specifies one or more storage device pool objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec storage device pool object to Get-BEStorageDevicePool.

BackupExec.Management.CLI.BEStorageDevicePool

You can pipe a Backup Exec storage device pool object to Get-BEStorageDevicePool.

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Get-BEStorageDevicePool returns objects that represent Backup Exec storage device pools.

Examples

Example 1

C:\PS> Get-BEStorageDevicePool

This command gets all of the storage device pools.

Example 2
C:\PS> Get-BEStorageDevicePool -Name "Any disk storage"

This command gets the storage device pool named "Any disk storage".

Example 3
C:\PS> Get-BEStorageDevicePool -Name "*pool*"

This command gets all of the storage device pools that match the wildcard "*pool*".


Get-BETapeDriveDevice Help

Get-BETapeDriveDevice Cmdlet
Synopsis

Gets tape storage in Backup Exec.

Syntax
Get-BETapeDriveDevice [[-Name] [<String[]>]] [<CommonParameters>]

Get-BETapeDriveDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BETapeDriveDevice -Media [<BEMedia[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BETapeDriveDevice -RoboticLibraryDevice [<BERoboticLibraryDevice[]>] [[-Name] [<String[]>]] [<CommonParameters>]

Get-BETapeDriveDevice [-Id] [<Guid[]>] [<CommonParameters>]

Get-BETapeDriveDevice -InputObject [<BETapeDriveDevice[]>] [<CommonParameters>]
Description

Gets tape storage in Backup Exec.

Without parameters, Get-BETapeDriveDevice gets all of the Backup Exec tape storage. You can also specify a tape device by tape device name or tape device ID (Guid) or pass a Backup Exec tape device object through the pipeline to Get-BETapeDriveDevice.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the tape storage. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Media <BEMedia[]>

Specifies one or more Backup Exec media objects to filter the tape storage. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEMedia.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice[]>

Specifies one or more robotic library device objects to filter the tape storage. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BERoboticLibraryDevice.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more tape drive devices by tape drive device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more tape drive devices by tape drive device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BETapeDriveDevice[]>

Specifies one or more tape drive device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter tape drive devices returned by Get-BETapeDriveDevice.

BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to filter tape drive devices returned by Get-BETapeDriveDevice.

BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to filter tape drive devices returned by Get-BETapeDriveDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec tape drive device object to Get-BETapeDriveDevice.

BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Get-BETapeDriveDevice.

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

Get-BETapeDriveDevice returns objects that represent Backup Exec tape drive devices.

Examples

Example 1

C:\PS> Get-BETapeDriveDevice

This command gets all of the tape drive devices.

Example 2
C:\PS> Get-BETapeDriveDevice -Name "Device 01"

This command gets the tape drive device named "Device 01".

Example 3
C:\PS> Get-BETapeDriveDevice -Name "Device*"

This command gets all of the tape drive devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BETapeDriveDevice

This command gets all of the tape drive devices attached to the local Backup Exec server.

Related Links


Get-BEVirtualDiskDevice Help

Get-BEVirtualDiskDevice Cmdlet
Synopsis

Gets virtual disk devices in Backup Exec.

Syntax
Get-BEVirtualDiskDevice [[-Name] [<String[]>]] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEVirtualDiskDevice -BackupExecServer [<BEBackupExecServer[]>] [[-Name] [<String[]>]] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEVirtualDiskDevice -StorageArrayDevice [<BEStorageArrayDevice[]>] [[-Name] [<String[]>]] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEVirtualDiskDevice [-Id] [<Guid[]>] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]

Get-BEVirtualDiskDevice -InputObject [<BEVirtualDiskDevice[]>] [-Unconfigured [<SwitchParameter>]] [<CommonParameters>]
Description

Gets virtual disk devices in Backup Exec.

Without parameters, Get-BEVirtualDiskDevice gets all of the Backup Exec virtual disk devices. You can also specify a virtual disk device by virtual disk device name or virtual disk device ID (Guid) or pass a Backup Exec virtual disk device object through the pipeline to Get-BEVirtualDiskDevice.

By default, Get-BEVirtualDiskDevice does not return unconfigured virtual disk devices. Specify the -Unconfigured parameter to get unconfigured virtual disk devices.

Parameters

-Unconfigured <SwitchParameter>

Returns unconfigured virtual disk devices.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

Specifies one or more Backup Exec server objects to filter the virtual machines. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEBackupExecServer.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-StorageArrayDevice <BEStorageArrayDevice[]>

Specifies one or more storage array objects to filter the virtual machines. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEStorageArrayDevice.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more virtual disk devices by virtual disk device name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Id <Guid[]>

Specifies one or more virtual disk devices by virtual disk device ID (Guid). To specify multiple IDs, use commas to separate the IDs.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-InputObject <BEVirtualDiskDevice[]>

Specifies one or more virtual disk device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to filter virtual disk devices returned by Get-BEVirtualDiskDevice.

BackupExec.Management.CLI.BEStorageArrayDevice

You can pipe a Backup Exec storage array object to filter virtual machines returned by Get-BEVirtualDiskDevice.

System.Guid

You can pipe a System.Guid that contains the ID of a Backup Exec virtual disk device object to Get-BEVirtualDiskDevice.

BackupExec.Management.CLI.BEVirtualDiskDevice

You can pipe a Backup Exec virtual disk device object to Get-BEVirtualDiskDevice.

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Get-BEVirtualDiskDevice returns objects that represent Backup Exec virtual disk devices.

Examples

Example 1

C:\PS> Get-BEVirtualDiskDevice

This command gets all of the virtual disk devices.

Example 2
C:\PS> Get-BEVirtualDiskDevice -Name "Device 01"

This command gets the virtual disk device named "Device 01".

Example 3
C:\PS> Get-BEVirtualDiskDevice -Name "Device*"

This command gets all of the virtual disk devices that match the wildcard "Device*".

Example 4
C:\PS> Get-BEBackupExecServer -Local | Get-BEVirtualDiskDevice

This command gets all of the virtual disk devices attached to the local Backup Exec server.

Related Links


Grant-BETrust Help

Grant-BETrust Cmdlet
Synopsis

Establishes a trust between the local Backup Exec server and a remote computer running the Backup Exec agent.

Syntax
Grant-BETrust -AgentServer [<BEAgentServer[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Grant-BETrust [-ComputerName] [<String[]>] [-LogonAccount] [<BELogonAccount>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Establishes a trust between the local Backup Exec server and a remote computer running the Agent for Windows.

Parameters

-AgentServer <BEAgentServer[]>

Specifies one or more agent server objects that you want to establish trust with.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ComputerName <String[]>

Specifies one or more computer names that you want to establish trust with.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

Specifies the Backup Exec logon account you want to use to log on to the remote computers.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

A Backup Exec agent server object can be piped into Grant-BETrust.

System.String

A string can be piped into Grant-BETrust.

Return Values
BackupExec.Management.CLI.BEAgentServer

The Backup Exec agent server object that has been trusted.

System.String

The computer name that has been trusted.

Examples

Example 1

C:\PS> "server01","server02","server03" | Grant-BETrust -LogonAccount "System Logon Account"

This command establishes trust with servers named "server01","server02", and "server03".

Example 2
C:\PS> type servers.txt | Grant-BETrust -LogonAccount "System Logon Account"

This command establishes trust with the names of servers within a text file.


Import-BELegacyBackupToDiskFolderDevice Help

Import-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Imports a legacy backup-to-disk folder device in Backup Exec.

Syntax
Import-BELegacyBackupToDiskFolderDevice [-Name] [<String>] [-Path] [<String>] [-BufferedReadsEnabled [<Boolean>]] [-BufferedReadsAutoDetectEnabled [<Boolean>]] [-BackupExecServer [<BEBackupExecServer>]] [-Description [<String>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Imports a legacy backup-to-disk folder device in Backup Exec. You must import an existing backup-to-disk folder into Backup Exec to restore data from it.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device should be created on in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Path <String>

Specifies the path to legacy backup-to-disk folder.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the legacy backup-to-disk folder device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsAutoDetectEnabled <Boolean>

Specifies if Backup Exec automatically detects the preferred settings for read and write buffers.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsEnabled <Boolean>

Enables the reading of large blocks of data. This option may increase performance.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new legacy backup-to-disk folder device.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec legacy backup-to-disk folder device object to create to Import-BELegacyBackupToDiskFolderDevice.

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Import-BELegacyBackupToDiskFolderDevice returns the legacy backup-to-disk folder device that was created.

Example

C:\PS> Import-BELegacyBackupToDiskFolderDevice -Name "Device 0001" -Path E:\b2d

These commands import the contents of "E:\b2d" as a new legacy backup-to-disk folder named "Device 0001".


Initialize-BEUnconfiguredDiskCartridgeDevice Help

Initialize-BEUnconfiguredDiskCartridgeDevice Cmdlet
Synopsis

Configures an unconfigured disk cartridge device so that it can be used with Backup Exec.

Syntax
Initialize-BEUnconfiguredDiskCartridgeDevice -InputObject [<BEDiskCartridgeDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Configures an unconfigured disk cartridge device so that it can be used with Backup Exec.

Use this command with Get-BEDiskCartridgeDevice and -Unconfigured to get the unconfigured disk cartridge devices.

You can use this command to configure unconfigured local disk storage devices that do not have drive letters associated with them. To configure local disk storage devices that have drive letters associated with them, use New-BEDiskCartridgeDevice.

Parameters

-InputObject <BEDiskCartridgeDevice[]>

Specifies one or more disk cartridge device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Initialize-BEUnconfiguredDiskCartridgeDevice.

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

Initialize-BEUnconfiguredDiskCartridgeDevice outputs a BEDiskCartridgeDevice object.

Example

C:\PS> Get-BEDiskCartridgeDevice -Unconfigured | Select-Object -First 1 | Initialize-BEUnconfiguredDiskCartridgeDevice

These commands configure the first unconfigured disk cartridge device returned from Get-BEDiskCartridgeDevice.

Related Links


Initialize-BEUnconfiguredDiskStorageDevice Help

Initialize-BEUnconfiguredDiskStorageDevice Cmdlet
Synopsis

Configures a disk storage device so that it can be used with Backup Exec.

Syntax
Initialize-BEUnconfiguredDiskStorageDevice -InputObject [<BEDiskStorageDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Configures a disk storage device so that it can be used with Backup Exec.

Use this command with Get-BEDiskStorageDevice and -Unconfigured switch to get the unconfigured disk storage devices to configure.

You can use this command to configure unconfigured local disk storage devices that do not have drive letters associated with them. To configure local disk storage devices that have drive letters associated with them, use New-BEDiskStorageDevice.

Parameters

-InputObject <BEDiskStorageDevice[]>

Specifies one or more disk storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskStorageDevice

You can pipe a Backup Exec disk storage device object to Initialize-BEUnconfiguredDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Initialize-BEUnconfiguredBEDiskStorageDevice outputs a Backup Exec disk storage device object.

Example

C:\PS> Get-BEDiskStorageDevice -Unconfigured | Select-Object -First 1 | Initialize-BEUnconfiguredDiskStorageDevice

These commands configure the first unconfigured disk storage device returned from Get-BEDiskStorageDevice.

Related Links


Initialize-BEUnconfiguredVirtualDiskDevice Help

Initialize-BEUnconfiguredVirtualDiskDevice Cmdlet
Synopsis

Configures an unconfigured virtual disk device so that it can be used with Backup Exec.

Syntax
Initialize-BEUnconfiguredVirtualDiskDevice -InputObject [<BEVirtualDiskDevice[]>] [-MakeDeduplicationDiskStorageDevice [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Configures an unconfigured virtual disk device so that it can be used with Backup Exec.

You can use this command with Get-BEVirtualDiskDevice and -Unconfigured to get the unconfigured virtual disk devices to configure.

Parameters

-MakeDeduplicationDiskStorageDevice <SwitchParameter>

Specifies if you want to make a deduplication disk storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEVirtualDiskDevice[]>

Specifies one or more virtual disk device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEVirtualDiskDevice

You can pipe a Backup Exec virtual disk device object to Initialize-BEUnconfiguredVirtualDiskDevice.

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Initialize-BEUnconfiguredVirtualDiskDevice outputs a Backup Exec virtual disk device object.

Example

C:\PS> Get-BEVirtualDiskDevice -Unconfigured | Select-Object -First 1 | Initialize-BEUnconfiguredVirtualDiskDevice

These commands configure the first unconfigured virtual disk device returned from Get-BEVirtualDiskDevice.

Related Link

Get-BEVirtualDiskDevice


Invoke-BEReport Help

Invoke-BEReport Cmdlet
Synopsis

Runs a Backup Exec report.

Syntax
Invoke-BEReport -Report [<BEReport>] [-Path] [<String>] [[-Format] {Html | Pdf | Csv | Xml | Xls}] [-AuditLogCategory {Alert | AuditLog | DeviceAndMedia | EncryptionKey | ErrorHandlingRules | Job | LogonAccount | ServerConfiguration}] [-AgentServer [<BEAgentServer[]>]] [-MediaVault [<BEMediaVault[]>]] [-MediaSet [<BEMediaSet[]>]] [-DaysBefore [<Int32>]] [-BackupExecServer [<BEBackupExecServer[]>]] [-DaysAfter [<Int32>]] [-MaximumEventCount [<Int32>]] [-WithinHour [<Int32>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Runs a Backup Exec report.

Reports are run by passing the results of Get-BEReport to Invoke-BEReport.

To get the filter parameters that apply to a report, use the ValidFilters property of the objects returned by Get-BEReport.

Parameters

-Report <BEReport>

Specifies the report to run.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Path <String>

Specifies the path for the file where the report output is written.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Format

Specifies the report output format.

The valid values are:
Html
Pdf
Csv
Xml
Xls

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-DaysBefore <Int32>

Specifies the number of days prior to the current day to begin the filter process on the data to be included in the report.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DaysAfter <Int32>

Specifies the number of days after the current day to begin the filter process on the data to be included in the report.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WithinHour <Int32>

Specifies the number of hours either before or after the present hour to filter the data to be included in the report.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumEventCount <Int32>

Specifies the number of events to include in the report.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer[]>

Filters the report based on Backup Exec servers. See Get-BEBackupExecServer.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer[]>

Filters the report based on specific backed up servers. See Get-BEAgentServer.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AuditLogCategory

Filters the report based on audit log categories.

The valid values are:
Alert
AuditLog
DeviceAndMedia
EncryptionKey
ErrorHandlingRules
Job
LogonAccount
ServerConfiguration

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaSet <BEMediaSet[]>

Filters the report based on media sets. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaVault <BEMediaVault[]>

Filters the report based on media vaults. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEReport

You can pipe a Backup Exec report object to Invoke-BEReport.

Return Value
System.IO.FileInfo

Invoke-BEReport returns the file object where the report results are written.

Example

C:\PS> Get-BEReport "Audit Log" | Invoke-BEReport -Path .\AuditLog.html | Invoke-Item

These commands run the report named "Audit Log" and displays the report in the default web browser.

Related Links


Move-BEMediaToMediaSet Help

Move-BEMediaToMediaSet Cmdlet
Synopsis

Moves media to a media set in Backup Exec.

Syntax
Move-BEMediaToMediaSet -InputObject [<BEMedia[]>] -MediaSet [<BEMediaSet>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Moves media to a media set in Backup Exec.

Parameters

-MediaSet <BEMediaSet>

Specifies the Backup Exec media set to move the media.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMedia[]>

Specifies one or more media objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to Move-BEMediaToMediaSet.

Return Value
BackupExec.Management.CLI.BEMedia

Move-BEMediaToMediaSet returns the media that was moved.

Example

C:\PS> Get-BEMedia "Media0001" | Move-BEMediaToMediaSet -MediaSet "MediaSet0001"

Moves the media named "Media0001" to the media set named "MediaSet0001".

Related Link

Get-BEMedia


Move-BEMediaToMediaVault Help

Move-BEMediaToMediaVault Cmdlet
Synopsis

Moves media to a media vault in Backup Exec.

Syntax
Move-BEMediaToMediaVault -InputObject [<BEMedia[]>] -MediaVault [<BEMediaVault>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Moves media to a media vault in Backup Exec.

Parameters

-MediaVault <BEMediaVault>

Specifies the Backup Exec media vault to move the media.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMedia[]>

Specifies one or more media objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to Move-BEMediaToMediaVault.

Return Value
BackupExec.Management.CLI.BEMedia

Move-BEMediaToMediaVault returns the media that was moved.

Example

C:\PS> Get-BEMedia "Media0001" | Move-BEMediaToMediaVault -MediaVault "MediaVault0001"

Moves the media named "Media0001" to the media vault named "MediaVault0001".

Related Link

Get-BEMedia


New-BEBackupDefinition Help

New-BEBackupDefinition Cmdlet
Synopsis

Creates a new backup definition in Backup Exec.

Syntax
New-BEBackupDefinition -AgentServer [<BEAgentServer>] [-BackupJobDefault] {BackupToDisk | BackupToDiskThenDuplicateToDisk | BackupToDiskThenDuplicateToTape | BackupToDiskCartridge | BackupToDiskCartridgeThenDuplicateToDiskCartridge | BackupToDiskCartridgeThenDuplicateToTape | BackupToDeduplicationDevice | BackupToDeduplicationDeviceThenDuplicateToDeduplicationDevice | BackupToDeduplicationDeviceThenDuplicateToTape | BackupToTape} [-ExchangeContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-ExchangeUseGrt [<Boolean>]] [-ExchangePreConsistencyCheck [<Boolean>]] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupOpenFileIfClosedWithinSeconds [<UInt32>]] [-SharePointContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-SharePointUseGrt [<Boolean>]] [-SharePointPreConsistencyCheck [<Boolean>]] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly}] [-SharePointReleaseLockOnFarmTopology [<Boolean>]] [-RunBackupWhenThreatConLevelReached [<String>]] [-ThreatConLevel {Level2 | Level3 | Level4}] [-ProcessOffhostLogicalVolumesSequentially [<Boolean>]] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-FailIfNoOffhostBackup [<Boolean>]] [-FileSystemFollowSymbolicLink [<Boolean>]] [-FileSystemBackupRemoteStorage [<Boolean>]] [-FileSystemFollowJunctionPoint [<Boolean>]] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-FileSystemEnableNtfsSingleInstanceBackup [<Boolean>]] [-VirtualMachineUseGrtForSql [<Boolean>]] [-VirtualMachineUseGrtForSharePoint [<Boolean>]] [-VirtualMachineUseGrtForExchange [<Boolean>]] [-VirtualMachineUseGrtForFileSystem [<Boolean>]] [-VirtualMachineUseGrtForActiveDirectory [<Boolean>]] [-Name [<String>]] [-WithInitialFullBackupOnly [<SwitchParameter>]] [-VMwareVSpherePort [<UInt32>]] [-HyperVExcludeVirtualMachinesNeedingSavedState [<Boolean>]] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-LinuxMacLockRemoteFile [<Boolean>]] [-ActiveDirectoryPreConsistencyCheck [<Boolean>]] [-LinuxMacFollowRemoteMountPoint [<Boolean>]] [-LinuxMacPreserveChangeTime [<Boolean>]] [-LinuxMacFollowLocalMountPoint [<Boolean>]] [-OracleMinimumNumberOfDevicesRequiredForJob [<UInt32>]] [-VirtualMachineBackupPoweredOffVirtualMachine [<Boolean>]] [-OracleMaximumNumberOfDevicesToUseForResources [<UInt32>]] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-ActiveDirectoryUseGrt [<Boolean>]] [-UseOffhostBackup [<Boolean>]] [-SharePointWebApplicationSelection [<BESharePointWebApplicationSelection[]>]] [-SharePointServiceApplicationSelection [<BESharePointServiceApplicationSelection[]>]] [-SharePointSingleSignOnDatabaseSelection {Include | Exclude}] [-SharePointInfoPathServicesSelection {Include | Exclude}] [-SharePointHelpSearchSelection {Include | Exclude}] [-SharePointSharedServiceProviderSelection [<BESharePointSharedServiceProviderSelection[]>]] [-SharePointPortalSiteSelection [<BESharePointPortalSiteSelection[]>]] [-SharePointSharedServiceApplicationProxySelection [<BESharePointSharedServiceApplicationProxySelection[]>]] [-SharePointServiceApplicationProxySelection [<BESharePointServiceApplicationProxySelection[]>]] [-SharePointSharedServiceApplicationSelection [<BESharePointSharedServiceApplicationSelection[]>]] [-ExchangeStorageGroupDatabaseSelection [<BEExchangeStorageGroupDatabaseSelection[]>]] [-ExchangeDatabaseSelection [<BEExchangeDatabaseSelection[]>]] [-FileSystemSelection [<BEFileSystemSelection[]>]] [-EnableSimplifiedDisasterRecovery [<Boolean>]] [-SystemStateSelection {Include | Exclude}] [-SharePointGlobalSettingsSelection {Include | Exclude}] [-SharePointCentralAdministrationWebApplicationSelection {Include | Exclude}] [-SharePointConfigurationDatabaseSelection {Include | Exclude}] [-SqlDatabaseSelection [<BESqlDatabaseSelection[]>]] [-SharePointAllResourcesSelection {Include | Exclude}] [-NetworkSubnet [<BENetworkInterfaceSubnet>]] [-AllowAnyNetworkForAgentAccess [<Boolean>]] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful [<Boolean>]] [-NetworkInterface [<BENetworkInterface>]] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-ProcessLogicalVolumesSequentially [<Boolean>]] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-EnableCheckpointRestart [<Boolean>]] [-UseSnapshotTechnology [<Boolean>]] [-RestrictToBackupExecServersInPool [<BEBackupExecServerPool>]] [-EnableTestRun [<Boolean>]] [-RestrictToBackupExecServer [<BEBackupExecServer>]] [-SharePointServiceSiteSelection [<BESharePointServiceSiteSelection[]>]] [-Priority {Normal | Lowest | Low | High | Highest}] [-TestRunCheckMediaAvailable [<Boolean>]] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunCheckStorageSpace [<Boolean>]] [-TestRunSchedule [<BESchedule>]] [-TestRunCheckLogonAccount [<Boolean>]] [<CommonParameters>]
Description

Creates a new backup definition in Backup Exec.

The value of the BackupJobDefault parameter determines the default job options to use for the backup definition.

The parameters passed to New-BEBackupDefinition are options for all the tasks in the backup definition.

When no selection parameters are passed to New-BEBackupDefinition, the entire agent server is backed up.

New-BEBackupDefinition can be used with the following commands to modify the tasks in the backup definition: Set-BEBackupDefinition, Add-BEIncrementalBackupTask, Add-BEDifferentialBackupTask, Add-BEDuplicateStageBackupTask, Add-BEConvertToVirtualStageBackupTask, Add-BEVerifyBackupTask, Set-BEIncrementalBackupTask, Set-BEDifferentialBackupTask, Set-BEDuplicateStageBackupTask, Set-BEVerifyBackupTask, and Remove-BEBackupTask.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

Parameters

-EnableSimplifiedDisasterRecovery <Boolean>

Enables Simplified System Recovery.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemStateSelection

Includes or excludes System State in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

Includes or excludes one or more file system selections in the backup definition. To specify files or directories to include, specify one or more paths using commas to separate the values. To specify files or directories to exclude, use the output of New-BEFileSystemSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>

Includes or excludes one or more Exchange 2003 storage groups or databases in the backup definition. To specify storage groups to include, specify one or more storage group names using commas to separate the values (specifying '*' will include all storage groups). To specify storage groups to exclude, or to specify individual databases to include or exclude, use the output of New-BEExchangeStorageGroupDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>

Includes or excludes one or more databases for Exchange 2007 or later in the backup definition. To specify databases to include, specify one or more database names using commas to separate the values (specifying '*' will include all databases). To specify databases to exclude, use the output of New-BEExchangeDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDatabaseSelection <BESqlDatabaseSelection[]>

Includes or excludes one or more SQL instances or databases in the backup definition. To specify SQL instances to include, specify one or more SQL instance names using commas to separate the values (specifying '*' will include all SQL instances). To specify SQL instances to exclude, or to specify individual databases to include or exclude, use the output of New-BESqlDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointAllResourcesSelection

Includes or excludes all of the SharePoint resources categorically in the backup definition when you back up a Windows computer.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointConfigurationDatabaseSelection

Includes or excludes the SharePoint configuration database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointGlobalSettingsSelection

Includes or excludes the SharePoint global settings database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointCentralAdministrationWebApplicationSelection

Includes or excludes the SharePoint Central Administration Web Application in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointInfoPathServicesSelection

Includes or excludes the SharePoint Info Path Services in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointHelpSearchSelection

Includes or excludes the SharePoint Help Search in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSingleSignOnDatabaseSelection

Includes or excludes the SharePoint Single Sign-on Database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>

Includes or excludes one or more SharePoint Web Applications in the backup definition. To specify Web Applications to include, specify one or more Web Application names using commas to separate the values (specifying '*' will include all Web Applications). To specify Web Applications to exclude, use the output of New-BESharePointWebApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>

Includes or excludes one or more SharePoint Service Applications in the backup definition. To specify Service Applications to include, specify one or more Service Application names using commas to separate the values (specifying '*' will include all Service Applications). To specify Service Applications to exclude, use the output of New-BESharePointServiceApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>

Includes or excludes one or more SharePoint Service Application Proxies in the backup definition. To specify Service Application Proxies to include, specify one or more Service Application Proxy names using commas to separate the values (specifying '*' will include all Service Application Proxies). To specify Service Application Proxies to exclude, use the output of New-BESharePointServiceApplicationProxySelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>

Includes or excludes one or more SharePoint Shared Service Applications in the backup definition. To specify Shared Service Applications to include, specify one or more Shared Service Application names using commas to separate the values (specifying '*' will include all Shared Service Applications). To specify Shared Service Applications to exclude, use the output of New-BESharePointSharedServiceApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>

Includes or excludes one or more SharePoint Shared Service Application Proxies in the backup definition. To specify Shared Service Application Proxies to include, specify one or more Shared Service Application Proxy names using commas to separate the values (specifying '*' will include all Shared Service Application Proxies). To specify Shared Service Application Proxies to exclude, use the output of New-BESharePointSharedServiceApplicationProxySelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>

Includes or excludes one or more SharePoint Shared Service Providers in the backup definition. To specify Shared Service Providers to include, specify one or more Shared Service Provider names using commas to separate the values. To specify Shared Service Providers to exclude, use the output of New-BESharePointSharedServiceProviderSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>

Includes or excludes one or more SharePoint Portal Sites in the backup definition. To specify Portal Sites to include, specify one or more Portal Site names using commas to separate the values. To specify Portal Sites to exclude, use the output of New-BESharePointPortalSiteSelection with the -Exclude parameter to pass one or more Portal Sites to exclude to this parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>

Includes or excludes one or more SharePoint Service Sites in the backup definition. To specify Service Sites to include, specify one or more Service Site names using commas to separate the values. To specify Service Sites to exclude, use the output of New-BESharePointServiceSiteSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

Specifies the order that the job runs. If two jobs are scheduled to run at the same time, the priority you set determines which job runs first.

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server to which the job can be dispatched in a CASO environment. Cannot be specified if RestrictToBackupExecServersInPool is specified.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

Specifies a set of Backup Exec servers to which the job can be dispatched in a CASO environment. Cannot be specified if RestrictToBackupExecServer is specified.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestRun <Boolean>

Enables the test run process.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

Lets you schedule when and how often the test run job runs.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

Verifies that the Backup Exec logon account is correct for the data that you want to back up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

Tests if there is enough available capacity on the media to complete the job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

Tests whether the media is online and able to be overwritten.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

Specifies how to calculate if enough media is available to run the scheduled backup job.

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

Places the scheduled job on hold if Backup Exec detects any failures during the test run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

Specifies the name of the network interface card that connects the Backup Exec server to the network you want to use for the backup network. See Get-BENetworkInterface.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

Specifies the protocol you want to used to back up remote computers.

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Specifies the subnet you want to use to back up remote computers on by using one of the subnets of a network interface returned by Get-BENetworkInterface.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

Ensures that the data from the remote computer is backed up or restored over any available network if the remote computer that you select for backup or restore is not part of the specified backup network.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

Enables backup jobs to continue from the point at which the jobs was interrupted.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

Enables the use of a snapshot technology

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

Specifies the snapshot technology to use when you enable snapshot technology. UseSnapshotTechnology must be set to $true.

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

Specifies the Microsoft Volume Shadow Copy Service as the snapshot provider to use when you enable snapshot technology. UseSnapshotTechnology must be set to $true and SnapshotTechnology must be set to MicrosoftVolumeShadowCopyService.

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

Enables the backup of multiple volumes in one job, while creating a snapshot of only one logical volume at a time.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

Enables offhost backup. If enabled, then an offhost backup of all volumes will be performed if all requirements are met.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

Specifies the offhost backup snapshot provider to use. UseOffhostBackup must be set to $true.

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

Terminates the backup job if any of the volumes selected do not support offhost backup, or if an error occurs that is related to the snapshot or volume import. UseOffhostBackup must be set to $true.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

Enables the backup of multiple volumes in one job, while creating a snapshot of only one logical volume at a time for offhost backups. UseOffhostBackup must be set to $true.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunBackupWhenThreatConLevelReached <String>

Runs automatic backup jobs when the ThreatCon reaches a level that you specify.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ThreatConLevel

Specifies the ThreatCon level at which you want backup jobs to run. RunJobAfterThreatConLevelReached must be set to $true.

The valid values are:
Level2
Level3
Level4

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupMethod

Specifies the backup method to use to back up files and folders.

The valid values are:
UseModifiedTime
UseArchiveBit
UseCatalog

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Lets Backup Exec check the NTFS volume for identical files. If Backup Exec finds multiple copies of a file, only one instance of that file is backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

Backs up the information for the junction points and the files and directories to which they are linked.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

Backs up the information for the symbolic links and the files and directories to which they are linked.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

Backs up data that has been migrated from primary storage to secondary storage.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

Specifies how Backup Exec processes any open files for the backup job if snapshot technology is not used.

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

The number of seconds Backup Exec waits for files to close before skipping them and continuing the backup job. BackupOpenFile must be set to IfClosedWithinSpecifiedTime.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

Performs a consistency check before running the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

Enables restores of individual items from Information Store backup jobs.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Specifies a backup source for Exchange 2007 or later.

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

Releases the lock on the SharePoint farm topology before you run the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Runs a full consistency check (including indexes) of the Microsoft SQL databases used by Microsoft SharePoint before you back up the databases.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Continues with the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

Enables the restore of individual documents, images, sites, subsites, lists, and list items from backups of the database.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

Prevents the Agent of Windows from changing an object's attributes when a backup job occurs. An object is a file or a directory.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

Lets Backup Exec follow local mount points when it backs up data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

Lets Backup Exec follow remote mount points when it backs up data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

Lets the Agent for Windows have exclusive access to the files on the remote computers that are connected through Network File System (NFS).

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

Checks snapshots for data corruption.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Enables the backup job to continue even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Enables the restore of individual items from full backups of the Active Directory.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

Specifies the maximum number of devices that the backup job can use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

Specifies the minimum number of devices that the job can use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

Enables Backup Exec to back up virtual machines that are turned off.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

Enables individual files and folders to be restored from the full backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Enables Backup Exec to collect the information that is required to restore individual Active Directory objects on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Enables Backup Exec to collect the information that is required to restore individual Exchange databases and mailbox items on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Enables Backup Exec to collect the information that is required to restore individual SQL database items on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Enables Backup Exec to collect the information that is required to restore SharePoint data on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

Excludes all offline virtual machines that do not support online backups and that are in a running state when the backup starts.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Specifies one or more VMware transport modes Backup Exec should use in order of their priority.

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Specifies the VMware vSphere port Backup Exec should use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

Specifies the agent server object to back up.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new backup definition.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupJobDefault

Specifies the default job options to use for the backup definition.

The valid values are:
BackupToDisk
BackupToDiskThenDuplicateToDisk
BackupToDiskThenDuplicateToTape
BackupToDiskCartridge
BackupToDiskCartridgeThenDuplicateToDiskCartridge
BackupToDiskCartridgeThenDuplicateToTape
BackupToDeduplicationDevice
BackupToDeduplicationDeviceThenDuplicateToDeduplicationDevice
BackupToDeduplicationDeviceThenDuplicateToTape
BackupToTape

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WithInitialFullBackupOnly <SwitchParameter>

Creates a backup definition with an initial full backup only.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to New-BEBackupDefinition.

Return Value
BackupExec.Management.CLI.BEBackupDefinition

New-BEBackupDefinition returns the backup definition that was created.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Save-BEBackupDefinition

These commands create a new backup definition that backs up the entire local computer using the BackupToDisk defaults.

Example 2
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -FileSystemSelection C:\Windows\*,D:\* -SystemStateSelection Include | Save-BEBackupDefinition

These commands create a new backup definition that backs up the C:\Windows directory, the D: drive, and the System State of the local computer.

Example 3
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask * | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

These commands create a new backup definition that backs up the local computer with an initial full and a differential backup.

Related Links

Set-BEBackupDefinition
Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEConvertToVirtualStageBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupDefinition
New-BEFileSystemSelection
New-BEExchangeStorageGroupDatabaseSelection
New-BEExchangeDatabaseSelection
New-BESqlDatabaseSelection
New-BESharePointWebApplicationSelection
New-BESharePointServiceApplicationSelection
New-BESharePointServiceApplicationProxySelection
New-BESharePointSharedServiceApplicationSelection
New-BESharePointSharedServiceApplicationProxySelection
New-BESharePointSharedServiceProviderSelection
New-BESharePointPortalSiteSelection
New-BESharePointServiceSiteSelection
Get-BENetworkInterface
Get-BEAgentServer


New-BEBackupExecServerPool Help

New-BEBackupExecServerPool Cmdlet
Synopsis

Creates a new Backup Exec server pool.

Syntax
New-BEBackupExecServerPool [-Name] [<String>] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new Backup Exec server pool.

Parameters

-Description <String>

Specifies the description for the Backup Exec server pool.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new Backup Exec server pool.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec server pool object to create to New-BEBackupExecServerPool.

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

New-BEBackupExecServerPool returns the Backup Exec server pool that was created.

Example

C:\PS> New-BEBackupExecServerPool -Name "Server Pool 0001".

This command creates a Backup Exec server pool named "Server Pool 0001".


New-BEBarcodeRule Help

New-BEBarcodeRule Cmdlet
Synopsis

Creates a new bar code rule in Backup Exec.

Syntax
New-BEBarcodeRule -MediaType [<BEMediaType>] [-BarcodeSuffix [<String>]] [-Vendor [<String>]] [-BarcodePrefix [<String>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new bar code rule in Backup Exec.

Parameters

-MediaType <BEMediaType>

Specifies the media type to include in the bar code rule. See Get-BEMediaType

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Vendor <String>

Specifies the name of the robotic library's manufacturer.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodePrefix <String>

Specifies the code that is placed before the bar code that represents a media type.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodeSuffix <String>

Specifies the code that is placed after the bar code that represents a media type.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaType

You can pipe a Backup Exec media type object to New-BEBarcodeRule

Return Value
BackupExec.Management.CLI.BEBarcodeRule

New-BEBarcodeRule returns the bar code rule that was created.

Example

C:\PS> New-BEBarcodeRule -MediaType LTO-100 -BarcodeSuffix L1

This command creates a bar code rule for the media type named "LTO-100" with a barcode suffix named "L1".

Related Link

Get-BEMediaType


New-BECloudStorageDevice Help

New-BECloudStorageDevice Cmdlet
Synopsis

Creates a new cloud storage device in Backup Exec.

Syntax
New-BECloudStorageDevice [-Name] [<String>] [-HostServer] [<String>] [-ServerType] [<String>] [-LogicalStorageUnit] [<String>] [-LogonAccount] [<BELogonAccount>] [-DataStreamSizeBytes [<Int32>]] [-SplitDataStreamBytes [<Int64>]] [-AllowedConcurrentOperations [<Int32>]] [-IsStreamHandlerSupportEnabled [<Boolean>]] [-DiskSpaceReserveBytes [<Int64>]] [-BackupExecServer [<BEBackupExecServer>]] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Force [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new cloud storage device in Backup Exec.

To get a list of registered server types to pass to the ServerType parameter, call Get-BECloudStorageServerType.

To get a list off logical storage units to pass to the LogicalStorageUnit parameter, call Get-BEOpenStorageLogicalStorageUnit.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device should be created on in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HostServer <String>

Specifies the fully-qualified name of the server on which the device exists.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-ServerType <String>

Specifies the type of cloud storage device.

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-LogicalStorageUnit <String>

Specifies the logical storage unit of the cloud storage device.

Required | true
Position | 3
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

Specifies a Backup Exec logon account for the new cloud storage device. The logon account cannot be the System Logon Account.

Required | true
Position | 4
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the cloud storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

Sets the maximum allowed concurrent write operations allowed on this device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SplitDataStreamBytes <Int64>

Specifies the size at which you want Backup Exec to span to a new image.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Indicates the size of a single write operation that Backup Exec issues.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsStreamHandlerSupportEnabled <Boolean>

Specifies if stream handler is used.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Specifies the amount of disk space to set aside for applications other than Backup Exec.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new cloud storage device.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Forces the cloud storage device to be trusted by the Backup Exec server.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec cloud storage device object to create to New-BECloudStorageDevice.

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

New-BECloudStorageDevice returns the cloud storage device that was created.

Example

C:\PS> New-BECloudStorageDevice -Name "Device 0001" -HostServer "nirvanix.com" -ServerType "nirvanix" -LogicalStorageUnit "ChildAccount01" -LogonAccount "Logon Account 0001"

This command creates a cloud storage device named "Device 0001" that uses the logical storage type called "ChildAccount01" on the Nirvanix host server called "nirvanix.com" with the logon account "Logon Account 0001".

Related Links


New-BEConvertToVirtualTargetEnvironment Help

New-BEConvertToVirtualTargetEnvironment Cmdlet
Synopsis

Defines the target environment for a convert to virtual job.

Syntax
New-BEConvertToVirtualTargetEnvironment -LogonAccount [<BELogonAccount>] -ToolsIsoPath [<String>] -HyperVServerName [<String>] -HyperVDestinationPath [<String>] [<CommonParameters>]

New-BEConvertToVirtualTargetEnvironment -LogonAccount [<BELogonAccount>] -ToolsIsoPath [<String>] -VMwareVCenterServerName [<String>] -VMwareHostName [<String>] -VMwareDataStoreName [<String>] [-VMwareResourcePoolName [<String>]] [-VMwareVirtualMachineFolder [<String>]] [<CommonParameters>]

New-BEConvertToVirtualTargetEnvironment -LogonAccount [<BELogonAccount>] -ToolsIsoPath [<String>] -VMwareEsxServerName [<String>] -VMwareDataStoreName [<String>] [-VMwareResourcePoolName [<String>]] [<CommonParameters>]
Description

Defines the target environment for a convert to virtual job.

The output of New-BEConvertToVirtualTargetEnvironment is used for the TargetEnvironment parameter of the Submit-BEConvertBackupToVirtualJob and Add-BEConvertToVirtualStageBackupTask commands.

Parameters

-VMwareVCenterServerName <String>

Specifies the name of the VMware vCenter server where the virtual machine will be created.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareHostName <String>

Specifies the name of a host in a VMware vCenter where the virtual machine will be created.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareEsxServerName <String>

Specifies the name of a VMware ESX server where the virtual machine will be created.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareDataStoreName <String>

Specifies the name of a data store in a VMware host where the virtual machine will be created.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVirtualMachineFolder <String>

Specifies the folder path of a virutal machine folder in VMware vCenter where the virtual machine will be created.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareResourcePoolName <String>

Specifies the name of VMware resource pool.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVServerName <String>

Specifies the name of a Microsoft Hyper-V server.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVDestinationPath <String>

Specifies the directory where the Microsoft Hyper-V virtual machine will be created.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

Specifies the Backup Exec logon account used to log into the target virtual environment.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToolsIsoPath <String>

Specifies the full path of the VMware Tools or Hyper-V Integration Components ISO image.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
BackupExec.Management.CLI.BEConvertToVirtualTargetEnvironment

The object that represents convert to virtual environment that has been specified.

Examples

Example 1

C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -HyperVServerName hypervserver01 -HyperVDestinationPath c:\vms -LogonAccount "System Logon Account" -ToolsIsoPath c:\hypervtools.iso
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEConvertToVirtualStageBackupTask -SimultaneouslyWithBackup -TargetEnvironment $targetEnvironment | Save-BEBackupDefinition

These commands create a backup definition that has a convert to virtual stage that creates a virtual machine on a HyperV server simultaneously with a backup job.

Example 2
C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -VMwareVCenterServerName vcenterserver01 -VMwareHostName hostserver01 -VMwareDataStoreName datastore01 -LogonAccount "System Logon Account" -ToolsIsoPath c:\vmwaretools.iso
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition BackupToDisk | Add-BEConvertToVirtualStageBackupTask -SourceBackup AllBackups -Schedule (New-BESchedule -Weekdays -StartingAt 10PM) -TargetEnvironment $targetEnvironment | Save-BEBackupDefinition

These commands create a backup definition that has a convert to virtual stage that creates a virtual machine within a VMware vCenter from any of the backup jobs every weekday at 10pm.

Related Links

Submit-BEConvertBackupToVirtualJob
Add-BEConvertToVirtualStageBackupTask
Get-BEAgentServer
New-BEBackupDefinition
Save-BEBackupDefinition
New-BESchedule


New-BEDeduplicationDiskStorageDevice Help

New-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Creates a new deduplication disk storage device in Backup Exec.

Syntax
New-BEDeduplicationDiskStorageDevice [-Name] [<String>] [-StoragePath] [<String>] [-LogonAccount] [<BELogonAccount>] [-LogLevel {Minimal | Low | Normal | High | Full}] [-ClientSideDeduplicationEnabled [<Boolean>]] [-DataStreamSizeBytes [<Int32>]] [-LogRetentionDays [<Int32>]] [-BackupExecServer [<BEBackupExecServer>]] [-AllowedConcurrentOperations [<Int32>]] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Force [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new deduplication disk storage device in Backup Exec.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device should be created on in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StoragePath <String>

Specifies the path to storage volume.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

Specifies a Backup Exec logon account for the new deduplication storage device. The logon account cannot be the System Logon Account.

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the deduplication disk storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

Sets the maximum allowed concurrent operations allowed on this device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Indicates the size of a single write operation that Backup Exec issues.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ClientSideDeduplicationEnabled <Boolean>

Specifies if client-side deduplication is enabled for this OpenStorage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogLevel

Indicates the type of information you want to include in the diagnostic logs for this device.

The valid values are:
Minimal
Low
Normal
High
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogRetentionDays <Int32>

Specifies the number of days to retail log files.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new deduplication disk storage device.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Forces the deduplication disk storage device to be created even if the specified Backup Exec server does not meet the minimum memory requirements.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec deduplication disk storage device object to create to New-BEDeduplicationDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

New-BEDeduplicationDiskStorageDevice returns the deduplication disk storage device that was created.

Example

C:\PS> New-BEDeduplicationDiskStorageDevice -Name "Device 0001" -StoragePath "E:\pdde" -LogonAccount "Logon Account 0001"

This command creates a deduplication device named "Device 0001" that uses the path named "E:\pdde" and the logon account "Logon Account 0001".


New-BEDiskCartridgeDevice Help

New-BEDiskCartridgeDevice Cmdlet
Synopsis

Creates a new disk cartridge device in Backup Exec.

Syntax
New-BEDiskCartridgeDevice [-Name] [<String>] [-DriveLetter] [<String>] [-BlockSizeBytes [<Int32>]] [-BlockAndBufferSizeAutoDetectEnabled [<Boolean>]] [-BufferSizeBytes [<Int32>]] [-BufferedReadsWritesAutoDetectEnabled [<Boolean>]] [-BackupExecServer [<BEBackupExecServer>]] [-PreallocationIncrementBytes [<Int64>]] [-Description [<String>]] [-PreallocationEnabled [<Boolean>]] [-MaximumFileSizeBytes [<Int64>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new disk cartridge device in Backup Exec.

Parameters

-DriveLetter <String>

Specifies the a system drive letter for the new disk cartridge device.

Required | true
Position | 1
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device should be created on in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the disk cartridge device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

Specifies the maximum file size on the disk storage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

Enables preallocation of the disk space incrementally.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

Specifies the amount of disk space by which to increase the file size.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockAndBufferSizeAutoDetectEnabled <Boolean>

Specifies if Backup Exec automatically detects the preferred settings for the block and buffer size for the disk storage.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

Specifies the size in bytes of blocks of data that can be written to new media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

Specifies the amount of data sent to the disk cartridge on each read or write request.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

Specifies that you do not want Backup Exec to automatically detect settings for this disk and enables buffered reads and writes. Buffered reads and writes is the reading and writing of large blocks of data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new disk cartridge device.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec disk cartridge device object to create to New-BEDiskCartridgeDevice.

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

New-BEDiskCartridgeDevice returns the disk cartridge device that was created.

Example

C:\PS> New-BEDiskCartridgeDevice -Name "Device 0001" -DriveLetter E:

This command creates a new disk cartridge device named "Device 0001" on drive E of the local Backup Exec server.


New-BEDiskStorageDevice Help

New-BEDiskStorageDevice Cmdlet
Synopsis

Creates a new disk storage device in Backup Exec.

Syntax
New-BEDiskStorageDevice [-Name] [<String>] [-DriveLetter] [<String>] [-DiskSpaceReserveBytes [<Int64>]] [-VirtualWriteProtectionEnabled [<Boolean>]] [-BlockSizeBytes [<Int32>]] [-BufferSizeBytes [<Int32>]] [-BufferedReadsWritesAutoDetectEnabled [<Boolean>]] [-BlockAndBufferSizeAutoDetectEnabled [<Boolean>]] [-AllowedConcurrentWriteOperations [<UInt32>]] [-Description [<String>]] [-LowDiskSpaceInformationThresholdPercent [<Int32>]] [-PreallocationIncrementBytes [<Int64>]] [-BackupExecServer [<BEBackupExecServer>]] [-MaximumFileSizeBytes [<Int64>]] [-PreallocationEnabled [<Boolean>]] [-LowDiskSpaceWarningThresholdPercent [<Int32>]] [-LowDiskSpaceCriticalThresholdPercent [<Int32>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

New-BEDiskStorageDevice [-Name] [<String>] [-UncPath] [<String>] [-DiskSpaceReserveBytes [<Int64>]] [-VirtualWriteProtectionEnabled [<Boolean>]] [-BlockSizeBytes [<Int32>]] [-BufferSizeBytes [<Int32>]] [-BufferedReadsWritesAutoDetectEnabled [<Boolean>]] [-BlockAndBufferSizeAutoDetectEnabled [<Boolean>]] [-AllowedConcurrentWriteOperations [<UInt32>]] [-Description [<String>]] [-LowDiskSpaceInformationThresholdPercent [<Int32>]] [-PreallocationIncrementBytes [<Int64>]] [-BackupExecServer [<BEBackupExecServer>]] [-MaximumFileSizeBytes [<Int64>]] [-PreallocationEnabled [<Boolean>]] [-LowDiskSpaceWarningThresholdPercent [<Int32>]] [-LowDiskSpaceCriticalThresholdPercent [<Int32>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new disk storage device in Backup Exec.

Parameters

-DriveLetter <String>

Specifies the a system drive letter of the new disk device.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-UncPath <String>

Specifies the UNC path of the new disk device.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device should be created on in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the disk storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceInformationThresholdPercent <Int32>

Specifies the first threshold limit for initial low disk space alert.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceWarningThresholdPercent <Int32>

Specifies the second threshold limit for second low disk space alert.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceCriticalThresholdPercent <Int32>

Specifies the third and final threshold limit for initial low disk space alert, you are prompted immediately to create more disk space.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

Specifies the maximum file size on the disk storage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

Enables proallocation to occur.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

Specifies the size of preallocating space to increment at a time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

Specifies the size in bytes of blocks of data that can be written to new media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

Specifies the amount of data sent to the disk cartridge on each read or write request.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Specifies the amount of disk space to set aside for applications other than Backup Exec.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualWriteProtectionEnabled <Boolean>

Enables virtual write protection.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockAndBufferSizeAutoDetectEnabled <Boolean>

Specifies if Backup Exec automatically detects the preferred settings for the block and buffer size for the disk storage.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentWriteOperations <UInt32>

Allows concurrent write operations to disk.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

Specifies that you do not want Backup Exec to automatically detect settings for this disk and enables buffered reads and writes. Buffered reads and writes is the reading and writing of large blocks of data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new disk storage device.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec disk storage device object to create to New-BEDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

New-BEDiskStorageDevice returns the disk storage device that was created.

Example

C:\PS> New-BEDiskStorageDevice -Name "Device 0001" -DriveLetter E:

This command creates a new disk storage device named "Device 0001" on drive E of the local Backup Exec server.


New-BEEncryptionKey Help

New-BEEncryptionKey Cmdlet
Synopsis

Creates a new encryption key in Backup Exec.

Syntax
New-BEEncryptionKey [-Name] [<String>] [-Passphrase] [<SecureString>] [-EncryptionKeyType {Restricted | Common}] [-EncryptionType {Aes128Bit | Aes256Bit}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new encryption key in Backup Exec.

Parameters

-Passphrase <SecureString>

Designates a pass phrase for this key. For 128-bit AES encryption, the pass phrase must be at least eight characters. For 256-bit AES encryption, the pass phrase must be at least 16 characters.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption algorithm that you want to use.

The valid values are:
Aes128Bit
Aes256Bit

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKeyType

Specifies if the key is common or restricted. A restricted key allows only the key owner to restore the encrypted data.

The valid values are:
Restricted
Common

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new encryption key.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec encryption key object to create to New-BEEncryptionKey.

Return Value
BackupExec.Management.CLI.BEEncryptionKey

New-BEEncryptionKey returns the encryption key that was created.

Example

C:\PS> $passphrase = ConvertTo-SecureString "P@ssW0rD!" -AsPlainText -Force
C:\PS> New-BEEncryptionKey -Name "Encryption Key 0001" -Passphrase $passphrase -EncryptionType Aes128Bit

These commands create a secure string, which is then used as the passphrase to create an encryption key named "Encryption Key 0001".


New-BEExchangeDatabaseSelection Help

New-BEExchangeDatabaseSelection Cmdlet
Synopsis

Creates a backup selection object for Exchange 2010 databases.

Syntax
New-BEExchangeDatabaseSelection [[-DatabaseName] [<String>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Exchange 2010 databases.

Parameters

-DatabaseName <String>

Specifies the name of a database. Specify '*' to indicate all available databases.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the database selection specified with the -DatabaseName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BEExchangeDatabaseSelection.

Return Value
BackupExec.Management.CLI.BEExchangeDatabaseSelection

New-BEExchangeDatabaseSelection returns an BEExchangeDatabaseSelection object.

Examples

Example 1

C:\PS> $x = New-BEExchangeDatabaseSelection -DatabaseName "Database1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -ExchangeDatabaseSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the Exchange database named "Database1" on the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "Database1" | New-BEExchangeDatabaseSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -ExchangeDatabaseSelection $x

These commands submit a one-time backup job that backs up the Exchange database named "Database1" on the local computer.

Related Links


New-BEExchangeStorageGroupDatabaseSelection Help

New-BEExchangeStorageGroupDatabaseSelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft Exchange 2003 or 2007 databases.

Syntax
New-BEExchangeStorageGroupDatabaseSelection [[-StorageGroupName] [<String>]] [[-DatabaseName] [<String>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft Exchange 2003 or 2007 databases.

Parameters

-StorageGroupName <String>

Specifies the name of a storage group. Specify '*' to indicate all available storage groups.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-DatabaseName <String>

Specifies the name of a database. Specify '*' to indicate all available databases.

Required | false
Position | 1
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the storage group or database selection specified with the -StorageGroupName parameter and/or -DatabaseName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BEExchangeStorageGroupDatabaseSelection.

Return Value
BackupExec.Management.CLI.BEExchangeStorageGroupDatabaseSelection

New-BEExchangeStorageGroupDatabaseSelection returns an BEExchangeStorageGroupDatabaseSelection object

Examples

Example 1

C:\PS> $x = New-BEExchangeStorageGroupDatabaseSelection -StorageGroupName "StorageGroup1" -DatabaseName "Database1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -ExchangeStorageGroupDatabaseSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the Exchange database named "Database1" in a storage group named "StorageGroup1" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "StorageGroup1" | New-BEExchangeStorageGroupDatabaseSelection -Database "Database1"
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -ExchangeStorageGroupDatabaseSelection $x

These commands submit a one-time backup job that backs up the Exchange database named "Database1" in the storage group named "StorageGroup1" on the local computer.

Related Links


New-BEFileSystemSelection Help

New-BEFileSystemSelection Cmdlet
Synopsis

Creates a backup selection object for NTFS file system selections.

Syntax
New-BEFileSystemSelection [-Path] [<String>] [-IncludeOnlyModifiedFiles [<SwitchParameter>]] [-IncludeOnlyReadOnlyFiles [<SwitchParameter>]] [-NumberOfDaysFilesNotAccessed [<Int32>]] [-PathIsDirectory [<SwitchParameter>]] [-Recurse [<SwitchParameter>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]

New-BEFileSystemSelection [-Path] [<String>] -FromDate [<DateTime>] [-IncludeOnlyReadOnlyFiles [<SwitchParameter>]] [-NumberOfDaysFilesNotAccessed [<Int32>]] [-ToDate [<DateTime>]] [-Recurse [<SwitchParameter>]] [-PathIsDirectory [<SwitchParameter>]] [-IncludeOnlyModifiedFiles [<SwitchParameter>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for NTFS file system selections.

Parameters

-Path <String>

Specifies the path of the file system folder or file that you want to select. Wildcards accepted.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-PathIsDirectory <SwitchParameter>

Specifies that the value of the Path parameter is a directory instead of a file.

Required | false
Position | Named
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Recurse <SwitchParameter>

Specifies if you want to select all subfolders.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the filesystem selection specified by the -Path parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeOnlyModifiedFiles <SwitchParameter>

Specifies that you want to select only the files modified since the previous backup.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeOnlyReadOnlyFiles <SwitchParameter>

Specifies if you want to select only the files that are read-only.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromDate <DateTime>

Specifies a DateTime object to filter files with a timestamp that is after the specified DateTime.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToDate <DateTime>

Specifies a DateTime object to filter files with a timestamp that is before the specified DateTime. If the FromDate parameter is specified but the ToDate parameter is not specified, the ToDate parameter is automatically set to the current day at 11:59:59 PM. The FromDate parameter must be before the ToDate parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NumberOfDaysFilesNotAccessed <Int32>

Specifies the number of days to filter files that have not been accessed.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BEFileSystemSelection.

Return Value
BackupExec.Management.CLI.BEFileSystemSelection

New-BEFileSystemSelection returns a BEFileSystemSelection object.

Examples

Example 1

C:\PS> $x = New-BEFileSystemSelection -Path "C:\*" -Recurse
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -FileSystemSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the C: volume for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "C:\Windows\*" | New-BEFileSystemSelection -Recurse -Exclude
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -FileSystemSelection $x

These commands submit a one-time backup that backs up all of the data on the local computer with the exception of the C:\Windows directory.

Related Links


New-BELogonAccount Help

New-BELogonAccount Cmdlet
Synopsis

Creates a new Backup Exec logon account.

Syntax
New-BELogonAccount [[-Name] [<String>]] -Credential [<PSCredential>] [-AccountType {Restricted | Common}] [-Description [<String>]] [-SystemLogonAccount [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

New-BELogonAccount [[-Name] [<String>]] -UserName [<String>] -Password [<SecureString>] [-Description [<String>]] [-AccountType {Restricted | Common}] [-SystemLogonAccount [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new Backup Exec logon account.

Parameters

-Name <String>

Specifies the name of the new logon account.

Required | false
Position | 0
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Credential <PSCredential>

Specifies the credentials of the logon account.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UserName <String>

Specifies the user name of the logon account.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Password <SecureString>

Specifies the password of the logon account.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemLogonAccount <SwitchParameter>

Creates the System Logon Account.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the logon account.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AccountType

Specifies whether this is a common or restricted account.

The valid values are:
Restricted
Common

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
BackupExec.Management.CLI.BELogonAccount

New-BELogonAccount returns the logon account that was created.

Examples

Example 1

C:\PS> $credential = Get-Credential
C:\PS> New-BELogonAccount -Credential $credential

These commands create a new Backup Exec logon account using the credentials received from Get-Credential.

Example 2
C:\PS> $password = ConvertTo-SecureString "P@ssW0rD!" -AsPlainText -Force
C:\PS> New-BELogonAccount -UserName "mydomain\myuser" -Password $password

These commands create a new Backup Exec logon account by specifying a user name and password.


New-BEMediaSet Help

New-BEMediaSet Cmdlet
Synopsis

Creates a new media set in Backup Exec.

Syntax
New-BEMediaSet [-Name] [<String>] [-ReturnFromVaultPeriodHours [<Int32>]] [-MoveToVaultPeriodHours [<Int32>]] [-OverwriteProtectionPeriodHours [<Int32>]] [-Description [<String>]] [-MediaVault [<BEMediaVault>]] [-AppendPeriodHours [<Int32>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new media set in Backup Exec.

Parameters

-Description <String>

Specifies the description for the media set.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteProtectionPeriodHours <Int32>

Specifies the length of time that data is retained on a specific media before being overwritten.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AppendPeriodHours <Int32>

Specifies the length of time that data can be added to the media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaVault <BEMediaVault>

Specifies the Backup Exec media vault you want to send media that are associated with this media set.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MoveToVaultPeriodHours <Int32>

Specifies the time period after which this media will be reported as ready to be moved to this vault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReturnFromVaultPeriodHours <Int32>

Specifies the time period after which this media will be reported as ready to be returned from this vault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new media set.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec media set object to create to New-BEMediaSet.

Return Value
BackupExec.Management.CLI.BEMediaSet

New-BEMediaSet returns the media set that was created.

Example

C:\PS> New-BEMediaSet -Name "Media Set 0001"

This command creates a new media set named "Media Set 0001".


New-BEMediaVault Help

New-BEMediaVault Cmdlet
Synopsis

Creates a new media vault in Backup Exec.

Syntax
New-BEMediaVault [-Name] [<String>] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new media vault in Backup Exec.

Parameters

-Description <String>

Specifies the description for the media vault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new media vault.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec media vault object to create to New-BEMediaVault.

Return Value
BackupExec.Management.CLI.BEMediaVault

New-BEMediaVault returns the media vault that was created.

Example

C:\PS> New-BEMediaVault -Name "Media Vault 0001"

This command creates a new media vault named "Media Vault 0001".


New-BEOpenStorageDevice Help

New-BEOpenStorageDevice Cmdlet
Synopsis

Creates a new OpenStorage device in Backup Exec.

Syntax
New-BEOpenStorageDevice [-Name] [<String>] [-HostServer] [<String>] [-ServerType] [<String>] [-LogicalStorageUnit] [<String>] [-LogonAccount] [<BELogonAccount>] [-DataStreamSizeBytes [<Int32>]] [-SplitDataStreamBytes [<Int64>]] [-AllowedConcurrentOperations [<Int32>]] [-IsStreamHandlerSupportEnabled [<Boolean>]] [-DiskSpaceReserveBytes [<Int64>]] [-BackupExecServer [<BEBackupExecServer>]] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Force [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new OpenStorage device in Backup Exec.

To get a list of registered server types to pass to the ServerType parameter, call Get-BEOpenStorageServerType.

To get a list off logical storage units to pass to the LogicalStorageUnit parameter, call Get-BEOpenStorageLogicalStorageUnit.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device should be created on in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HostServer <String>

Specifies the fully-qualified name of the server on which the device exists.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-ServerType <String>

Specifies the type of OpenStorage device.

Required | true
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-LogicalStorageUnit <String>

Specifies the logical storage unit of the OpenStorage device.

Required | true
Position | 3
Accepts pipeline input | false
Accepts wildcard characters | false

-LogonAccount <BELogonAccount>

Specifies a Backup Exec logon account for the new OpenStorage device. The logon account cannot be the System Logon Account.

Required | true
Position | 4
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the OpenStorage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

Sets the maximum allowed concurrent write operations allowed on this device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SplitDataStreamBytes <Int64>

Specifies the size at which you want Backup Exec to span to a new image.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Indicates the size of a single write operation that Backup Exec issues.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsStreamHandlerSupportEnabled <Boolean>

Specifies if stream handler is used.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Specifies the amount of disk space to set aside for applications other than Backup Exec.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new OpenStorage device.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Force <SwitchParameter>

Forces the OpenStorage device to be trusted by the Backup Exec server.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec OpenStorage device object to create to New-BEOpenStorageDevice.

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

New-BEOpenStorageDevice returns the OpenStorage device that was created.

Example

C:\PS> New-BEOpenStorageDevice -Name "Device 0001" -HostServer "server01" -ServerType "Quantum" -LogicalStorageUnit "lsu1" -LogonAccount "Logon Account 0001"

This command creates an OpenStorage device named "Device 0001" that uses the logical storage type named "lsu1" on the Quantum host server named "server01" with the logon account "Logon Account 0001".

Related Links


New-BESchedule Help

New-BESchedule Cmdlet
Synopsis

Creates a new Backup Exec schedule.

Syntax
New-BESchedule [-WeeklyEvery] {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday} -StartingAt [<DateTime>] [-Every [<Int32>]] [<CommonParameters>]

New-BESchedule [-RunNow] [<SwitchParameter>] [<CommonParameters>]

New-BESchedule [-RunOnce] [<SwitchParameter>] -StartingAt [<DateTime>] [<CommonParameters>]

New-BESchedule [-Minutely] [<SwitchParameter>] -StartingAt [<DateTime>] [-Every [<Int32>]] [<CommonParameters>]

New-BESchedule [-Hourly] [<SwitchParameter>] -StartingAt [<DateTime>] [-Every [<Int32>]] [<CommonParameters>]

New-BESchedule [-Daily] [<SwitchParameter>] -StartingAt [<DateTime>] [-Every [<Int32>]] [<CommonParameters>]

New-BESchedule [-Weekdays] [<SwitchParameter>] -StartingAt [<DateTime>] [<CommonParameters>]

New-BESchedule [-MonthlyOnDayNumber] [<Int32>] -StartingAt [<DateTime>] [-Every [<Int32>]] [<CommonParameters>]

New-BESchedule [-MonthlyEvery] {First | Second | Third | Fourth | Last} [-Day] {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday | Weekday | WeekendDay | Day} -StartingAt [<DateTime>] [-Every [<Int32>]] [<CommonParameters>]

New-BESchedule [-YearlyOnMonthDayNumber] [<Int32>] [-Month] {January | February | March | April | May | June | July | August | September | October | November | December} -StartingAt [<DateTime>] [-Every [<Int32>]] [<CommonParameters>]

New-BESchedule [-YearlyEvery] {First | Second | Third | Fourth | Last} [-Day] {Sunday | Monday | Tuesday | Wednesday | Thursday | Friday | Saturday | Weekday | WeekendDay | Day} [-Month] {January | February | March | April | May | June | July | August | September | October | November | December} -StartingAt [<DateTime>] [-Every [<Int32>]] [<CommonParameters>]
Description

Creates a new Backup Exec schedule.

The output of New-BESchedule is used for the Schedule parameter of the following commands:
Add-BEConvertToVirtualStageBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEFullBackupTask
Add-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEFullBackupTask
Set-BEIncrementalBackupTask
Submit-BECleanJob
Submit-BEEjectMediaJob
Submit-BEExportExpiredMediaJob
Submit-BEExportMediaJob
Submit-BEImportMediaJob
Submit-BEInventoryJob

Parameters

-RunNow <SwitchParameter>

Runs the job immediately.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-RunOnce <SwitchParameter>

Runs the job immediately without a recurring schedule.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Minutely <SwitchParameter>

Schedules a recurrence pattern that is based on minutes.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Hourly <SwitchParameter>

Schedules a recurrence pattern that is based on hours.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Daily <SwitchParameter>

Schedules a recurrence pattern that is based on days.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Weekdays <SwitchParameter>

Schedules recurrence pattern that is based on weekdays.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WeeklyEvery

Schedules a recurrence pattern that is based on specific days of the week.

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyOnDayNumber <Int32>

Schedules a recurrence pattern that is based on a specific day of the month.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-MonthlyEvery

Schedules a recurrence pattern that is based on a specific days of the month.

The valid values are:
First
Second
Third
Fourth
Last

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-YearlyOnMonthDayNumber <Int32>

Schedules a recurrence pattern that is yearly on a specific day of the month.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-YearlyEvery

Schedules a recurrence pattern that is yearly based on a specific days of the month.

The valid values are:
First
Second
Third
Fourth
Last

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Month

Specifies a month.

The valid values are:
January
February
March
April
May
June
July
August
September
October
November
December

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-Day

Specifies a day.

The valid values are:
Sunday
Monday
Tuesday
Wednesday
Thursday
Friday
Saturday
Weekday
WeekendDay
Day

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Every <Int32>

Specifies how often to repeat the schedule. The default value is 1.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartingAt <DateTime>

Specifies when the schedule starts.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
BackupExec.Management.CLI.BESchedule

An object that represents the specified schedule.

Examples

Example 1

C:\PS> New-BESchedule -RunNow

This command creates a schedule that will run a job once and starts immediately.

Example 2
C:\PS> New-BESchedule -RunOnce -StartingAt 10PM

This command creates a schedule that will run a job once starting today at 10PM.

Example 3
C:\PS> New-BESchedule -Minutely -Every 5 -StartingAt 10PM

This command creates a schedule that will run a job every five minutes starting today at 10PM.

Example 4
C:\PS> New-BESchedule -Hourly -StartingAt 10PM

This command creates a schedule that will run a job every hour starting today at 10PM.

Example 5
C:\PS> New-BESchedule -Daily -StartingAt 10PM

This command creates a schedule that will run a job every day starting today at 10PM.

Example 6
C:\PS> New-BESchedule -Weekdays -StartingAt 10PM

This command creates a schedule that will run a job every weekday starting today at 10PM.

Example 7
C:\PS> New-BESchedule -WeeklyEvery Monday,Wednesday,Friday -StartingAt 10PM

This command creates a schedule that will run a job every Monday, Wednesday and Friday starting today at 10PM.

Example 8
C:\PS> New-BESchedule -MonthlyOnDayNumber 10 -StartingAt "1/1/2012 10PM"

This command creates a schedule that will run a job on the 10th of every month at 10PM effective on January 1, 2012.

Example 9
C:\PS> New-BESchedule -MonthlyEvery Last Friday -StartingAt "1/1/2012 10PM"

This command creates a schedule that will run a job every last Friday of the month at 10PM effective on January 1, 2012.

Example 10
C:\PS> New-BESchedule -YearlyOnMonthDayNumber 1 January -StartingAt "1/1/2012 10PM"

This command creates a schedule that will run a job every year on the 10th of January at 10PM effective on January 1, 2012.

Example 11
C:\PS> New-BESchedule -YearlyEvery First Monday March -StartingAt "1/1/2012 10PM"

This command creates a schedule that will run a job every year on the first Monday of March at 10PM effective on January 1, 2012.

Related Links

Add-BEConvertToVirtualStageBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEFullBackupTask
Add-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEFullBackupTask
Set-BEIncrementalBackupTask
Submit-BECleanJob
Submit-BEEjectMediaJob
Submit-BEExportExpiredMediaJob
Submit-BEExportMediaJob
Submit-BEImportMediaJob
Submit-BEInventoryJob


New-BESharePointPortalSiteSelection Help

New-BESharePointPortalSiteSelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SharePoint 2003 portal sites.

Syntax
New-BESharePointPortalSiteSelection [-PortalSite] [<String>] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SharePoint 2003 portal sites.

Parameters

-PortalSite <String>

Specifies the name of a portal site.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the portal site selection specified with the -PortalSite parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BESharePointPortalSiteSelection.

Return Value
BackupExec.Management.CLI.BESharePointPortalSiteSelection

New-BESharePointPortalSiteSelection returns an BESharePointPortalSiteSelection object.

Examples

Example 1

C:\PS> $x = New-BESharePointPortalSiteSelection -PortalSite "MyPortalSite"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointPortalSiteSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up an portal site named "MyPortalSite" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "MyPortalSite" | New-BESharePointPortalSiteSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointPortalSiteSelection $x

These commands submit a one-time backup job that backs up the portal site named "MyPortalSite" on the local computer.

Related Links


New-BESharePointServiceApplicationProxySelection Help

New-BESharePointServiceApplicationProxySelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 service application proxies.

Syntax
New-BESharePointServiceApplicationProxySelection [-ProxyName] [<String>] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 service application proxies.

Parameters

-ProxyName <String>

Specifies the name of a service application proxy. Specify '*' to indicate all available service application proxies.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the service application proxies specified with -ProxyName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BESharePointServiceApplicationProxySelection.

Return Value
BackupExec.Management.CLI.BESharePointServiceApplicationProxySelection

New-BESharePointServiceApplicationProxySelection returns an BESharePointServiceApplicationProxySelection object.

Examples

Example 1

C:\PS> $x = New-BESharePointServiceApplicationProxySelection -ProxyName "ServiceProxy"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointServiceApplicationProxySelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the service application proxy named "ServiceProxy" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "ServiceProxy"|New-BESharePointPortalSiteSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointServiceApplicationProxySelection $x

These commands submit a one-time backup job that backs up the service application proxy named "ServiceProxy" on the local computer.

Related Links


New-BESharePointServiceApplicationSelection Help

New-BESharePointServiceApplicationSelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 service applications.

Syntax
New-BESharePointServiceApplicationSelection [[-ApplicationName] [<String>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 service applications.

Parameters

-ApplicationName <String>

Specifies the name of a service application. Specify '*' to indicate all available service applications.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the application selection specified with the -ApplicationName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BESharePointServiceApplicationSelection.

Return Value
BackupExec.Management.CLI.BESharePointServiceApplicationSelection

New-BESharePointServiceApplicationSelection returns an BESharePointServiceApplicationSelection object.

Examples

Example 1

C:\PS> $x = New-BESharePointServiceApplicationSelection -ApplicationName "SharePointApp1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointServiceApplicationSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the service application named "SharePointApp1" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "SharePointApp1"|New-BESharePointServiceApplicationSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointServiceApplicationSelection $x

These commands submit a one-time backup job that backs up the service application named "SharePointApp1" on the local computer.

Related Links


New-BESharePointServiceSiteSelection Help

New-BESharePointServiceSiteSelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SharePoint 2003 service sites.

Syntax
New-BESharePointServiceSiteSelection [-ServiceSite] [<String>] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SharePoint 2003 service sites.

Parameters

-ServiceSite <String>

Specifies the name of a service site.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the service site selection specified with the -ServiceSite parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BESharePointServiceSiteSelection.

Return Value
BackupExec.Management.CLI.BESharePointServiceSiteSelection

New-BESharePointServiceSiteSelection returns an BESharePointServiceSiteSelection object.

Examples

Example 1

C:\PS> $x = New-BESharePointServiceSiteSelection -ServiceSite "Site1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -BESharePointServiceSiteSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the service site named "Site1" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "Site1" | New-BESharePointServiceSiteSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -BESharePointServiceSiteSelection $x

These commands submit a one-time backup job that backs up the service site named "Site1" on the local computer.

Related Links


New-BESharePointSharedServiceApplicationProxySelection Help

New-BESharePointSharedServiceApplicationProxySelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 shared service application proxies.

Syntax
New-BESharePointSharedServiceApplicationProxySelection [[-ProxyName] [<String>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 shared service application proxies.

Parameters

-ProxyName <String>

Specifies the name of a shared service application proxy. Specify '*' to indicate all available shared service application proxies.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the shared service application proxies specified with -ProxyName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BESharePointSharedServiceApplicationProxySelection.

Return Value
BackupExec.Management.CLI.BESharePointSharedServiceApplicationProxySelection

New-BESharePointSharedServiceApplicationProxySelection returns an BESharePointSharedServiceApplicationProxySelection object.

Examples

Example 1

C:\PS> $x = New-BESharePointSharedServiceApplicationProxySelection -ProxyName "ServiceProxy"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointSharedServiceApplicationProxySelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the shared service application proxy named "ServiceProxy" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "ServiceProxy" | New-BESharePointSharedServiceApplicationProxySelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointSharedServiceApplicationProxySelection $x

These commands submit a one-time backup job that backs up the shared service application proxy named "Database1" on the local computer.

Related Links


New-BESharePointSharedServiceApplicationSelection Help

New-BESharePointSharedServiceApplicationSelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 shared service applications.

Syntax
New-BESharePointSharedServiceApplicationSelection [[-ApplicationName] [<String>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 shared service applications.

Parameters

-ApplicationName <String>

Specifies the name of a shared service application. Specify '*' to indicate all available shared service applications.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the shared service selection specified with the -ApplicationName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BESharePointSharedServiceApplicationSelection.

Return Value
BackupExec.Management.CLI.BESharePointSharedServiceApplicationSelection

New-BESharePointSharedServiceApplicationSelection returns an BESharePointSharedServiceApplicationSelection object.

Examples

Example 1

C:\PS> $x = New-BESharePointSharedServiceApplicationSelection -ApplicationName "SharePointApp1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointSharedServiceApplicationSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the shared service application named "SharePointApp1" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "SharePointApp1" | New-BESharePointSharedServiceApplicationSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointSharedServiceApplicationSelection $x

These commands submit a one-time backup job that backs up the shared service application named "SharePointApp1" on the local computer.

Related Links


New-BESharePointSharedServiceProviderSelection Help

New-BESharePointSharedServiceProviderSelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 shared service providers.

Syntax
New-BESharePointSharedServiceProviderSelection [-ServiceProviderName] [<String>] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 shared service providers.

Parameters

-ServiceProviderName <String>

Specifies the name of a shared service provider.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the service provider specified with the -ServiceProviderName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BESharePointSharedServiceProviderSelection.

Return Value
BackupExec.Management.CLI.BESharePointSharedServiceProviderSelection

New-BESharePointSharedServiceProviderSelection returns an BESharePointSharedServiceProviderSelection object.

Examples

Example 1

C:\PS> $x = New-BESharePointSharedServiceProviderSelection -ServiceProviderName "SharePointProv1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointSharedServiceProviderSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the service provider named "SharePointProv1" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "SharePointProv1" | New-BESharePointSharedServiceProviderSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointSharedServiceProviderSelection $x

These commands submit a one-time backup job that backs up the service provider named "SharePointProv1" on the local computer.

Related Links


New-BESharePointWebApplicationSelection Help

New-BESharePointWebApplicationSelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 web applications.

Syntax
New-BESharePointWebApplicationSelection [[-WebApplicationName] [<String>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SharePoint 2007 and 2010 web applications.

Parameters

-WebApplicationName <String>

Specifies the name of a web application. Specify '*' to indicate all available web applications.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the web application selection specified with the -WebApplicationName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string object to New-BESharePointWebApplicationSelection.

Return Value
BackupExec.Management.CLI.BESharePointWebApplicationSelection

New-BESharePointWebApplicationSelection returns an BESharePointWebApplicationSelection object.

Examples

Example 1

C:\PS> $x = New-BESharePointWebApplicationSelection -WebApplicationName "WEB_APP1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SharePointWebApplicationSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the web application named "WEB_APP1" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = "WEB_APP1" | New-BESharePointWebApplicationSelection
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SharePointWebApplicationSelection $x

These commands submit a one-time backup job that backs up the web application named "WEB_APP1" on the local computer.

Related Links


New-BESqlDatabaseSelection Help

New-BESqlDatabaseSelection Cmdlet
Synopsis

Creates a backup selection object for Microsoft SQL databases.

Syntax
New-BESqlDatabaseSelection [[-InstanceName] [<String>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]

New-BESqlDatabaseSelection [-InstanceName] [<String>] [[-DatabaseName] [<String>]] [-Exclude [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a backup selection object for Microsoft SQL databases.

Parameters

-InstanceName <String>

Specifies a SQL instance name. Specify '*' to indicate all available SQL instances.

Required | true
Position | 0
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-DatabaseName <String>

Specifies a SQL database name. Specify '*' to indicate all available SQL databases.

Required | false
Position | 1
Accepts pipeline input | true (ByPropertyName)
Accepts wildcard characters | false

-Exclude <SwitchParameter>

Excludes the SQL Instance/Database selection specified with the -InstanceName parameter and the -DatabaseName parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
BackupExec.Management.CLI.BESqlDatabaseSelection

New-BESqlDatabaseSelection returns an BESqlDatabaseSelection object.

Examples

Example 1

C:\PS> $x = New-BESqlDatabaseSelection -InstanceName "Instance1" -DatabaseName "DB1"
C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk -SqlDatabaseSelection $x | Save-BEBackupDefinition

These commands create a backup definition that backs up the SQL database named "DB1" in the SQL instance named "Instance1" for the local computer using the "BackupToDisk" job defaults.

Example 2
C:\PS> $x = New-BESqlDatabaseSelection -InstanceName "Instance1" -DatabaseName "DB1"
C:\PS> Get-BEAgentServer -Local | Submit-BEOnetimeBackupJob -SqlDatabaseSelection $x

These commands submit a one-time backup job that backs up the Exchange database named "DB1" in the SQL instance named "Instance1" on the local computer.

Related Links


New-BEStorageDevicePool Help

New-BEStorageDevicePool Cmdlet
Synopsis

Creates a new storage device pool in Backup Exec.

Syntax
New-BEStorageDevicePool [-Name] [<String>] [-StoragePoolType] {Disk | Tape | DiskCartridge} [-Description [<String>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Creates a new storage device pool in Backup Exec.

Parameters

-StoragePoolType

Specifies the device pool type.

The valid values are:
Disk
Tape
DiskCartridge

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the storage device pool.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the new storage device pool.

Required | true
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string that contains the name of the Backup Exec storage device pool object to create to New-BEStorageDevicePool.

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

New-BEStorageDevicePool returns the storage device pool that was created.

Example

C:\PS> New-BEStorageDevicePool -Name "Storage Pool 0001".

This command creates a storage pool named "Storage Pool 0001".


Register-BEEvent Help

Register-BEEvent Cmdlet
Synopsis

Notifies a recipient of an event in Backup Exec.

Syntax
Register-BEEvent [-Event] {AlertChanged | ActiveJobChanged | JobCompleted} [[-SourceIdentifier] [<String>]] [[-Action] [<ScriptBlock>]] [-MessageData [<PSObject>]] [-SupportEvent [<SwitchParameter>]] [-Forward [<SwitchParameter>]] [<CommonParameters>]
Description

Notifies a recipient of an event in Backup Exec.

When the event occurs, it is added to the event queue in your session. To get events in the event queue, use the Get-Event cmdlet.

When you are notified of an event, an event subscriber is added to your session. To get the event subscribers in the session, use the Get-EventSubscriber cmdlet. To cancel the notification, use the Unregister-Event cmdlet, which deletes the event subscriber from the session.

Parameters

-Event

Specifies the event of which you want to be notified.

The valid values are:
AlertChanged
ActiveJobChanged
JobCompleted

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-SourceIdentifier <String>

Specifies a name that you select for the notification. The name that you select must be unique in the current session. The default value is the GUID that Windows PowerShell assigns.

Required | false
Position | 100
Accepts pipeline input | false
Accepts wildcard characters | false

-Action <ScriptBlock>

Specifies commands to handle the events.

The commands in the Action run when an event occurs, instead of sending the event to the event queue. Enclose the commands in braces ( { } ) to create a script block. The value of the Action parameter can include the $Event, $EventSubscriber, $Sender, $SourceEventArgs, and $SourceArgs automatic variables, which provide information about the event to the Action script block. For more information, see about_Automatic_Variables.

When you specify an action, Register-BEEvent returns an event job object that represents that action. You can use the Job cmdlets to manage the event job.

Required | false
Position | 101
Accepts pipeline input | false
Accepts wildcard characters | false

-MessageData <PSObject>

Specifies any additional data taht you want to associate with this event. The value of this parameter appears in the MessageData property of all events associated with this notification.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SupportEvent <SwitchParameter>

Hides the event notification. Use this parameter when the current notification is part of a more complex event registration mechanism and it should not be discovered independently.

To view or cancel a notification that was created with the SupportEvent parameter, use the Force parameter of the Get-EventSubscriber and Unregister-Event cmdlets.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Forward <SwitchParameter>

Sends events for this notification to a remote session. Use this parameter when you are registering for events on a remote computer or in a remote session.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
None or System.Management.Automation.PSEventJob

If you use the Action parameter, Register-EngineEvent returns a System.Management.Automation.PSEventJob object. Otherwise, it does not generate any output.

Examples

Example 1

C:\PS> Register-BEEvent -Event JobCompleted

This command subscribes to events generated when a Backup Exec job completes.

Example 2
C:\PS> $voice = New-Object -ComObject sapi.spvoice
C:\PS> Register-BEEvent -Event AlertChanged -Action { $voice.Speak($EventArgs.Alert.Message, 1) }

This command subscribes to events generated when a Backup Exec alert is added and uses the Windows Speech API to read the alert message out loud.


Remove-BEBackupDefinition Help

Remove-BEBackupDefinition Cmdlet
Synopsis

Removes a backup definition from Backup Exec.

Syntax
Remove-BEBackupDefinition -InputObject [<BEBackupDefinition[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes a backup definition from Backup Exec. When you remove a backup definition, the jobs associated with the backup definition are also removed.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupDefinition[]>

Specifies one or more backup definition objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Remove-BEBackupDefinition.

Return Value
None or BackupExec.Management.CLI.BEBackupDefinition

When you use the PassThru parameter, Remove-BEBackupDefinition returns an object that represents the backup definition that was removed. Otherwise, this cmdlet does not generate any output.

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Remove-BEBackupDefinition

These commands remove a backup definition named "Backup Definition 01".

Example 2
C:\PS> Get-BEBackupDefinition | Remove-BEBackupDefinition

These commands remove all of the backup definitions.

Related Link

Get-BEBackupDefinition


Remove-BEBackupExecServerPool Help

Remove-BEBackupExecServerPool Cmdlet
Synopsis

Removes Backup Exec server pools.

Syntax
Remove-BEBackupExecServerPool -InputObject [<BEBackupExecServerPool[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes Backup Exec server pools.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

Specifies one or more Backup Exec server pool objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServerPool

You can pipe a Backup Exec server pool object to Remove-BEBackupExecServerPool.

Return Value
None or BackupExec.Management.CLI.BEBackupExecServerPool

When you use the PassThru parameter, Remove-BEBackupExecServerPool returns an object that represents the Backup Exec server pool that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEBackupExecServerPool -Name "Server Pool 0001" | Remove-BEBackupExecServerPool

These commands remove the Backup Exec server pool named "Server Pool 0001".

Related Link

Get-BEBackupExecServerPool


Remove-BEBackupTask Help

Remove-BEBackupTask Cmdlet
Synopsis

Removes a backup task from a backup definition in Backup Exec.

Syntax
Remove-BEBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Remove-BEBackupTask -BackupDefinition [<BEBackupDefinition>] -SimultaneousConvertToVirtualStage [<SwitchParameter>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Remove-BEBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [-Name] [<String[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes a backup task from a backup definition in Backup Exec. You cannot remove the initial full backup from a backup definition.

To remove a backup task from a new backup definition, use Remove-BEBackupTask and New-BEBackupDefinition.

To remove a backup task from an existing backup definition, use Remove-BEBackupTask and Get-BEBackupDefinition.

To remove a backup task from the backup job defaults, use Remove-BEBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SimultaneousConvertToVirtualStage <SwitchParameter>

Removes the simultaneous convert-to-virtual stage from the backup definition.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more backup tasks to remove from the backup definition by backup task name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Remove-BEBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Remove-BEBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Remove-BEBackupTask "Incremental" | Save-BEBackupDefinition

These commands create a new backup definition for the local computer that removes the default incremental backup.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Remove-BEBackupTask * | Save-BEBackupDefinition

These commands remove all of the backup tasks, except for the initial full backup, from a backup definition named "Backup Definition 01".

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Remove-BEBackupTask * | Save-BEBackupJobDefault

These commands remove all of the backup tasks, except for the initial full backup, from the back up to disk job defaults.

Related Links


Remove-BEBarcodeRule Help

Remove-BEBarcodeRule Cmdlet
Synopsis

Removes bar code rules in Backup Exec.

Syntax
Remove-BEBarcodeRule -InputObject [<BEBarcodeRule[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes bar code rules in Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBarcodeRule[]>

Specifies one or more barcode rule objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBarcodeRule

You can pipe a Backup Exec barcode rule object to Remove-BEBarcodeRule.

Return Value
None or BackupExec.Management.CLI.BEBarcodeRule

When you use the PassThru parameter, Remove-BEBarcodeRule returns an object that represents the barcode rule that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEBarcodeRule -BarcodePrefix CLN | Remove-BEBarcodeRule

These commands remove all bar code rules with a bar code prefix of "CLN".

Related Link

Get-BEBarcodeRule


Remove-BECloudStorageDevice Help

Remove-BECloudStorageDevice Cmdlet
Synopsis

Removes a cloud storage device from Backup Exec.

Syntax
Remove-BECloudStorageDevice -InputObject [<BECloudStorageDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes a cloud storage device from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECloudStorageDevice[]>

Specifies one or more cloud storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudStorageDevice

You can pipe a Backup Exec cloud storage device object to Remove-BECloudStorageDevice.

Return Value
None or BackupExec.Management.CLI.BECloudStorageDevice

When you use the PassThru parameter, Remove-BECloudStorageDevice returns an object that represents the cloud storage device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BECloudStorageDevice "Device 0001" | Remove-BECloudStorageDevice

These commands remove a cloud storage device named "Device 0001".

Related Link

Get-BECloudStorageDevice


Remove-BEDeduplicationDiskStorageDevice Help

Remove-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Removes deduplication disk storage devices from Backup Exec.

Syntax
Remove-BEDeduplicationDiskStorageDevice -InputObject [<BEDeduplicationDiskStorageDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes deduplication disk storage devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDeduplicationDiskStorageDevice[]>

Specifies one or more deduplication disk storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

You can pipe a Backup Exec deduplication disk storage device object to Remove-BEDeduplicationDiskStorageDevice.

Return Value
None or BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

When you use the PassThru parameter, Remove-BEDeduplicationDiskStorageDevice returns an object that represents the deduplication disk storage device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEDeduplicationDiskStorageDevice "Device 0001" | Remove-BEDeduplicationDiskStorageDevice

These commands remove a deduplication disk storage device named "Device 0001".

Related Link

Get-BEDeduplicationDiskStorageDevice


Remove-BEDeviceFromStorageDevicePool Help

Remove-BEDeviceFromStorageDevicePool Cmdlet
Synopsis

Removes a device from a storage device pool in Backup Exec.

Syntax
Remove-BEDeviceFromStorageDevicePool -DiskStorageDevicePool [<BEDiskStorageDevicePool>] [-DiskStorageDevice] [<BEDiskStorageDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Remove-BEDeviceFromStorageDevicePool -TapeStorageDevicePool [<BETapeStorageDevicePool>] [-TapeDriveDevice] [<BETapeDriveDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Remove-BEDeviceFromStorageDevicePool -DiskStorageDevicePool [<BEDiskStorageDevicePool>] [-VirtualDiskDevice] [<BEVirtualDiskDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Remove-BEDeviceFromStorageDevicePool -DiskCartridgeStorageDevicePool [<BEDiskCartridgeStorageDevicePool>] [-DiskCartridgeDevice] [<BEDiskCartridgeDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes a device from a storage device pool in Backup Exec.

Parameters

-TapeStorageDevicePool <BETapeStorageDevicePool>

Specifies a tape storage device pool that you want to remove devices.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskStorageDevicePool <BEDiskStorageDevicePool>

Specifies a disk storage device pool that you want to remove devices.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskCartridgeStorageDevicePool <BEDiskCartridgeStorageDevicePool>

Specifies a disk cartridge storage device pool that you want to remove devices.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskCartridgeDevice <BEDiskCartridgeDevice[]>

Specifies a Backup Exec disk cartridge device to remove from the storage device pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageDevice <BEDiskStorageDevice[]>

Specifies a Backup Exec disk storage device to remove from the storage device pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualDiskDevice <BEVirtualDiskDevice[]>

Specifies a Backup Exec virtual disk device to remove from the storage device pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice[]>

Specifies a Backup Exec tape drive device to remove from the storage device pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeStorageDevicePool

You can pipe a Backup Exec tape storage device pool object to Remove-BEDeviceFromStorageDevicePool.

BackupExec.Management.CLI.BEDiskStorageDevicePool

You can pipe a Backup Exec disk storage device pool object to Remove-BEDeviceFromStorageDevicePool.

BackupExec.Management.CLI.BEDiskCartridgeStorageDevicePool

You can pipe a Backup Exec disk cartridge storage device pool object to Remove-BEDeviceFromStorageDevicePool.

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Remove-BEDeviceFromStorageDevicePool returns a Backup Exec storage device pool object.

Example

C:\PS> Get-BEStorageDevicePool "StorageDevicePool 0001" | Remove-BEDeviceFromStorageDevicePool "Device 0001"

These commands remove a device named "Device 0001" from a storage device pool named "StorageDevicePool 0001.

Related Link

Get-BEStorageDevicePool


Remove-BEDiskCartridgeDevice Help

Remove-BEDiskCartridgeDevice Cmdlet
Synopsis

Removes disk cartridge devices from Backup Exec.

Syntax
Remove-BEDiskCartridgeDevice -InputObject [<BEDiskCartridgeDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes disk cartridge devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDiskCartridgeDevice[]>

Specifies one or more disk cartridge device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Remove-BEDiskCartridgeDevice.

Return Value
None or BackupExec.Management.CLI.BEDiskCartridgeDevice

When you use the PassThru parameter, Remove-BEDiskCartridgeDevice returns an object that represents the disk cartridge device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEDiskCartridgeDevice "Device 0001" | Remove-BEDiskCartridgeDevice

These commands remove a disk cartridge device named "Device 0001".

Related Link

Get-BEDiskCartridgeDevice


Remove-BEDiskStorageDevice Help

Remove-BEDiskStorageDevice Cmdlet
Synopsis

Removes disk storage devices from Backup Exec.

Syntax
Remove-BEDiskStorageDevice -InputObject [<BEDiskStorageDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes disk storage devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDiskStorageDevice[]>

Specifies one or more disk storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskStorageDevice

You can pipe a Backup Exec disk storage device object to Remove-BEDiskStorageDevice.

Return Value
None or BackupExec.Management.CLI.BEDiskStorageDevice

When you use the PassThru parameter, Remove-BEDiskStorageDevice returns an object that represents the disk storage device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEDiskStorageDevice "Device 0001" | Remove-BEDiskStorageDevice

These commands remove a disk storage device named "Device 0001".

Related Link

Get-BEDiskStorageDevice


Remove-BEEncryptionKey Help

Remove-BEEncryptionKey Cmdlet
Synopsis

Removes encryption keys from Backup Exec.

Syntax
Remove-BEEncryptionKey -InputObject [<BEEncryptionKey[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes encryption keys from Backup Exec.

You must replace encryption keys that are in use by backup jobs before they can be removed. See Switch-BEEncryptionKey.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEEncryptionKey[]>

Specifies one or more encryption key objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEEncryptionKey

You can pipe a Backup Exec encryption key object to Remove-BEEncryptionKey.

Return Value
None or BackupExec.Management.CLI.BEEncryptionKey

When you use the PassThru parameter, Remove-BEEncryptionKey returns an object that represents the encryption key that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEEncryptionKey "EncryptionKey 0001" | Switch-BEEncryptionKey -ReplacementEncryptionKey "EncryptionKey 0002" | Remove-BEEncryptionKey

These commands replace any jobs that use an encryption key named "EncryptionKey 0001" with another encryption key named "EncryptionKey 0002" before removing "EncryptionKey 0001".

Related Links


Remove-BEJob Help

Remove-BEJob Cmdlet
Synopsis

Removes Backup Exec jobs.

Syntax
Remove-BEJob -InputObject [<BEJob[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes Backup Exec jobs.

To remove jobs that are associated with a backup definition, you must remove the backup definition. See Remove-BEBackupDefinition.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEJob[]>

Specifies one or more job objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to Remove-BEJob.

Return Value
None or BackupExec.Management.CLI.BEJob

When you use the PassThru parameter, Remove-BEJob returns an object that represents the job that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEJob "Job 0001" | Remove-BEJob

These commands remove a job named "Job 0001".

Related Links


Remove-BEJobHistory Help

Remove-BEJobHistory Cmdlet
Synopsis

Removes job histories from Backup Exec.

Syntax
Remove-BEJobHistory -InputObject [<BEJobHistory[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes job histories from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEJobHistory[]>

Specifies one or more job history objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJobHistory

You can pipe a Backup Exec job history object to Remove-BEJobHistory.

Return Value
None or BackupExec.Management.CLI.BEJobHistory

When you use the PassThru parameter, Remove-BEJobHistory returns an object that represents the job history that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEJob "Job 0001" | Get-BEJobHistory | Remove-BEJobHistory

These commands remove all job histories associated with a job named "Job 0001".

Related Links


Remove-BELegacyBackupToDiskFolderDevice Help

Remove-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Removes legacy backup-to-disk folder devices from Backup Exec.

Syntax
Remove-BELegacyBackupToDiskFolderDevice -InputObject [<BELegacyBackupToDiskFolderDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes legacy backup-to-disk folder devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BELegacyBackupToDiskFolderDevice[]>

Specifies one or more legacy backup-to-disk folder device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

You can pipe a legacy backup-to-disk folder device object to Remove-BELegacyBackupToDiskFolderDevice.

Return Value
None or BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

When you use the PassThru parameter, Remove-BELegacyBackupToDiskFolderDevice returns an object that represents the legacy backup-to-disk folder device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BELegacyBackupToDiskFolderDevice "Device 0001" | Remove-BELegacyBackupToDiskFolderDevice

These commands remove a legacy backup-to-disk folder device named "Device 0001".

Related Link

Get-BELegacyBackupToDiskFolderDevice


Remove-BELogonAccount Help

Remove-BELogonAccount Cmdlet
Synopsis

Removes Backup Exec logon accounts.

Syntax
Remove-BELogonAccount -InputObject [<BELogonAccount[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes Backup Exec logon accounts.

You cannot remove the System Logon Account and the user-default logon account.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BELogonAccount[]>

Specifies one or more logon account objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object to Remove-BELogonAccount.

Return Value
None or BackupExec.Management.CLI.BELogonAccount

When you use the PassThru parameter, Remove-BELogonAccount returns an object that represents the logon account that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BELogonAccount "LogonAccount 0001" | Remove-BELogonAccount

These commands remove a logon account named "LogonAccount 0001".

Related Link

Get-BELogonAccount


Remove-BEMedia Help

Remove-BEMedia Cmdlet
Synopsis

Removes media from Backup Exec.

Syntax
Remove-BEMedia -InputObject [<BEMedia[]>] [-PassThru [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-Force [<SwitchParameter>]] [<CommonParameters>]
Description

Removes media from Backup Exec.

You can only remove media that is associated with the retired media set. To remove media that is not in Retired Media, use the -Force parameter.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMedia[]>

Specifies one or more media objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Force <SwitchParameter>

Forces the media to be removed even if it is not in Retired Media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to Remove-BEMedia.

Return Value
None or BackupExec.Management.CLI.BEMedia

When you use the PassThru parameter, Remove-BEMedia returns an object that represents the media that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEMedia "Media 0001" | Remove-BEMedia

These commands remove a media object named "Media 0001".

Related Link

Get-BEMedia


Remove-BEMediaSet Help

Remove-BEMediaSet Cmdlet
Synopsis

Removes media sets from Backup Exec.

Syntax
Remove-BEMediaSet -InputObject [<BEMediaSet[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes media sets from Backup Exec.

You cannot remove system-defined media sets.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaSet[]>

Specifies one or more media set objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaSet

You can pipe a Backup Exec media set object to Remove-BEMediaSet.

Return Value
None or BackupExec.Management.CLI.BEMediaSet

When you use the PassThru parameter, Remove-BEMediaSet returns an object that represents the media set that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEMediaSet "MediaSet 0001" | Remove-BEMediaSet

These commands remove a media set named "MediaSet 0001".

Related Link

Get-BEMediaSet


Remove-BEMediaVault Help

Remove-BEMediaVault Cmdlet
Synopsis

Removes media vaults from Backup Exec.

Syntax
Remove-BEMediaVault -InputObject [<BEMediaVault[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes media vaults from Backup Exec.

You cannot remove system-defined media vaults.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaVault[]>

Specifies one or more media vault objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaVault

You can pipe a Backup Exec media vault object to Remove-BEMediaVault.

Return Value
None or BackupExec.Management.CLI.BEMediaVault

When you use the PassThru parameter, Remove-BEMediaVault returns an object that represents the media vault that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEMediaVault "MediaVault 0001" | Remove-BEMediaVault

These commands remove a media vault named "MediaVault 0001".

Related Link

Get-BEMediaVault


Remove-BEOpenStorageDevice Help

Remove-BEOpenStorageDevice Cmdlet
Synopsis

Removes an OpenStorage devices from Backup Exec.

Syntax
Remove-BEOpenStorageDevice -InputObject [<BEOpenStorageDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes an OpenStorage devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEOpenStorageDevice[]>

Specifies one or more OpenStorage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOpenStorageDevice

You can pipe a Backup Exec OpenStorage device object to Remove-BEOpenStorageDevice.

Return Value
None or BackupExec.Management.CLI.BEOpenStorageDevice

When you use the PassThru parameter, Remove-BEOpenStorageDevice returns an object that represents the OpenStorage device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEOpenStorageDevice "Device 0001" | Remove-BEOpenStorageDevice

These commands remove an OpenStorage device named "Device 0001".

Related Link

Get-BEOpenStorageDevice


Remove-BERoboticLibraryDevice Help

Remove-BERoboticLibraryDevice Cmdlet
Synopsis

Removes robotic library devices from Backup Exec.

Syntax
Remove-BERoboticLibraryDevice -InputObject [<BERoboticLibraryDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes robotic library devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibraryDevice[]>

Specifies one or more robotic library device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Remove-BERoboticLibraryDevice.

Return Value
None or BackupExec.Management.CLI.BERoboticLibraryDevice

When you use the PassThru parameter, Remove-BERoboticLibraryDevice returns an object that represents the robotic library device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Remove-BERoboticLibraryDevice

These commands remove a robotic library device named "Device 0001".

Related Link

Get-BERoboticLibraryDevice


Remove-BEServerFromBackupExecServerPool Help

Remove-BEServerFromBackupExecServerPool Cmdlet
Synopsis

Removes a managed Backup Exec server from a Backup Exec server pool.

Syntax
Remove-BEServerFromBackupExecServerPool -InputObject [<BEBackupExecServerPool[]>] [-BackupExecServer] [<BEBackupExecServer[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes a managed Backup Exec server from a Backup Exec server pool.

Parameters

-BackupExecServer <BEBackupExecServer[]>

Specifies the managed Backup Exec server to remove from the pool.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

Specifies one or more Backup Exec server pool objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServerPool

You can pipe a Backup Exec server pool object to Remove-BEServerFromBackupExecServerPool.

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

Remove-BEServerFromBackupExecServerPool returns a Backup Exec server pool object.

Example

C:\PS> Get-BEBackupExecServerPool "Server Pool 0001" | Remove-BEServerFromBackupExecServerPool -BackupExecServer "MyManagedServer"

These commands remove a managed Backup Exec server named "MyManagedServer" from a server pool named "Server Pool 0001".

Related Link

Get-BEBackupExecServerPool


Remove-BEStorageArrayDevice Help

Remove-BEStorageArrayDevice Cmdlet
Synopsis

Removes storage array devices from Backup Exec.

Syntax
Remove-BEStorageArrayDevice -InputObject [<BEStorageArrayDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes storage array devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageArrayDevice[]>

Specifies one or more storage array device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

You can pipe a Backup Exec storage array device object to Remove-BEStorageArrayDevice.

Return Value
None or BackupExec.Management.CLI.BEStorageArrayDevice

When you use the PassThru parameter, Remove-BEStorageArrayDevice returns an object that represents the storage array device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEStorageArrayDevice "Device 0001" | Remove-BEStorageArrayDevice

These commands remove a storage array device named "Device 0001".

Related Link

Get-BEStorageArrayDevice


Remove-BEStorageDevicePool Help

Remove-BEStorageDevicePool Cmdlet
Synopsis

Removes storage device pools from Backup Exec.

Syntax
Remove-BEStorageDevicePool -InputObject [<BEStorageDevicePool[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes storage device pools from Backup Exec.

You cannot remove system-defined storage device pools.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageDevicePool[]>

Specifies one or more storage device pool objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageDevicePool

You can pipe a Backup Exec storage device pool object to Remove-BEStorageDevicePool.

Return Value
None or BackupExec.Management.CLI.BEStorageDevicePool

When you use the PassThru parameter, Remove-BEStorageDevicePool returns an object that represents the storage device pool that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEStorageDevicePool "StorageDevicePool 0001" | Remove-BEStorageDevicePool

These commands remove a storage device pool named "StorageDevicePool 0001".

Related Link

Get-BEStorageDevicePool


Remove-BETapeDriveDevice Help

Remove-BETapeDriveDevice Cmdlet
Synopsis

Removes tape drive devices from Backup Exec.

Syntax
Remove-BETapeDriveDevice -InputObject [<BETapeDriveDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes tape drive devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BETapeDriveDevice[]>

Specifies one or more tape drive device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Remove-BETapeDriveDevice.

Return Value
None or BackupExec.Management.CLI.BETapeDriveDevice

When you use the PassThru parameter, Remove-BETapeDriveDevice returns an object that represents the tape drive device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Remove-BETapeDriveDevice

These commands remove a tape drive device named "Device 0001".

Related Link

Get-BETapeDriveDevice


Remove-BETapeDriveDeviceFromRoboticLibraryPartition Help

Remove-BETapeDriveDeviceFromRoboticLibraryPartition Cmdlet
Synopsis

Removes a tape drive device from a robotic library partition in Backup Exec.

Syntax
Remove-BETapeDriveDeviceFromRoboticLibraryPartition -InputObject [<BERoboticLibraryPartition[]>] [-TapeDriveDevice] [<BETapeDriveDevice[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes a tape drive device from a robotic library partition in Backup Exec.

Parameters

-TapeDriveDevice <BETapeDriveDevice[]>

Tape drive object to remove from the robotic library partition. See Get-BETapeDriveDevice.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibraryPartition[]>

Specifies one or more robotic library partition objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Remove-BETapeDriveDeviceFromRoboticLibraryPartition.

Return Value
BackupExec.Management.CLI.BERoboticLibraryPartition

Remove-BETapeDriveDeviceFromRoboticLibraryPartition outputs a Backup Exec robotic library partition object.

Example

C:\PS> Get-BERoboticLibraryDevice "Robotic library 0001" | Get-BERoboticLibraryPartition -FirstSlotNumber 1 | Remove-BETapeDriveDeviceFromRoboticLibraryPartition "Tape drive 0001"

These commands remove a tape drive device named "Tape drive 0001" from the robotic library partition that starts with slot 1 in the robotic library device named "Robotic library 0001".

Related Links


Remove-BEVirtualDiskDevice Help

Remove-BEVirtualDiskDevice Cmdlet
Synopsis

Removes virtual disk devices from Backup Exec.

Syntax
Remove-BEVirtualDiskDevice -InputObject [<BEVirtualDiskDevice[]>] [-PassThru [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Removes virtual disk devices from Backup Exec.

Parameters

-PassThru <SwitchParameter>

Passes the removed object to the pipeline. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEVirtualDiskDevice[]>

Specifies one or more virtual disk device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEVirtualDiskDevice

You can pipe a Backup Exec virtual disk device object to Remove-BEVirtualDiskDevice.

Return Value
None or BackupExec.Management.CLI.BEVirtualDiskDevice

When you use the PassThru parameter, Remove-BEVirtualDiskDevice returns an object that represents the virtual disk device that was removed. Otherwise, this cmdlet does not generate any output.

Example

C:\PS> Get-BEVirtualDiskDevice "Device 0001" | Remove-BEVirtualDiskDevice

These commands remove a virtual disk device named "Device 0001".

Related Link

Get-BEVirtualDiskDevice


Rename-BEBackupDefinition Help

Rename-BEBackupDefinition Cmdlet
Synopsis

Renames a backup definition in Backup Exec.

Syntax
Rename-BEBackupDefinition [-InputObject] [<BEBackupDefinition>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a backup definition in Backup Exec.

Parameters

-InputObject <BEBackupDefinition>

Specifies the backup definition object that you want to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

The new name to assign to the backup definition object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Rename-BEBackupDefinition.

Return Value
BackupExec.Management.CLI.BEBackupDefinition

Rename-BEBackupDefinition returns an object that represents the backup definition that was renamed.

Example

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Rename-BEBackupDefinition -NewName "Backup Definition 02"

These commands rename a backup definition named "Backup Definition 01" to "Backup Definition 02".

Related Link

Get-BEBackupDefinition


Rename-BEBackupTask Help

Rename-BEBackupTask Cmdlet
Synopsis

Renames a backup task in a backup definition in Backup Exec.

Syntax
Rename-BEBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String>] [-NewName] [<String>] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Rename-BEBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [-Name] [<String>] [-NewName] [<String>] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a backup task in a backup definition in Backup Exec.

To rename a backup task in a new backup definition, use Rename-BEBackupTask and New-BEBackupDefinition.

To rename a backup task in an existing backup definition, use Rename-BEBackupTask and Get-BEBackupDefinition.

To rename a backup task in the backup job defaults, use Rename-BEBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Name <String>

Specifies the name of the backup task in the backup definition to rename.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-NewName <String>

The new name of the backup task.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Rename-BEBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Rename-BEBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Rename-BEBackupTask -Name "Full" -NewName "Full 1" | Save-BEBackupDefinition

These commands rename the backup named "Full" in the backup definition named "Backup Definition 01" to "Full 1".

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Rename-BEBackupTask -Name "Duplicate" -NewName "Duplicate 1" | Save-BEBackupDefinition

These commands rename the duplicate stage named "Duplicate" in the backup definition named "Backup Definition 01" to "Duplicate 1".

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Rename-BEBackupTask -Name "Full" -NewName "Full 1" | Save-BEBackupJobDefault

These commands rename the backup named "Full" in the back up to disk job defaults to "Full 1".

Related Links


Rename-BECloudStorageDevice Help

Rename-BECloudStorageDevice Cmdlet
Synopsis

Renames a cloud storage device in Backup Exec.

Syntax
Rename-BECloudStorageDevice [-InputObject] [<BECloudStorageDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a cloud storage device in Backup Exec.

Parameters

-InputObject <BECloudStorageDevice>

Specifies the cloud storage device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the cloud storage device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudStorageDevice

You can pipe a Backup Exec cloud storage device object to Rename-BECloudStorageDevice.

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

Rename-BECloudStorageDevice returns an object that represents the cloud storage device that was renamed.

Example

C:\PS> Get-BECloudStorageDevice "Device 0001" | Rename-BECloudStorageDevice -NewName "Device 0002"

These commands rename a cloud storage device named "Device 0001" to "Device 0002".

Related Link

Get-BECloudStorageDevice


Rename-BEDeduplicationDiskStorageDevice Help

Rename-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Renames a deduplication disk storage device in Backup Exec.

Syntax
Rename-BEDeduplicationDiskStorageDevice [-InputObject] [<BEDeduplicationDiskStorageDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a deduplication disk storage device in Backup Exec.

Parameters

-InputObject <BEDeduplicationDiskStorageDevice>

Specifies the deduplication disk storage device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the deduplication disk storage device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

You can pipe a Backup Exec deduplication disk storage device object to Rename-BEDeduplicationDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Rename-BEDeduplicationDiskStorageDevice returns an object that represents the deduplication disk storage device that was renamed.

Example

C:\PS> Get-BEDeduplicationDiskStorageDevice "Device 0001" | Rename-BEDeduplicationDiskStorageDevice -NewName "Device 0002"

These commands rename a deduplication disk storage device named "Device 0001" to "Device 0002".

Related Link

Get-BEDeduplicationDiskStorageDevice


Rename-BEDiskCartridgeDevice Help

Rename-BEDiskCartridgeDevice Cmdlet
Synopsis

Renames disk cartridge device in Backup Exec.

Syntax
Rename-BEDiskCartridgeDevice [-InputObject] [<BEDiskCartridgeDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a disk cartridge device in Backup Exec.

Parameters

-InputObject <BEDiskCartridgeDevice>

Specifies the disk cartridge device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the disk cartridge device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Rename-BEDiskCartridgeDevice.

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

Rename-BEDiskCartridgeDevice returns an object that represents the disk cartridge device that was renamed.

Example

C:\PS> Get-BEDiskCartridgeDevice "Device 0001" | Rename-BEDiskCartridgeDevice -NewName "Device 0002"

These commands rename a disk cartridge device named "Device 0001" to "Device 0002".

Related Link

Get-BEDiskCartridgeDevice


Rename-BEDiskStorageDevice Help

Rename-BEDiskStorageDevice Cmdlet
Synopsis

Renames a disk storage device in Backup Exec.

Syntax
Rename-BEDiskStorageDevice [-InputObject] [<BEDiskStorageDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a disk storage device in Backup Exec.

Parameters

-InputObject <BEDiskStorageDevice>

Specifies the disk storage device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the disk storage device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskStorageDevice

You can pipe a Backup Exec disk storage device object to Rename-BEDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Rename-BEDiskStorageDevice returns an object that represents the disk storage device that was renamed.

Example

C:\PS> Get-BEDiskStorageDevice "Device 0001" | Rename-BEDiskStorageDevice -NewName "Device 0002"

These commands rename a disk storage device named "Device 0001" to "Device 0002".

Related Link

Get-BEDiskStorageDevice


Rename-BELegacyBackupToDiskFolderDevice Help

Rename-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Renames a legacy backup-to-disk folder device in Backup Exec.

Syntax
Rename-BELegacyBackupToDiskFolderDevice [-InputObject] [<BELegacyBackupToDiskFolderDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a legacy backup-to-disk folder device in Backup Exec.

Parameters

-InputObject <BELegacyBackupToDiskFolderDevice>

Specifies the legacy backup-to-disk folder device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the legacy backup-to-disk folder device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

You can pipe a Backup Exec legacy backup-to-disk folder device object to Rename-BELegacyBackupToDiskFolderDevice.

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Rename-BELegacyBackupToDiskFolderDevice returns an object that represents the legacy backup-to-disk folder device that was renamed.

Example

C:\PS> Get-BELegacyBackupToDiskFolderDevice "Device 0001" | Rename-BELegacyBackupToDiskFolderDevice -NewName "Device 0002"

These commands rename a legacy backup-to-disk folder device named "Device 0001" to "Device 0002".

Related Link

Get-BELegacyBackupToDiskFolderDevice


Rename-BELogonAccount Help

Rename-BELogonAccount Cmdlet
Synopsis

Renames a Backup Exec logon account.

Syntax
Rename-BELogonAccount [-InputObject] [<BELogonAccount>] [[-NewName] [<String>]] [[-CurrentPassword] [<SecureString>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a Backup Exec logon account.

The System Logon Account cannot be renamed.

Parameters

-CurrentPassword <SecureString>

Specifies the current account password of the logon account. This is required when you rename a restricted logon account that was created by different user.

Required | false
Position | 2
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BELogonAccount>

Specifies the logon account object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the logon account object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object to Rename-BELogonAccount.

Return Value
BackupExec.Management.CLI.BELogonAccount

Rename-BELogonAccount returns an object that represents the logon account that was renamed.

Example

C:\PS> Get-BELogonAccount "LogonAccount 0001" | Rename-BELogonAccount -NewName "LogonAccount 0002"

These commands rename a logon account named "LogonAccount 0001" to "LogonAccount 0002".

Related Link

Get-BELogonAccount


Rename-BEMedia Help

Rename-BEMedia Cmdlet
Synopsis

Renames media in Backup Exec.

Syntax
Rename-BEMedia [-InputObject] [<BEMedia>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames media in Backup Exec.

Parameters

-InputObject <BEMedia>

Specifies the media object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the media object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to Rename-BEMedia.

Return Value
BackupExec.Management.CLI.BEMedia

Rename-BEMedia returns an object that represents the media that was renamed.

Example

C:\PS> Get-BEMedia "Media 0001" | Rename-BEMedia -NewName "Media 0002"

These commands rename a media object named "Media 0001" to "Media 0002".

Related Link

Get-BEMedia


Rename-BEMediaSet Help

Rename-BEMediaSet Cmdlet
Synopsis

Renames a media set in Backup Exec.

Syntax
Rename-BEMediaSet [-InputObject] [<BEMediaSet>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a media set in Backup Exec.

System-defined media sets cannot be renamed.

Parameters

-InputObject <BEMediaSet>

Specifies the media set object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the media set object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaSet

You can pipe a Backup Exec media set object to Rename-BEMediaSet.

Return Value
BackupExec.Management.CLI.BEMediaSet

Rename-BEMediaSet returns an object that represents the media set that was renamed.

Example

C:\PS> Get-BEMediaSet "MediaSet 0001" | Rename-BEMediaSet -NewName "MediaSet 0002"

These commands rename a media set named "MediaSet 0001" to "MediaSet 0002".

Related Link

Get-BEMediaSet


Rename-BEMediaVault Help

Rename-BEMediaVault Cmdlet
Synopsis

Renames a media vault in Backup Exec.

Syntax
Rename-BEMediaVault [-InputObject] [<BEMediaVault>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a media vault in Backup Exec.

System-defined media vaults cannot be renamed.

Parameters

-InputObject <BEMediaVault>

Specifies the media vault object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the media vault object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaVault

You can pipe a Backup Exec media vault object to Rename-BEMediaVault.

Return Value
BackupExec.Management.CLI.BEMediaVault

Rename-BEMediaVault returns an object that represents the media vault that was renamed.

Example

C:\PS> Get-BEMediaVault "MediaVault 0001" | Rename-BEMediaVault -NewName "MediaVault 0002"

These commands rename a media vault named "MediaVault 0001" to "MediaVault 0002".

Related Link

Get-BEMediaVault


Rename-BEOpenStorageDevice Help

Rename-BEOpenStorageDevice Cmdlet
Synopsis

Renames an OpenStorage device in Backup Exec.

Syntax
Rename-BEOpenStorageDevice [-InputObject] [<BEOpenStorageDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames an OpenStorage device in Backup Exec.

Parameters

-InputObject <BEOpenStorageDevice>

Specifies the OpenStorage device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the OpenStorage device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOpenStorageDevice

You can pipe a Backup Exec OpenStorage device object to Rename-BEOpenStorageDevice.

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

Rename-BEOpenStorageDevice returns an object that represents the OpenStorage device that was renamed.

Example

C:\PS> Get-BEOpenStorageDevice "Device 0001" | Rename-BEOpenStorageDevice -NewName "Device 0002"

These commands rename an OpenStorage device named "Device 0001" to "Device 0002".

Related Link

Get-BEOpenStorageDevice


Rename-BERoboticLibraryDevice Help

Rename-BERoboticLibraryDevice Cmdlet
Synopsis

Renames a robotic library device in Backup Exec.

Syntax
Rename-BERoboticLibraryDevice [-InputObject] [<BERoboticLibraryDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a robotic library device in Backup Exec.

Parameters

-InputObject <BERoboticLibraryDevice>

Specifies the robotic library device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the robotic library device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Rename-BERoboticLibraryDevice.

Return Value
BackupExec.Management.CLI.BERoboticLibraryDevice

Rename-BERoboticLibraryDevice returns an object that represents the robotic library device that was renamed.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Rename-BERoboticLibraryDevice -NewName "Device 0002"

These commands rename a robotic library device named "Device 0001" to "Device 0002".

Related Link

Get-BERoboticLibraryDevice


Rename-BEStorageArrayDevice Help

Rename-BEStorageArrayDevice Cmdlet
Synopsis

Renames a storage array device in Backup Exec.

Syntax
Rename-BEStorageArrayDevice [-InputObject] [<BEStorageArrayDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a storage array device in Backup Exec.

Parameters

-InputObject <BEStorageArrayDevice>

Specifies the storage array device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the storage array device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

You can pipe a Backup Exec storage array device object to Rename-BEStorageArrayDevice.

Return Value
BackupExec.Management.CLI.BEStorageArrayDevice

Rename-BEStorageArrayDevice returns an object that represents the storage array device that was renamed.

Example

C:\PS> Get-BEStorageArrayDevice "Device 0001" | Rename-BEStorageArrayDevice -NewName "Device 0002"

These commands rename a storage array device named "Device 0001" to "Device 0002".

Related Link

Get-BEStorageArrayDevice


Rename-BEStorageDevicePool Help

Rename-BEStorageDevicePool Cmdlet
Synopsis

Renames a storage device pool in Backup Exec.

Syntax
Rename-BEStorageDevicePool [-InputObject] [<BEStorageDevicePool>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a storage device pool in Backup Exec.

System-defined storage device pools cannot be renamed.

Parameters

-InputObject <BEStorageDevicePool>

Specifies the storage device pool object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the storage device pool object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageDevicePool

You can pipe a Backup Exec storage device pool object to Rename-BEStorageDevicePool.

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Rename-BEStorageDevicePool returns an object that represents the storage device pool that was renamed.

Example

C:\PS> Get-BEStorageDevicePool "StorageDevicePool 0001" | Rename-BEStorageDevicePool -NewName "StorageDevicePool 0002"

These commands rename a storage device pool named "StorageDevicePool 0001" to "StorageDevicePool 0002".

Related Link

Get-BEStorageDevicePool


Rename-BETapeDriveDevice Help

Rename-BETapeDriveDevice Cmdlet
Synopsis

Renames a tape drive device in Backup Exec.

Syntax
Rename-BETapeDriveDevice [-InputObject] [<BETapeDriveDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a tape drive device in Backup Exec.

Parameters

-InputObject <BETapeDriveDevice>

Specifies the tape drive device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the tape drive device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Rename-BETapeDriveDevice.

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

Rename-BETapeDriveDevice returns an object that represents the tape drive device that was renamed.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Rename-BETapeDriveDevice -NewName "Device 0002"

These commands rename a tape drive device named "Device 0001" to "Device 0002".

Related Link

Get-BETapeDriveDevice


Rename-BEVirtualDiskDevice Help

Rename-BEVirtualDiskDevice Cmdlet
Synopsis

Renames a virtual disk device in Backup Exec.

Syntax
Rename-BEVirtualDiskDevice [-InputObject] [<BEVirtualDiskDevice>] [[-NewName] [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Renames a virtual disk device in Backup Exec.

Parameters

-InputObject <BEVirtualDiskDevice>

Specifies the virtual disk device object to rename.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-NewName <String>

Specifies the new name to assign to the virtual disk device object.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEVirtualDiskDevice

You can pipe a Backup Exec virtual disk device object to Rename-BEVirtualDiskDevice.

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Rename-BEVirtualDiskDevice returns an object that represents the virtual disk device that was renamed.

Example

C:\PS> Get-BEVirtualDiskDevice "Device 0001" | Rename-BEVirtualDiskDevice -NewName "Device 0002"

These commands rename a virtual disk device named "Device 0001" to "Device 0002".

Related Link

Get-BEVirtualDiskDevice


Restart-BEService Help

Restart-BEService Cmdlet
Synopsis

Restarts one or more Backup Exec services.

Syntax
Restart-BEService [[-Name] [<String[]>]] [-PassThru [<SwitchParameter>]] [-ServiceType {Core | Deduplication}] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Restart-BEService -DisplayName [<String[]>] [-ServiceType {Core | Deduplication}] [-PassThru [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Restarts one or more Backup Exec services.

If you do not pass parameters to Restart-BEService, all of the core Backup Exec services are restarted.

Parameters

-PassThru <SwitchParameter>

Returns an object that represents the service. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies the name of the Backup Exec Service to restart.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-DisplayName <String[]>

Specifies the common name of the Backup Exec service to restart.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceType

Specifies type of Backup Exec service to restart.

The valid values are:
Core
Deduplication

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe the name of the Backup Exec service to Restart-BEService.

Return Value
None or System.ServiceProcess.ServiceController

When you use the PassThru parameter, Restart-BEService generates a System.ServiceProcess.ServiceController object representing the service. Otherwise, this cmdlet does not generate any output.

Examples

Example 1

C:\PS> Restart-BEService

This command restarts all of the Backup Exec core services.

Example 2
C:\PS> Restart-BEService -ServiceType Deduplication

This command restarts all of the Backup Exec deduplication services.


Resume-BEJob Help

Resume-BEJob Cmdlet
Synopsis

Takes a job off hold in Backup Exec.

Syntax
Resume-BEJob -InputObject [<BEJob[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Takes a job off hold in Backup Exec.

Use Resume-BEJob to resume jobs that you place on hold (see Suspend-BEJob).

Parameters

-InputObject <BEJob[]>

Specifies one or more job objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to Resume-BEJob.

Return Value
BackupExec.Management.CLI.BEJob

Resume-BEJob returns a Backup Exec job object.

Example

C:\PS> Get-BEJob "Job 0001" | Resume-BEJob

These commands take a job named "Job 0001" off hold.

Related Links


Resume-BEJobQueue Help

Resume-BEJobQueue Cmdlet
Synopsis

Takes the job queue for a server off hold in Backup Exec.

Syntax
Resume-BEJobQueue [-BackupExecServer [<BEBackupExecServer>]] [<CommonParameters>]
Description

Takes the job queue for a server off hold in Backup Exec.

Use Resume-BEJobQueue to resume the job queue for a server that you place on hold (see Suspend-BEJobQueue).

If you do not specify the -BackupExecServer parameter, Resume-BEJobQueue takes the local Backup Exec server's job queue off hold.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server for which to take the job queue off hold in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to Resume-BEJobQueue.

Return Value
BackupExec.Management.CLI.BEBackupExecServer

Resume-BEJobQueue returns a Backup Exec server object.

Examples

Example 1

C:\PS> Resume-BEJobQueue

This command takes the local Backup Exec server's job queue off hold.

Example 2
C:\PS> Get-BEBackupExecServer "ManagedServer0001" | Resume-BEJobQueue

These commands take the job queue of the Backup Exec server named "ManagedServer0001" off hold.

Related Links


Save-BEBackupDefinition Help

Save-BEBackupDefinition Cmdlet
Synopsis

Saves a new or modified backup definition in Backup Exec.

Syntax
Save-BEBackupDefinition [-BackupDefinition] [<BEBackupDefinition>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Force [<SwitchParameter>]] [<CommonParameters>]
Description

Saves a new or modified backup definition in Backup Exec.

When you create a new backup definition (see New-BEBackupDefinition) or edit a backup definition (see Get-BEBackupDefinition), the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to save.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Force <SwitchParameter>

Confirms that Save-BEBackupDefinition can proceed when using direct access and the AgentServer uses a different port than the default port of 10000.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Save-BEBackupDefinition.

Return Value
BackupExec.Management.CLI.BEBackupDefinition

Save-BEBackupDefinition returns the saved backup definition.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | New-BEBackupDefinition -BackupJobDefault BackupToDisk | Save-BEBackupDefinition

These commands create a new backup definition that backs up the entire local computer using the BackupToDisk defaults.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Add-BEDifferentialBackupTask | Save-BEBackupDefinition

These commands add a differential backup to a backup definition named "Backup Definition 01".

Related Links


Save-BEBackupJobDefault Help

Save-BEBackupJobDefault Cmdlet
Synopsis

Saves modified Backup Exec job defaults.

Syntax
Save-BEBackupJobDefault [-BackupJobDefault] [<BEBackupJobDefaults>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Saves modified Backup Exec job defaults.

When you edit backup job defaults (see Get-BEBackupJobDefault), the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to save.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupJobDefaults

You can pipe a Backup Exec backup job default object to Save-BEBackupJobDefault.

Return Value
BackupExec.Management.CLI.BEBackupJobDefaults

Save-BEBackupJobDefault returns the saved backup job defaults.

Example

C:\PS> Get-BEBackupJobDefault BackupToTape | Set-BEBackupJobDefault -Priority High | Save-BEBackupJobDefault

These commands sets the default backup to tape job priority to "High".

Related Links


Search-BECatalog Help

Search-BECatalog Cmdlet
Synopsis

Searches the Backup Exec catalog for files and folders.

Syntax
Search-BECatalog [-AgentServer [<BEAgentServer[]>]] [-Path] [<String>] [-FromLastWriteTime [<DateTime>]] [-Recurse [<SwitchParameter>]] [-ToLastWriteTime [<DateTime>]] [-ToLength [<UInt64>]] [-FromLength [<UInt64>]] [-PathIsDirectory [<SwitchParameter>]] [-ToCreationTime [<DateTime>]] [-FromBackupTime [<DateTime>]] [-FromCreationTime [<DateTime>]] [-ToBackupTime [<DateTime>]] [<CommonParameters>]
Description

Searches the Backup Exec catalog for files and folders.

Parameters

-AgentServer <BEAgentServer[]>

Specifies one or more agent server objects to filter search results. Enter a variable that contains the objects, or type a command or expression that gets the objects. See Get-BEAgentServer.

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Path <String>

Specifies the path of the file system folder or file taht you want to search (wildcards accepted).

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-PathIsDirectory <SwitchParameter>

Specifies that the value of the Path parameter is a directory instead of a file.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromBackupTime <DateTime>

Filters the search results to items that have been backed up since the specified time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToBackupTime <DateTime>

Filters the search results to items that have been backed up before the specified time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromCreationTime <DateTime>

Filters the search results to items that have been created since the specified time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToCreationTime <DateTime>

Filters the search results to items that have been created before the specified time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromLastWriteTime <DateTime>

Filters the search results to items that have been modified since the specified time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToLastWriteTime <DateTime>

Filters the search results to items that have been modified before the specified time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FromLength <UInt64>

Filters the search results to items that are greater than the specified file size in bytes.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ToLength <UInt64>

Filters the search results to items that are less than the specified file size in bytes.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Recurse <SwitchParameter>

Specifies that you want to search the subfolders.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to filter search results returned by Search-BECatalog.

Return Value
BackupExec.Management.CLI.BEFileSystemCatalogSearchResult

Search-BECatalog returns object that represent Backup Exec catalog search results.

Examples

Example 1

C:\PS> Get-BEAgentServer server01 | Search-BECatalog *.txt

These commands search for all of the text files backed up for a server named "server01".

Example 2
C:\PS> Get-BEAgentServer server01 | Search-BECatalog C:\Windows\*.dll -Recurse

These commands search for all of the DLL files in the C:\Windows directory and all of its subdirectories backed up for a server named "server01".

Example 3
C:\PS> Get-BEAgentServer server01 | Search-BECatalog C:\Users -PathIsDirectory

These commands search for all backups of the C:\Users directory backed up for a server named "server01".

Related Link

Get-BEAgentServer


Set-BEAgentServer Help

Set-BEAgentServer Cmdlet
Synopsis

Sets the properties for a Backup Exec agent server.

Syntax
Set-BEAgentServer -InputObject [<BEAgentServer[]>] [-LogonAccount [<BELogonAccount>]] [-Description [<String>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec agent server.

Parameters

-LogonAccount <BELogonAccount>

Specifies the Backup Exec logon account used to browse the agent server.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the agent server.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServer[]>

Specifies one or more agent server objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to Set-BEAgentServer.

Return Value
BackupExec.Management.CLI.BEAgentServer

Set-BEAgentServer returns an object that represents the changed Backup Exec agent server.

Example

C:\PS> Get-BEAgentServer server01 | Set-BEAgentServer -LogonAccount "System Logon Account"

These commands set the logon account for a server named "server01" to the System Logon Account.

Related Link

Get-BEAgentServer


Set-BEAgentServerBackupSource Help

Set-BEAgentServerBackupSource Cmdlet
Synopsis

Sets the properties for a Backup Exec agent server backup source.

Syntax
Set-BEAgentServerBackupSource -InputObject [<BEAgentServerBackupSource[]>] [-LogonAccount [<BELogonAccount>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec agent server backup source.

Parameters

-LogonAccount <BELogonAccount>

Specifies the Backup Exec logon account used to browse the agent server backup source.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAgentServerBackupSource[]>

Specifies one or more agent server backup source objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServerBackupSource

You can pipe a Backup Exec agent server backup source object to Set-BEAgentServerBackupSource.

Return Value
BackupExec.Management.CLI.BEAgentServerBackupSource

Set-BEAgentServerBackupSource returns an object that represents the changed Backup Exec agent server backup source.

Example

C:\PS> Get-BEAgentServer | Get-BEAgentServerBackupSource C: | Set-BEAgentServerBackupSource -LogonAccount "System Logon Account"

These commands set the logon account for the C: volume of a server named "server01" to the System Logon Account.

Related Links


Set-BEAlertCategory Help

Set-BEAlertCategory Cmdlet
Synopsis

Sets the properties for a Backup Exec alert category.

Syntax
Set-BEAlertCategory -InputObject [<BEAlertCategory[]>] [-AutoClearAlertAfterMinutes [<Int32>]] [-AutoClearAlertEnabled [<Boolean>]] [-AutoClearAlertResponse {Cancel | Yes | No}] [-RecipientNotificationEnabled [<Boolean>]] [-Enabled [<Boolean>]] [-IncludeJobLog [<Boolean>]] [-EventLogRecordingEnabled [<Boolean>]] [-SnmpNotificationEnabled [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec alert category.

Parameters

-Enabled <Boolean>

Enables the alert.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RecipientNotificationEnabled <Boolean>

Enables recipient notification when alerts occur.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IncludeJobLog <Boolean>

Includes a copy of the job log with the notification.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnmpNotificationEnabled <Boolean>

Enables SNMP notifications for the alert.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EventLogRecordingEnabled <Boolean>

Enters the alert into the Windows Event Viewer.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutoClearAlertEnabled <Boolean>

Automatically clears the alert.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutoClearAlertAfterMinutes <Int32>

Specifies the number of minutes you want the alert to remain active before it is cleared.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutoClearAlertResponse

Specifies the response that you want Backup Exec to send automatically when the alert is cleared.

The valid values are:
Cancel
Yes
No

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEAlertCategory[]>

Specifies one or more alert category objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAlertCategory

You can pipe a Backup Exec alert category object to Set-BEAlertCategory.

Return Value
BackupExec.Management.CLI.BEAlertCategory

Set-BEAlertCategory returns an object that represents the changed Backup Exec alert category.

Example

C:\PS> Get-BEAlertCategory "Media Overwrite" | Set-BEAlertCategory -AutoClearAlertEnabled $true -AutoClearAlertAfterMinutes 5 -AutoClearAlertResponse No

These commands configure any "Media Overwrite" alerts to auto-clear after five minutes with a response of "No".

Related Link

Get-BEAlertCategory


Set-BEBackupDefinition Help

Set-BEBackupDefinition Cmdlet
Synopsis

Sets the properties for a backup definition in Backup Exec.

Syntax
Set-BEBackupDefinition [-BackupDefinition] [<BEBackupDefinition>] [-ExchangePreConsistencyCheck [<Boolean>]] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-FileSystemBackupOpenFileIfClosedWithinSeconds [<UInt32>]] [-FileSystemBackupRemoteStorage [<Boolean>]] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-SharePointPreConsistencyCheck [<Boolean>]] [-SharePointContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-SharePointReleaseLockOnFarmTopology [<Boolean>]] [-ExchangeUseGrt [<Boolean>]] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly}] [-ProcessOffhostLogicalVolumesSequentially [<Boolean>]] [-RunBackupWhenThreatConLevelReached [<String>]] [-FailIfNoOffhostBackup [<Boolean>]] [-UseOffhostBackup [<Boolean>]] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-FileSystemFollowJunctionPoint [<Boolean>]] [-FileSystemFollowSymbolicLink [<Boolean>]] [-FileSystemEnableNtfsSingleInstanceBackup [<Boolean>]] [-ThreatConLevel {Level2 | Level3 | Level4}] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-SharePointUseGrt [<Boolean>]] [-VirtualMachineUseGrtForSql [<Boolean>]] [-VirtualMachineUseGrtForSharePoint [<Boolean>]] [-VirtualMachineUseGrtForExchange [<Boolean>]] [-VirtualMachineUseGrtForFileSystem [<Boolean>]] [-VirtualMachineUseGrtForActiveDirectory [<Boolean>]] [-VMwareVSpherePort [<UInt32>]] [-HyperVExcludeVirtualMachinesNeedingSavedState [<Boolean>]] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-LinuxMacLockRemoteFile [<Boolean>]] [-ActiveDirectoryPreConsistencyCheck [<Boolean>]] [-LinuxMacFollowRemoteMountPoint [<Boolean>]] [-LinuxMacPreserveChangeTime [<Boolean>]] [-LinuxMacFollowLocalMountPoint [<Boolean>]] [-OracleMinimumNumberOfDevicesRequiredForJob [<UInt32>]] [-VirtualMachineBackupPoweredOffVirtualMachine [<Boolean>]] [-OracleMaximumNumberOfDevicesToUseForResources [<UInt32>]] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-ActiveDirectoryUseGrt [<Boolean>]] [-ProcessLogicalVolumesSequentially [<Boolean>]] [-SharePointHelpSearchSelection {Include | Exclude}] [-SharePointSingleSignOnDatabaseSelection {Include | Exclude}] [-SharePointInfoPathServicesSelection {Include | Exclude}] [-SharePointGlobalSettingsSelection {Include | Exclude}] [-SharePointCentralAdministrationWebApplicationSelection {Include | Exclude}] [-SharePointSharedServiceApplicationSelection [<BESharePointSharedServiceApplicationSelection[]>]] [-SharePointSharedServiceApplicationProxySelection [<BESharePointSharedServiceApplicationProxySelection[]>]] [-SharePointServiceApplicationProxySelection [<BESharePointServiceApplicationProxySelection[]>]] [-SharePointWebApplicationSelection [<BESharePointWebApplicationSelection[]>]] [-SharePointServiceApplicationSelection [<BESharePointServiceApplicationSelection[]>]] [-SystemStateSelection {Include | Exclude}] [-FileSystemSelection [<BEFileSystemSelection[]>]] [-ClearExistingSelection [<SwitchParameter>]] [-EnableSimplifiedDisasterRecovery [<Boolean>]] [-SelectEntireAgentServer [<SwitchParameter>]] [-SharePointAllResourcesSelection {Include | Exclude}] [-SharePointConfigurationDatabaseSelection {Include | Exclude}] [-SqlDatabaseSelection [<BESqlDatabaseSelection[]>]] [-ExchangeStorageGroupDatabaseSelection [<BEExchangeStorageGroupDatabaseSelection[]>]] [-ExchangeDatabaseSelection [<BEExchangeDatabaseSelection[]>]] [-SharePointSharedServiceProviderSelection [<BESharePointSharedServiceProviderSelection[]>]] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkSubnet [<BENetworkInterfaceSubnet>]] [-NetworkInterface [<BENetworkInterface>]] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful [<Boolean>]] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-UseSnapshotTechnology [<Boolean>]] [-AllowAnyNetworkForAgentAccess [<Boolean>]] [-EnableCheckpointRestart [<Boolean>]] [-RestrictToBackupExecServer [<BEBackupExecServer>]] [-RestrictToBackupExecServersInPool [<BEBackupExecServerPool>]] [-Priority {Normal | Lowest | Low | High | Highest}] [-SharePointPortalSiteSelection [<BESharePointPortalSiteSelection[]>]] [-SharePointServiceSiteSelection [<BESharePointServiceSiteSelection[]>]] [-TestRunCheckStorageSpace [<Boolean>]] [-TestRunCheckMediaAvailable [<Boolean>]] [-TestRunCheckLogonAccount [<Boolean>]] [-EnableTestRun [<Boolean>]] [-TestRunSchedule [<BESchedule>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a backup definition in Backup Exec.

The parameters passed to Set-BEBackupDefinition are options for all of the tasks in the backup definition.

The values of selection parameters passed to Set-BEBackupDefinition are added to the current selections in the backup definition that you want to edit. To clear the existing selections, use ClearExistingSelection.

Set-BEBackupDefinition can be used with the following commands to modify the tasks in the backup definition: Add-BEIncrementalBackupTask, Add-BEDifferentialBackupTask, Add-BEDuplicateStageBackupTask, Add-BEConvertToVirtualStageBackupTask, Add-BEVerifyBackupTask, Set-BEIncrementalBackupTask, Set-BEDifferentialBackupTask, Set-BEDuplicateStageBackupTask, Set-BEVerifyBackupTask, and Remove-BEBackupTask.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

Parameters

-EnableSimplifiedDisasterRecovery <Boolean>

Enables Simplified System Recovery.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SelectEntireAgentServer <SwitchParameter>

Selects the entire agent server to be backed up.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ClearExistingSelection <SwitchParameter>

Clears the existing backup selections.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemStateSelection

Includes or excludes System State in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

Includes or excludes one or more file system selections in the backup definition. To specify files or directories to include, specify one or more paths using commas to separate the values. To specify files or directories to exclude, use the output of New-BEFileSystemSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>

Includes or excludes one or more Exchange 2003 storage groups or databases in the backup definition. To specify storage groups to include, specify one or more storage group names using commas to separate the values (specifying '*' will include all storage groups). To specify storage groups to exclude, or to specify individual databases to include or exclude, use the output of New-BEExchangeStorageGroupDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>

Includes or excludes one or more databases for Exchange 2007 or later in the backup definition. To specify databases to include, specify one or more database names using commas to separate the values (specifying '*' will include all databases). To specify databases to exclude, use the output of New-BEExchangeDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDatabaseSelection <BESqlDatabaseSelection[]>

Includes or excludes one or more SQL instances or databases in the backup definition. To specify SQL instances to include, specify one or more SQL instance names using commas to separate the values (specifying '*' will include all SQL instances). To specify SQL instances to exclude, or to specify individual databases to include or exclude, use the output of New-BESqlDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointAllResourcesSelection

Includes or excludes all of the SharePoint resources categorically in the backup definition when you back up a Windows computer.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointConfigurationDatabaseSelection

Includes or excludes the SharePoint configuration database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointGlobalSettingsSelection

Includes or excludes the SharePoint global settings database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointCentralAdministrationWebApplicationSelection

Includes or excludes the SharePoint Central Administration Web Application in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointInfoPathServicesSelection

Includes or excludes the SharePoint Info Path Services in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointHelpSearchSelection

Includes or excludes the SharePoint Help Search in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSingleSignOnDatabaseSelection

Includes or excludes the SharePoint Single Sign-on Database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>

Includes or excludes one or more SharePoint Web Applications in the backup definition. To specify Web Applications to include, specify one or more Web Application names using commas to separate the values (specifying '*' will include all Web Applications). To specify Web Applications to exclude, use the output of New-BESharePointWebApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>

Includes or excludes one or more SharePoint Service Applications in the backup definition. To specify Service Applications to include, specify one or more Service Application names using commas to separate the values (specifying '*' will include all Service Applications). To specify Service Applications to exclude, use the output of New-BESharePointServiceApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>

Includes or excludes one or more SharePoint Service Application Proxies in the backup definition. To specify Service Application Proxies to include, specify one or more Service Application Proxy names using commas to separate the values (specifying '*' will include all Service Application Proxies). To specify Service Application Proxies to exclude, use the output of New-BESharePointServiceApplicationProxySelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>

Includes or excludes one or more SharePoint Shared Service Applications in the backup definition. To specify Shared Service Applications to include, specify one or more Shared Service Application names using commas to separate the values (specifying '*' will include all Shared Service Applications). To specify Shared Service Applications to exclude, use the output of New-BESharePointSharedServiceApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>

Includes or excludes one or more SharePoint Shared Service Application Proxies in the backup definition. To specify Shared Service Application Proxies to include, specify one or more Shared Service Application Proxy names using commas to separate the values (specifying '*' will include all Shared Service Application Proxies). To specify Shared Service Application Proxies to exclude, use the output of New-BESharePointSharedServiceApplicationProxySelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>

Includes or excludes one or more SharePoint Shared Service Providers in the backup definition. To specify Shared Service Providers to include, specify one or more Shared Service Provider names using commas to separate the values. To specify Shared Service Providers to exclude, use the output of New-BESharePointSharedServiceProviderSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>

Includes or excludes one or more SharePoint Portal Sites in the backup definition. To specify Portal Sites to include, specify one or more Portal Site names using commas to separate the values. To specify Portal Sites to exclude, use the output of New-BESharePointPortalSiteSelection with the -Exclude parameter to pass one or more Portal Sites to exclude to this parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>

Includes or excludes one or more SharePoint Service Sites in the backup definition. To specify Service Sites to include, specify one or more Service Site names using commas to separate the values. To specify Service Sites to exclude, use the output of New-BESharePointServiceSiteSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

Specifies the order that the job runs. If two jobs are scheduled to run at the same time, the priority you set determines which job runs first.

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server to which the job can be dispatched in a CASO environment. Cannot be specified if RestrictToBackupExecServersInPool is specified.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

Specifies a set of Backup Exec servers to which the job can be dispatched in a CASO environment. Cannot be specified if RestrictToBackupExecServer is specified.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestRun <Boolean>

Enables the test run process.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

Lets you schedule the time and how often the test run job runs.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

Verifies that the Backup Exec logon account is correct for the data that you want to back up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

Tests if there is enough available capacity on the media to complete the job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

Tests if the media is online and able to be overwritten.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

Specifies how to calculate if enough media is available to run the scheduled backup job.

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

Places the scheduled job on hold if Backup Exec detects any failures during the test run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

Specifies the name of the network interface card that connects the Backup Exec server to the network you want to use for the backup network. See Get-BENetworkInterface.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

Specifies the protocol you want to used to back up remote computers.

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Specifies the subnet you want to use to back up remote computers on by using one of the subnets of a network interface returned by Get-BENetworkInterface.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

Ensures that the data from the remote computer is backed up or restored over any available network if the remote computer that you select for backup or restore is not part of the specified backup network.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

Enables backup jobs to continue from the point at which the jobs was interrupted.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

Enables the use of a snapshot technology

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

Specifies the snapshot technology to use when you enable snapshot technology. UseSnapshotTechnology must be set to $true.

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

Specifies the Microsoft Volume Shadow Copy Service as the snapshot provider to use when you enable snapshot technology. UseSnapshotTechnology must be set to $true and SnapshotTechnology must be set to MicrosoftVolumeShadowCopyService.

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

Enables the backup of multiple volumes in one job, while creating a snapshot of only one logical volume at a time.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

Enables offhost backup. If enabled, then an offhost backup of all volumes will be performed if all requirements are met.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

Specifies the offhost backup snapshot provider to use. UseOffhostBackup must be set to $true.

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

Terminates the backup job if any of the volumes selected do not support offhost backup, or if an error occurs that is related to the snapshot or volume import. UseOffhostBackup must be set to $true.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

Enables the backup of multiple volumes in one job, while creating a snapshot of only one logical volume at a time for offhost backups. UseOffhostBackup must be set to $true.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunBackupWhenThreatConLevelReached <String>

Runs automatic backup jobs when the ThreatCon reaches a level that you specify.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ThreatConLevel

Specifies the ThreatCon level at which you want backup jobs to run. RunJobAfterThreatConLevelReached must be set to $true.

The valid values are:
Level2
Level3
Level4

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupMethod

Specifies the backup method to use to back up files and folders.

The valid values are:
UseModifiedTime
UseArchiveBit
UseCatalog

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Lets Backup Exec check the NTFS volume for identical files. If Backup Exec finds multiple copies of a file, only one instance of that file is backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

Backs up the information for the junction points and the files and directories to which they are linked.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

Backs up the information for the symbolic links and the files and directories to which they are linked.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

Backs up data that has been migrated from primary storage to secondary storage.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

Specifies how Backup Exec processes any open files for the backup job if snapshot technology is not used.

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

The number of seconds Backup Exec waits for files to close before skipping them and continuing the backup job. BackupOpenFile must be set to IfClosedWithinSpecifiedTime.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

Performs a consistency check before running the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

Enables restores of individual items from Information Store backup jobs.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Specifies a backup source for Exchange 2007 or later.

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

Releases the lock on the SharePoint farm topology before you run the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Runs a full consistency check (including indexes) of the Microsoft SQL databases used by Microsoft SharePoint before you back up the databases.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Continues with the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

Enables the restore of individual documents, images, sites, subsites, lists, and list items from backups of the database.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

Prevents the Agent of Windows from changing an object's attributes when a backup job occurs. An object is a file or a directory.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

Lets Backup Exec follow local mount points when it backs up data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

Lets Backup Exec follow remote mount points when it backs up data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

Lets the Agent for Windows have exclusive access to the files on the remote computers that are connected through Network File System (NFS).

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

Checks snapshots for data corruption.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Enables the backup job to continue even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Enables the restore of individual items from full backups of the Active Directory.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

Specifies the maximum number of devices that the backup job can use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

Specifies the minimum number of devices that the job can use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

Enables Backup Exec to back up virtual machines that are turned off.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

Enables individual files and folders to be restored from the full backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Enables Backup Exec to collect the information that is required to restore individual Active Directory objects on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Enables Backup Exec to collect the information that is required to restore individual Exchange databases and mailbox items on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Enables Backup Exec to collect the information that is required to restore individual SQL database items on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Enables Backup Exec to collect the information that is required to restore SharePoint data on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

Excludes all offline virtual machines that do not support online backups and that are in a running state when the backup starts.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Specifies one or more VMware transport modes Backup Exec should use in order of their priority.

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Specifies the VMware vSphere port Backup Exec should use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to edit.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Set-BEBackupDefinition.

Return Value
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEBackupDefinition -FileSystemSelection D:\* | Save-BEBackupDefinition

These commands add D:\* as a backup selection to the current selections in the backup definition named "Backup Definition 01".

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEBackupDefinition -ClearExistingSelection -FileSystemSelection D:\* | Save-BEBackupDefinition

These commands set D:\* as the only backup selection in the backup definition named "Backup Definition 01".

Related Links

Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEDuplicateStageBackupTask
Add-BEConvertToVirtualStageBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEDuplicateStageBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupDefinition
New-BEFileSystemSelection
New-BEExchangeStorageGroupDatabaseSelection
New-BEExchangeDatabaseSelection
New-BESqlDatabaseSelection
New-BESharePointWebApplicationSelection
New-BESharePointServiceApplicationSelection
New-BESharePointServiceApplicationProxySelection
New-BESharePointSharedServiceApplicationSelection
New-BESharePointSharedServiceApplicationProxySelection
New-BESharePointSharedServiceProviderSelection
New-BESharePointPortalSiteSelection
New-BESharePointServiceSiteSelection
Get-BENetworkInterface
Get-BEBackupDefinition


Set-BEBackupExecServerPool Help

Set-BEBackupExecServerPool Cmdlet
Synopsis

Sets the properties for a Backup Exec server pool.

Syntax
Set-BEBackupExecServerPool -InputObject [<BEBackupExecServerPool[]>] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec server pool.

Parameters

-Description <String>

Specifies the description for the Backup Exec server pool.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEBackupExecServerPool[]>

Specifies one or more Backup Exec server pool objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServerPool

You can pipe a Backup Exec server pool object to Set-BEBackupExecServerPool.

Return Value
BackupExec.Management.CLI.BEBackupExecServerPool

Set-BEBackupExecServerPool returns an object that represents the changed Backup Exec server pool.

Example

C:\PS> Get-BEBackupExecServerPool -Name "Server Pool 0001" | Set-BEBackupExecServerPool -Description "Test Pool"

These commands change the description of a Backup Exec server pool named "Server Pool 0001" to "Test Pool".

Related Link

Get-BEBackupExecServerPool


Set-BEBackupExecSetting Help

Set-BEBackupExecSetting Cmdlet
Synopsis

Modifies global Backup Exec settings.

Syntax
Set-BEBackupExecSetting [-DiscoverDataToBackupCancel {After1Hour | After2Hours | After4Hours | After6Hours | After12Hours | After18Hours | After24Hours}] [-DiscoverDataToBackupSchedule [<BESchedule>]] [-EnableDiscoverDataToBackup [<Boolean>]] [-AllowAnyNetworkForAgentAccess [<Boolean>]] [-NetworkSubnet [<BENetworkInterfaceSubnet>]] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-NetworkInterface [<BENetworkInterface>]] [-ReportUseCompanyLogoImageFile [<Boolean>]] [-ReportShowRow {All | Distinct}] [-ReportMaxRowsToInclude [<UInt32>]] [-ReportCompanyLogoImageFilePath [<String>]] [-ReportFooterIncludeTime [<Boolean>]] [-ReportFooterText [<String>]] [-ReportBannerColor [<Color>]] [-PromptBeforeOverwritingMedia [<Boolean>]] [-MediaOverwriteProtectionLevel {None | Full | Partial}] [-InventoryRoboticLibrariesOnBackupExecServiceStart [<Boolean>]] [-MediaOverwriteOption {OverwriteScratchBeforeRecyclable | OverwriteRecyclableBeforeScratchMedia}] [-LimitDiskStorageToReadOnlyIfDetachedForDays [<Int32>]] [-RemoteAgentTcpDynamicPortRangeLowerBound [<UInt16>]] [-EnableRemoteAgentTcpDynamicPortRange [<Boolean>]] [-EnableSelectionOfUserShare [<Boolean>]] [-RemoteAgentTcpDynamicPortRangeUpperBound [<UInt16>]] [-DisasterRecoveryAlternateDataPath [<String>]] [-DisasterRecoveryDataPath [<String>]] [-UseFipsSoftwareEncryption [<Boolean>]] [-ReportFormat {Html | Pdf}] [-JobLogInformationLevel {Summary | SummaryAndDirectories | SummaryDirectoriesAndFiles | SummaryDirectoriesAndFileDetails}] [-JobStalledRecoveredSeconds [<UInt32>]] [-JobStalledThresholdSeconds [<UInt32>]] [-JobLogFilePrefix [<String>]] [-UseStorageBasedCatalog [<Boolean>]] [-RequestMediaInSequenceForCatalogOperation [<Boolean>]] [-JobLogEmailAttachmentFormat {Text | Html}] [-DefaultSchedule [<BESchedule>]] [-GrtRestoreTemporaryStagingPath [<String>]] [-GrtBackupTemporaryStagingPath [<String>]] [-DefaultKeepJobQueuedFor [<TimeSpan>]] [-SendMaintenanceReminderAlertOn [<DateTime>]] [-EnableProgressIndicatorForBackupJob [<Boolean>]] [-DefaultCancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-DatabaseMaintenanceKeepJobHistoryForDays [<UInt32>]] [-DatabaseMaintenanceKeepJobHistoryForMediaWithOverwriteProtection [<Boolean>]] [-DatabaseMaintenanceDeleteAgedData [<Boolean>]] [-DatabaseMaintenanceKeepJobLogsForDays [<UInt32>]] [-DatabaseMaintenanceKeepAuditLogsForDays [<UInt32>]] [-DatabaseMaintenanceKeepReportsForDays [<UInt32>]] [-DatabaseMaintenanceKeepAlertHistoryForDays [<UInt32>]] [-EnableDatabaseMaintenance [<Boolean>]] [-CatalogPath [<String>]] [-TruncateCatalogAfterDays [<UInt32>]] [-DatabaseMaintenancePerformEverydayAt [<DateTime>]] [-DatabaseMaintenanceOptimizeSize [<Boolean>]] [-DatabaseMaintenanceSaveDatabaseContent [<Boolean>]] [-DatabaseMaintenancePerformDatabaseConsistencyCheck [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Modifies global Backup Exec settings.

Use Set-BEBackupExecSetting to retrieve global Backup Exec settings.

Parameters

-GrtBackupTemporaryStagingPath <String>

Designates a location where Backup Exec can stage temporary data during GRT-enabled backup jobs.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-GrtRestoreTemporaryStagingPath <String>

Designates a location where Backup Exec can stage temporary data during GRT restore jobs.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DefaultSchedule <BESchedule>

Specifies the default job schedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DefaultKeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past its scheduled start time at which Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DefaultCancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the job's scheduled start time at which you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableProgressIndicatorForBackupJob <Boolean>

Displays the percentage complete number while a backup job processes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SendMaintenanceReminderAlertOn <DateTime>

Lets you select the date on which you want to receive a reminder to renew your maintenance contracts for Backup Exec features that are installed.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobStalledThresholdSeconds <UInt32>

Specifies the amount of time you want to wait before Backup Exec changes an unresponsive job's status to Stalled.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobStalledRecoveredSeconds <UInt32>

Specifies the amount of time you want to wait before Backup Exec fails jobs that stalled and then recovers them.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobLogInformationLevel

Specifies the amount of detail you want to include in the completed job log.

The valid values are:
Summary
SummaryAndDirectories
SummaryDirectoriesAndFiles
SummaryDirectoriesAndFileDetails

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobLogFilePrefix <String>

Specifies a prefix to add to the job logs that are processed. The default prefix is BEX.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobLogEmailAttachmentFormat

Specifies the format to use when attaching job logs to an email notification.

The valid values are:
Text
Html

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RequestMediaInSequenceForCatalogOperation <Boolean>

Catalogs the media in tape drives and disk cartridges by starting with the lowest known tape number in the tape family.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseStorageBasedCatalog <Boolean>

Lets Backup Exec read the catalog information from the storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TruncateCatalogAfterDays <UInt32>

Retains only the header information and removes all file details and directory details after the specified amount of time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CatalogPath <String>

Specifies the path where you want to locate the catalogs.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDatabaseMaintenance <Boolean>

Activates the database maintenance process.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenancePerformEverydayAt <DateTime>

Specifies the time you want to perform database maintenance.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenancePerformDatabaseConsistencyCheck <Boolean>

Checks the logical and physical consistency of the data in the database.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceSaveDatabaseContent <Boolean>

Places the data that is contained in the database into the Backup Exec data directory so that the database backup file (BEDB.bak) can be backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceOptimizeSize <Boolean>

Reorganizes fragmented pages and decrease the size of the physical database to 10 percent above what is actually used.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceDeleteAgedData <Boolean>

Activates the deletion of expired job history, job logs, alert history, and reports from the Backup Exec Database after the specified number of days have passed.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepJobHistoryForMediaWithOverwriteProtection <Boolean>

Keeps all job history data for any media to which an overwrite protection policy is currently assigned.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepJobHistoryForDays <UInt32>

Specifies the number of days to keep job history data in the database before it is deleted.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepJobLogsForDays <UInt32>

Specifies the number of days to keep job logs in the database before they are deleted.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepAlertHistoryForDays <UInt32>

Specifies the number of days to keep alert history data in the database before it is deleted.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepReportsForDays <UInt32>

Specifies the number of days to keep report data in the database before it is deleted.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DatabaseMaintenanceKeepAuditLogsForDays <UInt32>

Specifies the number of days to keep audit log data in the database before it is deleted.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportFormat

Specifies the format for reports.

The valid values are:
Html
Pdf

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportMaxRowsToInclude <UInt32>

Specifies the maximum number of rows to show in a report.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportShowRow

Specifies the rows to display in a report.

The valid values are:
All
Distinct

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportUseCompanyLogoImageFile <Boolean>

Uses a customized image file in the header of all custom reports.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportCompanyLogoImageFilePath <String>

Identifies the path to the logo that you want to use in all custom reports.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportBannerColor <Color>

Specifies the banner color for reports.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportFooterText <String>

Specifies the text that you want to display in the footer of custom reports.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReportFooterIncludeTime <Boolean>

Includes the time when the report runs in the footer of custom reports.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDiscoverDataToBackup <Boolean>

Enables Backup Exec's task to discover data to back up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiscoverDataToBackupSchedule <BESchedule>

Specifies the schedule that the task to discover data to back up runs.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiscoverDataToBackupCancel

Specifies the number of hours after which the data discovery task is cancelled if it is not finished.

The valid values are:
After1Hour
After2Hours
After4Hours
After6Hours
After12Hours
After18Hours
After24Hours

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

Ensures that the data from the remote computer is backed up or restored over any available network if the remote computer that you select for backup or restore is not part of the specified backup network.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

Specifies the name of the network interface card that connects the Backup Exec server to the network you want to use for the backup network. See Get-BENetworkInterface.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

Specifies the protocol you want to used to back up remote computers.

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Specifies the subnet you want to use to back up remote computers on by using one of the subnets of a network interface returned by Get-BENetworkInterface.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableSelectionOfUserShare <Boolean>

Lets you include user-defined shares in jobs.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableRemoteAgentTcpDynamicPortRange <Boolean>

Lets remote agents use a range of ports for communication.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoteAgentTcpDynamicPortRangeLowerBound <UInt16>

The lower-bound port for the remote agents to use for communication.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoteAgentTcpDynamicPortRangeUpperBound <UInt16>

The upper-bound port for the remote agents to use for communication.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseFipsSoftwareEncryption <Boolean>

Enables software encryption that complies with FIPS 140-2 standards.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DisasterRecoveryDataPath <String>

Specifies the path that you want to use to store the disaster recovery information files for the backed up computers.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DisasterRecoveryAlternateDataPath <String>

Specifies the alternate path that you want to use to store a copies of the disaster recovery information files for the backed up computers.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InventoryRoboticLibrariesOnBackupExecServiceStart <Boolean>

Enables Backup Exec to inventory all of the slots in a robotic library when Backup Exec services start.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaOverwriteProtectionLevel

Specifies when Backup Exec is permitted to overwrite media.

The valid values are:
None
Full
Partial

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PromptBeforeOverwritingMedia <Boolean>

Prompts you before Backup Exec overwrites media.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaOverwriteOption

Specifies the type of media that should be overwritten first.

The valid values are:
OverwriteScratchBeforeRecyclable
OverwriteRecyclableBeforeScratchMedia

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LimitDiskStorageToReadOnlyIfDetachedForDays <Int32>

Specifies the number of days that the disk-based storage must be detached from the Backup Exec server before Backup Exec is limited to read-only operations.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
BackupExec.Management.CLI.BEBackupExecSettings

Get-BEBackupExecSetting returns an object that represents global Backup Exec settings.

Example

C:\PS> Set-BEBackupExecSetting -JobLogInformationLevel SummaryDirectoriesAndFileDetails

This command updates the global settings to include summary information, processed subdirectories, a list of all the file names and their attributes in the job log.

Related Links


Set-BEBackupJobDefault Help

Set-BEBackupJobDefault Cmdlet
Synopsis

Sets the properties for the job defaults in Backup Exec.

Syntax
Set-BEBackupJobDefault [-BackupJobDefault] [<BEBackupJobDefaults>] [-LinuxMacFollowRemoteMountPoint [<Boolean>]] [-LinuxMacFollowLocalMountPoint [<Boolean>]] [-LinuxMacPreserveChangeTime [<Boolean>]] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-ActiveDirectoryPreConsistencyCheck [<Boolean>]] [-LinuxMacLockRemoteFile [<Boolean>]] [-SharePointUseGrt [<Boolean>]] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly}] [-ExchangeUseGrt [<Boolean>]] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-SharePointContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-SharePointPreConsistencyCheck [<Boolean>]] [-SharePointReleaseLockOnFarmTopology [<Boolean>]] [-ActiveDirectoryUseGrt [<Boolean>]] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-HyperVExcludeVirtualMachinesNeedingSavedState [<Boolean>]] [-VirtualMachineUseGrtForSharePoint [<Boolean>]] [-VMwareVSpherePort [<UInt32>]] [-VirtualMachineUseGrtForSql [<Boolean>]] [-VirtualMachineBackupPoweredOffVirtualMachine [<Boolean>]] [-OracleMinimumNumberOfDevicesRequiredForJob [<UInt32>]] [-OracleMaximumNumberOfDevicesToUseForResources [<UInt32>]] [-VirtualMachineUseGrtForExchange [<Boolean>]] [-VirtualMachineUseGrtForActiveDirectory [<Boolean>]] [-VirtualMachineUseGrtForFileSystem [<Boolean>]] [-ExchangePreConsistencyCheck [<Boolean>]] [-EnableCheckpointRestart [<Boolean>]] [-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful [<Boolean>]] [-TestRunJobSizeCalculationMethod {UsePreviousJobHistories | PerformPreScan}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-UseSnapshotTechnology [<Boolean>]] [-TestRunCheckMediaAvailable [<Boolean>]] [-EnableTestRun [<Boolean>]] [-RestrictToBackupExecServersInPool [<BEBackupExecServerPool>]] [-RestrictToBackupExecServer [<BEBackupExecServer>]] [-TestRunCheckStorageSpace [<Boolean>]] [-TestRunCheckLogonAccount [<Boolean>]] [-TestRunSchedule [<BESchedule>]] [-ProcessLogicalVolumesSequentially [<Boolean>]] [-FileSystemFollowSymbolicLink [<Boolean>]] [-FileSystemFollowJunctionPoint [<Boolean>]] [-FileSystemEnableNtfsSingleInstanceBackup [<Boolean>]] [-FileSystemBackupOpenFileIfClosedWithinSeconds [<UInt32>]] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupRemoteStorage [<Boolean>]] [-FileSystemBackupMethod {UseModifiedTime | UseArchiveBit | UseCatalog}] [-FailIfNoOffhostBackup [<Boolean>]] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-UseOffhostBackup [<Boolean>]] [-ThreatConLevel {Level2 | Level3 | Level4}] [-RunBackupWhenThreatConLevelReached [<String>]] [-ProcessOffhostLogicalVolumesSequentially [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for the job defaults in Backup Exec.

The parameters passed to Set-BEBackupJobDefault are options for all of the tasks in the backup job defaults.

Set-BEBackupJobDefault can be used with the following commands to modify the tasks in the backup job defaults: Get-BEBackupJobDefault, Add-BEIncrementalBackupTask, Add-BEDifferentialBackupTask, Add-BEVerifyBackupTask, Set-BEIncrementalBackupTask, Set-BEDifferentialBackupTask, Set-BEVerifyBackupTask, and Remove-BEBackupTask.

When you edit backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-RestrictToBackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server to which the job can be dispatched in a CASO environment. Cannot be specified if RestrictToBackupExecServersInPool is specified.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

Specifies a set of Backup Exec servers to which the job can be dispatched in a CASO environment. Cannot be specified if RestrictToBackupExecServer is specified.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableTestRun <Boolean>

Enables the test run process.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunSchedule <BESchedule>

Lets you schedule the time and how often the test run job runs.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckLogonAccount <Boolean>

Verifies that the Backup Exec logon account is correct for the data that you want to back up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckStorageSpace <Boolean>

Tests if there is enough available capacity on the media to complete the job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunCheckMediaAvailable <Boolean>

Tests if the media is online and able to be overwritten.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunJobSizeCalculationMethod

Specifies how to calculate if enough media is available to run the scheduled backup job.

The valid values are:
UsePreviousJobHistories
PerformPreScan

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TestRunPlaceScheduledBackupJobOnHoldIfUnsuccessful <Boolean>

Places the scheduled job on hold if Backup Exec detects any failures during the test run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

Enables backup jobs to continue from the point at which the jobs was interrupted.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

Enables the use of a snapshot technology.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

Specifies the snapshot technology to use when you enable snapshot technology. UseSnapshotTechnology must be set to $true.

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

Specifies the Microsoft Volume Shadow Copy Service as the snapshot provider to use when you enable snapshot technology. UseSnapshotTechnology must be set to $true and SnapshotTechnology must be set to MicrosoftVolumeShadowCopyService.

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

Enables the backup of multiple volumes in one job, while creating a snapshot of only one logical volume at a time.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

Enables offhost backup. If enabled, then an offhost backup of all volumes will be performed if all requirements are met.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

Specifies the offhost backup snapshot provider to use. UseOffhostBackup must be set to $true.

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

Terminates the backup job if any of the volumes selected do not support offhost backup, or if an error occurs that is related to the snapshot or volume import. UseOffhostBackup must be set to $true.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

Enables the backup of multiple volumes in one job, while creating a snapshot of only one logical volume at a time for offhost backups. UseOffhostBackup must be set to $true.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunBackupWhenThreatConLevelReached <String>

Runs automatic backup jobs when the ThreatCon reaches a level that you specify.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ThreatConLevel

Specifies the ThreatCon level at which automatic backup jobs run. RunBackupAfterThreatConLevelReached must be set.

The valid values are:
Level2
Level3
Level4

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupMethod

Specifies the backup method to use to back up files and folders.

The valid values are:
UseModifiedTime
UseArchiveBit
UseCatalog

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Lets Backup Exec check the NTFS volume for identical files. If Backup Exec finds multiple copies of a file, only one instance of that file is backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

Backs up the information for the junction points and the files and directories to which they are linked.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

Backs up the information for the symbolic links and the files and directories to which they are linked.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

Backs up data that has been migrated from primary storage to secondary storage.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

Specifies how Backup Exec processes any open files for the backup job if snapshot technology is not used.

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

The number of seconds Backup Exec waits for files to close before skipping them and continuing the backup job. BackupOpenFile must be set to IfClosedWithinSpecifiedTime.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

Performs a consistency check before running the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

Enables restores of individual items from Information Store backup jobs.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Specifies a backup source for Exchange 2007 or later.

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

Releases the lock on the SharePoint farm topology before you run the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Runs a full consistency check (including indexes) of the Microsoft SQL databases used by Microsoft SharePoint before you back up the databases.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Continues with the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

Enables the restore of individual documents, images, sites, subsites, lists, and list items from backups of the database.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

Prevents the Agent of Windows from changing an object's attributes when a backup job occurs. An object is a file or a directory.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

Lets Backup Exec follow local mount points when it backs up data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

Lets Backup Exec follow remote mount points when it backs up data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

Lets the Agent for Windows have exclusive access to the files on the remote computers that are connected through Network File System (NFS).

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

Checks snapshots for data corruption.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Enables the backup job to continue even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Enables the restore of individual items from full backups of the Active Directory.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

Specifies the maximum number of devices that the backup job can use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

Specifies the minimum number of devices that the job can use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

Enables Backup Exec to back up virtual machines that are turned off.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

Enables individual files and folders to be restored from the full backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Enables Backup Exec to collect the information that is required to restore individual Active Directory objects on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Enables Backup Exec to collect the information that is required to restore individual Exchange databases and mailbox items on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Enables Backup Exec to collect the information that is required to restore individual SQL database items on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Enables Backup Exec to collect the information that is required to restore SharePoint data on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

Excludes all offline virtual machines that do not support online backups and that are in a running state when the backup starts.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Specifies one or more VMware transport modes Backup Exec should use in order of their priority.

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Specifies the VMware vSphere port Backup Exec should use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupJobDefaults

You can pipe a Backup Exec backup job default object to Set-BEBackupJobDefault.

Return Value
BackupExec.Management.CLI.BEBackupJobDefaults

Set-BEBackupJobDefault returns the modified backup job defaults.

Example

C:\PS> Get-BEBackupJobDefault BackupToTape | Set-BEBackupJobDefault -Priority High | Save-BEBackupJobDefault

These commands set default backup-to-tape job priority to "High".

Related Links

Get-BEBackupJobDefault
Add-BEIncrementalBackupTask
Add-BEDifferentialBackupTask
Add-BEVerifyBackupTask
Set-BEIncrementalBackupTask
Set-BEDifferentialBackupTask
Set-BEVerifyBackupTask
Remove-BEBackupTask
Save-BEBackupJobDefault


Set-BECloudStorageDevice Help

Set-BECloudStorageDevice Cmdlet
Synopsis

Sets the properties for a Backup Exec cloud storage device.

Syntax
Set-BECloudStorageDevice -InputObject [<BECloudStorageDevice[]>] [-IsStreamHandlerSupportEnabled [<Boolean>]] [-DataStreamSizeBytes [<Int32>]] [-DiskSpaceReserveBytes [<Int64>]] [-SplitDataStreamBytes [<Int64>]] [-Description [<String>]] [-LogonAccount [<BELogonAccount>]] [-Disabled [<Boolean>]] [-AllowedConcurrentOperations [<Int32>]] [-Paused [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec cloud storage device.

Parameters

-LogonAccount <BELogonAccount>

Specifies a Backup Exec logon account for the new cloud storage device. The logon account cannot be the System Logon Account.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the cloud storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the cloud storage device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the cloud storage device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

Sets the maximum allowed concurrent write operations allowed on this device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SplitDataStreamBytes <Int64>

Specifies the size at which you want Backup Exec to span to a new image.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Indicates the size of a single write operation that Backup Exec issues.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsStreamHandlerSupportEnabled <Boolean>

Specifies if stream handler is used.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Specifies the amount of disk space to set aside for applications other than Backup Exec.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BECloudStorageDevice[]>

Specifies one or more cloud storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BECloudStorageDevice

You can pipe a Backup Exec cloud storage device object to Set-BECloudStorageDevice.

Return Value
BackupExec.Management.CLI.BECloudStorageDevice

Set-BECloudStorageDevice returns an object that represents the changed Backup Exec cloud storage device.

Example

C:\PS> Get-BECloudStorageDevice "Device 0001" | Set-BECloudStorageDevice -Paused $true

These commands pause the cloud storage device named "Device 0001".

Related Link

Get-BECloudStorageDevice


Set-BEDeduplicationDiskStorageDevice Help

Set-BEDeduplicationDiskStorageDevice Cmdlet
Synopsis

Sets the properties for a deduplication disk storage device in Backup Exec.

Syntax
Set-BEDeduplicationDiskStorageDevice -InputObject [<BEDeduplicationDiskStorageDevice[]>] [-LogLevel {Minimal | Low | Normal | High | Full}] [-ClientSideDeduplicationEnabled [<Boolean>]] [-LogRetentionDays [<Int32>]] [-DataStreamSizeBytes [<Int32>]] [-Description [<String>]] [-LogonAccount [<BELogonAccount>]] [-Disabled [<Boolean>]] [-AllowedConcurrentOperations [<Int32>]] [-Paused [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a deduplication disk storage device in Backup Exec.

Parameters

-LogonAccount <BELogonAccount>

Specifies a Backup Exec logon account associated with this deduplication storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the deduplication disk storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the deduplication disk storage device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the deduplication disk storage device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

Sets the maximum allowed concurrent operations allowed on this device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Specifies the size of a single write operation that Backup Exec issues

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ClientSideDeduplicationEnabled <Boolean>

Enables client-side deduplication for this device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogLevel

Indicates the type of information you want to include in the diagnostic logs for this device.

The valid values are:
Minimal
Low
Normal
High
Full

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LogRetentionDays <Int32>

Specifies the number of days to retail log files.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDeduplicationDiskStorageDevice[]>

Specifies one or more deduplication disk storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

You can pipe a Backup Exec deduplication disk storage device object to Set-BEDeduplicationDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

Set-BEDeduplicationDiskStorageDevice returns an object that represents the changed deduplication disk storage device.

Example

C:\PS> Get-BEDeduplicationDiskStorageDevice "Device 0001" | Set-BEDeduplicationDiskStorageDevice -Paused $true

These commands pause the deduplication disk storage device named "Device 0001".

Related Link

Get-BEDeduplicationDiskStorageDevice


Set-BEDifferentialBackupTask Help

Set-BEDifferentialBackupTask Cmdlet
Synopsis

Modifies differential backups in a backup definition in Backup Exec.

Syntax
Set-BEDifferentialBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-DominoMarkArchiveLogsForRecycling [<Boolean>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-BackupSetDescription [<String>]] [-PreCommand [<String>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-PostCommand [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-Schedule [<BESchedule>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Set-BEDifferentialBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [-Name] [<String[]>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-DominoMarkArchiveLogsForRecycling [<Boolean>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-BackupSetDescription [<String>]] [-PreCommand [<String>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-PostCommand [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-Schedule [<BESchedule>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Modifies differential backups in a backup definition in Backup Exec.

You can modify differential backups in a new backup definition or edit a backup definition. You can also modify differential backups in the backup job defaults.

To modify differential backups in a new backup definition, use Set-BEDifferentialBackupTask and New-BEBackupDefinition.

To modify differential backups in an existing backup definition, use Set-BEDifferentialBackupTask and Get-BEBackupDefinition.

To modify differential backups in the backup job defaults, use Set-BEDifferentialBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

Specifies the type of data compression to use performed by the hardware or software. The Storage parameter must be set to a tape-based storage device.

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Allows backup data to be sent directly to the device specified in the Storage parameter from the Agent for Windows if the device supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

Specifies a command to run before the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

Specifies a command to run after the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Allows Backup Exec to check the return codes of the pre- and post-commands to determine if they completed successfully.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

Runs the backup job only if the pre-command is successful. If the pre-command fails, the job does not run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

Runs the post-command only if the pre-command is successful.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

Runs the post-command regardless of whether the job is successful or not.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

Runs the post-command after the verification completes if you selected to verify the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

Designates the number of minutes Backup Exec should wait before canceling a pre- or post-command that did not complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

Determines the location where the pre- and post-command run.

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

Runs a verify operation automatically when the backup job completes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

Specifies the type of consistency check to perform before the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

Specifies the type of consistency check to use after the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

For SQL 2005 or later, adds checksums to the SQL database data being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

Creates an on-disk copy of the SQL database being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

Specifies the path for the on-disk copy of the SQL database being backed up. CreateDiskCopy must be set to $true.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

For SQL 2008 or later, specifies the compression setting you want to use.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

Lets you delete the archived log files automatically after the backup.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

Enables Backup Exec to skip any archived logfiles that were already backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

Enables Backup Exec to take the database offline before you start the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DominoMarkArchiveLogsForRecycling <Boolean>

Reuses the transaction log after it has been backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more differential backup jobs to modify by differential backup job name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Set-BEDifferentialBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Set-BEDifferentialBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEDifferentialBackupTask -Name "Differential 2" -Storage "Any disk storage" | Save-BEBackupDefinition

These commands set the storage of the differential backup named "Differential 2" in the backup definition named "Backup Definition 01" to the "Any disk storage" pool.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEDifferentialBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

These commands set the storage of all the differential backups in the backup definition named "Backup Definition 01" to the "Any disk storage" pool.

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Set-BEDifferentialBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupJobDefault

These commands set the storage of all the differential backups in the back up to disk job defaults to the "Any disk storage" pool.

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule


Set-BEDiskCartridgeDevice Help

Set-BEDiskCartridgeDevice Cmdlet
Synopsis

Sets the properties for a disk cartridge device in Backup Exec.

Syntax
Set-BEDiskCartridgeDevice -InputObject [<BEDiskCartridgeDevice[]>] [[-BackupExecServer] [<BEBackupExecServer>]] [-BlockSizeBytes [<Int32>]] [-BlockAndBufferSizeAutoDetectEnabled [<Boolean>]] [-BufferedReadsWritesAutoDetectEnabled [<Boolean>]] [-BufferSizeBytes [<Int32>]] [-Disabled [<Boolean>]] [-Description [<String>]] [-PreallocationIncrementBytes [<Int64>]] [-PreallocationEnabled [<Boolean>]] [-MaximumFileSizeBytes [<Int64>]] [-Paused [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a disk cartridge device in Backup Exec.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device is attached to in a CASO environment.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the disk cartridge device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the disk cartridge device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the disk cartridge device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

Specifies the maximum file size on the disk storage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

Enables proallocation to occur.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

Specifies the size of preallocating space to increment at a time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockAndBufferSizeAutoDetectEnabled <Boolean>

Specifies if Backup Exec automatically detects the preferred settings for the block and buffer size for the disk storage.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

Specifies the size in bytes of blocks of data that can be written to new media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

Specifies the amount of data sent to the disk cartridge on each read or write request.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

Specifies that you do not want Backup Exec to automatically detect settings for this disk and enables buffered reads and writes. Buffered reads and writes is the reading and writing of large blocks of data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDiskCartridgeDevice[]>

Specifies one or more disk cartridge device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Set-BEDiskCartridgeDevice.

Return Value
BackupExec.Management.CLI.BEDiskCartridgeDevice

Set-BEDiskCartridgeDevice returns an object that represents the changed disk cartridge device.

Example

C:\PS> Get-BEDiskCartridgeDevice "Device 0001" | Set-BEDiskCartridgeDevice -Paused $true

These commands pause the disk cartridge device named "Device 0001".

Related Link

Get-BEDiskCartridgeDevice


Set-BEDiskStorageDevice Help

Set-BEDiskStorageDevice Cmdlet
Synopsis

Sets the properties for a disk storage device in Backup Exec.

Syntax
Set-BEDiskStorageDevice -InputObject [<BEDiskStorageDevice[]>] [[-BackupExecServer] [<BEBackupExecServer>]] [-BufferSizeBytes [<Int32>]] [-DiskSpaceReserveBytes [<Int64>]] [-BlockSizeBytes [<Int32>]] [-VirtualWriteProtectionEnabled [<Boolean>]] [-BufferedReadsWritesAutoDetectEnabled [<Boolean>]] [-BlockAndBufferSizeAutoDetectEnabled [<Boolean>]] [-AllowedConcurrentWriteOperations [<UInt32>]] [-Disabled [<Boolean>]] [-Paused [<Boolean>]] [-PreallocationIncrementBytes [<Int64>]] [-Description [<String>]] [-LowDiskSpaceInformationThresholdPercent [<Int32>]] [-MaximumFileSizeBytes [<Int64>]] [-PreallocationEnabled [<Boolean>]] [-LowDiskSpaceWarningThresholdPercent [<Int32>]] [-LowDiskSpaceCriticalThresholdPercent [<Int32>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a disk storage device in Backup Exec.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device is attached to in a CASO environment.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the disk storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the disk storage device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the disk storage device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceInformationThresholdPercent <Int32>

Specifies the first threshold limit for initial low disk space alert.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceWarningThresholdPercent <Int32>

Specifies the second threshold limit for second low disk space alert.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceCriticalThresholdPercent <Int32>

Specifies the third and final threshold limit for initial low disk space alert, you are prompted immediately to create more disk space.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

Specifies the maximum file size on the disk storage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

Enables proallocation to occur.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

Specifies the size of preallocating space to increment at a time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

Specifies the size in bytes of blocks of data that can be written to new media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

Specifies the amount of data sent to the disk cartridge on each read or write request.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Specifies the amount of disk space to set aside for applications other than Backup Exec.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualWriteProtectionEnabled <Boolean>

Enables virtual write protection.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockAndBufferSizeAutoDetectEnabled <Boolean>

Specifies if Backup Exec automatically detects the preferred settings for the block and buffer size for the disk storage.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentWriteOperations <UInt32>

Allows concurrent write operations to disk.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

Specifies that you do not want Backup Exec to automatically detect settings for this disk, and that you want this disk storage to allow buffered reads and writes, which is the reading and writing of large blocks of data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEDiskStorageDevice[]>

Specifies one or more disk storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEDiskStorageDevice

You can pipe a Backup Exec disk storage device object to Set-BEDiskStorageDevice.

Return Value
BackupExec.Management.CLI.BEDiskStorageDevice

Set-BEDiskStorageDevice returns an object that represents the changed disk storage device.

Example

C:\PS> Get-BEDiskStorageDevice "Device 0001" | Set-BEDiskStorageDevice -Paused $true

These commands pause the disk storage device named "Device 0001".

Related Link

Get-BEDiskStorageDevice


Set-BEDuplicateStageBackupTask Help

Set-BEDuplicateStageBackupTask Cmdlet
Synopsis

Modifies duplicate stages in a backup definition in Backup Exec.

Syntax
Set-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] [-VerifyAsPartOfJob [<Boolean>]] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-EncryptionKey [<BEEncryptionKey>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMedia [<Boolean>]] [-Storage [<BEStorage>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-DiskStorageKeepForHours [<Int32>]] [-SubmitOnHold [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Set-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [-SourceBackup] {AllBackups | MostRecentFullBackup | SpecificSourceBackups} [-Name] [<String[]>] [[-SpecificSourceBackup] [<String[]>]] -Schedule [<BESchedule>] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-BackupSetDescription [<String>]] [-SubmitOnHold [<Boolean>]] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageMediaSet [<BEMediaSet>]] [-TapeStorageExportMedia [<Boolean>]] [-Storage [<BEStorage>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Set-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] -ImmediatelyAfterBackup [<String>] [-VerifyAsPartOfJob [<Boolean>]] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-EncryptionKey [<BEEncryptionKey>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-SubmitOnHold [<Boolean>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Set-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] -ImmediatelyAfterDuplicate [<String>] [-VerifyAsPartOfJob [<Boolean>]] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-EncryptionKey [<BEEncryptionKey>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-SubmitOnHold [<Boolean>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Set-BEDuplicateStageBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] -SourceDuplicate [<String>] -Schedule [<BESchedule>] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-VerifyAsPartOfJob [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-SubmitOnHold [<Boolean>]] [-BackupSetDescription [<String>]] [-TapeStorageEnabledHardwareCompression [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-TapeStorageMediaSet [<BEMediaSet>]] [-TapeStorageExportMedia [<Boolean>]] [-Storage [<BEStorage>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Modifies duplicate stages in a backup definition in Backup Exec.

You can modify duplicate stages in a new backup definition or edit a backup definition.

To modify duplicate stages in a new backup definition, use Set-BEDuplicateStageBackupTask and New-BEBackupDefinition.

To modify duplicate stages in an existing backup definition, use Set-BEDuplicateStageBackupTask and Get-BEBackupDefinition.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SourceBackup

Specifies the source backup in the backup definition to duplicate.

The valid values are:
AllBackups
MostRecentFullBackup
SpecificSourceBackups

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-SpecificSourceBackup <String[]>

Specifies one or more backup jobs in the backup definition to duplicate by name (string). To specify multiple names, use commas to separate the names. The Source parameter must be set to SpecificBackups.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterBackup <String>

Specifies the name of the backup job in the backup definition to duplicate.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterDuplicate <String>

Specifies the name of a duplicate backup job in the backup definition to duplicate.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SourceDuplicate <String>

Specifies the name of the duplicate backup job in the backup definition to duplicate.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

Runs a verify operation automatically when the backup job completes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnabledHardwareCompression <Boolean>

Enables hardware compression. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more duplicate stages to modify by duplicate stage name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Set-BEDuplicateStageBackupTask.

Return Value
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEDuplicateStageBackupTask -Name "Duplicate 2" -Storage "Any disk storage" | Save-BEBackupDefinition

These commands set the storage of the duplicate stage named "Duplicate 2" in the backup definition named "Backup Definition 01" to the "Any disk storage" pool.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEDuplicateStageBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

These commands set the storage of all the duplicate stages in the backup definition named "Backup Definition 01" to the "Any disk storage" pool.

Related Links


Set-BEErrorHandlingRule Help

Set-BEErrorHandlingRule Cmdlet
Synopsis

Sets the properties for a Backup Exec error-handling rule.

Syntax
Set-BEErrorHandlingRule -InputObject [<BEErrorHandlingRule[]>] [-Note [<String>]] [-RetryIntervalMinutes [<Int32>]] [-Enabled [<Boolean>]] [-RetryJobEnabled [<Boolean>]] [-MaximumRetries [<Int32>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec error-handling rule.

Parameters

-Enabled <Boolean>

Enables the error-handling rule.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RetryJobEnabled <Boolean>

Allows Backup Exec to retry the job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumRetries <Int32>

Specifies the number of times you want the job retried.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RetryIntervalMinutes <Int32>

Specifies the number of minutes to wait before the job is retried.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Note <String>

Shows any miscellaneous information for the error-handling rule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEErrorHandlingRule[]>

Specifies one or more error handling rule objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEErrorHandlingRule

You can pipe a Backup Exec error-handling rule object to Set-BEErrorHandlingRule.

Return Value
BackupExec.Management.CLI.BEErrorHandlingRule

Set-BEErrorHandlingRule returns an object that represents the changed Backup Exec error-handling rule.

Example

C:\PS> Get-BEErrorHandlingRule "Job Cancellation" | Set-BEErrorHandlingRule -Enabled $true

These commands enable the error-handling rule named "Job Cancellation".

Related Link

Get-BEErrorHandlingRule


Set-BEFullBackupTask Help

Set-BEFullBackupTask Cmdlet
Synopsis

Modifies full backups in a backup definition in Backup Exec.

Syntax
Set-BEFullBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-OraclePerformBackupOffline [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-Storage [<BEStorage>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-TapeStorageExportMedia [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PreCommand [<String>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-PostCommand [<String>]] [-Schedule [<BESchedule>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Force [<SwitchParameter>]] [<CommonParameters>]

Set-BEFullBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [-Name] [<String[]>] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-VerifyAsPartOfJob [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-OraclePerformBackupOffline [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-PreCommand [<String>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-PostCommand [<String>]] [-Schedule [<BESchedule>]] [-BackupSetDescription [<String>]] [-KeepJobQueuedFor [<TimeSpan>]] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Modifies full backups in a backup definition in Backup Exec.

You can modify full backups in a new backup definition or edit a backup definition. You can also modify full backups in the backup job defaults.

To modify full backups in a new backup definition, use Set-BEFullBackupTask and New-BEBackupDefinition.

To modify full backups in an existing backup definition, use Set-BEFullBackupTask and Get-BEBackupDefinition.

To modify full backups in the backup job defaults, use Set-BEFullBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

Specifies the type of data compression to use performed by the hardware or software. The Storage parameter must be set to a tape-based storage device.

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Allows backup data to be sent directly to the device specified in the Storage parameter from the Agent for Windows if the device supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

Specifies a command to run before the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

Specifies a command to run after the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Allows Backup Exec to check the return codes of the pre- and post-commands to determine if they completed successfully.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

Runs the backup job only if the pre-command is successful. If the pre-command fails, the job does not run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

Runs the post-command only if the pre-command is successful.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

Runs the post-command regardless of whether the job is successful or not.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

Runs the post-command after the verification completes if you selected to verify the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

Designates the number of minutes Backup Exec should wait before canceling a pre- or post-command that did not complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

Determines the location where the pre- and post-command run.

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

Runs a verify operation automatically when the backup job completes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

Specifies the type of consistency check to perform before the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

Specifies the type of consistency check to use after the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

For SQL 2005 or later, adds checksums to the SQL database data being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

Creates an on-disk copy of the SQL database being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

Specifies the path for the on-disk copy of the SQL database being backed up. CreateDiskCopy must be set to $true.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

For SQL 2008 or later, specifies the compression setting you want to use.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

Lets you delete the archived log files automatically after the backup.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

Enables Backup Exec to skip any archived logfiles that were already backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

Enables Backup Exec to take the database offline before you start the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

Backs up the selected data, verifies the media, and then deletes the data from the volume. Since the operation deletes the files and you must perform a restore to get the data back, you must specify the Force parameter when enabling this option.

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more full backup jobs to modify by full backup job name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-Force <SwitchParameter>

Confirms that the DeleteSelectedFilesAfterSuccessfulBackup parameter results in a loss of data and want to continue to use it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Set-BEFullBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Set-BEFullBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEFullBackupTask -Name "Full 2" -Storage "Any disk storage" | Save-BEBackupDefinition

These commands set the storage of the full backup named "Full 2" in the backup definition named "Backup Definition 01" to the "Any disk storage" pool.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEFullBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

These commands set the storage of all the full backups in the backup definition named "Backup Definition 01" to the "Any disk storage" pool.

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Set-BEFullBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupJobDefault

These commands set the storage of all the full backups in the backup-to-disk job defaults to the "Any disk storage" pool.

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule


Set-BEIncrementalBackupTask Help

Set-BEIncrementalBackupTask Cmdlet
Synopsis

Modifies incremental backups in a backup definition in Backup Exec.

Syntax
Set-BEIncrementalBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] [-EncryptionKey [<BEEncryptionKey>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-VerifyAsPartOfJob [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlIncrementalBackupMethod {Log | Differential}] [-OraclePerformBackupOffline [<Boolean>]] [-DominoMarkArchiveLogsForRecycling [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-BackupSetDescription [<String>]] [-PreCommand [<String>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-PostCommand [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-Schedule [<BESchedule>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Set-BEIncrementalBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [-Name] [<String[]>] [-EncryptionKey [<BEEncryptionKey>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-VerifyAsPartOfJob [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlIncrementalBackupMethod {Log | Differential}] [-OraclePerformBackupOffline [<Boolean>]] [-DominoMarkArchiveLogsForRecycling [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-DiskStorageKeepForHours [<Int32>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-Storage [<BEStorage>]] [-TapeStorageExportMedia [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-BackupSetDescription [<String>]] [-PreCommand [<String>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-PostCommand [<String>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-KeepJobQueuedFor [<TimeSpan>]] [-Schedule [<BESchedule>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Modifies existing incremental backups in a backup definition in Backup Exec.

You can modify incremental backups in a new backup definition or a edit a backup definition. You can also modify incremental backups in the backup job defaults.

To modify incremental backups in a new backup definition, use Set-BEIncrementalBackupTask and New-BEBackupDefinition.

To modify incremental backups in an existing backup definition, use Set-BEIncrementalBackupTask and Get-BEBackupDefinition.

To modify incremental backups in the backup job defaults, use Set-BEIncrementalBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

Specifies the type of data compression to use performed by the hardware or software. The Storage parameter must be set to a tape-based storage device.

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Allows backup data to be sent directly to the device specified in the Storage parameter from the Agent for Windows if the device supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

Specifies a command to run before the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

Specifies a command to run after the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Allows Backup Exec to check the return codes of the pre- and post-commands to determine if they completed successfully.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

Runs the backup job only if the pre-command is successful. If the pre-command fails, the job does not run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

Runs the post-command only if the pre-command is successful.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

Runs the post-command regardless of whether the job is successful or not.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

Runs the post-command after the verification completes if you selected to verify the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

Designates the number of minutes Backup Exec should wait before canceling a pre- or post-command that did not complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

Determines the location where the pre- and post-command run.

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyAsPartOfJob <Boolean>

Runs a verify operation automatically when the backup job completes.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

Specifies the type of consistency check to perform before the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

Specifies the type of consistency check to use after the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

For SQL 2005 or later, adds checksums to the SQL database data being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

Creates an on-disk copy of the SQL database being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

Specifies the path for the on-disk copy of the SQL database being backed up. CreateDiskCopy must be set to $true.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

For SQL 2008 or later, specifies the compression setting you want to use.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

Lets you delete the archived log files automatically after the backup.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

Enables Backup Exec to skip any archived logfiles that were already backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

Enables Backup Exec to take the database offline before you start the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlIncrementalBackupMethod

Specifies the SQL incremental backup for the backup job.

The valid values are:
Log
Differential

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DominoMarkArchiveLogsForRecycling <Boolean>

Reuses the transaction log after it has been backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies one or more incremental backup jobs to modify by incremental backup job name (wildcards accepted). To specify multiple names, use commas to separate the names.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Set-BEIncrementalBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Set-BEIncrementalBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEIncrementalBackupTask -Name "Incremental 2" -Storage "Any disk storage" | Save-BEBackupDefinition

These commands set the storage of the incremental backup named "Incremental 2" in the backup definition named "Backup Definition 01" to the "Any disk storage" pool.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEIncrementalBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupDefinition

These commands set the storage of all the incremental backups in the backup definition named "Backup Definition 01" to the "Any disk storage" pool.

Example 3
C:\PS> Get-BEBackupJobDefault BackupToDisk | Set-BEIncrementalBackupTask -Name * -Storage "Any disk storage" | Save-BEBackupJobDefault

These commands set the storage of all the incremental backups in the back up to disk job defaults to the "Any disk storage" pool.

Related Links

New-BEBackupDefinition
Get-BEBackupDefinition
Get-BEBackupJobDefault
Save-BEBackupDefinition
Save-BEBackupJobDefault
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
New-BESchedule


Set-BELegacyBackupToDiskFolderDevice Help

Set-BELegacyBackupToDiskFolderDevice Cmdlet
Synopsis

Sets the properties for a legacy backup-to-disk folder device in Backup Exec.

Syntax
Set-BELegacyBackupToDiskFolderDevice -InputObject [<BELegacyBackupToDiskFolderDevice[]>] [[-BackupExecServer] [<BEBackupExecServer>]] [-BufferedReadsAutoDetectEnabled [<Boolean>]] [-BufferedReadsEnabled [<Boolean>]] [-Paused [<Boolean>]] [-Description [<String>]] [-Disabled [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a legacy backup-to-disk folder device in Backup Exec.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device is attached to in a CASO environment.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the legacy backup-to-disk folder device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the legacy backup-to-disk folder device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the legacy backup-to-disk folder device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsAutoDetectEnabled <Boolean>

Specifies if Backup Exec automatically detects the preferred settings for read and write buffers.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsEnabled <Boolean>

Allows the reading of large blocks of data, this option may increase performance.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BELegacyBackupToDiskFolderDevice[]>

Specifies one or more legacy backup-to-disk folder device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

You can pipe a Backup Exec legacy backup-to-disk folder device object to Set-BELegacyBackupToDiskFolderDevice.

Return Value
BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

Set-BELegacyBackupToDiskFolderDevice returns an object that represents the changed legacy backup-to-disk folder device.

Example

C:\PS> Get-BELegacyBackupToDiskFolderDevice "Device 0001" | Set-BELegacyBackupToDiskFolderDevice -Paused $true

These commands pause the legacy backup-to-disk folder device named "Device 0001".

Related Link

Get-BELegacyBackupToDiskFolderDevice


Set-BELogonAccount Help

Set-BELogonAccount Cmdlet
Synopsis

Sets the properties for a Backup Exec logon account.

Syntax
Set-BELogonAccount -InputObject [<BELogonAccount[]>] [-AccountType {Restricted | Common}] [-Description [<String>]] [-CurrentPassword [<SecureString>]] [-UserName [<String>]] [-NewPassword [<SecureString>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Set-BELogonAccount -InputObject [<BELogonAccount[]>] -Credential [<PSCredential>] [-AccountType {Restricted | Common}] [-CurrentPassword [<SecureString>]] [-Description [<String>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec logon account.

If the logon account is a restricted account and you are not the owner of the account, use the -CurrentPassword parameter to modify the logon account.

Parameters

-InputObject <BELogonAccount[]>

Specifies one or more logon account objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-CurrentPassword <SecureString>

Specifies the current password assigned to this account. This must be specified if you are logged in as a user that is not the owner of the logon account, and the logon account is restricted.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Credential <PSCredential>

Specifies the credentials of the logon account.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UserName <String>

Specifies the user name of the logon account.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NewPassword <SecureString>

Specifies the new password of the logon account.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the logon account.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AccountType

Specifies if this is a common or restricted account.

The valid values are:
Restricted
Common

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object to Set-BELogonAccount.

Return Value
BackupExec.Management.CLI.BELogonAccount

Set-BELogonAccount returns an object that represents the changed logon account.

Example

C:\PS> Get-BELogonAccount "LogonAccount 0001" | Set-BELogonAccount -AccountType Common

These commands change the logon account named "LogonAccount 0001" to a common logon account.

Related Link

Get-BELogonAccount


Set-BEMedia Help

Set-BEMedia Cmdlet
Synopsis

Sets the properties for a media in Backup Exec.

Syntax
Set-BEMedia -InputObject [<BEMedia[]>] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a media in Backup Exec.

Parameters

-Description <String>

Specifies the description for the media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMedia[]>

Specifies one or more media objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to Set-BEMedia.

Return Value
BackupExec.Management.CLI.BEMedia

Set-BEMedia returns an object that represents the changed media.

Example

C:\PS> Get-BEMedia "Media 0001" | Set-BEMedia -Description "Test Media"

These commands add the description "Test Media" to a media named "Media 0001".

Related Link

Get-BEMedia


Set-BEMediaSet Help

Set-BEMediaSet Cmdlet
Synopsis

Sets the properties for a media set in Backup Exec.

Syntax
Set-BEMediaSet -InputObject [<BEMediaSet[]>] [-ReturnFromVaultPeriodHours [<Int32>]] [-MoveToVaultPeriodHours [<Int32>]] [-OverwriteProtectionPeriodHours [<Int32>]] [-Description [<String>]] [-MediaVault [<BEMediaVault>]] [-AppendPeriodHours [<Int32>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a media set in Backup Exec.

Parameters

-Description <String>

Specifies the description for the media set.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteProtectionPeriodHours <Int32>

Specifies the length of time that data is retained on a specific media before being overwritten.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AppendPeriodHours <Int32>

Specifies the length of time that data can be added to the media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaVault <BEMediaVault>

Specifies the Backup Exec media vault you want to send media that are associated with this media set.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MoveToVaultPeriodHours <Int32>

Specifies the time period after which this media will be reported as ready to be moved to this vault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReturnFromVaultPeriodHours <Int32>

Specifies the time period after which this media will be reported as ready to be returned from this vault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaSet[]>

Specifies one or more media set objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaSet

You can pipe a Backup Exec media set object to Set-BEMediaSet.

Return Value
BackupExec.Management.CLI.BEMediaSet

Set-BEMediaSet returns an object that represents the changed media set.

Example

C:\PS> Get-BEMediaSet "Media Set 0001" | Set-BEMediaSet -Description "Test Media Set"

These commands add the description "Test Media Set" to a media set named "Media Set 0001".

Related Link

Get-BEMediaSet


Set-BEMediaType Help

Set-BEMediaType Cmdlet
Synopsis

Sets the properties for a Backup Exec media type.

Syntax
Set-BEMediaType -InputObject [<BEMediaType[]>] [-MediaLabelDigits [<UInt32>]] [-MediaLabelPrefix [<String>]] [-MediaLabelNextValue [<UInt32>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec media type.

Parameters

-MediaLabelPrefix <String>

Specifies the media label prefix for the media type.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaLabelNextValue <UInt32>

Specifies the next number that will be included in the label of the next media that matches the media type when that media is entered for the first time into this installation of Backup Exec.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaLabelDigits <UInt32>

Specifies the minimum size of the numeric portion of the media label for the media type.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaType[]>

Specifies one or more media type objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaType

You can pipe a Backup Exec media type object to Set-BEMediaType.

Return Value
BackupExec.Management.CLI.BEMediaType

Set-BEMediaType returns an object that represents the changed Backup Exec media type.

Example

C:\PS> Get-BEMediaType LTO | Set-BEMediaType -MediaLabelPrefix WORM

These commands change the media label prefix of the LTO media type to "WORM".

Related Link

Get-BEMediaType


Set-BEMediaVault Help

Set-BEMediaVault Cmdlet
Synopsis

Sets the properties for a media vault in Backup Exec.

Syntax
Set-BEMediaVault -InputObject [<BEMediaVault[]>] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a media vault in Backup Exec.

Parameters

-Description <String>

Specifies the description for the media vault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEMediaVault[]>

Specifies one or more media vault objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEMediaVault

You can pipe a Backup Exec media vault object to Set-BEMediaVault.

Return Value
BackupExec.Management.CLI.BEMediaVault

Set-BEMediaVault returns an object that represents the changed media vault.

Example

C:\PS> Get-BEMediaVault "Media Vault 0001" | Set-BEMediaVault -Description "Test Media Vault"

These commands set the description of a media vault named "Media Vault 0001" to "Test Media Vault".

Related Link

Get-BEMediaVault


Set-BEOpenStorageDevice Help

Set-BEOpenStorageDevice Cmdlet
Synopsis

Sets the properties for a Backup Exec OpenStorage device.

Syntax
Set-BEOpenStorageDevice -InputObject [<BEOpenStorageDevice[]>] [-IsStreamHandlerSupportEnabled [<Boolean>]] [-DataStreamSizeBytes [<Int32>]] [-DiskSpaceReserveBytes [<Int64>]] [-SplitDataStreamBytes [<Int64>]] [-Description [<String>]] [-LogonAccount [<BELogonAccount>]] [-Disabled [<Boolean>]] [-AllowedConcurrentOperations [<Int32>]] [-Paused [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec OpenStorage device.

Parameters

-LogonAccount <BELogonAccount>

Specifies a Backup Exec logon account for the new OpenStorage device. The logon account cannot be the System Logon Account.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the OpenStorage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the OpenStorage device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the OpenStorage device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentOperations <Int32>

Sets the maximum allowed concurrent write operations allowed on this device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SplitDataStreamBytes <Int64>

Specifies the size at which you want Backup Exec to span to a new image.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DataStreamSizeBytes <Int32>

Indicates the size of a single write operation that Backup Exec issues.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-IsStreamHandlerSupportEnabled <Boolean>

Specifies if stream handler is used.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Specifies the amount of disk space to set aside for applications other than Backup Exec.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEOpenStorageDevice[]>

Specifies one or more OpenStorage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEOpenStorageDevice

You can pipe a Backup Exec OpenStorage device object to Set-BEOpenStorageDevice.

Return Value
BackupExec.Management.CLI.BEOpenStorageDevice

Set-BEOpenStorageDevice returns an object that represents the changed Backup Exec OpenStorage device.

Example

C:\PS> Get-BEOpenStorageDevice "Device 0001" | Set-BEOpenStorageDevice -Paused $true

These commands pause the OpenStorage device named "Device 0001".

Related Link

Get-BEOpenStorageDevice


Set-BERoboticLibraryDevice Help

Set-BERoboticLibraryDevice Cmdlet
Synopsis

Sets the properties for a robotic library device in Backup Exec.

Syntax
Set-BERoboticLibraryDevice -InputObject [<BERoboticLibraryDevice[]>] [-SlotsNumbersAreZeroBased [<Boolean>]] [-BarcodeRulesEnabled [<Boolean>]] [-StartupInitializationEnabled [<Boolean>]] [-Description [<String>]] [-SlotsPerPartition [<Int32[]>]] [-Paused [<Boolean>]] [-Disabled [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a robotic library device in Backup Exec.

Parameters

-SlotsPerPartition <Int32[]>

Specifies the number of slots per partition. You cannot exceed the total number of slots specified in the robotic library device. To get the robotic library partitions that are created as a result, use Get-BERobiticLibraryPartition.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the robotic library device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the robotic library device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the robotic library device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartupInitializationEnabled <Boolean>

Enables initialization for the robotic library when Backup Exec service starts.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BarcodeRulesEnabled <Boolean>

Enables barcode rules.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SlotsNumbersAreZeroBased <Boolean>

Specifies if the slot numbers start at 0 or 1.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibraryDevice[]>

Specifies one or more robotic library device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Set-BERoboticLibraryDevice.

Return Value
BackupExec.Management.CLI.BERoboticLibraryDevice

Set-BERoboticLibraryDevice returns an object that represents the changed robotic library device.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Set-BERoboticLibraryDevice -Paused $true

These commands pause the robotic library device named "Device 0001".

Related Link

Get-BERoboticLibraryDevice


Set-BERoboticLibrarySlot Help

Set-BERoboticLibrarySlot Cmdlet
Synopsis

Sets the properties for a Backup Exec robotic library slot.

Syntax
Set-BERoboticLibrarySlot -InputObject [<BERoboticLibrarySlot[]>] [-IsCleaningSlot [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a Backup Exec robotic library slot.

Parameters

-IsCleaningSlot <Boolean>

Designates the slot as a cleaning slot.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BERoboticLibrarySlot[]>

Specifies one or more robotic library slot objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Set-BERoboticLibrarySlot.

Return Value
BackupExec.Management.CLI.BERoboticLibrarySlot

Set-BERoboticLibrarySlot returns an object that represents the changed Backup Exec robotic library slot.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 01" | Get-BERoboticLibrarySlot -SlotNumber 1 | Set-BERoboticLibrarySlot -IsCleaningSlot $true

These commands designate the first slot of a robotic libaray device named "Device 01" as a cleaning slot.

Related Links


Set-BEStorageArrayDevice Help

Set-BEStorageArrayDevice Cmdlet
Synopsis

Sets the properties for a storage array in Backup Exec.

Syntax
Set-BEStorageArrayDevice -InputObject [<BEStorageArrayDevice[]>] [-Paused [<Boolean>]] [-Description [<String>]] [-Disabled [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a storage array in Backup Exec.

Parameters

-Description <String>

Specifies the description for the storage array.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the storage array device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the storage array device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageArrayDevice[]>

Specifies one or more storage arrays. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

You can pipe a Backup Exec storage array object to Set-BEStorageArrayDevice.

Return Value
BackupExec.Management.CLI.BEStorageArrayDevice

Set-BEStorageArrayDevice returns an object that represents the changed storage array.

Example

C:\PS> Get-BEStorageArrayDevice "Device 0001" | Set-BEStorageArrayDevice -Paused $true

These commands pause the storage array named "Device 0001".

Related Link

Get-BEStorageArrayDevice


Set-BEStorageDevice Help

Set-BEStorageDevice Cmdlet
Synopsis

Sets the properties for a storage device in Backup Exec.

Syntax
Set-BEStorageDevice -InputObject [<BEStorageDevice[]>] [-Paused [<Boolean>]] [-Description [<String>]] [-Disabled [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a storage device in Backup Exec.

Parameters

-Description <String>

Specifies the description for the storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the storage device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the storage device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageDevice[]>

Specifies one or more storage device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageDevice

You can pipe a Backup Exec storage device object to Set-BEStorageDevice.

Return Value
BackupExec.Management.CLI.BEStorageDevice

Set-BEStorageDevice returns an object that represents the changed storage device.

Example

C:\PS> Get-BEStorageDevice "Device 0001" | Set-BEStorageDevice -Paused $true

These commands pause the storage device named "Device 0001".

Related Link

Get-BEStorageDevice


Set-BEStorageDevicePool Help

Set-BEStorageDevicePool Cmdlet
Synopsis

Sets the properties for a storage device pool in Backup Exec.

Syntax
Set-BEStorageDevicePool -InputObject [<BEStorageDevicePool[]>] [-Description [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a storage device pool in Backup Exec.

Parameters

-Description <String>

Specifies the description for the storage device pool.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEStorageDevicePool[]>

Specifies one or more storage device pool objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageDevicePool

You can pipe a Backup Exec storage device pool object to Set-BEStorageDevicePool.

Return Value
BackupExec.Management.CLI.BEStorageDevicePool

Set-BEStorageDevicePool returns an object that represents the changed storage device pool.

Example

C:\PS> Get-BEStorageDevicePool -Name "Storage Pool 0001" | Set-BEStorageDevicePool -Description "Test Pool"

These commands change the description of a storage pool named "Storage Pool 0001" to "Test Pool".

Related Link

Get-BEStorageDevicePool


Set-BETapeDriveDevice Help

Set-BETapeDriveDevice Cmdlet
Synopsis

Sets the properties for a tape drive device in Backup Exec.

Syntax
Set-BETapeDriveDevice -InputObject [<BETapeDriveDevice[]>] [-ReadSingleBlockModeEnabled [<Boolean>]] [-WriteSingleBlockModeEnabled [<Boolean>]] [-BufferCount [<Int32>]] [-HighWaterCount [<Int32>]] [-ReadScsiPassThruModeEnabled [<Boolean>]] [-WriteScsiPassThruModeEnabled [<Boolean>]] [-Description [<String>]] [-Disabled [<Boolean>]] [-ReadableMediaType [<BEMediaType[]>]] [-WritableMediaType [<BEMediaType[]>]] [-BlockSizeBytes [<Int32>]] [-BufferSizeBytes [<Int32>]] [-Paused [<Boolean>]] [-CompressionEnabled [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a tape drive device in Backup Exec.

Parameters

-ReadableMediaType <BEMediaType[]>

Specifies the readable media type.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WritableMediaType <BEMediaType[]>

Specifies the writeable media type.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the tape drive device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the tape drive device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the tape drive device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CompressionEnabled <Boolean>

Enables compression on this device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

Specifies the size in bytes of blocks of data that can be written to new media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

Specifies the amount of data sent to the disk cartridge on each read or write request.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferCount <Int32>

Specifies the number of buffers allocated for this tape device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HighWaterCount <Int32>

Specifies the number of buffers to be filled before data is first sent to the tape drive, and any time after that if the tape drive under runs.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReadSingleBlockModeEnabled <Boolean>

Specifies if this tape drive reads only one block of data at a time, regardless of the size of the buffer block.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WriteSingleBlockModeEnabled <Boolean>

Specifies if this tape drive writes only one block of data at a time. This parameter provides greater control over the handling of data write errors.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReadScsiPassThruModeEnabled <Boolean>

Specifies if this tape drive reads data without going through a Microsoft tape device API. This parameter allows the data to pass directly through the tape drive and allows more detailed information if device errors occur.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WriteScsiPassThruModeEnabled <Boolean>

Specifies if this tape drive writes data without going through the Microsoft tape device API. This parameter allows data to pass directly through the device driver and allows more detailed information if device errors occur.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BETapeDriveDevice[]>

Specifies one or more tape drive device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Set-BETapeDriveDevice.

Return Value
BackupExec.Management.CLI.BETapeDriveDevice

Set-BETapeDriveDevice returns an object that represents the changed tape drive device.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Set-BETapeDriveDevice -Paused $true

These commands pause the tape drive device named "Device 0001".

Related Link

Get-BETapeDriveDevice


Set-BETraceSource Help

Set-BETraceSource Cmdlet
Synopsis

Configures, starts, and stops a trace of BEMCLI components.

Syntax
Set-BETraceSource [[-FilePath] [<String>]] [[-Level] {Off | Critical | Error | Warning | Information | Verbose | ActivityTracing | All}] [-Debugger [<SwitchParameter>]] [-PSHost [<SwitchParameter>]] [-ListenerOptions {None | LogicalOperationStack | DateTime | Timestamp | ProcessId | ThreadId | Callstack}] [-Force [<SwitchParameter>]] [<CommonParameters>]

Set-BETraceSource [-RemoveFilePath [<String>]] [-RemoveDebugger [<SwitchParameter>]] [-RemovePSHost [<SwitchParameter>]] [<CommonParameters>]
Description

Configures, starts, and stops a trace of BEMCLI components.

Parameters

-Level

Specifies the type of events that you want to trace.

The valid values are:
Off
Critical
Error
Warning
Information
Verbose
ActivityTracing
All

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-ListenerOptions

Adds optional data to the prefix of each trace message in the output. To specify multiple options, separate them with commas, but with no spaces, and enclose them in quotation marks, such as "ProcessID,ThreadID".

The valid values are:
None
LogicalOperationStack
DateTime
Timestamp
ProcessId
ThreadId
Callstack

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FilePath <String>

Sends the trace output to the specified file. This parameter also selects the file trace listener. If you use this parameter to start the trace, use the RemoveFilePath parameter to stop the trace.

Required | false
Position | 1
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | false

-PSHost <SwitchParameter>

Sends the trace output to the Windows PowerShell host. This parameter also selects the PSHost trace listener. If you use this parameter to start the trace, use the RemovePSHost parameter to stop the trace.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Debugger <SwitchParameter>

Sends the trace output to the debugger. You can view the output in any user-mode or kernel mode debugger or in Microsoft Visual Studio. This parameter also selects the default trace listener. If you use this parameter to start the trace, use the RemoveDebugger parameter to stop the trace.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemovePSHost <SwitchParameter>

Stops the trace by removing the PSHost trace listener.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoveDebugger <SwitchParameter>

Stops the trace by removing the debugger trace listener.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoveFilePath <String>

Stops the trace by removing the file trace listener associated with the specified file. Enter the path and file name of the trace output file.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Force <SwitchParameter>

Allows the cmdlet to overwrite a read-only file. Use with the FilePath parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe a string to Set-BETraceSource to enable the file trace listener.

Return Value
None

This cmdlet does not generate any output.

Examples

Example 1

C:\PS> Set-BETraceSource -Level Information -PSHost

This command starts BEMCLI tracing for information level events and logs them to the Windows PowerShell host.

Example 2
C:\PS> Set-BETraceSource -RemovePSHost

This command stops tracing BEMCLI events to the Windows PowerShell host.


Set-BEUserDefaultLogonAccount Help

Set-BEUserDefaultLogonAccount Cmdlet
Synopsis

Sets the default Backup Exec logon account for the current user.

Syntax
Set-BEUserDefaultLogonAccount -LogonAccount [<BELogonAccount>] [[-CurrentPassword] [<SecureString>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the default Backup Exec logon account for the current user.

Parameters

-LogonAccount <BELogonAccount>

Specifies the Backup Exec logon account.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-CurrentPassword <SecureString>

Specifies the current password assigned to this account. This must be specified if you are logged in as a user that is not the owner of the logon account, and the logon account is restricted.

Required | false
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object to Set-BEUserDefaultLogonAccount.

Return Value
BackupExec.Management.CLI.BELogonAccount

Set-BEUserDefaultLogonAccount returns an object that represents the changed logon account.

Example

C:\PS> Get-BELogonAccount "LogonAccount 0001" | Set-BEUserDefaultLogonAccount

These commands make the logon account named "LogonAccount 0001" the default logon account for the current user.

Related Link

Get-BELogonAccount


Set-BEVerifyBackupTask Help

Set-BEVerifyBackupTask Cmdlet
Synopsis

Modifies verify tasks in a backup definition in Backup Exec.

Syntax
Set-BEVerifyBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] [-VerifyDataOnClient [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] -SourceBackup [<String[]>] -Schedule [<BESchedule>] [-VerifyDataOnClient [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupDefinition [<BEBackupDefinition>] [-Name] [<String[]>] -ImmediatelyAfterBackup [<String>] [-VerifyDataOnClient [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [-Name] [<String[]>] [-VerifyDataOnClient [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [-Name] [<String[]>] -SourceBackup [<String[]>] -Schedule [<BESchedule>] [-VerifyDataOnClient [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Set-BEVerifyBackupTask -BackupJobDefault [<BEBackupJobDefaults>] [-Name] [<String[]>] -ImmediatelyAfterBackup [<String>] [-VerifyDataOnClient [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Modifies verify tasks in a backup definition in Backup Exec.

You can modify verify tasks in a new backup definition or edit an existing backup definition. You can also modify verify tasks in the backup job defaults.

To modify verify tasks in a new backup definition, use Set-BEVerifyBackupTask and New-BEBackupDefinition.

To modify verify tasks in an existing backup definition, use Set-BEVerifyBackupTask and Get-BEBackupDefinition.

To modify verify tasks in the backup job defaults, use Set-BEVerifyBackupTask and Get-BEBackupJobDefault.

When you create or edit a backup definition, the backup definition must be passed to Save-BEBackupDefinition to commit the changes.

When you edit the backup job defaults, the backup job defaults must be passed to Save-BEBackupJobDefault to commit the changes.

Parameters

-BackupDefinition <BEBackupDefinition>

Specifies the backup definition to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupJobDefault <BEBackupJobDefaults>

Specifies the backup job defaults to modify.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-SourceBackup <String[]>

Specifies one or more backups in the backup definition to verify on a scheduled basis.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImmediatelyAfterBackup <String>

Specifies the name of the backup job in the backup definition to verify.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VerifyDataOnClient <Boolean>

Lets you run the verify operation remotely, if the Backup Exec agent supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies the name of the verify task.

Required | true
Position | 0
Accepts pipeline input | false
Accepts wildcard characters | true

-WhatIf <SwitchParameter>

Describes what would happen if you executed the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEBackupDefinition

You can pipe a Backup Exec backup definition object to Set-BEVerifyBackupTask.

BackupExec.Management.CLI.BackupJobDefault

You can pipe a Backup Exec backup job default object to Set-BEVerifyBackupTask.

Return Values
BackupExec.Management.CLI.BEBackupDefinition

The backup definition that has been modified.

BackupExec.Management.CLI.BackupJobDefault

The backup job default that has been modified.

Examples

Example 1

C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEVerifyBackupTask -Name "Verify 2" -VerifyDataOnClient $true | Save-BEBackupDefinition

These commands set the VerifyDataOnClient setting of the verify task named "Verify 2" in the backup definition named "Backup Definition 01" to True.

Example 2
C:\PS> Get-BEBackupDefinition "Backup Definition 01" | Set-BEVerifyBackupTask -Name * -VerifyDataOnClient $true | Save-BEBackupDefinition

These commands set the VerifyDataOnClient setting of all the verify tasks in the backup definition named "Backup Definition 01" to True.

Related Links


Set-BEVirtualDiskDevice Help

Set-BEVirtualDiskDevice Cmdlet
Synopsis

Sets the properties for a virtual disk device in Backup Exec.

Syntax
Set-BEVirtualDiskDevice -InputObject [<BEVirtualDiskDevice[]>] [[-BackupExecServer] [<BEBackupExecServer>]] [-BufferSizeBytes [<Int32>]] [-DiskSpaceReserveBytes [<Int64>]] [-PreallocationIncrementBytes [<Int64>]] [-BlockSizeBytes [<Int32>]] [-BufferedReadsWritesAutoDetectEnabled [<Boolean>]] [-VirtualWriteProtectionEnabled [<Boolean>]] [-AllowedConcurrentWriteOperations [<UInt32>]] [-Disabled [<Boolean>]] [-Paused [<Boolean>]] [-PreallocationEnabled [<Boolean>]] [-Description [<String>]] [-LowDiskSpaceCriticalThresholdPercent [<Int32>]] [-MaximumFileSizeBytes [<Int64>]] [-LowDiskSpaceInformationThresholdPercent [<Int32>]] [-LowDiskSpaceWarningThresholdPercent [<Int32>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Sets the properties for a virtual disk device in Backup Exec.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server the device is attached to in a CASO environment.

Required | false
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-Description <String>

Specifies the description for the virtual disk device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Disabled <Boolean>

Specifies if the virtual disk device is disabled.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Paused <Boolean>

Specifies if the virtual disk device is paused.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceInformationThresholdPercent <Int32>

Species the first threshold limit for initial low disk space alert.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceWarningThresholdPercent <Int32>

Specifies the second threshold limit for second low disk space alert.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LowDiskSpaceCriticalThresholdPercent <Int32>

Specifies the third and final threshold limit for initial low disk space alert, you are prompted immediately to create more disk space.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MaximumFileSizeBytes <Int64>

Specifies the maximum file size on the disk storage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationEnabled <Boolean>

Enables proallocation to occur.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreallocationIncrementBytes <Int64>

Specifies the size of preallocating space to increment at a time.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BlockSizeBytes <Int32>

Specifies the size in bytes of blocks of data that can be written to new media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferSizeBytes <Int32>

Specifies the amount of data sent to the disk cartridge on each read or write request.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskSpaceReserveBytes <Int64>

Specifies the amount of disk space to set aside for applications other than Backup Exec.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualWriteProtectionEnabled <Boolean>

Enables virtual write protection.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowedConcurrentWriteOperations <UInt32>

Allows concurrent write operations to disk.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BufferedReadsWritesAutoDetectEnabled <Boolean>

Specifies that you do not want Backup Exec to automatically detect settings for this disk, and that you want this disk storage to allow buffered reads and writes, which is the reading and writing of large blocks of data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEVirtualDiskDevice[]>

Specifies one or more virtual disk device objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEVirtualDiskDevice

You can pipe a Backup Exec virtual disk device object to Set-BEVirtualDiskDevice.

Return Value
BackupExec.Management.CLI.BEVirtualDiskDevice

Set-BEVirtualDiskDevice returns an object that represents the changed virtual disk device.

Example

C:\PS> Get-BEVirtualDiskDevice "Device 0001" | Set-BEVirtualDiskDevice -Paused $true

These commands pause the virtual disk device named "Device 0001".

Related Link

Get-BEVirtualDiskDevice


Show-BEHelp Help

Show-BEHelp Cmdlet
Synopsis

Launches the BEMCLI help documentation.

Syntax
Show-BEHelp [<CommonParameters>]
Description

Launches the BEMCLI help documentation.

Parameters

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
None

This cmdlet does not accept any input.

Return Value
None

This cmdlet does not generate any output

Example

C:\PS> Show-BEHelp

This command launches the BEMCLI help documentation.


Start-BEJob Help

Start-BEJob Cmdlet
Synopsis

Starts a Backup Exec job.

Syntax
Start-BEJob -InputObject [<BEJob[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Starts a Backup Exec job.

Start-BEJob can start any Backup Exec job, that includes jobs that are on hold or completed.

Parameters

-InputObject <BEJob[]>

Specifies one or more job objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to Start-BEJob.

Return Value
BackupExec.Management.CLI.BEJob

Start-BEJob returns a Backup Exec job object.

Example

C:\PS> Get-BEJob -Name "Job 0001" | Start-BEJob

These commands will start the Backup Exec job named "Job 0001".

Related Link

Get-BEJob


Start-BEService Help

Start-BEService Cmdlet
Synopsis

Start one or more Backup Exec services.

Syntax
Start-BEService [[-Name] [<String[]>]] [-PassThru [<SwitchParameter>]] [-ServiceType {Core | Deduplication}] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Start-BEService -DisplayName [<String[]>] [-ServiceType {Core | Deduplication}] [-PassThru [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Start one or more Backup Exec services.

If you do not pass parameters to Start-BEService, all of the core Backup Exec services are started.

Parameters

-PassThru <SwitchParameter>

Returns an object that represents the service. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies the name of the Backup Exec Service to start.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-DisplayName <String[]>

Specifies the common name of the Backup Exec service to restart.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceType

Specifies type of Backup Exec service to start.

The valid values are:
Core
Deduplication

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe the name of the Backup Exec service to Start-BEService.

Return Value
None or System.ServiceProcess.ServiceController

When you use the PassThru parameter, Start-BEService generates a System.ServiceProcess.ServiceController object representing the service. Otherwise, this cmdlet does not generate any output.

Examples

Example 1

C:\PS> Start-BEService

This command starts all of the Backup Exec core services.

Example 2
C:\PS> Start-BEService -ServiceType Deduplication

This command starts all of the Backup Exec deduplication services.


Stop-BEJob Help

Stop-BEJob Cmdlet
Synopsis

Cancels active Backup Exec jobs.

Syntax
Stop-BEJob -InputObject [<BEJob[]>] [-TimeoutSeconds [<Int32>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Cancels active Backup Exec jobs in progress.

Stop-BEJob returns the job histories associated with the jobs that were canceled.

If you do not specify the -TimeoutSeconds parameter, Stop-BEJob waits indefinitely for the specified jobs to reach a canceled state.

If you specify -TimeoutSeconds parameter and the time is exceeded before the job reaches a canceled state, the command returns even if the job is still running. No error message displays.

Parameters

-TimeoutSeconds <Int32>

Determines the maximum wait time for each job in seconds. If the time is exceeded before the job reaches a canceled state, the command returns even if the job is still running. No error message is displayed.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEJob[]>

Specifies one or more job objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to Stop-BEJob.

Return Value
BackupExec.Management.CLI.BEJobHistory

Stop-BEJob returns a Backup Exec job history object if the -TimeoutSeconds time is not exceeded, otherwise nothing is returned.

Example

C:\PS> Get-BEJob "Job 0001" | Stop-BEJob

These commands cancel a job named "Job 0001".

Related Link

Get-BEJob


Stop-BEService Help

Stop-BEService Cmdlet
Synopsis

Stops one or more Backup Exec services.

Syntax
Stop-BEService [[-Name] [<String[]>]] [-PassThru [<SwitchParameter>]] [-ServiceType {Core | Deduplication}] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Stop-BEService -DisplayName [<String[]>] [-ServiceType {Core | Deduplication}] [-PassThru [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Stops one or more Backup Exec services.

If you do not pass parameters to Stop-BEService, all of the core Backup Exec services are stopped.

Parameters

-PassThru <SwitchParameter>

Returns an object that represents the service. By default, this cmdlet does not generate any output.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String[]>

Specifies the name of the Backup Exec Service to stop.

Required | false
Position | 0
Accepts pipeline input | true (ByValue ByPropertyName)
Accepts wildcard characters | true

-DisplayName <String[]>

Specifies the common name of the Backup Exec service to restart.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ServiceType

Specifies the Backup Exec service to stop.

The valid values are:
Core
Deduplication

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
System.String

You can pipe the name of the Backup Exec service to Stop-BEService.

Return Value
None or System.ServiceProcess.ServiceController

When you use the PassThru parameter, Stop-BEService generates a System.ServiceProcess.ServiceController object representing the service. Otherwise, this cmdlet does not generate any output.

Examples

Example 1

C:\PS> Stop-BEService

This command stops all of the Backup Exec core services.

Example 2
C:\PS> Stop-BEService -ServiceType Deduplication

This command stops all of the Backup Exec deduplication services.


Submit-BECatalogMediaJob Help

Submit-BECatalogMediaJob Cmdlet
Synopsis

Submits a job to perform a catalog of backup sets on media in Backup Exec.

Syntax
Submit-BECatalogMediaJob -DiskCartridgeDevice [<BEDiskCartridgeDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-MediaPassword [<SecureString>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BECatalogMediaJob -TapeDriveDevice [<BETapeDriveDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-MediaPassword [<SecureString>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BECatalogMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot>] [-BackupExecServer [<BEBackupExecServer>]] [-MediaPassword [<SecureString>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BECatalogMediaJob -Media [<BEMedia>] [-BackupExecServer [<BEBackupExecServer>]] [-MediaPassword [<SecureString>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to perform a catalog of backup sets on media in Backup Exec.

If you specify a storage device, the media that you want to catalog must be in the storage device. If you specify media, Backup Exec determines the appropriate device to perform the catalog job.

Parameters

-DiskCartridgeDevice <BEDiskCartridgeDevice>

Specifies the disk cartridge device to catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

Specifies the tape drive device to catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot>

Specifies the robotic library slot to catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Media <BEMedia>

Specifies the media to catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MediaPassword <SecureString>

Specifies the media password if the media is protected by a password.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Submit-BECatalogMediaJob.

BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BECatalogMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BECatalogMediaJob.

BackupExec.Management.CLI.BEMedia

You can pipe a Backup Exec media object to Submit-BECatalogMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BECatalogMediaJob returns the job that was submitted.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BECatalogMediaJob

These commands submit a catalog job that catalogs the media in the tape drive device named "Device 0001".

Related Link

Get-BETapeDriveDevice


Submit-BECleanJob Help

Submit-BECleanJob Cmdlet
Synopsis

Submits a tape drive cleaning job in Backup Exec.

Syntax
Submit-BECleanJob -TapeDriveDevice [<BETapeDriveDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a tape drive cleaning job in Backup Exec.

Parameters

-TapeDriveDevice <BETapeDriveDevice>

Specifies the drive that contains the cleaning tape.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server that process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BECleanJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BECleanJob returns the job that was submitted.

Examples

Example 1

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BECleanJob

These commands submit a cleaning job that cleans the tape drive device named "Device 0001".

Example 2
C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BECleanJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

These commands submit a cleaning job that cleans the tape drive device named "Device 0001" every day at 10pm.

Related Links


Submit-BEConvertBackupToVirtualJob Help

Submit-BEConvertBackupToVirtualJob Cmdlet
Synopsis

Submits a convert to virtual job in Backup Exec.

Syntax
Submit-BEConvertBackupToVirtualJob -AgentServer [<BEAgentServer>] -TargetEnvironment [<BEConvertToVirtualTargetEnvironment>] [-Priority {Normal | Lowest | Low | High | Highest}] [-StartDate [<DateTime>]] [-ExcludeNonSystemData [<SwitchParameter>]] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-SubmitOnHold [<Boolean>]] [-VirtualMachineCpuCount [<UInt32>]] [-NotBefore [<DateTime>]] [-PointInTime [<DateTime>]] [-Name [<String>]] [-VirtualMachinePhysicalRamMB [<UInt32>]] [-OverwriteExistingVirtualMachine [<Boolean>]] [-VirtualMachineName [<String>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEConvertBackupToVirtualJob -JobHistory [<BEJobHistory>] -TargetEnvironment [<BEConvertToVirtualTargetEnvironment>] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-Priority {Normal | Lowest | Low | High | Highest}] [-StartDate [<DateTime>]] [-SubmitOnHold [<Boolean>]] [-ExcludeNonSystemData [<SwitchParameter>]] [-VirtualMachineName [<String>]] [-Name [<String>]] [-VirtualMachineCpuCount [<UInt32>]] [-VirtualMachinePhysicalRamMB [<UInt32>]] [-OverwriteExistingVirtualMachine [<Boolean>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a convert to virtual job in Backup Exec.

You can specify a Backup Exec job history object as the point in time in the backup set for the convert to virtual operation.

You can also specify a point-in-time range to determine the point in time in the backup set for the convert to virtual operation.

Parameters

-Name <String>

Specifies the name of the job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

Specifies the server from which the data was backed up.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-PointInTime <DateTime>

Specifies a point in time in the backup set to use for the convert to virtual operation.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotBefore <DateTime>

Specifies a starting point in time in the backup set to use for the convert to virtual operation.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobHistory <BEJobHistory>

Specifies the job history object referencing the backup set to use for the convert to virtual operation.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TargetEnvironment <BEConvertToVirtualTargetEnvironment>

Specifies the target virtual environment where the virtual machine will be created. See New-BEConvertToVirtualTargetEnvironment.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineName <String>

Specifies the name of the virtual machine to create.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingVirtualMachine <Boolean>

Overwrites an existing virtual machine with the same name if it exists.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachinePhysicalRamMB <UInt32>

Specifies the amount of RAM in MB the virtual machine will get.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineCpuCount <UInt32>

Specifies the number of CPUs the virtual machine will get.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExcludeNonSystemData <SwitchParameter>

Excludes user data from the convert to virtual operation.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartDate <DateTime>

Indicates when the job should start. If you do not specify this parameter, the job starts immediately.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

Specifies the order that the job runs. If two jobs are scheduled to run at the same time, the priority you set determines which job runs first.

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutomaticallyDeleteJob

Deletes the job automatically when it completes.

The valid values are:
Never
IfSuccessful
WhenComplete

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

You can pipe in a Backup Exec agent server object into Submit-BEConvertBackupToVirtualJob.

BackupExec.Management.CLI.BEJobHistory

You can pipe in a Backup Exec job history object into Submit-BEConvertBackupToVirtualJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEConvertBackupToVirtualJob returns a Backup Exec job object

Examples

Example 1

C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -HyperVServerName hypervserver01 -HyperVDestinationPath c:\vms -LogonAccount "System Logon Account" -ToolsIsoPath c:\hypervtools.iso
C:\PS> Get-BEJob "Job 0001" | Get-BEJobHistory -FromLastJobRun | Submit-BEConvertBackupToVirtualJob -FileSystemSelection C:\BackedUpData\*.*

These commands create a virtual machine on a Hyper-V server using data from the most recent run of a job named "Job 0001".

Example 2
C:\PS> $targetEnvironment = New-BEConvertToVirtualTargetEnvironment -VMwareVCenterServerName vcenterserver01 -VMwareHostName hostserver01 -VMwareDataStoreName datastore01 -LogonAccount "System Logon Account" -ToolsIsoPath c:\vmwaretools.iso
C:\PS> Get-BEAgentServer myserver.mycompany.com | Submit-BEConvertBackupToVirtualJob -FileSystemSelection C:\BackedUpData\*.*

These commands create a virtual machine within a VMware vCenter using data from the most recent backup of a server named "myserver.mycompany.com".

Related Links


Submit-BEEjectMediaJob Help

Submit-BEEjectMediaJob Cmdlet
Synopsis

Submits a job to eject the media that is in a disk cartridge or tape drive device in Backup Exec.

Syntax
Submit-BEEjectMediaJob -DiskCartridgeDevice [<BEDiskCartridgeDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEEjectMediaJob -TapeDriveDevice [<BETapeDriveDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to eject the media that is in a disk cartridge or tape drive device in Backup Exec.

Some devices do not support a software-driven media eject. If the media is a tape, the tape is rewound and you may be prompted to manually remove it.

Parameters

-DiskCartridgeDevice <BEDiskCartridgeDevice>

Specifies the disk cartridge media to eject.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

Specifies the tape media to eject.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Submit-BEEjectMediaJob.

BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BEEjectMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEEjectMediaJob returns the job that was submitted.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BEEjectMediaJob

These commands submit an eject job that ejects the media in the tape drive device named "Device 0001".

Related Links


Submit-BEEraseMediaJob Help

Submit-BEEraseMediaJob Cmdlet
Synopsis

Submits a media erase job in Backup Exec.

Syntax
Submit-BEEraseMediaJob -TapeDriveDevice [<BETapeDriveDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-LongErase [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEEraseMediaJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-BackupExecServer [<BEBackupExecServer>]] [-LongErase [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEEraseMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-BackupExecServer [<BEBackupExecServer>]] [-LongErase [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a media erase job in Backup Exec.

By default, Submit-BEEraseMediaJob performs a Quick erase. You can specify the -LongErase parameter to perform a long erase.

Devices that do not support a long erase will only perform a quick erase.

Parameters

-TapeDriveDevice <BETapeDriveDevice>

Specifies the tape drive on which you want to run the erase media job.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition on which you want to run the erase media job.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot on which you want to run the erase media job.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server that should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LongErase <SwitchParameter>

Performs a long erase of the media, rather than a quick erase.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BEEraseMediaJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BEEraseMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BEEraseMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEEraseMediaJob returns the job that was submitted.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BEEraseMediaJob

These commands submit an erase job that erases the media in the tape drive device named "Device 0001".

Related Link

Get-BETapeDriveDevice


Submit-BEExportExpiredMediaJob Help

Submit-BEExportExpiredMediaJob Cmdlet
Synopsis

Submits a job to export expired media from a robotic library device in Backup Exec.

Syntax
Submit-BEExportExpiredMediaJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEExportExpiredMediaJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEExportExpiredMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to export expired media from a robotic library device in Backup Exec.

The media you cannot write to is removed. Submit-BEExportExpiredMediaJob lets you automate media handling in robotic libraries.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device that contains the media to export.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition that contains the media to export.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot that contains the media to export.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BEExportExpiredMediaJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BEExportExpiredMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BEExportExpiredMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEExportExpiredMediaJob returns the job that was submitted.

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEExportExpiredMediaJob

These commands submit an export expired media job that exports the expired media from the robotic library named "Device 0001".

Example 2
C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEExportExpiredMediaJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

These commands submit an export expired media job that exports the expired media from the robotic library named "Device 0001" every day at 10pm.

Related Links


Submit-BEExportMediaJob Help

Submit-BEExportMediaJob Cmdlet
Synopsis

Submits a job to export media from a robotic library device in Backup Exec

Syntax
Submit-BEExportMediaJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-ImportAfterExport [<SwitchParameter>]] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEExportMediaJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-ImportAfterExport [<SwitchParameter>]] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEExportMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-ImportAfterExport [<SwitchParameter>]] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to export media from a robotic library device in Backup Exec.

You can specify multiple library partitions or you can specify an individual robotic library slot.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device that contains the media to export.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition that contains the media to export.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot that contains the media to export.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ImportAfterExport <SwitchParameter>

Imports the media after the export job completes.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BEExportMediaJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BEExportMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BEExportMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEExportMediaJob returns the job that was submitted.

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEExportMediaJob

These commands submit an export media job that exports the media from the robotic library named "Device 0001".

Example 2
C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEExportMediaJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

These commands submit an export media job that exports the media from the robotic library named "Device 0001" every day at 10pm.

Related Links


Submit-BEFileSystemRestoreJob Help

Submit-BEFileSystemRestoreJob Cmdlet
Synopsis

Submits a file system restore job in Backup Exec.

Syntax
Submit-BEFileSystemRestoreJob -AgentServer [<BEAgentServer>] [-FileSystemSelection] [<BEFileSystemSelection[]>] [-PreCommand [<String>]] [-PostCommand [<String>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-SubmitOnHold [<Boolean>]] [-StartDate [<DateTime>]] [-Priority {Normal | Lowest | Low | High | Highest}] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-Storage [<BEStorage>]] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RedirectToVirtualDiskFileName [<String>]] [-RestoreCorruptFile [<Boolean>]] [-RestoreDirectoryStructure [<Boolean>]] [-RedirectToVirtualDisk {None | VHD}] [-NotBefore [<DateTime>]] [-RedirectToPath [<String>]] [-RedirectToPathLogonAccount [<BELogonAccount>]] [-RestoreJunctionPoint [<Boolean>]] [-Name [<String>]] [-PointInTime [<DateTime>]] [-RestoreDiskQuotaData [<Boolean>]] [-OverwriteExistingFile {IfExistingIsOlder | No | Yes}] [-RestoreSecurityInformation {FilesAndNtfsPermissions | NtfsPermissionsOnly | FilesOnly}] [-RestoreRemovableStorageData [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEFileSystemRestoreJob -JobHistory [<BEJobHistory>] [-FileSystemSelection] [<BEFileSystemSelection[]>] [-PreCommand [<String>]] [-PostCommand [<String>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-Priority {Normal | Lowest | Low | High | Highest}] [-AutomaticallyDeleteJob {Never | IfSuccessful | WhenComplete}] [-SubmitOnHold [<Boolean>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-Storage [<BEStorage>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-RedirectToVirtualDisk {None | VHD}] [-RedirectToVirtualDiskFileName [<String>]] [-RestoreCorruptFile [<Boolean>]] [-StartDate [<DateTime>]] [-RedirectToPath [<String>]] [-RedirectToPathLogonAccount [<BELogonAccount>]] [-RestoreDirectoryStructure [<Boolean>]] [-RestoreDiskQuotaData [<Boolean>]] [-RestoreJunctionPoint [<Boolean>]] [-Name [<String>]] [-OverwriteExistingFile {IfExistingIsOlder | No | Yes}] [-RestoreSecurityInformation {FilesAndNtfsPermissions | NtfsPermissionsOnly | FilesOnly}] [-RestoreRemovableStorageData [<Boolean>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a file system restore job in Backup Exec.

You can specify a Backup Exec job history object as the point-in-time in the backup set for the restore.

You can also specify a point-in-time range to determine the point-in-time in the backup set for the restore.

Parameters

-FileSystemSelection <BEFileSystemSelection[]>

Includes or excludes one or more file system selections in the backup definition. To specify files or directories to include, specify one or more paths using commas to separate the values. To specify files or directories to exclude, use the output of New-BEFileSystemSelection with the -Exclude parameter.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToPath <String>

Specifies the path to restore to for a redirected restore job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToPathLogonAccount <BELogonAccount>

Specifies a Backup Exec logon account for the redirected restore job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToVirtualDisk

Redirects the restore job to a virtual disk. RedirectToPath must be specified.

The valid values are:
None
VHD

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RedirectToVirtualDiskFileName <String>

Specifies the name of the virtual disk to redirect the restore job. If not specified, a VHD is created for each backup set in the restore job. The RedirectToVirtualDisk parameter must be set to VHD.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreCorruptFile <Boolean>

Restores corrupted files.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreDirectoryStructure <Boolean>

Restores a file system directory structure.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OverwriteExistingFile

Overwrites any existing file during the restore.

The valid values are:
IfExistingIsOlder
No
Yes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreSecurityInformation

Restores security information.

The valid values are:
FilesAndNtfsPermissions
NtfsPermissionsOnly
FilesOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreRemovableStorageData <Boolean>

Restores removable storage data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreDiskQuotaData <Boolean>

Restores disk quota data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestoreJunctionPoint <Boolean>

Restores junction points.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the restore job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

Specifies the server from which the data was backed up.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-PointInTime <DateTime>

Specifies up to a point in time in the backup set to restore.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NotBefore <DateTime>

Specifies a starting point in time in the backup set to restore.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-JobHistory <BEJobHistory>

Specifies the job history object referencing the backup set.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-StartDate <DateTime>

Indicates when the job should start. If you do not specify this parameter, the job starts immediately.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

Specifies the order that the job runs. If two jobs are scheduled to run at the same time, the priority you set determines which job runs first.

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AutomaticallyDeleteJob

Deletes the job automatically when it completes.

The valid values are:
Never
IfSuccessful
WhenComplete

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

Specifies a command to run before the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

Specifies a command to run after the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Allows Backup Exec to check the return codes of the pre- and post-commands to determine if they completed successfully.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

Runs the backup job only if the pre-command is successful. If the pre-command fails, the job does not run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

Runs the post-command only if the pre-command is successful.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

Runs the post-command regardless of whether the job is successful or not.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

Designates the number of minutes Backup Exec should wait before canceling a pre- or post-command that did not complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

Determines the location where the pre- and post-command run.

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for a restore job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

You can pipe in a Backup Exec agent server object into Submit-BEFileSystemRestoreJob.

BackupExec.Management.CLI.BEJobHistory

You can pipe in a Backup Exec job history object into Submit-BEFileSystemRestoreJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEFileSystemRestoreJob returns a Backup Exec job object.

Examples

Example 1

C:\PS> Get-BEJob "Job 0001" | Get-BEJobHistory -FromLastJobRun | Submit-BEFileSystemRestoreJob -FileSystemSelection C:\BackedUpData\*.*

These commands restore a directory named C:\BackedUpData from the most recent run of a job named "Job 0001".

Example 2
C:\PS> Get-BEAgentServer myserver.mycompany.com | Submit-BEFileSystemRestoreJob -FileSystemSelection C:\BackedUpData\*.*

These commands restore a directory named C:\BackedUpData from the most recent backup of a server named "myserver.mycompany.com".

Related Links


Submit-BEFormatMediaJob Help

Submit-BEFormatMediaJob Cmdlet
Synopsis

Submits a job to format the media in a storage device in Backup Exec.

Syntax
Submit-BEFormatMediaJob -TapeDriveDevice [<BETapeDriveDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-FormatWorm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEFormatMediaJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-BackupExecServer [<BEBackupExecServer>]] [-FormatWorm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEFormatMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-BackupExecServer [<BEBackupExecServer>]] [-FormatWorm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to format the media in a storage device in Backup Exec.

You must have the media that you want to format in the storage device.

Formatting erases the media. All data on the media is lost.

Parameters

-TapeDriveDevice <BETapeDriveDevice>

Specifies the tape drive to format.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition to format.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot to format.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FormatWorm <SwitchParameter>

Enables the write once, read many parameter. Drives formatted with WORM cannot be reformatted.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BEFormatMediaJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BEFormatMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BEFormatMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEFormatMediaJob returns the job that was submitted.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BEFormatMediaJob

These commands submit a job that formats the media in the tape drive device named "Device 0001".

Related Link

Get-BETapeDriveDevice


Submit-BEImportMediaJob Help

Submit-BEImportMediaJob Cmdlet
Synopsis

Submits a job to insert media into the robotic library so that the Backup Exec database is updated.

Syntax
Submit-BEImportMediaJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-InventoryAfterImport [<SwitchParameter>]] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEImportMediaJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-InventoryAfterImport [<SwitchParameter>]] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEImportMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-InventoryAfterImport [<SwitchParameter>]] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to insert media into the robotic library so that the Backup Exec database is updated.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device that contains the media to import.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition that contains the media to import.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot that contains the media to import.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InventoryAfterImport <SwitchParameter>

Allows Backup Exec to create an inventory job. The inventory job automatically runs after the import job completes, and updates the Backup Exec database with information about the media.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BEImportMediaJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BEImportMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BEImportMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEImportMediaJob returns the job that was submitted.

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEImportMediaJob

These commands submit an import media job that imports the media from the robotic library named "Device 0001".

Example 2
C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEImportMediaJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

These commands submit an import media job that imports the media from the robotic library named "Device 0001" every day at 10pm.

Related Links


Submit-BEInitializeJob Help

Submit-BEInitializeJob Cmdlet
Synopsis

Submits a job to initialize a robotic library device in Backup Exec.

Syntax
Submit-BEInitializeJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to initialize a robotic library device in Backup Exec.

If there is media in the robotic library slots during startup, Backup Exec attempts to return the media to the original slot.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device to initialize.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BEInitializeJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEInitializeJob returns the job that was submitted.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEInitializeJob

These commands submit a job to initialize the robotic library named "Device 0001".

Related Link

Get-BERoboticLibraryDevice


Submit-BEInventoryAndCatalogMediaJob Help

Submit-BEInventoryAndCatalogMediaJob Cmdlet
Synopsis

Submits a job to inventory and catalog a media in a storage device in Backup Exec.

Syntax
Submit-BEInventoryAndCatalogMediaJob -DiskCartridgeDevice [<BEDiskCartridgeDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -TapeDriveDevice [<BETapeDriveDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -DiskStorageDevice [<BEDiskStorageDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -LegacyBackupToDiskFolderDevice [<BELegacyBackupToDiskFolderDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -DeduplicationDiskStorageDevice [<BEDeduplicationDiskStorageDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryAndCatalogMediaJob -VirtualDiskDevice [<BEVirtualDiskDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to inventory and catalog a media in a storage device in Backup Exec.

Parameters

-DiskCartridgeDevice <BEDiskCartridgeDevice>

Specifies the disk cartridge device to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

Specifies the tape drive device to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DiskStorageDevice <BEDiskStorageDevice>

Specifies the disk device to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-LegacyBackupToDiskFolderDevice <BELegacyBackupToDiskFolderDevice>

Specifies the backup-to-disk device to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-DeduplicationDiskStorageDevice <BEDeduplicationDiskStorageDevice>

Specifies the deduplication disk storage device to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-VirtualDiskDevice <BEVirtualDiskDevice>

Specifies the virtual disk device to inventory and catalog.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Submit-BEInventoryAndCatalogMediaJob.

BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BEInventoryAndCatalogMediaJob.

BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BEInventoryAndCatalogMediaJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BEInventoryAndCatalogMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BEInventoryAndCatalogMediaJob.

BackupExec.Management.CLI.BEDiskStorageDevice

You can pipe a Backup Exec disk storage device object to Submit-BEInventoryAndCatalogMediaJob.

BackupExec.Management.CLI.BELegacyBackupToDiskFolderDevice

You can pipe a Backup Exec legacy backup-to-disk folder device object to Submit-BEInventoryAndCatalogMediaJob.

BackupExec.Management.CLI.BEDeduplicationDiskStorageDevice

You can pipe a Backup Exec deduplication disk storage device object to Submit-BEInventoryAndCatalogMediaJob.

BackupExec.Management.CLI.BEVirtualDiskDevice

You can pipe a Backup Exec virtual disk device object to Submit-BEInventoryAndCatalogMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEInventoryAndCatalogMediaJob returns the job that was submitted.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BEInventoryAndCatalogMediaJob

These commands submit a job that inventories and catalogs the media in the tape drive device named "Device 0001".

Related Link

Get-BETapeDriveDevice


Submit-BEInventoryJob Help

Submit-BEInventoryJob Cmdlet
Synopsis

Submits a job to inventory media in a storage device in Backup Exec.

Syntax
Submit-BEInventoryJob -DiskCartridgeDevice [<BEDiskCartridgeDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryJob -TapeDriveDevice [<BETapeDriveDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEInventoryJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-BackupExecServer [<BEBackupExecServer>]] [-Schedule [<BESchedule>]] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to inventory media in a storage device in Backup Exec.

An inventory job updates Backup Exec with the current media information.

Parameters

-DiskCartridgeDevice <BEDiskCartridgeDevice>

Specifies the disk cartridge device to inventory.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-TapeDriveDevice <BETapeDriveDevice>

Specifies the tape drive device to inventory.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device to inventory.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition to inventory.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot to inventory.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Schedule <BESchedule>

Specifies the time and frequency that you want to run the job. See New-BESchedule.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEDiskCartridgeDevice

You can pipe a Backup Exec disk cartridge device object to Submit-BEInventoryJob.

BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BEInventoryJob.

BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BEInventoryJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BEInventoryJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BEInventoryJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEInventoryJob returns the job that was submitted.

Examples

Example 1

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEInventoryJob

These commands submit a job that inventories the media in the robotic library named "Device 0001".

Example 2
C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEInventoryJob -Schedule (New-BESchedule -Daily -StartingAt 10pm)

These commands submit a job that inventories the media in the robotic library named "Device 0001" every day at 10pm.

Related Links


Submit-BELabelMediaJob Help

Submit-BELabelMediaJob Cmdlet
Synopsis

Submits a job to write a new media label on media in a storage device in Backup Exec.

Syntax
Submit-BELabelMediaJob -TapeDriveDevice [<BETapeDriveDevice>] -Label [<String>] [-BackupExecServer [<BEBackupExecServer>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BELabelMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot>] -Label [<String>] [-BackupExecServer [<BEBackupExecServer>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to write a new media label on media in a storage device in Backup Exec.

Parameters

-TapeDriveDevice <BETapeDriveDevice>

Specifies the tape drive to label.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot>

Specifies the robotic library slot to label.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Label <String>

Describes the media.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BELabelMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BELabelMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BELabelMediaJob returns the job that was submitted.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BELabelMediaJob

These commands submit a job that writes a new label to the media in the tape drive device named "Device 0001".

Related Link

Get-BETapeDriveDevice


Submit-BELockJob Help

Submit-BELockJob Cmdlet
Synopsis

Submits a job to lock the front panel of a robotic library in Backup Exec.

Syntax
Submit-BELockJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to lock the front panel of a robotic library in Backup Exec.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library to lock.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server that should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BELockJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BELockJob returns the job that was submitted.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BELockJob

These commands submit a job that locks the front panel of the robotic library named "Device 0001".

Related Link

Get-BERoboticLibraryDevice


Submit-BEOnetimeBackupJob Help

Submit-BEOnetimeBackupJob Cmdlet
Synopsis

Submits a one time backup job in Backup Exec.

Syntax
Submit-BEOnetimeBackupJob -AgentServer [<BEAgentServer>] [-DiskStorageKeepForHours [<Int32>]] [-SubmitOnHold [<Boolean>]] [-BackupSetDescription [<String>]] [-TapeStorageRetensionMediaBeforeBackup [<Boolean>]] [-TapeStorageEjectMediaAfterComplete [<Boolean>]] [-TapeStorageEnableWriteOnceReadManyMedia [<Boolean>]] [-TapeStorageEnableDirectCopyToTape [<Boolean>]] [-EnableDirectAccessIfAvailable [<Boolean>]] [-StartDate [<DateTime>]] [-PreCommand [<String>]] [-TapeStorageMediaAppendMethod {Append | AppendOnly | Overwrite}] [-KeepJobQueuedFor [<TimeSpan>]] [-CancelJobIfRunningAfterScheduledTimeBy [<TimeSpan>]] [-TapeStorageCompressionMethod {None | SoftwareIfNoHardware | HardwareOnly | SoftwareOnly}] [-TapeStorageExportMediaToVault [<BEMediaVault>]] [-VirtualMachineUseGrtForActiveDirectory [<Boolean>]] [-VirtualMachineUseGrtForExchange [<Boolean>]] [-VirtualMachineUseGrtForSql [<Boolean>]] [-VirtualMachineUseGrtForFileSystem [<Boolean>]] [-OracleMaximumNumberOfDevicesToUseForResources [<UInt32>]] [-OracleMinimumNumberOfDevicesRequiredForJob [<UInt32>]] [-VirtualMachineBackupPoweredOffVirtualMachine [<Boolean>]] [-Storage [<BEStorage>]] [-TapeStorageMediaSet [<BEMediaSet>]] [-TapeStorageExportMedia [<Boolean>]] [-VMwareVSpherePort [<UInt32>]] [-VirtualMachineUseGrtForSharePoint [<Boolean>]] [-HyperVExcludeVirtualMachinesNeedingSavedState [<Boolean>]] [-VMwareTransportModePriority {SAN | NBD | NBDSSL | Hotadd}] [-OracleDeleteBackedUpArchivedLogFile [<Boolean>]] [-OracleSkipBackedUpArchivedLogFile [<Boolean>]] [-OraclePerformBackupOffline [<Boolean>]] [-SqlUseSoftwareCompression [<Boolean>]] [-SqlUseChecksumOnBackup [<Boolean>]] [-SqlCreateDiskCopy [<Boolean>]] [-SqlDiskCopyPath [<String>]] [-Name [<String>]] [-DeleteSelectedFilesAfterSuccessfulBackup {Never | FilesOnly | FilesAndFolders}] [-SqlBackupMethod {FullCopy | DatabaseSnapshot | LogNoTruncate | Log}] [-SqlAdvancedLogBackupOption {None | NoRecover | Standby}] [-SqlPostConsistencyCheck {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-RunPostCommandEvenIfJobIsUnsuccessful [<Boolean>]] [-RunPostCommandAfterVerification [<Boolean>]] [-CancelPrePostCommandIfNotCompleteWithinMinutes [<UInt32>]] [-RunPostCommandOnlyIfPreCommandIsSuccessful [<Boolean>]] [-PostCommand [<String>]] [-PrePostCommandSuccessfulIfReturnsZero [<Boolean>]] [-RunJobOnlyIfPreCommandIsSuccessful [<Boolean>]] [-EncryptionKey [<BEEncryptionKey>]] [-SqlPreConsistencyCheckMethod {None | Physical | FullExcludingIndexes | FullIncludingIndexes}] [-SqlContinueIfConsistencyCheckUnsuccessful [<Boolean>]] [-EncryptionType {None | Software | Hardware | SoftwareIfNoHardware}] [-RunCommandLocation {OnEachAgentServer | OnBackupExecServer}] [-Verify {None | AsPartOfJob | AsSeparateJobImmediatelyAfter}] [-EnableDirectAccessForVerifyJobIfAvailable [<Boolean>]] [-SharePointPortalSiteSelection [<BESharePointPortalSiteSelection[]>]] [-SharePointServiceSiteSelection [<BESharePointServiceSiteSelection[]>]] [-Priority {Normal | Lowest | Low | High | Highest}] [-SharePointSharedServiceProviderSelection [<BESharePointSharedServiceProviderSelection[]>]] [-SharePointServiceApplicationProxySelection [<BESharePointServiceApplicationProxySelection[]>]] [-SharePointSharedServiceApplicationSelection [<BESharePointSharedServiceApplicationSelection[]>]] [-SharePointSharedServiceApplicationProxySelection [<BESharePointSharedServiceApplicationProxySelection[]>]] [-NetworkSubnet [<BENetworkInterfaceSubnet>]] [-AllowAnyNetworkForAgentAccess [<Boolean>]] [-EnableCheckpointRestart [<Boolean>]] [-NetworkProtocol {AnyAvailable | IPv4 | IPv6}] [-RestrictToBackupExecServer [<BEBackupExecServer>]] [-RestrictToBackupExecServersInPool [<BEBackupExecServerPool>]] [-NetworkInterface [<BENetworkInterface>]] [-SharePointServiceApplicationSelection [<BESharePointServiceApplicationSelection[]>]] [-ExchangeDatabaseSelection [<BEExchangeDatabaseSelection[]>]] [-SqlDatabaseSelection [<BESqlDatabaseSelection[]>]] [-SharePointAllResourcesSelection {Include | Exclude}] [-ExchangeStorageGroupDatabaseSelection [<BEExchangeStorageGroupDatabaseSelection[]>]] [-EnableSimplifiedDisasterRecovery [<Boolean>]] [-SystemStateSelection {Include | Exclude}] [-FileSystemSelection [<BEFileSystemSelection[]>]] [-SharePointHelpSearchSelection {Include | Exclude}] [-SharePointSingleSignOnDatabaseSelection {Include | Exclude}] [-SharePointWebApplicationSelection [<BESharePointWebApplicationSelection[]>]] [-SharePointInfoPathServicesSelection {Include | Exclude}] [-SharePointConfigurationDatabaseSelection {Include | Exclude}] [-SharePointGlobalSettingsSelection {Include | Exclude}] [-SharePointCentralAdministrationWebApplicationSelection {Include | Exclude}] [-SharePointPreConsistencyCheck [<Boolean>]] [-SharePointContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-SharePointUseGrt [<Boolean>]] [-SharePointReleaseLockOnFarmTopology [<Boolean>]] [-ExchangeContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-ExchangeUseGrt [<Boolean>]] [-ExchangeHighAvailability {FromPassiveCopyIfAvailableOtherwiseActiveCopy | FromPassiveCopyOnly | FromActiveCopyOnly}] [-ActiveDirectoryPreConsistencyCheck [<Boolean>]] [-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful [<Boolean>]] [-ActiveDirectoryUseGrt [<Boolean>]] [-LinuxMacLockRemoteFile [<Boolean>]] [-LinuxMacPreserveChangeTime [<Boolean>]] [-LinuxMacFollowLocalMountPoint [<Boolean>]] [-LinuxMacFollowRemoteMountPoint [<Boolean>]] [-ExchangePreConsistencyCheck [<Boolean>]] [-UseOffhostBackup [<Boolean>]] [-OffhostBackupSnapshotProvider {Automatic | Software | Hardware}] [-FailIfNoOffhostBackup [<Boolean>]] [-ProcessLogicalVolumesSequentially [<Boolean>]] [-UseSnapshotTechnology [<Boolean>]] [-SnapshotTechnology {Automatic | MicrosoftVolumeShadowCopyService}] [-SnapshotProvider {Automatic | System | Software | Hardware}] [-FileSystemBackupRemoteStorage [<Boolean>]] [-FileSystemBackupOpenFile {Never | IfClosedWithinSpecifiedTime | WithALock | WithoutALock}] [-FileSystemBackupOpenFileIfClosedWithinSeconds [<UInt32>]] [-FileSystemFollowSymbolicLink [<Boolean>]] [-ProcessOffhostLogicalVolumesSequentially [<Boolean>]] [-FileSystemEnableNtfsSingleInstanceBackup [<Boolean>]] [-FileSystemFollowJunctionPoint [<Boolean>]] [-Force [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a one time backup job in Backup Exec.

When no selection parameters are passed to Submit-BEOnetimeBackupJob, you are prompted before the entire agent server is selected for backup. To avoid the prompt, specify the -Force parameter.

To create scheduled backup jobs, use New-BEBackupDefinition.

Parameters

-EnableSimplifiedDisasterRecovery <Boolean>

Enables Simplified System Recovery.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SystemStateSelection

Includes or excludes System State in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemSelection <BEFileSystemSelection[]>

Includes or excludes one or more file system selections in the backup definition. To specify files or directories to include, specify one or more paths using commas to separate the values. To specify files or directories to exclude, use the output of New-BEFileSystemSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeStorageGroupDatabaseSelection <BEExchangeStorageGroupDatabaseSelection[]>

Includes or excludes one or more Exchange 2003 storage groups or databases in the backup definition. To specify storage groups to include, specify one or more storage group names using commas to separate the values (specifying '*' will include all storage groups). To specify storage groups to exclude, or to specify individual databases to include or exclude, use the output of New-BEExchangeStorageGroupDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeDatabaseSelection <BEExchangeDatabaseSelection[]>

Includes or excludes one or more databases for Exchange 2007 or later in the backup definition. To specify databases to include, specify one or more database names using commas to separate the values (specifying '*' will include all databases). To specify databases to exclude, use the output of New-BEExchangeDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDatabaseSelection <BESqlDatabaseSelection[]>

Includes or excludes one or more SQL instances or databases in the backup definition. To specify SQL instances to include, specify one or more SQL instance names using commas to separate the values (specifying '*' will include all SQL instances). To specify SQL instances to exclude, or to specify individual databases to include or exclude, use the output of New-BESqlDatabaseSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointAllResourcesSelection

Includes or excludes all of the SharePoint resources categorically in the backup definition when you back up a Windows computer.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointConfigurationDatabaseSelection

Includes or excludes the SharePoint configuration database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointGlobalSettingsSelection

Includes or excludes the SharePoint global settings database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointCentralAdministrationWebApplicationSelection

Includes or excludes the SharePoint Central Administration Web Application in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointInfoPathServicesSelection

Includes or excludes the SharePoint Info Path Services in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointHelpSearchSelection

Includes or excludes the SharePoint Help Search in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSingleSignOnDatabaseSelection

Includes or excludes the SharePoint Single Sign-on Database in the backup definition.

The valid values are:
Include
Exclude

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointWebApplicationSelection <BESharePointWebApplicationSelection[]>

Includes or excludes one or more SharePoint Web Applications in the backup definition. To specify Web Applications to include, specify one or more Web Application names using commas to separate the values (specifying '*' will include all Web Applications). To specify Web Applications to exclude, use the output of New-BESharePointWebApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationSelection <BESharePointServiceApplicationSelection[]>

Includes or excludes one or more SharePoint Service Applications in the backup definition. To specify Service Applications to include, specify one or more Service Application names using commas to separate the values (specifying '*' will include all Service Applications). To specify Service Applications to exclude, use the output of New-BESharePointServiceApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceApplicationProxySelection <BESharePointServiceApplicationProxySelection[]>

Includes or excludes one or more SharePoint Service Application Proxies in the backup definition. To specify Service Application Proxies to include, specify one or more Service Application Proxy names using commas to separate the values (specifying '*' will include all Service Application Proxies). To specify Service Application Proxies to exclude, use the output of New-BESharePointServiceApplicationProxySelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationSelection <BESharePointSharedServiceApplicationSelection[]>

Includes or excludes one or more SharePoint Shared Service Applications in the backup definition. To specify Shared Service Applications to include, specify one or more Shared Service Application names using commas to separate the values (specifying '*' will include all Shared Service Applications). To specify Shared Service Applications to exclude, use the output of New-BESharePointSharedServiceApplicationSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceApplicationProxySelection <BESharePointSharedServiceApplicationProxySelection[]>

Includes or excludes one or more SharePoint Shared Service Application Proxies in the backup definition. To specify Shared Service Application Proxies to include, specify one or more Shared Service Application Proxy names using commas to separate the values (specifying '*' will include all Shared Service Application Proxies). To specify Shared Service Application Proxies to exclude, use the output of New-BESharePointSharedServiceApplicationProxySelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointSharedServiceProviderSelection <BESharePointSharedServiceProviderSelection[]>

Includes or excludes one or more SharePoint Shared Service Providers in the backup definition. To specify Shared Service Providers to include, specify one or more Shared Service Provider names using commas to separate the values. To specify Shared Service Providers to exclude, use the output of New-BESharePointSharedServiceProviderSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPortalSiteSelection <BESharePointPortalSiteSelection[]>

Includes or excludes one or more SharePoint Portal Sites in the backup definition. To specify Portal Sites to include, specify one or more Portal Site names using commas to separate the values. To specify Portal Sites to exclude, use the output of New-BESharePointPortalSiteSelection with the -Exclude parameter to pass one or more Portal Sites to exclude to this parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointServiceSiteSelection <BESharePointServiceSiteSelection[]>

Includes or excludes one or more SharePoint Service Sites in the backup definition. To specify Service Sites to include, specify one or more Service Site names using commas to separate the values. To specify Service Sites to exclude, use the output of New-BESharePointServiceSiteSelection with the -Exclude parameter.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Priority

Specifies the order that the job runs. If two jobs are scheduled to run at the same time, the priority you set determines which job runs first.

The valid values are:
Normal
Lowest
Low
High
Highest

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server to which the job can be dispatched in a CASO environment. Cannot be specified if RestrictToBackupExecServersInPool is specified.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RestrictToBackupExecServersInPool <BEBackupExecServerPool>

Specifies a set of Backup Exec servers to which the job can be dispatched in a CASO environment,. Cannot be specified if RestrictToBackupExecServer is specified.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkInterface <BENetworkInterface>

Specifies the name of the network interface card that connects the Backup Exec server to the network you want to use for the backup network. See Get-BENetworkInterface.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkProtocol

Specifies the protocol you want to used to back up remote computers.

The valid values are:
AnyAvailable
IPv4
IPv6

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-NetworkSubnet <BENetworkInterfaceSubnet>

Specifies the subnet you want to use to back up remote computers on by using one of the subnets of a network interface returned by Get-BENetworkInterface.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AllowAnyNetworkForAgentAccess <Boolean>

Ensures that the data from the remote computer is backed up or restored over any available network if the remote computer that you select for backup or restore is not part of the specified backup network.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableCheckpointRestart <Boolean>

Enables backup jobs to continue from the point at which the jobs was interrupted.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseSnapshotTechnology <Boolean>

Enables the use of a snapshot technology

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotTechnology

Specifies the snapshot technology to use when you enable snapshot technology. UseSnapshotTechnology must be set to $true.

The valid values are:
Automatic
MicrosoftVolumeShadowCopyService

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SnapshotProvider

Specifies the Microsoft Volume Shadow Copy Service as the snapshot provider to use when you enable snapshot technology. UseSnapshotTechnology must be set to $true and SnapshotTechnology must be set to MicrosoftVolumeShadowCopyService.

The valid values are:
Automatic
System
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessLogicalVolumesSequentially <Boolean>

Enables the backup of multiple volumes in one job, while creating a snapshot of only one logical volume at a time.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-UseOffhostBackup <Boolean>

Enables offhost backup. If enabled, then an offhost backup of all volumes will be performed if all requirements are met.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OffhostBackupSnapshotProvider

Specifies the offhost backup snapshot provider to use. UseOffhostBackup must be set to $true.

The valid values are:
Automatic
Software
Hardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FailIfNoOffhostBackup <Boolean>

Terminates the backup job if any of the volumes selected do not support offhost backup, or if an error occurs that is related to the snapshot or volume import. UseOffhostBackup must be set to $true.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ProcessOffhostLogicalVolumesSequentially <Boolean>

Enables the backup of multiple volumes in one job, while creating a snapshot of only one logical volume at a time for offhost backups. UseOffhostBackup must be set to $true.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemEnableNtfsSingleInstanceBackup <Boolean>

Lets Backup Exec check the NTFS volume for identical files. If Backup Exec finds multiple copies of a file, only one instance of that file is backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowJunctionPoint <Boolean>

Backs up the information for the junction points and the files and directories to which they are linked.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemFollowSymbolicLink <Boolean>

Backs up the information for the symbolic links and the files and directories to which they are linked.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupRemoteStorage <Boolean>

Backs up data that has been migrated from primary storage to secondary storage.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFile

Specifies how Backup Exec processes any open files for the backup job if snapshot technology is not used.

The valid values are:
Never
IfClosedWithinSpecifiedTime
WithALock
WithoutALock

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-FileSystemBackupOpenFileIfClosedWithinSeconds <UInt32>

The number of seconds Backup Exec waits for files to close before skipping them and continuing the backup job. BackupOpenFile must be set to IfClosedWithinSpecifiedTime.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangePreConsistencyCheck <Boolean>

Performs a consistency check before running the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeUseGrt <Boolean>

Enables restores of individual items from Information Store backup jobs.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ExchangeHighAvailability

Specifies a backup source for Exchange 2007 or later.

The valid values are:
FromPassiveCopyIfAvailableOtherwiseActiveCopy
FromPassiveCopyOnly
FromActiveCopyOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointReleaseLockOnFarmTopology <Boolean>

Releases the lock on the SharePoint farm topology before you run the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointPreConsistencyCheck <Boolean>

Runs a full consistency check (including indexes) of the Microsoft SQL databases used by Microsoft SharePoint before you back up the databases.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Continues with the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SharePointUseGrt <Boolean>

Enables the restore of individual documents, images, sites, subsites, lists, and list items from backups of the database.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacPreserveChangeTime <Boolean>

Prevents the Agent of Windows from changing an object's attributes when a backup job occurs. An object is a file or a directory.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowLocalMountPoint <Boolean>

Lets Backup Exec follow local mount points when it backs up data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacFollowRemoteMountPoint <Boolean>

Lets Backup Exec follow remote mount points when it backs up data.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-LinuxMacLockRemoteFile <Boolean>

Lets the Agent for Windows have exclusive access to the files on the remote computers that are connected through Network File System (NFS).

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryPreConsistencyCheck <Boolean>

Checks snapshots for data corruption.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryContinueIfConsistencyCheckIsUnsuccessful <Boolean>

Enables the backup job to continue even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ActiveDirectoryUseGrt <Boolean>

Enables the restore of individual items from full backups of the Active Directory.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMaximumNumberOfDevicesToUseForResources <UInt32>

Specifies the maximum number of devices that the backup job can use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleMinimumNumberOfDevicesRequiredForJob <UInt32>

Specifies the minimum number of devices that the job can use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineBackupPoweredOffVirtualMachine <Boolean>

Enables Backup Exec to back up virtual machines that are turned off.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForFileSystem <Boolean>

Enables individual files and folders to be restored from the full backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForActiveDirectory <Boolean>

Enables Backup Exec to collect the information that is required to restore individual Active Directory objects on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForExchange <Boolean>

Enables Backup Exec to collect the information that is required to restore individual Exchange databases and mailbox items on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSql <Boolean>

Enables Backup Exec to collect the information that is required to restore individual SQL database items on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualMachineUseGrtForSharePoint <Boolean>

Enables Backup Exec to collect the information that is required to restore SharePoint data on the virtual machine.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-HyperVExcludeVirtualMachinesNeedingSavedState <Boolean>

Excludes all offline virtual machines that do not support online backups and that are in a running state when the backup starts.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareTransportModePriority

Specifies one or more VMware transport modes Backup Exec should use in order of their priority.

The valid values are:
SAN
NBD
NBDSSL
Hotadd

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VMwareVSpherePort <UInt32>

Specifies the VMware vSphere port Backup Exec should use.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Storage <BEStorage>

Specifies the storage device that you want to use for the backup job. See Get-BEStorage.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaSet <BEMediaSet>

Specifies the media set to associate with the media. The media is protected from being overwritten based on the settings for the media set. The Storage parameter must be set to a tape-based storage device. See Get-BEMediaSet.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMedia <Boolean>

Exports the media from the device when the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageExportMediaToVault <BEMediaVault>

Logically moves the media to the specified vault when the job completes. The Storage parameter must be set to a tape-based storage device and TapeStorageExportMedia must be set to $true. See Get-BEMediaVault.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEjectMediaAfterComplete <Boolean>

Ejects the media from the storage device after the job completes. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableWriteOnceReadManyMedia <Boolean>

Specifies the use of WORM (write once, read many) media for this backup job. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageEnableDirectCopyToTape <Boolean>

Enables data to be copied from a virtual tape library directly to a physical tape device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageRetensionMediaBeforeBackup <Boolean>

Retensions the media before data is written to it. The Storage parameter must be set to a tape-based storage device.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskStorageKeepForHours <Int32>

Specifies the number of hours to retain the data on the media before the media can be overwritten. The Storage parameter must be set to a disk-based storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SubmitOnHold <Boolean>

Submits the job with an on-hold status.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-BackupSetDescription <String>

Describes the data that was backed up and the location of the data.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-KeepJobQueuedFor <TimeSpan>

Specifies the maximum amount of time past the scheduled start time that Backup Exec considers the job to be missed and reschedules it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelJobIfRunningAfterScheduledTimeBy <TimeSpan>

Specifies the amount of time after the scheduled start time that you want to cancel the job if it is still running.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageCompressionMethod

Specifies the type of data compression to use performed by the hardware or software. The Storage parameter must be set to a tape-based storage device.

The valid values are:
None
SoftwareIfNoHardware
HardwareOnly
SoftwareOnly

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TapeStorageMediaAppendMethod

Specifies if you want to overwrite or append to the media when the job starts. The Storage parameter must be set to a tape-based storage device.

The valid values are:
Append
AppendOnly
Overwrite

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessIfAvailable <Boolean>

Allows backup data to be sent directly to the device specified in the Storage parameter from the Agent for Windows if the device supports it.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-StartDate <DateTime>

Indicates when the job should start. If you do not specify this parameter, the job starts immediately.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PreCommand <String>

Specifies a command to run before the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PostCommand <String>

Specifies a command to run after the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-PrePostCommandSuccessfulIfReturnsZero <Boolean>

Allows Backup Exec to check the return codes of the pre- and post-commands to determine if they completed successfully.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunJobOnlyIfPreCommandIsSuccessful <Boolean>

Runs the backup job only if the pre-command is successful. If the pre-command fails, the job does not run.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandOnlyIfPreCommandIsSuccessful <Boolean>

Runs the post-command only if the pre-command is successful.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandEvenIfJobIsUnsuccessful <Boolean>

Runs the post-command regardless of whether the job is successful or not.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunPostCommandAfterVerification <Boolean>

Runs the post-command after the verification completes if you selected to verify the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-CancelPrePostCommandIfNotCompleteWithinMinutes <UInt32>

Designates the number of minutes Backup Exec should wait before canceling a pre- or post-command that did not complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RunCommandLocation

Determines the location where the pre- and post-command run.

The valid values are:
OnEachAgentServer
OnBackupExecServer

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Verify

Runs a verify operation automatically when the backup job completes.

The valid values are:
None
AsPartOfJob
AsSeparateJobImmediatelyAfter

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EnableDirectAccessForVerifyJobIfAvailable <Boolean>

Specifies if the Agent for Windows verifies the data if the device specified in the Storage parameter supports it. The Verify parameter must be set to AsSeparateJobImmediatelyAfter.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionType

Specifies the type of encryption that you want to use for the backup job.

The valid values are:
None
Software
Hardware
SoftwareIfNoHardware

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-EncryptionKey <BEEncryptionKey>

Specifies the encryption key that you want to use. EncryptionType must be set to a value other than None.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPreConsistencyCheckMethod

Specifies the type of consistency check to perform before the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlContinueIfConsistencyCheckUnsuccessful <Boolean>

Continues the backup job even if the consistency check fails.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlPostConsistencyCheck

Specifies the type of consistency check to use after the backup job runs.

The valid values are:
None
Physical
FullExcludingIndexes
FullIncludingIndexes

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseChecksumOnBackup <Boolean>

For SQL 2005 or later, adds checksums to the SQL database data being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlCreateDiskCopy <Boolean>

Creates an on-disk copy of the SQL database being backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlDiskCopyPath <String>

Specifies the path for the on-disk copy of the SQL database being backed up. CreateDiskCopy must be set to $true.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlUseSoftwareCompression <Boolean>

For SQL 2008 or later, specifies the compression setting you want to use.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleDeleteBackedUpArchivedLogFile <Boolean>

Lets you delete the archived log files automatically after the backup.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OracleSkipBackedUpArchivedLogFile <Boolean>

Enables Backup Exec to skip any archived logfiles that were already backed up.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-OraclePerformBackupOffline <Boolean>

Enables Backup Exec to take the database offline before you start the backup job.

The valid values are:
$true
$false

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DeleteSelectedFilesAfterSuccessfulBackup

Backs up the selected data, verifies the media, and then deletes the data from the volume. Since the operation deletes the files and you must perform a restore to get the data back, you must specify the Force parameter when enabling this option.

The valid values are:
Never
FilesOnly
FilesAndFolders

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlBackupMethod

Specifies the SQL backup method you want to use for this backup job.

The valid values are:
FullCopy
DatabaseSnapshot
LogNoTruncate
Log

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-SqlAdvancedLogBackupOption

Specifies the advanced log backup option you want to use for this backup job.

The valid values are:
None
NoRecover
Standby

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Name <String>

Specifies the name of the backup job.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AgentServer <BEAgentServer>

Specifies the object representing the agent server to back up.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-Force <SwitchParameter>

Confirms that the DeleteSelectedFilesAfterSuccessfulBackup parameter results in a loss of data and want to continue to use it.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to Submit-BEOnetimeBackupJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEOnetimeBackupJob returns the job that was submitted.

Examples

Example 1

C:\PS> Get-BEAgentServer -Local | Submit-BEOneTimeBackupJob -Force | Wait-BEJob

These commands submit a one-time backup that backs up all data on the local computer and waits for the job to complete.

Example 2
C:\PS> Get-BEAgentServer -Local | Submit-BEOneTimeBackupJob -SystemStateSelection Include -FileSystemSelection C:\*,D:\*

These commands submit a one-time backup that backs up the System State and the data on the C: and D: drives of the local computer.

Related Links

New-BEBackupDefinition
New-BEFileSystemSelection
New-BEExchangeStorageGroupDatabaseSelection
New-BEExchangeDatabaseSelection
New-BESqlDatabaseSelection
New-BESharePointWebApplicationSelection
New-BESharePointServiceApplicationSelection
New-BESharePointServiceApplicationProxySelection
New-BESharePointSharedServiceApplicationSelection
New-BESharePointSharedServiceApplicationProxySelection
New-BESharePointSharedServiceProviderSelection
New-BESharePointPortalSiteSelection
New-BESharePointServiceSiteSelection
Get-BENetworkInterface
Get-BEStorage
Get-BEMediaSet
Get-BEMediaVault
Get-BEAgentServer
Wait-BEJob


Submit-BERetensionMediaJob Help

Submit-BERetensionMediaJob Cmdlet
Synopsis

Submits a job to retension the media in a storage device in Backup Exec.

Syntax
Submit-BERetensionMediaJob -TapeDriveDevice [<BETapeDriveDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BERetensionMediaJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BERetensionMediaJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BERetensionMediaJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to retension the media in a storage device in Backup Exec.

Use retension to run the tape in the tape drive from beginning to end at a fast speed so that the tape winds evenly and runs more smoothly past the tape drive heads.

Parameters

-TapeDriveDevice <BETapeDriveDevice>

Specifies the tape drive device to retension.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device to retension.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition to retension.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot to retension.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BETapeDriveDevice

You can pipe a Backup Exec tape drive device object to Submit-BERetensionMediaJob.

BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BERetensionMediaJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BERetensionMediaJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BERetensionMediaJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BERetensionMediaJob returns the job that was submitted.

Example

C:\PS> Get-BETapeDriveDevice "Device 0001" | Submit-BERetensionMediaJob

These commands submit a job that retensions the media in the tape drive device named "Device 0001".

Related Link

Get-BETapeDriveDevice


Submit-BEScanJob Help

Submit-BEScanJob Cmdlet
Synopsis

Submits a job to perform an update of slot information for a robotic library device in Backup Exec.

Syntax
Submit-BEScanJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEScanJob -RoboticLibraryPartition [<BERoboticLibraryPartition>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEScanJob -RoboticLibrarySlot [<BERoboticLibrarySlot[]>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to perform an update of the slot information for a robotic library device in Backup Exec.

This utility job is useful when you change magazines or insert new media in a magazine.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device that you want to scan.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibraryPartition <BERoboticLibraryPartition>

Specifies the robotic library partition that you want to scan.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-RoboticLibrarySlot <BERoboticLibrarySlot[]>

Specifies the robotic library slot that you want to scan.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BEScanJob.

BackupExec.Management.CLI.BERoboticLibraryPartition

You can pipe a Backup Exec robotic library partition object to Submit-BEScanJob.

BackupExec.Management.CLI.BERoboticLibrarySlot

You can pipe a Backup Exec robotic library slot object to Submit-BEScanJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEScanJob returns the job that was submitted.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEScanJob

These commands submit a job that scans the media in the robotic library named "Device 0001".

Related Link

Get-BERoboticLibraryDevice


Submit-BEStorageArrayDeviceConfigurationJob Help

Submit-BEStorageArrayDeviceConfigurationJob Cmdlet
Synopsis

Configures a storage array device in Backup Exec.

Syntax
Submit-BEStorageArrayDeviceConfigurationJob -StorageArrayDevice [<BEStorageArrayDevice>] -VirtualDiskSizeGigabyte [<UInt32>] [-MakeDeduplicationDiskStorageDevice [<SwitchParameter>]] [-BackupExecServer [<BEBackupExecServer>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]

Submit-BEStorageArrayDeviceConfigurationJob -StorageArrayDevice [<BEStorageArrayDevice>] -DiskGroupPhysicalDisk [<BEStorageArrayPhysicalDisk[]>] [-MakeDeduplicationDiskStorageDevice [<SwitchParameter>]] [-RemoveHotSparePhysicalDisk [<BEStorageArrayPhysicalDisk[]>]] [-BackupExecServer [<BEBackupExecServer>]] [-AddHotSparePhysicalDisk [<BEStorageArrayPhysicalDisk[]>]] [-VirtualDiskCount [<Int32>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Submit-BEStorageArrayDeviceConfigurationJob -StorageArrayDevice [<BEStorageArrayDevice>] -ConfigureHotSparesOnly [<SwitchParameter>] [-RemoveHotSparePhysicalDisk [<BEStorageArrayPhysicalDisk[]>]] [-BackupExecServer [<BEBackupExecServer>]] [-AddHotSparePhysicalDisk [<BEStorageArrayPhysicalDisk[]>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Configures a storage array device in Backup Exec.

Parameters

-StorageArrayDevice <BEStorageArrayDevice>

Specifies the storage array device to be configured.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualDiskSizeGigabyte <UInt32>

Specifies the virtual disk size.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-DiskGroupPhysicalDisk <BEStorageArrayPhysicalDisk[]>

Specifies the physical disks that will belong to the disk group.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-VirtualDiskCount <Int32>

Specifies the number of virtual disk to create from the physical disk that are in the storage array.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ConfigureHotSparesOnly <SwitchParameter>

Configures the hot spare physical disks only.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-AddHotSparePhysicalDisk <BEStorageArrayPhysicalDisk[]>

Specifies one or more physical disks to add as a hot spare.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-RemoveHotSparePhysicalDisk <BEStorageArrayPhysicalDisk[]>

Specifies one or more physical disks to remove as a hot spare.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-MakeDeduplicationDiskStorageDevice <SwitchParameter>

Makes a deduplication disk storage device.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEStorageArrayDevice

A Backup Exec storage array device object can be piped into Submit-BEStorageArrayDeviceConfigurationJob

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEStorageArrayDeviceConfigurationJob outputs a Backup Exec job object.

Examples

Example 1

C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -VirtualDiskSizeGigabyte 10

These commands configure a virtual disk of the specified size on the storage array device named "Device 0001". The storage array selects the physical disks that are a part of the disk storage group.

Example 2
C:\PS> $physicalDisks = Get-BEStorageArrayDevice -Name "Device 0001" | Get-BEStorageArrayPhysicalDisk -IsConfigured $false
C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -ConfigureHotSparesOnly -AddHotSparePhysicalDisk $physicalDisks

These commands configure all of the unconfigured physical disks on a storage array device named "Device 0001" as hot spares.

Example 3
C:\PS> $physicalDisks = Get-BEStorageArrayDevice -Name "Device 0001" | Get-BEStorageArrayPhysicalDisk -IsConfigured $false
C:\PS> Get-BEStorageArrayDevice -Name "Device 0001" | Submit-BEStorageArrayDeviceConfigurationJob -DiskGroupPhysicalDisk $physicalDisks

These commands configure a disk storage group with all of the unconfigured physical disks on a storage array device named "Device 0001".

Related Links


Submit-BEUnlockJob Help

Submit-BEUnlockJob Cmdlet
Synopsis

Submits a job to unlock the front panel of a robotic library in Backup Exec.

Syntax
Submit-BEUnlockJob -RoboticLibraryDevice [<BERoboticLibraryDevice>] [-BackupExecServer [<BEBackupExecServer>]] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Submits a job to unlock the front panel of a robotic library in Backup Exec.

Parameters

-RoboticLibraryDevice <BERoboticLibraryDevice>

Specifies the robotic library device to un-lock.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-BackupExecServer <BEBackupExecServer>

Specifies which Backup Exec server should process the job in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BERoboticLibraryDevice

You can pipe a Backup Exec robotic library device object to Submit-BEUnlockJob.

Return Value
BackupExec.Management.CLI.BEJob

Submit-BEUnlockJob returns the job that was submitted.

Example

C:\PS> Get-BERoboticLibraryDevice "Device 0001" | Submit-BEUnlockJob

These commands submit a job that unlocks the front panel of the robotic library named "Device 0001".

Related Link

Get-BERoboticLibraryDevice


Suspend-BEJob Help

Suspend-BEJob Cmdlet
Synopsis

Places a job on hold in Backup Exec.

Syntax
Suspend-BEJob -InputObject [<BEJob[]>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Places a job on hold in Backup Exec.

Use Resume-BEJob to resume jobs that you place on hold.

Parameters

-InputObject <BEJob[]>

Specifies one or more job objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to Suspend-BEJob.

Return Value
BackupExec.Management.CLI.BEJob

Suspend-BEJob returns a Backup Exec job object.

Example

C:\PS> Get-BEJob "Job 0001" | Suspend-BEJob

These commands place a job named "Job 0001" on hold.

Related Links


Suspend-BEJobQueue Help

Suspend-BEJobQueue Cmdlet
Synopsis

Places the job queue for a server on hold in Backup Exec.

Syntax
Suspend-BEJobQueue [-BackupExecServer [<BEBackupExecServer>]] [<CommonParameters>]
Description

Places the job queue for a server on hold in Backup Exec.

Use Resume-BEJobQueue to resume the job queue for a server that you place on hold.

If you do not specify -BackupExecServer parameter, Suspend-BEJobQueue places the local Backup Exec server's job queue on hold.

Parameters

-BackupExecServer <BEBackupExecServer>

Specifies the Backup Exec server for which to place the job queue on hold in a CASO environment.

Required | false
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEBackupExecServer

You can pipe a Backup Exec server object to Suspend-BEJobQueue.

Return Value
BackupExec.Management.CLI.BEBackupExecServer

Suspend-BEJobQueue returns a Backup Exec server object.

Examples

Example 1

C:\PS> Suspend-BEJobQueue

This command places the local Backup Exec server's job queue on hold.

Example 2
C:\PS> Get-BEBackupExecServer "ManagedServer0001" | Suspend-BEJobQueue

These commands place the job queue of the Backup Exec server named "ManagedServer0001" on hold.

Related Links


Switch-BEEncryptionKey Help

Switch-BEEncryptionKey Cmdlet
Synopsis

Replaces one encryption key with another for all backup jobs in Backup Exec.

Syntax
Switch-BEEncryptionKey -InputObject [<BEEncryptionKey[]>] -ReplacementEncryptionKey [<BEEncryptionKey>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Switch-BEEncryptionKey -InputObject [<BEEncryptionKey[]>] -ReplaceWithNone [<SwitchParameter>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]
Description

Replaces one encryption key with another for all backup jobs in Backup Exec.

If an encryption key is in use by one or more jobs, you must use Switch-BEEncryptionKey before deleting the encryption key with the Remove-BEEncryptionKey command.

Parameters

-InputObject <BEEncryptionKey[]>

Specifies one or more encryption key objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-ReplacementEncryptionKey <BEEncryptionKey>

Specifies the encryption key to be used as the replacement.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-ReplaceWithNone <SwitchParameter>

Specifies that no encryption key is to be used as a replacement.

Required | true
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEEncryptionKey

You can pipe a Backup Exec encryption key object to Switch-BEEncryptionKey.

Return Value
BackupExec.Management.CLI.BEEncryptionKey

Switch-BEEncryptionKey returns a Backup Exec encryption key object.

Examples

Example 1

C:\PS> Get-BEEncryptionKey "Encryption Key 0001" | Replace-BEEncryptionKey -ReplacementEncryptionKey "Encryption Key 0002"

These commands replace the encryption key named "Encryption Key 0001" with the encryption key named "Encryption Key 0002" for all jobs that are using it.

Example 2
C:\PS> Get-BEEncryptionKey "Encryption Key 0001" | Replace-BEEncryptionKey -ReplaceWithNone

These commands remove the encryption key named "Encryption Key 0001" from all jobs that use it.

Related Links


Test-BELogonAccount Help

Test-BELogonAccount Cmdlet
Synopsis

Test the Backup Exec logon account assigned to an agent server or backup source.

Syntax
Test-BELogonAccount [-AgentServer] [<BEAgentServer>] [<CommonParameters>]

Test-BELogonAccount [-AgentServerBackupSource] [<BEAgentServerBackupSource>] [<CommonParameters>]
Description

Tests the Backup Exec logon account assigned to an agent server or backup source.

Parameters

-AgentServer <BEAgentServer>

Specifies an agent server to test the logon account.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-AgentServerBackupSource <BEAgentServerBackupSource>

Specifies a backup source to test the logon account.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Types
BackupExec.Management.CLI.BEAgentServer

You can pipe a Backup Exec agent server object to Test-BELogonAccount.

BackupExec.Management.CLI.BEAgentServerBackupSource

You can pipe a Backup Exec agent server backup source to Test-BELogonAccount.

Return Values
BackupExec.Management.CLI.BEAgentServer

Test-BELogonAccount returns a Backup Exec agent server object.

BackupExec.Management.CLI.BEAgentServerBackupSource

Test-BELogonAccount returns a Backup Exec agent server backup source object.

Examples

Example 1

C:\PS> Get-BEAgentServer myserver.mycompany.com | Test-BELogonAccount

These commands test the logon account for the agent server named "myserver.mycompany.com".

Example 2
C:\PS> Get-BEAgentServer myserver.mycompany.com | Get-BEAgentServerBackupSource C: | Test-BELogonAccount

These commands test the logon account for the C: volume of an agent server named "myserver.mycompany.com".

Related Links


Use-BERestrictedLogonAccount Help

Use-BERestrictedLogonAccount Cmdlet
Synopsis

Allows the current user to use a restricted logon account owned by another user.

Syntax
Use-BERestrictedLogonAccount [-LogonAccount] [<BELogonAccount>] [-CurrentPassword] [<SecureString>] [<CommonParameters>]
Description

Allows the current user to use a restricted logon account owned by another user.

Parameters

-LogonAccount <BELogonAccount>

Specifies the name of the restricted logon account to use.

Required | true
Position | 0
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-CurrentPassword <SecureString>

Specifies the password of the resticted logon account.

Required | true
Position | 1
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BELogonAccount

You can pipe a Backup Exec logon account object to Use-BERestrictedLogonAccount.

Return Value
BackupExec.Management.CLI.BELogonAccount

The logon account that the user now has access to.

Example

C:\PS> $password = Read-Host -AsSecureString
C:\PS> Get-BELogonAccount "Logon Account 01" | Use-BERestrictedLogonAccount -CurrentPassword $password

These commands grant the current user access to a restricted logon account named "Logon Account 01".

Related Link

Get-BELogonAccount


Wait-BEJob Help

Wait-BEJob Cmdlet
Synopsis

Waits for a job to complete in Backup Exec.

Syntax
Wait-BEJob -InputObject [<BEJob[]>] [-Any [<SwitchParameter>]] [-TimeoutSeconds [<Int32>]] [-WhatIf [<SwitchParameter>]] [-Confirm [<SwitchParameter>]] [<CommonParameters>]
Description

Waits for a job to complete in Backup Exec.

Wait-BEJob returns the job histories associated with the jobs that complete.

If you do not specify the -TimeoutSeconds, Wait-BEJob waits indefinitely for the specified jobs to complete.

If you specify the -TimeoutSeconds parameter and the time is exceeded before a job completes, the command returns even if the job is still running. No error message displays.

Parameters

-Any <SwitchParameter>

Specifies that Wait-BEJob return after any of the jobs complete if multiple jobs are waiting to complete.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-TimeoutSeconds <Int32>

Determines the maximum wait time for each job in seconds. If the time is exceeded before the job completes, the command returns even if the job is still running. No error message displays.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-InputObject <BEJob[]>

Specifies one or more job objects. Enter a variable that contains the objects, or type a command or expression that gets the objects.

Required | true
Position | Named
Accepts pipeline input | true (ByValue)
Accepts wildcard characters | false

-WhatIf <SwitchParameter>

Describes what happens if you execute the command without actually executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

-Confirm <SwitchParameter>

Prompts you for confirmation before executing the command.

Required | false
Position | Named
Accepts pipeline input | false
Accepts wildcard characters | false

<CommonParameters>

For more information about common parameters, type "Get-Help about_commonparameters".

Input Type
BackupExec.Management.CLI.BEJob

You can pipe a Backup Exec job object to Wait-BEJob.

Return Value
BackupExec.Management.CLI.BEJobHistory

Wait-BEJob returns a Backup Exec job history object if the -TimeoutSeconds time is not exceeded, otherwise nothing is returned.

Examples

Example 1

C:\PS> Get-BEJob "Job 0001" | Wait-BEJob

These commands wait for a job named "Job 0001" to complete.

Example 2
C:\PS> Get-BEAgentServer myserver.mycompany.com | Submit-BEOnetimeBackupJob | Wait-BEJob

These commands submit a one-time backup that backs up a server named "myserver.mycompany.com" and waits for the job to complete.

Related Links